Go Back   Android Forums > Android Discussion > Android Lounge
Android Lounge A place for general Android discussion and questions.

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old September 8th, 2012, 08:24 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: May 2010
Location: North east England
Posts: 28
 
Device(s): Samsung Galaxy S3, Motorola Xoom Wi-Fi Tablet
Carrier: Not Provided

Thanks: 5
Thanked 0 Times in 0 Posts
Default

I've had a series of problems with photos on my Motorola Xoom (now with Jelly Bean). These are mainly stored on a 32GB SD card, and the problems initially manifested themselves in images that showed as blanks in the standard Gallery app. I downloaded an app called SDrescan but it didn't seem to help. I've run another app called SDCardTester a few times and it shows no problems on my SD card.

The number of photos in my subdirectories reported by the Gallery app seems to increase every time I rescan (I haven't added any recently) and bears no relation to the actual number. A directory called "New York 2012 1" reports 4041 images in Gallery but only 449 in QuickPic (the QuickPic count matches the one for the same folder on my Windows PC). In the Gallery app, I still have the blanks but also see a lot of the photos shown twice or more.

What's worse, some photos seem to have disappeared altogether, which isn't helped by the fact that Gallery only shows the path when you select an individual photo and click "Details". I've tried to "unhide" a few photos from an app called KeepSafe and this worked when I first used the app but not now. I select the pics and click "Unhide" and confirm but then see a message saying "0 photos unlocked". Neither Gallery nor QuickPic seems to have any easily configurable list of directories (folders) to show, and I've lost track of where these "unhidden" photos should appear if they did unlock successfully. I've always found Unix-style path conventions (or the lack of them) frustrating. At least in Windows you can be reasonably confident that the default location for photos is in "Pictures" or "My Pictures" within the user folder - on Linux, Solaris and Android there seems to be any number of different places where they could live. (Is the default save location under the control of a non-"rooted" user?)

I've seen the odd report online of people having similar problems, but nothing conclusive. Has anyone any idea of what's going wrong here? Have I got faulty hardware, or is it just that Android Ice Cream Sandwich and Jelly Bean both have serious bugs in file management? Thanks in advance for any hints or tips.

__________________
John H
North east England
Gadget fan with an interest in user interfaces - not always the most patient person if I think they've got it wrong!
GStadium is offline  
Last edited by Xyro; September 8th, 2012 at 08:24 AM. Reason: Sneaky mod bump
Reply With Quote
sponsored links
Old September 8th, 2012, 09:02 AM   #2 (permalink)
Need Beer and Mustard
 
breadnatty08's Avatar
 
Join Date: Nov 2009
Location: District of Columbia
Posts: 17,774
 
Device(s): LG G2, Moto G, Galaxy S3, Galaxy Nexus LTE, Nexus 7, HTC Flyer
Carrier: Verizon

Thanks: 5,735
Thanked 5,422 Times in 3,575 Posts
Default

Have you mounted your SD Card to your PC and searched for it from there? Is there anything else on your card you seem to be missing?
Using Astro, if I click on "Pictures", it agregates all my photos (screen shots, wallpapers etc) into one section even if they're stored in different locations (this is on my Nexus 7).
I'm not familiar with the Xoom specifically, but they're both running stock Jelly Bean, so hopefully it's similar.
__________________
New to the forum? Check out the FAQ
Haven't signed up? Join the best Android Forum out there!
Sign up here
breadnatty08 is offline  
Reply With Quote
Old September 8th, 2012, 09:08 AM   #3 (permalink)
4 8 15 16 23 42
 
Xyro's Avatar
 
Join Date: Dec 2009
Location: UK
Posts: 11,991
 
Device(s): SGS3, Nexus 7, HTC Desire HD, HTC Hero (GSM)
Carrier: Orange

Thanks: 3,186
Thanked 7,189 Times in 3,840 Posts
xyro.af@gmail.com
Default

Personally, I would try clearing the cache of the gallery app. Then I would clear the data for that app too, although I'm not sure if you can do that without a factory reset if you're not rooted. Worst comes to worst, a factory reset is something you might have to try.

I'm not really sure what you mean by hidden photos. That keepsafe app is for hiding photos, but you can't unhide photos you didn't deliberately hide yourself, if that makes sense. It isn't for troubleshooting missing photos.

I know quickpic refers to hidden photos too, but that is referring to showing pictures from directories that are normally skipped over by quickpic. So for example, I see lots of app assets, music album art, podcast logos, etc, when I tell quickpic to unhide everything.

You mentioned not being able to set which directories quickpic scans. If you go to Settings >> Browse and then pick 'included folders', only the directories you choose will be scanned for photos. So, if you put all of your images in the same folder on your sdcard (it doesn't matter where, so long as you know how to navigate there), and select that folder, quickpic should show you all of your images and nothing else.

Then you can just add any new pictures to that same directory and they'll show up in quickpic too. Ensuring they end up in the right directory will depend on where those images are coming from.
__________________
Site Rules/Guidelines

If you see a post that needs a mod's attention, hit the button.
Xyro is offline  
Reply With Quote
Old September 8th, 2012, 09:22 AM   #4 (permalink)
Nexican
 
jmar's Avatar
 
Join Date: Sep 2010
Location: San Jose, CA
Gender: Male
Posts: 4,840
 
Device(s): hammerhead, falcon, dream, grouper (Retired: mako, toro, daytona, vivow, inc, aloha, encore)
Carrier: AT&T & VZW

Thanks: 7,605
Thanked 3,205 Times in 1,884 Posts
jdmartinez89@gmail.com
Default

If I was in your shoes, I would backup everything onto my computer, including sdcard contents.

Then I would format the sdcard and factory reset to a clean install of Jelly Bean. Big Pain In the Arse but it is what I would do and have had to do with my GNex.

Honestly though, I wish I could help more but this is the best I have for you.

Let me know how it goes. Good luck.

jmar
__________________
Introduce Yourself Here
Forum Rules & Guidelines - FAQ
Was someone helpful? Hit the Thanks! button. Do you like the contents of a post? Hit the Like button. If you see rude behavior, bickering or spam, Report! it to the Moderators.
My favorite getaway--->Galaxy Nexus Watering Hole
jmar is offline  
Reply With Quote
Old September 14th, 2012, 01:14 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: May 2010
Location: North east England
Posts: 28
 
Device(s): Samsung Galaxy S3, Motorola Xoom Wi-Fi Tablet
Carrier: Not Provided

Thanks: 5
Thanked 0 Times in 0 Posts
Default

Thanks for the suggestions.

I've just connected the Xoom to my Windows PC and the directory view looks bizarre from a Windows viewpoint. (Unfortunately it looks as if I can't insert an image in this posting without uploading it to the web somewhere, and I don't have a suitable location.) I'll have to be content with describing it.

At the top level, Computer > Xoom shows "SD card" with 25.1GB free of 29.7, which should be about right. When I click on this, the heading changes to Computer > Xoom > SD Card as expected. However, I then see what look like multiple copies of each directory, regardless of the view selected in Windows. I have Documents 12 times, LOST 11 times then LOST.DIR once, then Music and Pics each 12 times. I know Android is Linux based but I don't think duplicate directory names at the same level are any more valid in Linux than in Windows - are they? Does this mean my SD card is completely scrambled?

Computer > Xoom > Internal Storage looks much more reassuring, with no duplicate names.
GStadium is offline  
Reply With Quote
Old September 14th, 2012, 01:17 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: May 2010
Location: North east England
Posts: 28
 
Device(s): Samsung Galaxy S3, Motorola Xoom Wi-Fi Tablet
Carrier: Not Provided

Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Xyro View Post
I'm not really sure what you mean by hidden photos. That keepsafe app is for hiding photos, but you can't unhide photos you didn't deliberately hide yourself, if that makes sense. It isn't for troubleshooting missing photos.
Sorry, I wasn't clear there but these were photos I had hidden myself by putting them into the app's "safe". They can only be used by other apps when they're "unhidden" so I tried to do this prior to sending them to someone. I realise that it's not a disc repair tool.
GStadium is offline  
Reply With Quote
Old September 14th, 2012, 01:51 PM   #7 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: May 2010
Location: North east England
Posts: 28
 
Device(s): Samsung Galaxy S3, Motorola Xoom Wi-Fi Tablet
Carrier: Not Provided

Thanks: 5
Thanked 0 Times in 0 Posts
Default

Thanks - I think I have established that my Mediastore database was corrupted and, with the help of an article on the Motorola forum, have fixed things, at least for now. In case anyone else might benefit from it, the link is https://forums.motorola.com/posts/cf07acdc3a

Fingers crossed.
GStadium is offline  
Reply With Quote
Reply
Tags
corruption, file management, images, location, sd card, visibility


Go Back   Android Forums > Android Discussion > Android Lounge
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:15 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.