Go Back   Android Forums > Android Discussion > Android Lounge
Android Lounge A place for general Android discussion and questions.

test: Reply
 
LinkBack Thread Tools
Old October 4th, 2012, 03:48 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default Lag in games sometimes, and sometimes not

Hello people,

I just got my new phone (Samsung galaxy S advance) and I am experiencing some random lag moments in my games and sometimes in the UI.

Even easy to run games have these kind of moments.
I played for example Bad piggies. Most of the time the game lags and I need to shutdown and relaunch the app. After like 2 tries the frames are back to being smooth.

Same happens with Blood and glory. Runs shitty and after a view relaunches its runs alot smoother.

My question is if this is common or is there something wrong with my phone?
I am not using any custom rom nor have I rooted it.
I close all my apps + delete memory to speed things up.
I am also not using an SD, maybe thats the problem?

Thanks in advance.

Advertisements
Keunus is offline  
Reply With Quote
sponsored links
Old October 4th, 2012, 04:26 PM   #2 (permalink)
Senior Member
 
ExtremeNerd's Avatar
 
Join Date: Aug 2012
Location: STL
Gender: Male
Posts: 744
 
Device(s): SGS 3, HTC Glacier, Skypad A2, Viewsonic G Tab
Carrier: T-Mobile

Thanks: 51
Thanked 237 Times in 148 Posts
Default

The S Advance isn't a top end phone. It may have some problems running memory intensive apps, like Bad Piggies. It has a 1 GHz processor and 768mb of RAM. It should run them, but it doesn't surprise me that they aren't flawless.
ExtremeNerd is offline  
Reply With Quote
Old October 4th, 2012, 07:46 PM   #3 (permalink)
The Doctor
 
chanchan05's Avatar
 
Join Date: Jun 2011
Gender: Male
Posts: 11,376
 
Device(s): Note 3 LTE (N7105), Samsung Galaxy Tab 7.0 Plus (P6200), Samsung Galaxy SL (I9003), , Samsung Galaxy
Carrier: Globe Philippines

Thanks: 172
Thanked 2,513 Times in 2,079 Posts
Default

Quote:
Originally Posted by ExtremeNerd View Post
The S Advance isn't a top end phone. It may have some problems running memory intensive apps, like Bad Piggies. It has a 1 GHz processor and 768mb of RAM. It should run them, but it doesn't surprise me that they aren't flawless.

The S.advance has a dual core 1ghz. It should run bad piggies with no problem. Even lower spec'd phones can run that game no issues (like a galaxy s). I'm guessing the phone is still relatively new and still hasnt optimized itself to the OP's.usage. Probably some app was using the memory and did not unload immediately. Or perhaps its just because you're still.on Gingerbread. It's an older version of Android. Samsung did say that the update for ICS for the S advance was scrappex and its going to jump straight to jelly bean.
__________________
https://shared.com?ref=51950 100GB free storage. WOW.

Worried about your health? Take the True Health Assessment now! Click HERE
chanchan05 is offline  
Reply With Quote
Old October 5th, 2012, 02:19 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

thanks for the replies. i will just wait for jelly bean to come out on the s advance. hope that fixes the issue
Keunus is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Discussion > Android Lounge
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:04 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.