Go Back   Android Forums > Android Development > Application Development > App & Game Announcements
App & Game Announcements A place for developers to announce new applications and games.

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 12th, 2012, 01:45 AM   #1 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default [PC/Mac/Linux] [FREE] Gif2Boot: Convert animated GIFs to boot animations! (v0.5.3 updated 8/21/2012)

Gif2Boot


This tool will allow you to take any animated gif and convert it to a bootanimation.zip file for your android phone! It is meant to be robust and easy to use.

User Guide
1) Download the latest version of Gif2Boot (links at bottom of post) and extract it.
2) Run gif2boot.jar (You will need to have Java installed)
3) Follow the on screen instructions



Features explained

If you're not sure how or why to use a new feature, please read my explanation posts here:
center frame

Change log
Code:
8/21/2012 version 0.5.3
■ resolution input box now allows arbitrary values (so all resolutions are supported)
■ fixed temporary file cleanup

6/15/2012 version 0.5.2
■ fixed a bug that caused flashing boot animation in windows to fail (caused by chnages in previous version)
■ fixed the center frame algorithm (it was causing a little bit of stretching)

6/12/2012 version 0.5.1
■ fixed a bug where the boot animation would be saved in the wrong folder under certain circumstances

6/12/2012 version 0.5
■ added experimental (safe) support for ADB on Mac
■ some code clean-up & optimization
■ added donation link :)

5/10/2012 version 0.4
■ added GUI
■ multi-threaded processing
■ support for all android devices & screen resolutions
■ ADB support
■ zoom frame option
■ lots of code clean-up

4/18/2012 version 0.2a
■ added --centerFrame option, which attempts to do some intelligent cropping

4/17/2012 version 0.1a
■ initial release 
■ converts animated gif to bootanimation.zip
■ works with gif of any size/resolution (smoothly resizes to 320x480, for phones like the Transform Ultra)
■ auto-detects framerate from gif animation
Planned features
Code:
■ manual entry of framerate and other options
■ anything the users want :)
Disclaimer: modifying your boot animation should not pose any risk to your phone, that being said, make a backup anyway

I have tested this software on 2 phones and 1 tablet with a 100% success rate. If it doesn't work for you, send me a PM and I'll get it fixed!

Bugs/Features: I want this software to be useful and easy to use. Please submit any ideas, suggestions, bug reports you have!


Download:
Gif2Boot v0.5.3 <--- newest version
Gif2Boot v0.5.2
Gif2Boot v0.5.1
Gif2Boot v0.5
Gif2Boot v0.4
Gif2Boot v0.2a
Gif2Boot v0.1a



__________________
If you like my work, feel free to donate.

Gif2Boot - Convert GIFs to boot animations! (no root required)
BLuFeNiX is offline  
Last edited by BLuFeNiX; August 24th, 2012 at 12:19 AM.
Reply With Quote
The Following 7 Users Say Thank You to BLuFeNiX For This Useful Post:
BestInGalaxy (January 18th, 2013), chevanlol360 (June 12th, 2012), darkxsun (August 17th, 2012), lingamkrishnan (July 28th, 2012), Loota (August 3rd, 2012), nyydynasty (January 21st, 2013), Simba501 (July 1st, 2012)
sponsored links
Old June 12th, 2012, 11:40 AM   #2 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default feature explained: center frame

The "center frame" option is great for animations like this one:



Because of the empty space on the sides and the content in the middle, the animation would normally be rotated counterclockwise and squished and therefore wouldn't look very good. This option crops the sides off and doesn't rotate the image. Like this:



The above image is the same ratio as the original animation, nothing is squished or stretched.
BLuFeNiX is offline  
Last edited by BLuFeNiX; June 15th, 2012 at 04:12 PM.
Reply With Quote
The Following User Says Thank You to BLuFeNiX For This Useful Post:
chevanlol360 (June 12th, 2012)
Old July 28th, 2012, 03:17 AM   #3 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks for the awesome work. Please add 800x1280 resolution.
lingamkrishnan is offline  
Reply With Quote
The Following User Says Thank You to lingamkrishnan For This Useful Post:
BLuFeNiX (July 29th, 2012)
Old July 29th, 2012, 09:33 PM   #4 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Sure thing, I'll try and get a minor version update released for you sometime tomorrow. Thanks for the support!
BLuFeNiX is offline  
Reply With Quote
Old July 29th, 2012, 11:58 PM   #5 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It looks cool.
JavaTheHutt is offline  
Reply With Quote
Old August 17th, 2012, 01:56 PM   #6 (permalink)
Member
 
Join Date: Sep 2010
Posts: 470
 
Device(s): Samsung Galaxy Nexus, Asus Nexus 7, Motorola Droid 2 (previous: HTC Thunderbolt, Motorola Droid, LG
Carrier: Not Provided

Thanks: 159
Thanked 119 Times in 70 Posts
Default

Cool application, but the resolution options are limited (no support for Galaxy Nexus and other portrait, HD phones). Why not include text fields rather than a pulldown? Or include a "custom" option in the pulldown, where users can enter a different resolution?
darkxsun is offline  
Reply With Quote
Old August 18th, 2012, 01:59 AM   #7 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by darkxsun View Post
Cool application, but the resolution options are limited (no support for Galaxy Nexus and other portrait, HD phones). Why not include text fields rather than a pulldown? Or include a "custom" option in the pulldown, where users can enter a different resolution?
That's on my to-do list. I've just been really busy. The next update will allow arbitrary resolutions
BLuFeNiX is offline  
Reply With Quote
The Following User Says Thank You to BLuFeNiX For This Useful Post:
darkxsun (August 18th, 2012)
Old August 18th, 2012, 10:33 AM   #8 (permalink)
Member
 
Join Date: Sep 2010
Posts: 470
 
Device(s): Samsung Galaxy Nexus, Asus Nexus 7, Motorola Droid 2 (previous: HTC Thunderbolt, Motorola Droid, LG
Carrier: Not Provided

Thanks: 159
Thanked 119 Times in 70 Posts
Default

Quote:
Originally Posted by BLuFeNiX View Post
That's on my to-do list. I've just been really busy. The next update will allow arbitrary resolutions
Sounds great. Keep up the good work.
darkxsun is offline  
Reply With Quote
Old August 21st, 2012, 01:24 PM   #9 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default v0.5.3 is out!

Quote:
Originally Posted by lingamkrishnan View Post
Thanks for the awesome work. Please add 800x1280 resolution.
Quote:
Originally Posted by darkxsun View Post
Cool application, but the resolution options are limited (no support for Galaxy Nexus and other portrait, HD phones). Why not include text fields rather than a pulldown? Or include a "custom" option in the pulldown, where users can enter a different resolution?
Sorry that took so long, but here it is! Check the links at the bottom of the OP for version 0.5.3. This version allows any resolution

Let me know what other ideas you guys have for improvements!
BLuFeNiX is offline  
Reply With Quote
The Following User Says Thank You to BLuFeNiX For This Useful Post:
darkxsun (August 22nd, 2012)
Old August 23rd, 2012, 01:36 PM   #10 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Having a problem on both mac and windows.

On mac the I click create and it just sit's there, no progress.

on windows it processes but then brings up a prompt that says "I/O error. Do you have sufficient privileges to the file system?"


any ideas?
noriyori is offline  
Reply With Quote
sponsored links
Old August 23rd, 2012, 05:47 PM   #11 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by noriyori View Post
Having a problem on both mac and windows.

On mac the I click create and it just sit's there, no progress.

on windows it processes but then brings up a prompt that says "I/O error. Do you have sufficient privileges to the file system?"


any ideas?
Please run the program from a command line and send me the output. When run on windows, does it give you a prompt to elevate to admin privileges? For Mac I have no idea. I've never actually run it on a mac, so I'll need the log. Thanks for trying it out!

EDIT: If you have any trouble with this, let me know and I will send you a debug build that creates the output for you. The result is the same though.
BLuFeNiX is offline  
Last edited by BLuFeNiX; August 23rd, 2012 at 07:32 PM.
Reply With Quote
Old September 19th, 2012, 06:10 AM   #12 (permalink)
h20
Member
 
h20's Avatar
 
Join Date: Jan 2012
Location: Daytona Beach FL
Posts: 143
 
Device(s): mobile=galaxy s2-VILLUMINAT-CM11-Extreme_Kernel1 @pc=#!_crunchbang_wal
Carrier: Not Provided

Thanks: 35
Thanked 36 Times in 29 Posts
Default

tried to run jar in win 7 get error " cant find main class"

my system variables are set like this
TEMP=%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\Sy stem32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShel l\v1.0\;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x86;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x64;C:\Program Files (x86)\Android\android-sdk\platform-tools;C:\Program Files (x86)\Android\android-sdk\tools;C:\Program Files\Java\jdk1.7.0_03\bin;C:\Program Files\Java\jre7\bin;C:\Program Files (x86)\Java\jre1.5.0\bin
CLASSPATH=.;C:\Program Files (x86)\Java\jre1.5.0\lib\ext\QTJava.zip
JAVA HOME= C:\Program Files (x86)\Java\jre1.5.0
PATH=C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoo t%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowe rShell\v1.0\;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x86;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x64;C:\Program Files (x86)\Android\android-sdk\platform-tools;C:\Program Files (x86)\Android\android-sdk\tools;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Java\jre1.5.0\bin

cant get it to work what am i doing wrong??
__________________
It is best not to travel with a dead man....
h20 is offline  
Last edited by h20; September 19th, 2012 at 10:17 AM.
Reply With Quote
Old September 19th, 2012, 07:07 PM   #13 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by h20 View Post
tried to run jar in win 7 get error " cant find main class"

my system variables are set like this
TEMP=%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\Sy stem32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShel l\v1.0\;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x86;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x64;C:\Program Files (x86)\Android\android-sdk\platform-tools;C:\Program Files (x86)\Android\android-sdk\tools;C:\Program Files\Java\jdk1.7.0_03\bin;C:\Program Files\Java\jre7\bin;C:\Program Files (x86)\Java\jre1.5.0\bin
CLASSPATH=.;C:\Program Files (x86)\Java\jre1.5.0\lib\ext\QTJava.zip
JAVA HOME= C:\Program Files (x86)\Java\jre1.5.0
PATH=C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoo t%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowe rShell\v1.0\;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x86;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x64;C:\Program Files (x86)\Android\android-sdk\platform-tools;C:\Program Files (x86)\Android\android-sdk\tools;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Java\jre1.5.0\bin

cant get it to work what am i doing wrong??
You are running a very old version of Java (1.5), please upgrade to 1.7, AKA Java7 (although 1.6 might work... I don't recall what version I compiled it for).
BLuFeNiX is offline  
Reply With Quote
The Following User Says Thank You to BLuFeNiX For This Useful Post:
h20 (September 20th, 2012)
Old September 20th, 2012, 11:36 AM   #14 (permalink)
h20
Member
 
h20's Avatar
 
Join Date: Jan 2012
Location: Daytona Beach FL
Posts: 143
 
Device(s): mobile=galaxy s2-VILLUMINAT-CM11-Extreme_Kernel1 @pc=#!_crunchbang_wal
Carrier: Not Provided

Thanks: 35
Thanked 36 Times in 29 Posts
Default

thanks bro my java was a mess i actually had java 7 and java 1.5 installed at the same time uninstalled 1.5 and fixed my system variables now your program works sweet thanks for the help
h20 is offline  
Reply With Quote
Old September 20th, 2012, 12:10 PM   #15 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by h20 View Post
thanks bro my java was a mess i actually had java 7 and java 1.5 installed at the same time uninstalled 1.5 and fixed my system variables now your program works sweet thanks for the help
No problem. I'm glad you're able to use it
BLuFeNiX is offline  
Reply With Quote
Old September 20th, 2012, 01:25 PM   #16 (permalink)
AF Contributor
 
Mayhem's Avatar
 
Join Date: Sep 2010
Location: Austin, Texas area
Gender: Male
Posts: 846
 
Device(s): Samsung Galaxy Nexus 32GB. Nook Tablet w/CM10.
Carrier: Verizon

Thanks: 69
Thanked 144 Times in 114 Posts
Default

For anyone else, here's the download page for Java SE.
__________________
"A free American means just this: individual freedom for all, rich or poor, or else this system of government we call democracy is only an expedient to enslave man to the machine and make him like it. - Frank Lloyd Wright
Mayhem is offline  
Reply With Quote
The Following User Says Thank You to Mayhem For This Useful Post:
BLuFeNiX (September 20th, 2012)
Old September 20th, 2012, 01:38 PM   #17 (permalink)
AF Contributor
 
Mayhem's Avatar
 
Join Date: Sep 2010
Location: Austin, Texas area
Gender: Male
Posts: 846
 
Device(s): Samsung Galaxy Nexus 32GB. Nook Tablet w/CM10.
Carrier: Verizon

Thanks: 69
Thanked 144 Times in 114 Posts
Default

I'm turning this into a boot animation.

I just need something that'll rip the video into individual frames, then convert them into an animated gif. Anyone know of a program that'll do that?
Mayhem is offline  
Last edited by Mayhem; September 20th, 2012 at 01:43 PM.
Reply With Quote
Old September 20th, 2012, 01:38 PM   #18 (permalink)
h20
Member
 
h20's Avatar
 
Join Date: Jan 2012
Location: Daytona Beach FL
Posts: 143
 
Device(s): mobile=galaxy s2-VILLUMINAT-CM11-Extreme_Kernel1 @pc=#!_crunchbang_wal
Carrier: Not Provided

Thanks: 35
Thanked 36 Times in 29 Posts
Default

okay made my fist gif but its looping 5x. looked at the desc.txt file and shouldn't it be p=1 on 4th line to stop the loop ? idk this is the first boot animation i have made. the gif i made is set to pay thru once. which it dose then loaded it into your program an pushed to phone.the reboot plays thru and then loops till i hit the power button by then phones booted of course gif length is 5 sec. or if i let i go it runs the gif 5 times then stops and i am on home screen


edit solved:: didn't know that your program installed to data\local\ bootanimation.zip. so when i deleted the boot animation file in system\media. i thought it was the one i installed with your program.. i then created a new animation manually from scratch and pasted back in media well it didn't work i got the exact same problem because i did not know about the animation in data\local\ ..so i kept looking at the desc.txt file. and couldn't figure out what was wrong. i finally found the file in data\local. and looked at its desc.txt file. for some reason line 2 was set as “p 20 0 part0”. so i edited the file to read p 1 0 part0”. and now it works fine... fyi for anyone who don't know. a boot animation in data\local will play before. and in place of anyone in system\media.
h20 is offline  
Last edited by h20; September 20th, 2012 at 09:25 PM.
Reply With Quote
Old September 20th, 2012, 01:41 PM   #19 (permalink)
h20
Member
 
h20's Avatar
 
Join Date: Jan 2012
Location: Daytona Beach FL
Posts: 143
 
Device(s): mobile=galaxy s2-VILLUMINAT-CM11-Extreme_Kernel1 @pc=#!_crunchbang_wal
Carrier: Not Provided

Thanks: 35
Thanked 36 Times in 29 Posts
Default

Quote:
Originally Posted by Mayhem View Post
I'm turning this into a boot animation.

I just need something that'll rip the video into individual frames, then convert them into an animated gif. Anyone know of a program that'll do that?
AVS video editor is what i used its free for 30 days full use
h20 is offline  
Reply With Quote
Old September 20th, 2012, 11:01 PM   #20 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by h20 View Post
okay made my fist gif but its looping 5x. looked at the desc.txt file and shouldn't it be p=1 on 4th line to stop the loop ? idk this is the first boot animation i have made. the gif i made is set to pay thru once. which it dose then loaded it into your program an pushed to phone.the reboot plays thru and then loops till i hit the power button by then phones booted of course gif length is 5 sec. or if i let i go it runs the gif 5 times then stops and i am on home screen


edit solved:: didn't know that your program installed to data\local\ bootanimation.zip. so when i deleted the boot animation file in system\media. i thought it was the one i installed with your program.. i then created a new animation manually from scratch and pasted back in media well it didn't work i got the exact same problem because i did not know about the animation in data\local\ ..so i kept looking at the desc.txt file. and couldn't figure out what was wrong. i finally found the file in data\local. and looked at its desc.txt file. for some reason line 2 was set as p 20 0 part0. so i edited the file to read p 1 0 part0. and now it works fine... fyi for anyone who don't know. a boot animation in data\local will play before. and in place of anyone in system\media.
Yeah, manual entry of loops and stuff is on my list of things to do. As well as flashing destination.


Quote:
Originally Posted by Mayhem View Post
I'm turning this into a boot animation.

I just need something that'll rip the video into individual frames, then convert them into an animated gif. Anyone know of a program that'll do that?
I was planning on adding video support eventually, but I didn't get enough donations to make it worth my time right now :P Try looking into ffmpeg, imagemagick, and mencoder. I'm sure one or more of those things can get it done for you.
BLuFeNiX is offline  
Reply With Quote
sponsored links
Old October 4th, 2012, 04:58 PM   #21 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 10
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 2 Times in 2 Posts
Exclamation

Doesn't work
extirpate326 is offline  
Reply With Quote
Old October 5th, 2012, 09:36 AM   #22 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by extirpate326 View Post
Doesn't work
Why even bother posting if you aren't going to give any helpful information? It works fine for me and many other people.
BLuFeNiX is offline  
Reply With Quote
Old October 15th, 2012, 07:31 AM   #23 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 8
 
Device(s): Notion Ink adam Motorola Defy +
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 2 Posts
Default Hangs

It keeps hanging at 72 % but does not seem to move on .
Pity as I wanted to recreate a bootanimation I found before megaupload was taken down..
pucky is offline  
Reply With Quote
Old October 15th, 2012, 11:58 AM   #24 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by pucky View Post
It keeps hanging at 72 % but does not seem to move on .
Pity as I wanted to recreate a bootanimation I found before megaupload was taken down..
That's strange. It sounds like the gif you are using may be corrupted or formatted weirdly. If you send me the gif I will see what's wrong and get it working for you.
BLuFeNiX is offline  
Reply With Quote
Old October 27th, 2012, 03:12 PM   #25 (permalink)
Member
 
Join Date: Jun 2010
Posts: 112
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 22 Times in 9 Posts
Default

22% for me, with this one http://i.imgur.com/kM5sl.gif
w0bbl3r is offline  
Reply With Quote
Old October 27th, 2012, 10:42 PM   #26 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by w0bbl3r View Post
22% for me, with this one http://i.imgur.com/kM5sl.gif
Hmm, it works for me. What OS are you using? Could you run the program in a terminal/command line and paste the output? If you aren't sure how to do this, let me know and I will create a build that does it all for you.

Thanks!
BLuFeNiX is offline  
Reply With Quote
Old October 28th, 2012, 03:06 AM   #27 (permalink)
Member
 
Join Date: Jun 2010
Posts: 112
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 22 Times in 9 Posts
Default

It works fine if i leave the size alone, appears to be only when i try and make it fit the Gnex screen.

It doesn't flash the animation though, tried in recovery and bootloader, says no device connected, a terminal window with "./fastboot-mac devices" shows the device is connected OK.

I don't know how to run the .jar in terminal i'm afraid

(Mac 10.8.2)
w0bbl3r is offline  
Last edited by w0bbl3r; October 28th, 2012 at 03:14 AM.
Reply With Quote
Old October 28th, 2012, 11:08 AM   #28 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by w0bbl3r View Post
It works fine if i leave the size alone, appears to be only when i try and make it fit the Gnex screen.

It doesn't flash the animation though, tried in recovery and bootloader, says no device connected, a terminal window with "./fastboot-mac devices" shows the device is connected OK.

I don't know how to run the .jar in terminal i'm afraid

(Mac 10.8.2)
Knowing that it is dependent on size helps. I will see if I can recreate the problem myself at 720x1280 resolution. As for the flash not working, I do not have a Mac to test on, so I had to do some guessing on the ADB part (it works fine in Win/Linux). I'll investigate that too. Thank you for your help.
BLuFeNiX is offline  
Reply With Quote
The Following User Says Thank You to BLuFeNiX For This Useful Post:
w0bbl3r (October 28th, 2012)
Old October 28th, 2012, 04:47 PM   #29 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by BLuFeNiX View Post
Knowing that it is dependent on size helps. I will see if I can recreate the problem myself at 720x1280 resolution. As for the flash not working, I do not have a Mac to test on, so I had to do some guessing on the ADB part (it works fine in Win/Linux). I'll investigate that too. Thank you for your help.
Okay, I have tried the same gif with many different resolutions, but I never get a freeze. How much RAM do you have? I may need to create a fix for people with less than 1GB of RAM. I've also put it on my list to get an old mac, or run Mac OS in a virtual machine.
BLuFeNiX is offline  
Reply With Quote
Old October 29th, 2012, 03:04 PM   #30 (permalink)
Member
 
Join Date: Jun 2010
Posts: 112
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 22 Times in 9 Posts
Default

I have 12Gb, quad core Mac Pro.

I've tried a bunch of resolutions but it only completes if i don't change it from the default, and as i said, even when it does complete, it won't flash
w0bbl3r is offline  
Reply With Quote
sponsored links
Old October 29th, 2012, 07:26 PM   #31 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by w0bbl3r View Post
I have 12Gb, quad core Mac Pro.

I've tried a bunch of resolutions but it only completes if i don't change it from the default, and as i said, even when it does complete, it won't flash
That's very strange. I'll have to get a virtual machine running and check it out. Thanks for the info.
BLuFeNiX is offline  
Reply With Quote
Old April 9th, 2013, 10:47 PM   #32 (permalink)
New Member
 
Join Date: Apr 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default I/O Error

Hi,
I just tried this Gif2boot and when I create it (which doesn't work with my resolution 1024x768) with the default resolution that it's set to, I get an I/O error. Do you have sufficient permissions for the filesystem?" Message.

I know this was mentioned before, but I'm not very tech-savvy and have no idea what to do .. Please help!
chawpsticks is offline  
Reply With Quote
Old April 9th, 2013, 11:22 PM   #33 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by chawpsticks View Post
Hi,
I just tried this Gif2boot and when I create it (which doesn't work with my resolution 1024x768) with the default resolution that it's set to, I get an I/O error. Do you have sufficient permissions for the filesystem?" Message.

I know this was mentioned before, but I'm not very tech-savvy and have no idea what to do .. Please help!
Hi,

Are you using the latest version (Gif2Boot v0.5.3)? Also, make sure you are using Java 7. If both of those conditions are met, try running Gif2Boot as an administrator. What OS are you using?
BLuFeNiX is offline  
Reply With Quote
Old June 15th, 2013, 08:35 PM   #34 (permalink)
New Member
 
Join Date: Apr 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Are you going to be updating to add resolution for the HTC One, 1920 x 1080?
I love your app, used it for my Inspire, worked great!
zole2112 is offline  
Reply With Quote
Old June 16th, 2013, 02:00 AM   #35 (permalink)
Member
Thread Author (OP)
 
BLuFeNiX's Avatar
 
Join Date: Feb 2012
Posts: 206
 
Device(s):
Carrier: Not Provided

Thanks: 113
Thanked 104 Times in 59 Posts
Default

Quote:
Originally Posted by zole2112 View Post
Are you going to be updating to add resolution for the HTC One, 1920 x 1080?
I love your app, used it for my Inspire, worked great!
Hi,

You can type the resolution in manually and it should work. Let me know if it doesn't. Thanks for using my app!
BLuFeNiX is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Development > Application Development > App & Game Announcements
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:48 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.