Go Back   Android Forums > Android Development > Application Development
Application Development Dev lounge for our application developers.

test: Reply
 
LinkBack Thread Tools
Old March 2nd, 2011, 01:47 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Feb 2011
Location: Orange County
Gender: Male
Posts: 91
 
Device(s): Google/Asus Nexus 7
Carrier: Not Provided

Thanks: 7
Thanked 0 Times in 0 Posts
Default WARNING: Application does not specify an API level requirement!

I get this message in the console when testing on an Android device: "WARNING: Application does not specify an API level requirement!"

I checked my AVD manager in Eclipse and the API level is there. But how do I specify it in the application?

Thanks!

Advertisements
StevenHu is offline  
Reply With Quote
sponsored links
Old March 2nd, 2011, 07:00 PM   #2 (permalink)
ROM Developer
 
cr5315's Avatar
 
Join Date: Jul 2010
Location: Narnia
Posts: 435
 
Device(s): Current: HTC Evo 4G, Asus Nexus 7 Retired: LG Ally
Carrier: Not Provided

Thanks: 103
Thanked 161 Times in 105 Posts
Default

In your AndroidManifest, go to the </application> tag and right under that put
<uses-sdk android:minSdkVersion="3" />

The 3 is the API level for Android 1.5
If you want other levels, use:
1.5 - 3
1.6 - 4
2.1 - 7
2.2 - 8
2.3.1 - 9
2.3.3 - 10
__________________

(That's a link. Just saying.)
cr5315 is offline  
Reply With Quote
Reply
Tags
api level requirement


Go Back   Android Forums > Android Development > Application Development
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:14 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.