Go Back   Android Forums > Android Development > Application Development
Application Development Dev lounge for our application developers.

test: Reply
 
LinkBack Thread Tools
Old September 24th, 2012, 05:58 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
FallnShadw's Avatar
 
Join Date: Sep 2012
Posts: 49
 
Device(s): Samsung Rugby Smart
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default Semi-Urgent: App available to over 0 devices

I've got my app done, designed and tested so I was uploading it to the developer console to publish it and I saw this message:

Quote:
Supported Devices:



This application is only available to devices with these features, as defined in your application manifest.
Screen layouts: SMALL NORMAL LARGE XLARGE
Required device features


android.hardware.telephony
android.hardware.touchscreen





This application is available to over 0 devices.
Because of this message, I just saved it and didn't publish it because, what's the point if no one can see it?

What can I do to fix this issue?

Advertisements
FallnShadw is offline  
Reply With Quote
sponsored links
Old September 24th, 2012, 11:33 AM   #2 (permalink)
Senior Member
 
jonbonazza's Avatar
 
Join Date: Jul 2010
Gender: Male
Posts: 1,935
 
Device(s): Nexus 4, Samsung Galaxy S II, HTC Evo 4G, Amazon Kindle Fire
Carrier: ATT

Thanks: 235
Thanked 482 Times in 294 Posts
Default

remove the appropriate lines from your manifest.

With that said, what's wrong with this? If you require those screen sizes and those features, then it makes sense that it wouldn't show up for those who don't have them.
jonbonazza is offline  
Reply With Quote
Old September 25th, 2012, 12:06 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
FallnShadw's Avatar
 
Join Date: Sep 2012
Posts: 49
 
Device(s): Samsung Rugby Smart
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Because it says it's available to 0 devices... doesn't that mean it wouldn't show up on the market for anyone? because Google uses those are filters so you can't see apps your phone can't support.

Unless I took that phrase as something it's not? I'm not sure.. because I've never released an app before. That's why I was asking.
FallnShadw is offline  
Reply With Quote
Old September 25th, 2012, 03:46 AM   #4 (permalink)
Junior Member
Thread Author (OP)
 
FallnShadw's Avatar
 
Join Date: Sep 2012
Posts: 49
 
Device(s): Samsung Rugby Smart
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Alright... so I clicked Activate but I suppose I didn't "Save" after that.. when I activated the app and saved it, it says it's available on 1554 devices. But ironically, my phone is not on the list of supported phones -.-
FallnShadw is offline  
Reply With Quote
Old September 25th, 2012, 09:18 AM   #5 (permalink)
Senior Member
 
jonbonazza's Avatar
 
Join Date: Jul 2010
Gender: Male
Posts: 1,935
 
Device(s): Nexus 4, Samsung Galaxy S II, HTC Evo 4G, Amazon Kindle Fire
Carrier: ATT

Thanks: 235
Thanked 482 Times in 294 Posts
Default

I don't know how only 1554 devices can work with your app, when the only features you require are touchscreen and telephony, which every android phone is required to have.... Sounds like the detection code on the Dev Console is bugged...
jonbonazza is offline  
Reply With Quote
Old September 25th, 2012, 04:27 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
FallnShadw's Avatar
 
Join Date: Sep 2012
Posts: 49
 
Device(s): Samsung Rugby Smart
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

I'm not sure either. I thought the simplicity wouldn't be better with more devices
FallnShadw is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Development > Application Development
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:14 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.