Go Back   Android Forums > Android Phones > ZTE AT&T Avail (ZTE Merit) > Avail - All Things Root

Like Tree1Likes

test: Reply
 
LinkBack Thread Tools
Old April 2nd, 2012, 07:47 PM   #51 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 16
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Should the phone be in USB storage mode or not? USB debugging is on.

Advertisements
Thrive is offline  
Reply With Quote
sponsored links
Old April 2nd, 2012, 08:31 PM   #52 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 154
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 86 Times in 34 Posts
Default

Quote:
Originally Posted by Thrive View Post
Should the phone be in USB storage mode or not? USB debugging is on.
Make sure USB Storage is off. USB Debugging must be on or else it will not work.
anthony062991 is offline  
Reply With Quote
Old April 2nd, 2012, 09:45 PM   #53 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 16
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

K, got down to the command before reboot, and got this:

Code:
~/AndroidSDK/platform-tools> adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop" 
cannot create /data/local.prop: permission denied
I also just got a call, which I ignored. Not sure if that'll be a problem. I sure hope not. I'm stopping exactly right here and not touching the phone until I get some kind of answer. Thanks again!

Edit - also switched back over to OpenSuSE, if that makes a difference. SDK was easier to set up there.
Thrive is offline  
Last edited by Thrive; April 2nd, 2012 at 09:48 PM.
Reply With Quote
Old April 2nd, 2012, 10:03 PM   #54 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 16
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Awww ****. You're offline.

I unplugged it and restarted the phone. It seems to be working fine. I hope I didn't ruin anything.
Thrive is offline  
Last edited by Thrive; April 2nd, 2012 at 10:23 PM.
Reply With Quote
Old April 3rd, 2012, 12:26 AM   #55 (permalink)
Junior Member
 
Join Date: Jan 2012
Posts: 16
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

I tried one more time, just for the lulz, and it worked! My phone is successfully rooted. Thanks a lot for all the help!
Thrive is offline  
Reply With Quote
Old April 5th, 2012, 09:47 AM   #56 (permalink)
911
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

does this works with htc wildfire 2.2.1 .........
plz reply ASAP....
thanks
911 is offline  
Reply With Quote
Old April 5th, 2012, 12:27 PM   #57 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 154
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 86 Times in 34 Posts
Default

Quote:
Originally Posted by 911 View Post
does this works with htc wildfire 2.2.1 .........
plz reply ASAP....
thanks
Sorry, but this will not work with htc wildfire.
anthony062991 is offline  
Reply With Quote
Old April 7th, 2012, 05:57 PM   #58 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

It won't detect my avail, what am i supposed to do?
scottharris is offline  
Reply With Quote
Old April 13th, 2012, 06:20 PM   #59 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

does this have to be on windows 7 or can I still root my avail with XP?
rapskallyun is offline  
Reply With Quote
Old April 13th, 2012, 06:40 PM   #60 (permalink)
Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 154
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 86 Times in 34 Posts
Default

Quote:
Originally Posted by rapskallyun View Post
does this have to be on windows 7 or can I still root my avail with XP?
As long if it's windows. You should not have a problem.
anthony062991 is offline  
Reply With Quote
sponsored links
Old April 16th, 2012, 05:26 PM   #61 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

When I get to the adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop" I keep getting an error saying cannot create /data/local.prop: permission denied. How can I create that file? I'm still trying to find more information other places but not having a lot of luck so far. I've been copying and pasting all the codes so I don't mess anything up but I'm not having any luck so far. Everything else seems to go smoothly except for creating the /data/local.prop and pushing su into /system/xbin/. Where am I messing up at??

I talked to a friend who's pretty good with this stuff and he said I need to make my phone re-writable but I'm Having trouble figuring out how to do that :/
rapskallyun is offline  
Last edited by rapskallyun; April 16th, 2012 at 05:41 PM.
Reply With Quote
Old April 17th, 2012, 04:43 AM   #62 (permalink)
Junior Member
 
Lincoln357's Avatar
 
Join Date: Mar 2012
Posts: 45
 
Device(s): ZTE V860
Carrier: Not Provided

Thanks: 10
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Lincoln357
Default

Why don't you try easier method?It's located here Android Srbija Forum - Pogledaj temu - [Tut]Recovery,Root
and it's in Serbian,if you cannot translate it let me know and I'll write a guide in English.
Worked perfectly every time.
Lincoln357 is offline  
Reply With Quote
Old April 30th, 2012, 07:18 PM   #63 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rapskallyun View Post
When I get to the adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop" I keep getting an error saying cannot create /data/local.prop: permission denied. How can I create that file? I'm still trying to find more information other places but not having a lot of luck so far. I've been copying and pasting all the codes so I don't mess anything up but I'm not having any luck so far. Everything else seems to go smoothly except for creating the /data/local.prop and pushing su into /system/xbin/. Where am I messing up at??

I am having the same trouble and don't know what else to do. Any help is really accepted.
F8ality is offline  
Reply With Quote
Old April 30th, 2012, 07:24 PM   #64 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi i am trying this but i cant even get the picture of the horse to come up right off the bat. not sure whats going on lol. Help asap cus i really would love to root this phone to get rid of the ton of useless stuff preloaded onto it to free up some nice memory. Thanks!
tsiconquest88 is offline  
Reply With Quote
Old May 1st, 2012, 10:01 AM   #65 (permalink)
Junior Member
 
Join Date: Feb 2012
Posts: 65
 
Device(s):
Carrier: Not Provided

Thanks: 11
Thanked 7 Times in 6 Posts
Default

Have you tried this?
http://androidforums.com/avail-all-things-root/479920-anyone-working-root.html#post3951993

Good luck.
chrismbrunner is offline  
Reply With Quote
Old May 1st, 2012, 04:45 PM   #66 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

why are yall doing the adb install and push this and put that file in this?
open Dialer
1.) Dial *983*7668# (do not hit send - you should see a message come up about being root let it set for 5 to 10 mins)
2.) Dial *983*24737# (do not hit send - you should see a message saying disabling QID)
3.) Go to market and download and install Superuser by chainsdd or ddchains -- should be the first in the list
4.) Run Superuser, hit the menu button, then select preferences, scroll down to Su Binary and do the update
then you should be all set,then install busybox and titanium backup.
mikec628 is offline  
Reply With Quote
Old May 1st, 2012, 05:06 PM   #67 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

So mike are you saying not to do any of the above stuff? And just start by doing what you just posted?
Im going to have to try this. Cus i never even seen the horse pic come up in the cdm box so i was having issues right from the start and never got to finish anthonys way. Not sure why it wasnt working but whatever.
also when putting that code into the dialer do i have to wait the 5 to 10 mins for something to happen? Cus if i hit call then i do get a finding ssdm code which then says not found error. So should i just put the code in the dialer and wait to see what happens without hitting send? Thanks
tsiconquest88 is offline  
Reply With Quote
Old May 1st, 2012, 06:40 PM   #68 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok ignore my post above this mike. BUT i am having an issue. First dialer worked and said wait for root. Second dialer said disable QID. Is that right or should it say disabling QID? I downloaded super and the other stuff for the heck of it and superuser is saying the following when i tried the su update...

Fixing database... okay
Checking for busybox... okay
Checking install path /system/bin/su
Downloading new binary... okay
Checking md5sum... okay
gaining root access...
Checking installed version=fail


And thats where it ends. Titanium says no root access. Cant continue. So yea issue with that too.. let me know whats up if u have an idea lol. Thanks man.
tsiconquest88 is offline  
Reply With Quote
Old May 1st, 2012, 06:51 PM   #69 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

Do you have a good over the air signal (not wifi). My wifes did that. I live out past the sticks and dont have a good signal here. I needed at less 3 bars for it to pass. So yes you are on the right path. After you get Checking installed version=passed it should ask you for root permission. if not run it again then it will ask you that.Then you will be rooted.
mikec628 is offline  
Reply With Quote
Old May 2nd, 2012, 07:08 AM   #70 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yea idk if shutting down helped but i did that then it worked. Man everyone needs to do thisethod. Its so easy! Mike if i were to now get rid of root di i just uninstall super, busybox, and titanium? Or does that end up having my preloaded apps i deleted to come back? I thought i could choose to put the preloaded apps on sd or uninstall. All i see is uninstall via the titanium though. Am i missing something? Or is it in the paid version?
tsiconquest88 is offline  
Reply With Quote
sponsored links
Old May 2nd, 2012, 07:50 AM   #71 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

I used titanium to get rid of all the att stuff and then i uninstalled it. I then went and did the [Guide] Partition SD Card (for more user storage) . If you need to get rid of root. There isa few ways to do it. I had to unroot ones and i used the Tcard flash from zteusa. It puts u back to the day you pulled it out of the box.
mikec628 is offline  
Reply With Quote
Old May 2nd, 2012, 03:53 PM   #72 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well since everything seems to work no different than before. i dont mind keeping it rooted. Or is it bad to keep rooted and all?
tsiconquest88 is offline  
Reply With Quote
Old May 2nd, 2012, 05:51 PM   #73 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wow thanks to titanium i see something that looks not too right? Lol. My system rom is 230mb but apparently only 48.7 left? Wtf is that about lol?. I barely have anything left on my phone to take up memory thanks to root and titanium letting me uninstall crap. And i have over half of my 170 mb phone memory left so wtf gives with that seemingly low rom left?
tsiconquest88 is offline  
Reply With Quote
Old May 2nd, 2012, 07:45 PM   #74 (permalink)
Junior Member
 
Join Date: Feb 2012
Posts: 65
 
Device(s):
Carrier: Not Provided

Thanks: 11
Thanked 7 Times in 6 Posts
Default

Might try Link2sd on the market. It's a free app and works great. It moves the cache and data to your sd card, and also the app if you want. I use it on all of my phones.
chrismbrunner is offline  
Reply With Quote
Old May 2nd, 2012, 09:29 PM   #75 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

And would help for this rom thing? I just dont get how my rom is so low yet my actual phone memory is decent.
How do i go about switching the apps i want that dont have sd option, to go on sd? I thought i read that you can after rooting and all?
tsiconquest88 is offline  
Reply With Quote
Old May 2nd, 2012, 11:05 PM   #76 (permalink)
Junior Member
 
Join Date: Feb 2012
Posts: 65
 
Device(s):
Carrier: Not Provided

Thanks: 11
Thanked 7 Times in 6 Posts
Default

I figured out what you are talking about. In titanium backup, i ignore that. I use it on 6 phones, and all of them have different amounts rom. It shows all of them extremely low. I don't notice any problems with any of the phones running poorly.
so, like I said, I ignore that info.

Hope this helps.
chrismbrunner is offline  
Last edited by chrismbrunner; May 2nd, 2012 at 11:10 PM.
Reply With Quote
Old May 3rd, 2012, 06:47 AM   #77 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ah ok i see. Wasnt sure if i should do a custom rom or something to free it up. Guess ill just leave it alone then.
tsiconquest88 is offline  
Reply With Quote
Old May 8th, 2012, 06:45 PM   #78 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mikec628 View Post
why are yall doing the adb install and push this and put that file in this?
open Dialer
1.) Dial *983*7668# (do not hit send - you should see a message come up about being root let it set for 5 to 10 mins)
2.) Dial *983*24737# (do not hit send - you should see a message saying disabling QID)
3.) Go to market and download and install Superuser by chainsdd or ddchains -- should be the first in the list
4.) Run Superuser, hit the menu button, then select preferences, scroll down to Su Binary and do the update
then you should be all set,then install busybox and titanium backup.
My phone says disable QID!!! And then when i get to updating Su binary this is wat it says...
Fixing database... okay
Checking for busybox... okay
Checking current install path ....fail!
Failed to find currently installed su binary.
ginacroote is offline  
Reply With Quote
Old May 8th, 2012, 06:47 PM   #79 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh yeah and i have 3 bars of service and i have installed busy box and titanium backup.
ginacroote is offline  
Reply With Quote
Old May 15th, 2012, 12:56 PM   #80 (permalink)
New Member
 
Join Date: May 2012
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

okay so i want to root my phone since we all know the internal memory sucks on this phone. i downloaded the adb file and when i type adb devices it doesn't show any devices
locuno1 is offline  
Reply With Quote
sponsored links
Old May 16th, 2012, 01:07 PM   #81 (permalink)
Junior Member
 
zajchik's Avatar
 
Join Date: Jul 2011
Location: SERBIA
Posts: 91
 
Device(s): ZTE roamer
Carrier: Not Provided

Thanks: 57
Thanked 3 Times in 3 Posts
Default

Since I saw that you have a problem with the root, I decided to ask you another way to root.

1.Install the drivers

artemfomin.blog.tut.by/files/2011/12/ZTE-Android-USB-Driver-5.2066.1.8.rar

or

artemfomin.blog.tut.by/files/2011/12/android_usb_windows.rar

The first driver will generally be sufficient, if not then install other than device menager.

2. Then dovnload ClockWorkMod 5.0.2.0 ZTE Roamer

artemfomin.blog.tut.by/files/2011/12/CWM-5.0.2.3.-Recovery-ZTE-Roamer.rar

and unzip to your desktop.

3. Turn off your phone, then when you turn it on vibrate and hold the menu button and volume-about ten seconds and you're entered in FastBoot, then connect the phone and desktop.

4.Open the folder ClockWorkMod 5.0.2.0 ZTE Roamer that you have unpacked and run. Bat file with pictures

http://dl.dropbox.com/u/50661190/a932c9aa1b8ef99a1f488a38f7295371.png

5. Now you have installed the recovery of fine root. Download file update.zip

artemfomin.blog.tut.by/files/2011/12/update.zip

Copy it to rot sd card, turn off your phone and enter a recovery volume + key combination and the menu,
Go to the zip instal from sd card, and select a update.zip and to it, the phone has a root

Note:

USB debugging must be included
zajchik is online now  
Reply With Quote
Old May 16th, 2012, 09:10 PM   #82 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by mikec628 View Post
why are yall doing the adb install and push this and put that file in this?
open Dialer
1.) Dial *983*7668# (do not hit send - you should see a message come up about being root let it set for 5 to 10 mins)
2.) Dial *983*24737# (do not hit send - you should see a message saying disabling QID)
3.) Go to market and download and install Superuser by chainsdd or ddchains -- should be the first in the list
4.) Run Superuser, hit the menu button, then select preferences, scroll down to Su Binary and do the update
then you should be all set,then install busybox and titanium backup.
FYI I succesfully rooted with this method but had to re-flash the firmware from the zte website from my sd card first, I had to get rid of an att update to get this method to work
dougggg is offline  
Reply With Quote
The Following User Says Thank You to dougggg For This Useful Post:
Russ71 (July 28th, 2012)
Old May 21st, 2012, 04:18 PM   #83 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Ok, I have an AT&T Avail and I just found this thread a little while ago and I entered *983*7668# and didn'y hit call or anything and it said "wait some time then system is root" I now have super user and root explorer installed and so far have gotten rid of mobile care,navigator,and all the other bloatware.... Weird... So I guess I didn't have to go thru all those steps...lol...THANKS!!!!! As for "dougggg" I didn't re flash or anything. Just hit the numbers and rolled with it.I was simply curious as to what puttin them numbers in would do and did it and saw it say system will be root then bam! it was ...Awesome!
Russ71 likes this.
UTPWD is offline  
Last edited by UTPWD; May 21st, 2012 at 04:21 PM.
Reply With Quote
Old May 24th, 2012, 06:31 PM   #84 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

I have one of these phones through straight talk and I can't get the *983 codes to do anything at all. I did the t card install and still nothing. Are the straight talk phones different somehow?
neutrontech is offline  
Reply With Quote
Old May 24th, 2012, 09:46 PM   #85 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

If you have done any updates to the phone you have to do the tcard flash then root the phone. Then do the dialer system to root the phone. Or cant get it to root do the t-flash then root. Works like a champ.
mikec628 is offline  
Reply With Quote
Old May 24th, 2012, 09:52 PM   #86 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by mikec628 View Post
If you have done any updates to the phone you have to do the tcard flash then root the phone. Then do the dialer system to root the phone. Or cant get it to root do the t-flash then root. Works like a champ.
That's what I'm saying. I did the t-flash, then tried immediately went to the dialer to enter the code, and nothing happens.
neutrontech is offline  
Reply With Quote
Old June 15th, 2012, 04:10 PM   #87 (permalink)
Senior Member
 
stayboogy's Avatar
 
Join Date: Jun 2012
Posts: 750
 
Device(s):
Carrier: Not Provided

Thanks: 38
Thanked 232 Times in 126 Posts
Default

Quote:
Originally Posted by mikec628 View Post
why are yall doing the adb install and push this and put that file in this?
open Dialer
1.) Dial *983*7668# (do not hit send - you should see a message come up about being root let it set for 5 to 10 mins)
2.) Dial *983*24737# (do not hit send - you should see a message saying disabling QID)
3.) Go to market and download and install Superuser by chainsdd or ddchains -- should be the first in the list
4.) Run Superuser, hit the menu button, then select preferences, scroll down to Su Binary and do the update
then you should be all set,then install busybox and titanium backup.
which phone did you get this to work on? the ATT ZTE Avail or the Straight Talk ZTE Merit? and yes i'm aware they are virtually the same phone, but please tell me which one you are using--did you buy it in a ST green box???

need to know this worked for someone before i try this for myself as i have a ST ZTE Merit not the ATT version

thanks in advance
stayboogy is offline  
Reply With Quote
Old June 15th, 2012, 08:24 PM   #88 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

sorry i didnt say which one i got. I did get the att avail z990. I got this phone from walmart but it was for the att perpay. I got the straightalksim and put in it. Im sure straight talk has there phone locked or something for u not to beable to root with the dialer code. With that being said im sure there is a way.
mikec628 is offline  
Reply With Quote
Old June 15th, 2012, 10:30 PM   #89 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

I talked to jcase (who got us root for the avail). If any one with the merit was adb and can pull system dump. He may can get yall some root for the merit.
mikec628 is offline  
Reply With Quote
Old June 16th, 2012, 08:59 AM   #90 (permalink)
Senior Member
 
stayboogy's Avatar
 
Join Date: Jun 2012
Posts: 750
 
Device(s):
Carrier: Not Provided

Thanks: 38
Thanked 232 Times in 126 Posts
Default

Quote:
Originally Posted by mikec628 View Post
I talked to jcase (who got us root for the avail). If any one with the merit was adb and can pull system dump. He may can get yall some root for the merit.
thanks for the reply.

someone posted the dump on another thread

http://androidforums.com/avail-all-things-root/554428-help-rooting-zte-merit-z990g.html

a root would be great so that we can get rid of the bloatware, fix all these security/privacy risks, free up more memory and space, and maintain a decent battery life
stayboogy is offline  
Reply With Quote
sponsored links
Old June 18th, 2012, 10:48 PM   #91 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation probelem with the code ( adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop" )

when i enter the code ( adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop" )

it give me error saying " cannot create /data/local.prop: permission denied "

anny suggestion wut to do ? thanks
JustinSolo is offline  
Reply With Quote
Old June 27th, 2012, 05:25 PM   #92 (permalink)
New Member
 
Join Date: May 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

After entering this code
adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop"

I also get this error
cannot create /data/local.prop: permission denied
Please help.
felixsarp is offline  
Reply With Quote
Old July 6th, 2012, 12:09 AM   #93 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

How Do you T-flash the Att/ZTE Avail. I have it and was searching throught the websites and found nothing.
bwandrych is offline  
Reply With Quote
Old July 7th, 2012, 08:23 PM   #94 (permalink)
Junior Member
 
Join Date: Jul 2012
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Natetd26 View Post
When I get to this part:

adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop"

it says permission denied!! Any help I would be very greatful!!
Quote:
Originally Posted by rkalajian View Post
I'm having an issue trying to root this damn phone, and was wondering if anyone knew the solution. When I dial *983*7668# and wait, nothing happens. If I click the send button I then get the "Connection problem or invalid MMI code" message. Either way, I can't continue on with the process. I get "cannot create /data/local.prop: permission denied"
Quote:
Originally Posted by rapskallyun View Post
When I get to the adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop" I keep getting an error saying cannot create /data/local.prop: permission denied. How can I create that file? I'm still trying to find more information other places but not having a lot of luck so far. I've been copying and pasting all the codes so I don't mess anything up but I'm not having any luck so far. Everything else seems to go smoothly except for creating the /data/local.prop and pushing su into /system/xbin/. Where am I messing up at??

I talked to a friend who's pretty good with this stuff and he said I need to make my phone re-writable but I'm Having trouble figuring out how to do that :/
Quote:
Originally Posted by F8ality View Post
I am having the same trouble and don't know what else to do. Any help is really accepted.
Quote:
Originally Posted by felixsarp View Post
After entering this code
adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop"

I also get this error
cannot create /data/local.prop: permission denied
Please help.
Seems to be a common problem as I'm getting to this point, too.
Is the T-card flash the solution?
TraceP38 is offline  
Reply With Quote
Old July 8th, 2012, 08:52 AM   #95 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Thought I'd report that after loading the one.three rom TapaTalk FCs when trying to upload a picture. Might be due to the ics camera app.
neutrontech is offline  
Reply With Quote
Old July 8th, 2012, 09:08 AM   #96 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

@TraceP38 Is this your first time rooting the phone? Have you done any over the air updates from att? I would do the T-card flash, then do the root. I had problems before I rooted, due to ATT updates on the phone. Dont hit send after the *983* code. Just watch the bottom of the screen. A message will pop up about 3 sec. after you put the code in. You can do updates after root if you want to. I never have.
mikec628 is offline  
Reply With Quote
Old July 8th, 2012, 06:56 PM   #97 (permalink)
Junior Member
 
Join Date: Jul 2012
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mikec628 View Post
@TraceP38 Is this your first time rooting the phone? Have you done any over the air updates from att? I would do the T-card flash, then do the root. I had problems before I rooted, due to ATT updates on the phone. Dont hit send after the *983* code. Just watch the bottom of the screen. A message will pop up about 3 sec. after you put the code in. You can do updates after root if you want to. I never have.
I went the T-card flash route and all is well now, thanks.

It was my first time rooting any phone, so I was a bit nervous about it, but worked my way through a number of roadblocks, mostly from reading here about what other's had encountered.

This forum rocks! :thu:
TraceP38 is offline  
Reply With Quote
Old July 8th, 2012, 08:53 PM   #98 (permalink)
Junior Member
 
Join Date: Apr 2012
Location: alabama
Posts: 81
 
Device(s): nexus4 (stock) att avail (retired)
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 5 Posts
Default

Glad to hear that. Now you can have some fun playing around with this little guy.
mikec628 is offline  
Reply With Quote
Old July 21st, 2012, 03:13 PM   #99 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default T card flash?

Can someone please explain what a t card flash is? Ive been trying to root my phone, and cant use options like super one click becuase I have a mac. I need to root directly from the phone using the dialer code, but have been unable to because of the att update.

How do I do a t card flash? Help would be appreciated.
Qwerty639 is offline  
Reply With Quote
Old July 21st, 2012, 11:31 PM   #100 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 821
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 13
Thanked 134 Times in 119 Posts
Default

Avail download page

Enjoy
Motorhead1991 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > ZTE AT&T Avail (ZTE Merit) > Avail - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:47 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.