Go Back   Android Forums > Android Phones > Motorola Droid Bionic > Bionic - All Things Root

test: Reply
 
LinkBack Thread Tools
Old September 16th, 2011, 11:58 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
dberthia's Avatar
 
Join Date: Nov 2009
Posts: 79
 
Device(s): Nexus 10, Bionic
Carrier: Verizon

Thanks: 6
Thanked 46 Times in 17 Posts
Default Swype problems

I rooted my Bionic, removed the stock version of Swype using TBU, and installed the latest beta version. This all works great until I reboot the phone, then I get constant Swype force closes. If I uninstall and reinstall Swype, it works fine again until I reboot, then I see the problems again.

Any suggestions as to how I can break out of this cycle and have Swype work properly after a reboot?

Advertisements
dberthia is offline  
Reply With Quote
sponsored links
Old September 16th, 2011, 01:59 PM   #2 (permalink)
Member
 
Join Date: Dec 2009
Posts: 358
 
Device(s): Bionic, Nexus 7
Carrier: Verizon

Thanks: 14
Thanked 87 Times in 72 Posts
Default

Search the Motorola Droid Bionic thread (parent to this one) for 'ATTN: Swype Lovers' by Messenger13, last post on Sept 13. There are detailed instructions.
Groid is offline  
Reply With Quote
Old September 16th, 2011, 03:09 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
dberthia's Avatar
 
Join Date: Nov 2009
Posts: 79
 
Device(s): Nexus 10, Bionic
Carrier: Verizon

Thanks: 6
Thanked 46 Times in 17 Posts
Default

Thanks for that link. Starting there, I eventually found the solution on Swype's forum. For posterity, here it is:
Quote:
If you used Titanium Backup like myself to "uninstall" pre-loaded Swype, then this may be the answer to your problem.

It will require you to have a Root Explorer-esque app.

First, uninstall all traces of Beta Swype Installer, and the Swype it tried to install. Then, open your root explorer and change to R/W so you can change some extensions.

Rename: \data\dalvik-cache\system@app@Swype.apk@classes.dex to have a .bak at the end.
Rename: \system\lib\libSwypeCore.so to have a .bak at the end.

Redownload your Beta Swype installer and go forward with the installation of Swype. It worked like a charm for me!

There were those two files left-over that Titanium Backup did not remove for me. If you used the same method to uninstall, then perhaps this will help!
dberthia is offline  
Reply With Quote
The Following 3 Users Say Thank You to dberthia For This Useful Post:
hunterwrot (September 19th, 2011), johnlgalt (September 16th, 2011), messenger13 (September 17th, 2011)
Old September 17th, 2011, 10:29 AM   #4 (permalink)
Senior Member
 
messenger13's Avatar
 
Join Date: Dec 2009
Location: Cleveland, OH
Posts: 3,130
 
Device(s): RAZR MAXX; DROID BIONIC (now the wife's); Moto (OG) DROID (now my son's)
Carrier: Verizon

Thanks: 82
Thanked 377 Times in 223 Posts
Thumbs up

Glad you got it sorted out. The pre-loaded version was fairly lame if you're used to the "real" version.
__________________
- Joe

RAZR Maxx ... Love it!
messenger13 is offline  
Reply With Quote
The Following User Says Thank You to messenger13 For This Useful Post:
hunterwrot (September 19th, 2011)
Old September 19th, 2011, 12:34 AM   #5 (permalink)
Member
 
Join Date: Jan 2011
Location: St. Augustine, FL
Posts: 169
 
Device(s): Droid Bionic Still play with my Droid X
Carrier: Not Provided

Thanks: 14
Thanked 11 Times in 8 Posts
Default

I am so lost. The problem is i read that original post and it did not work the first time so i think i messed up. What version is the beta version of swype i get confused on tibu now. I promise i am not an idiot i just got exited about better swype and kind of rushed it.
Edit: I figured it out. I just retraced my steps and it works. I love the new version already.
hunterwrot is offline  
Last edited by hunterwrot; September 19th, 2011 at 12:44 AM.
Reply With Quote
Reply
Tags
swype


Go Back   Android Forums > Android Phones > Motorola Droid Bionic > Bionic - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:07 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.