Go Back   Android Forums > Android Phones > Samsung Captivate > Captivate - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old August 15th, 2011, 03:02 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 92
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 2 Times in 2 Posts
Default Power button does not work, software of hardware issue?

Had my captivate for almost a year now. The GPS never worked well and the battery always sucked but I got used to all of that.

Currently running a custom Froyo rom, had it for about 7 months now with the same rom without any problem.

Just a few minutes ago I tried to turn on my phone and I couldn't turn it one. So I removed the battery and put it back in to restart the phone. It came on and everything was great until the screen turned off again. I tried turning it back on by pressing the power button and it does not turn on the phone. So I removed the battery and reinstalled it again. Still the same thing.

So while my phone was a sleep, I plugged in the USB cable and it turned on the phone and I was able to use it again until it goes to sleep again. Everything is full function except the power buttom

The last time I installed a new program was about 3 days ago and it was a game. I didn't do anything else to the phone, no updates or anything.

Is there a way to test to see if this is a hardware issue or a software issue?

update:
I think it is a hardware issue. I put the recovery mode by holding the power up/down button at the same time while I reboot, the phone. I am able to get to the recovery mode and the power button still does not work. On the recovery mode, the power button is the enter button but nothing happens.

SuperAkuma is offline  
Last edited by SuperAkuma; August 15th, 2011 at 03:16 AM.
Reply With Quote
sponsored links
Old August 16th, 2011, 01:34 PM   #2 (permalink)
Junior Member
 
Join Date: Oct 2010
Location: Colorado
Posts: 20
 
Device(s): Captivate running CM7, Galaxy Tab 10.1
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default

You could also try running adb logcat and see if you are getting any messages that would tell you that you are getting that keypress. Here is an example from my logcat when I hit the power key:

I/power ( 192): *** set_screen_state 1
D/Sensors ( 192): Smb380Sensor::~enable(0,1)
D/Sensors ( 192): Smb380Sensor::~enable(0, 1) open /sys/class/input/event1/device/enable
D/Sensors ( 192): Smb380Sensor::~enable(0, 1) opened /sys/class/input/event1/device/enable
D/Sensors ( 192): Smb380Sensor::~setDelay(0, 200000000)

If you do not see message traffic from the keypress then you may be correct in assuming a hardware malfuction. If you do see messages I would suggest that you flash back to a stock rom to see if that helps fix your issue. Another good place to look is to adb shell then cat /proc/kmsg. My two cents!
Usil is offline  
Last edited by Usil; August 16th, 2011 at 06:35 PM.
Reply With Quote
Old August 24th, 2011, 10:26 AM   #3 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've got the EXACT same problem. I called Samsung repair and it took me two days to finally get to talk to someone......After an hour of being on hold, I just hung up....BUT when I did talk someone they provided good customer service and let me know it should still be under warranty as long as I didn't damage it.

They sent me a shipping label and everything. They said 6-10 days to fix it and get it back to me. So that's what I am going to do...but our problems are exactly the same.

I even took my power button off to see if it wasn't getting a connection, but that didn't help either.
Killowatt59 is offline  
Reply With Quote
Old September 4th, 2011, 09:27 PM   #4 (permalink)
Klaatu barada nikto
 
reinbeau's Avatar
 
Join Date: Sep 2010
Location: South of Boston, MA
Posts: 1,344
 
Device(s): Samsung Captivate, 2.3.3, Serendipity VII
Carrier: Not Provided

Thanks: 174
Thanked 211 Times in 165 Posts
Default

SuperAkuma, Try taking a picture. Seriously. Take a picture and then see if your power button doesn't start working again. Don't ask me why, but it works.
__________________
Ann, Palm refugee, learning to grok Android. Perhaps your answer is in the CapFAQ
Excellent video tutorials, watch and learn!!
Now on Serendipity VII, click link to learn more
Did you read the first post in the thread?
reinbeau is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Captivate > Captivate - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:44 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.