Go Back   Android Forums > Android Phones > HTC Desire > Desire - Support and Troubleshooting

test: Reply
 
LinkBack Thread Tools
Old June 24th, 2010, 01:18 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: warrington, Cheshire
Posts: 7
 
Device(s): HTC desire
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default htc desire on t-mobile wont connect to mobile internet!

Got the phone on Monday and have just been getting my head around it but mainly at home and on wifi
out and about today and realised it just will not use mobile broadband
this is despite it being set (I think) to use mobile internet when no wifi

I tried to search and it seems lots of people have some sort of problem like this. when I'm in wireless settings and networks and push the connect to mobile network button, I just get a 'connection failed due to incorrect APN setting message' though having looked at it it looks right general.t-mobile.uk. nothing I do seems to change this (switching wifi off, walking out of range, leaving it on)

one thing I have also noticed though is I have never seen any g,h, e etc by the signal strenth indicator (which is normally only 1 or 2 bars - i.e. poor). so I assume it's just not finding 3g etc signal, despite the t-mobile website mobile broadband checker saying its been good strength in all the places Ive been today!

I've also tried repeated power off and on again and airplane mode, then switching this off.

this is really winding me up now as its a great phone but not if you cant use it's mobile internet functions when out and about.

Please save my sanity and any help will be greatfully received as cant seem to find answer on t-mobilebroadband help and don't want to call an expensive 0845 number if I can avoid it!
thanks
Matt

Advertisements
mellisr1 is offline  
Reply With Quote
sponsored links
Old June 24th, 2010, 01:40 PM   #2 (permalink)
Junior Member
 
Geetarman's Avatar
 
Join Date: May 2010
Posts: 65
 
Device(s): Nexus 4, Acer Iconia A500
Carrier: Not Provided

Thanks: 8
Thanked 13 Times in 9 Posts
Default

Sorry probably a stupid question but have you gone through the mobile set up info from the T-mobile site?
Geetarman is online now  
Reply With Quote
Old June 24th, 2010, 02:05 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: warrington, Cheshire
Posts: 7
 
Device(s): HTC desire
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Geetarman thanks,
just to check I wasn't being stupid (the phone seemed set up for t-mobile from the start) I ran through the t-mobile connecting to the internet guide for the Desire and set up a new APN as it instructuted - still the same problem

when I check the network it tells me it's T-mobile, signal strength is (currently) -101 dBm 6 Asu (what ever that means) and its a GPRS network, its in service and not roaming.

Doh, should I hard reset, but then will I loose all the t-mobile stuff or is that in the phone permanently unless I root it?
cheers
Matt
mellisr1 is offline  
Reply With Quote
Old June 24th, 2010, 02:15 PM   #4 (permalink)
Junior Member
 
Geetarman's Avatar
 
Join Date: May 2010
Posts: 65
 
Device(s): Nexus 4, Acer Iconia A500
Carrier: Not Provided

Thanks: 8
Thanked 13 Times in 9 Posts
Default

Hard reset is probably the last resort, bit of a pain really.

Check all the basics, have you got the Network Operator set to T-mobile? Is the new APN you set up is selected? Mobile network option selected?

Do you have any apps that might be stopping the 3G APNdroid etc?
Geetarman is online now  
Reply With Quote
Old June 24th, 2010, 02:20 PM   #5 (permalink)
Junior Member
 
Geetarman's Avatar
 
Join Date: May 2010
Posts: 65
 
Device(s): Nexus 4, Acer Iconia A500
Carrier: Not Provided

Thanks: 8
Thanked 13 Times in 9 Posts
Default

Oh other thing if the WiFi is on and there is available networks that you can't connect to you should switch of WiFi and then the phone will start to use 3G, sure it always trys to use wifi.

So try switching of the WiFi and see it it connect to 3G.
Geetarman is online now  
Reply With Quote
Old June 24th, 2010, 02:51 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: warrington, Cheshire
Posts: 7
 
Device(s): HTC desire
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

unfortunately, I've no idea if I've got an app which is messing it up - just to be sure though I unistalled everything I downloaded, (backed it up first but they were all freebies anyay)

I also unistalled 3g watchdog just in case. its set to t mobile and the APN I set up. Also, even if I turn off my wifi, it just doesn't pick up a mobile network

argghhh! annoying me now!
mellisr1 is offline  
Reply With Quote
Old June 24th, 2010, 03:37 PM   #7 (permalink)
Junior Member
 
Geetarman's Avatar
 
Join Date: May 2010
Posts: 65
 
Device(s): Nexus 4, Acer Iconia A500
Carrier: Not Provided

Thanks: 8
Thanked 13 Times in 9 Posts
Default

Sorry mate really not sure what else to try, the error sounds like the APN settings aren't right, probably worth double checking it all again, make sure you haven't missed a dot or something.

If no one else here can help them may be worth trying the t-mobile forum.
Geetarman is online now  
Reply With Quote
Old June 24th, 2010, 04:52 PM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: warrington, Cheshire
Posts: 7
 
Device(s): HTC desire
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks
Gave up and rang t mobile. Seems to work now. Guy was convinced that my New price plan hadn't applied properly so the 1gb allowance wasn't on so he reset it and hey presto

Fingers crossed it stays workin
Cheers
mellisr1 is offline  
Reply With Quote
Old June 25th, 2010, 06:22 AM   #9 (permalink)
Junior Member
 
Geetarman's Avatar
 
Join Date: May 2010
Posts: 65
 
Device(s): Nexus 4, Acer Iconia A500
Carrier: Not Provided

Thanks: 8
Thanked 13 Times in 9 Posts
Default

Glad it's working! Total pain when you can use your new toy to it's full potential!
Geetarman is online now  
Reply With Quote
Old April 5th, 2011, 02:09 PM   #10 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Another cause/solution

I just want to give my contribution here. I had similar problem with my mobile internet (HTC Desire).
Finally, I found out that problem came when I started using two different widgets for switching on/off different services. They interfere between themselves.
Even one of them was adding some strange strings in APN settings.
So, I cleared the unnecessary strings, and everything stared to work just fine!

Good luck!


--

Don't waste your time, search the ultimate goal!
iik71 is offline  
Reply With Quote
sponsored links
Old June 10th, 2011, 01:40 AM   #11 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Thumbs up Fix

This seems to work for alot of people including me

YouTube - ‪HTC Desire HD 3G wont turn on properly‬‏
stevo10 is offline  
Reply With Quote
The Following User Says Thank You to stevo10 For This Useful Post:
Skyblaize (January 10th, 2012)
Old June 13th, 2011, 10:38 AM   #12 (permalink)
Member
 
Join Date: Jan 2011
Posts: 157
 
Device(s):
Carrier: Not Provided

Thanks: 37
Thanked 10 Times in 9 Posts
Default

also- text YES to 2121- to make sure you are connected to the t-mobile AND orange network- i was only connected to the tmobile one recently and it drained my battery quickly due to the poor reception
erry is offline  
Reply With Quote
Old January 10th, 2012, 04:18 AM   #13 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks so much! Haven't a clue about how these things work but this was a great and easy fix for me
Skyblaize is offline  
Reply With Quote
Old January 29th, 2012, 04:41 PM   #14 (permalink)
New Member
 
Join Date: Dec 2009
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a similar problem today, I lost "data" and every site I tried to open went to my.t-mobile.com instead. Also no apps would work, for example Facebook said "no internet connection".

After following the information in this thread I could see one APN listed.

I then did something a little different. I had previously installed APN Manager from the Android Market. I opened it up and noticed the APN listed in settings was NOT the APN that was active. I clicked on the APN that should have been active (the one listed under settings > network > etc) and after it activated things immediately worked again.

I guess the moral of the story is there are "hidden APN's" that I could not see under settings. They WERE all visible using APN Manager though.
spookysco is offline  
Reply With Quote
Old January 30th, 2012, 08:20 AM   #15 (permalink)
Senior Member
 
Jon_LTD's Avatar
 
Join Date: Sep 2011
Location: Uk
Gender: Male
Posts: 786
 
Device(s): Samsung Galaxy S3 I9300 Nexus 7 32gb WiFi
Carrier: 3

Thanks: 48
Thanked 85 Times in 69 Posts
JonLTD
Default

This happened to me on Saturday for no apparent reason. I went to apn settings, pressed menu and restored the default settings. Everything seems to be working fine now. Weird.
Jon_LTD is online now  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC Desire > Desire - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:55 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.