Go Back   Android Forums > Android Phones > HTC Desire > Desire - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old July 4th, 2010, 10:23 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 1 Time in 1 Post
Default HTC Desire - Color Depth Very Poor

Hello,

I just received my HTC Desire on Orange, rooted and de-branded it. Works fine now, I'm on SW version 1.15 as otherwise, I get issues on Orange.

However, the color depth on my device is very poor, it looks like it only has 256 colours if that makes any sense? A bit like on the old PCs when you rebooted and your display graphics drivers weren't properly installed.

Can anyone please advise what I need to do please? Is there any way I can reinstall display drivers on Android? I hope this isn't a hardware issue. I have scoured Google long and hard, but it seems I'm the only one with this problem?

Thanks!

foxy29 is offline  
Reply With Quote
sponsored links
Old July 5th, 2010, 01:12 AM   #2 (permalink)
Member
 
g4rvd4's Avatar
 
Join Date: Jun 2010
Posts: 299
 
Device(s): HTC Desire
Carrier: Not Provided

Thanks: 19
Thanked 14 Times in 13 Posts
Default

Was it fine before you rooted it?
g4rvd4 is offline  
Reply With Quote
Old July 5th, 2010, 04:53 AM   #3 (permalink)
Senior Member
 
Jammy's Avatar
 
Join Date: May 2010
Location: United Kingdom
Posts: 972
 
Device(s): HTC Desire
Carrier: Not Provided

Thanks: 56
Thanked 175 Times in 118 Posts
Default

I believeit should be 16 bit, so 256 seems a little low.

Can you take a picture of it to show us?
__________________
HTC Desire GingerVillain 2.1 32.49.00.32U_5.11.05.27

Desire Root Index

My "I Am Android" Profile

Jammy is offline  
Reply With Quote
Old July 5th, 2010, 09:40 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 1 Time in 1 Post
Default

To be honest, I am not sure if it was ok or not before rooting. Having said that, when I turned it on, I wasn't stunned by the screen at all and noticed some weird behaviour, like the tone of the screen would change and get a bit of a grey hue at times, sometimes yellow, sometimes pink. I thought this was the light sensor.

When rooted, these stopped, but now I am stuck with a phone that's showing fewer colours than it should. It's probably not 256 colors, but I don't think it's 16 bit.

I attach one of the standard pictures that comes with it to this message. Took this with my webcam, so it's not a great picture, but you can see the face of the girl and those patches of colour between the various tones on her face. I do not think this should display like this?

foxy29 is offline  
Reply With Quote
The Following User Says Thank You to foxy29 For This Useful Post:
Komster (November 30th, 2011)
Old July 5th, 2010, 09:46 AM   #5 (permalink)
Senior Member
 
nacatomi's Avatar
 
Join Date: Jun 2010
Posts: 502
 
Device(s): HTC Desire Unlocked\Unbranded on 3 on Stock HTC FroYo
Carrier: Not Provided

Thanks: 11
Thanked 82 Times in 72 Posts
Default

Just checked mine and zoomed right in and its perfect on mine. No colour banding and lots of detail. Sorry...
nacatomi is offline  
Reply With Quote
The Following User Says Thank You to nacatomi For This Useful Post:
foxy29 (July 5th, 2010)
Old July 5th, 2010, 11:51 AM   #6 (permalink)
Member
 
Join Date: Jun 2010
Posts: 114
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 11 Times in 11 Posts
Default

I zoomed on the same picture and i dont have these patches. It might be your webcam ?? or can u see it too on the phone ?
If yes theni dont think it's normal
tanbe174 is offline  
Reply With Quote
The Following User Says Thank You to tanbe174 For This Useful Post:
foxy29 (July 5th, 2010)
Old July 5th, 2010, 12:18 PM   #7 (permalink)
Member
 
g4rvd4's Avatar
 
Join Date: Jun 2010
Posts: 299
 
Device(s): HTC Desire
Carrier: Not Provided

Thanks: 19
Thanked 14 Times in 13 Posts
Default

From your attachment, I can confirm that there is definitely something wrong with your screen.
My suggestion: unroot it back to your original ROM, and then see whether the problem persists. If it does, you can claim warranty.

Regards.
g4rvd4 is offline  
Reply With Quote
The Following User Says Thank You to g4rvd4 For This Useful Post:
foxy29 (July 5th, 2010)
Old July 5th, 2010, 01:48 PM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 1 Time in 1 Post
Default

Thanks for your input guys - I can confirm this is what it looks like on the phone, it's not the webcam. I get the same issues with videos on YouTube (even on my home wifi).

I have sent the phone back, will see what they say.
foxy29 is offline  
Reply With Quote
Old July 5th, 2010, 04:16 PM   #9 (permalink)
Senior Member
 
Join Date: Feb 2010
Location: UK
Posts: 2,278
 
Device(s): Nexus 7, Nexus 5, S3, Moto G,
Carrier: EE (Tmobile)

Thanks: 61
Thanked 160 Times in 143 Posts
Default

Hope you put Orange ROM on it first.....
nx1977 is offline  
Reply With Quote
Old September 6th, 2010, 10:38 AM   #10 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got the same problem too, have you fixed yours, what was it?
alexxfloo is offline  
Reply With Quote
sponsored links
Old September 30th, 2010, 04:28 PM   #11 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

same problem here, although all I did was agree to the update to the latest android 2.2 version. anyone know how to roll back to a previous version?
mosephthegreat is offline  
Reply With Quote
Old September 30th, 2010, 10:07 PM   #12 (permalink)
Member
 
dinaro's Avatar
 
Join Date: Sep 2010
Location: Toronto
Posts: 214
 
Device(s): Telus Desire 2.2
Carrier: Not Provided

Thanks: 24
Thanked 19 Times in 18 Posts
Default

Mine looks fine. Skin tones and everything else blends well.
dinaro is offline  
Reply With Quote
Old November 22nd, 2010, 05:09 PM   #13 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm experiencing the same problem here, has anyone figured out if it is a hardware fault that needs to be replaced? Just picked my htc desire up today and other than the screen its running flawlessly but its something that will begin to grate very soon.
watafu is offline  
Last edited by watafu; November 22nd, 2010 at 05:13 PM.
Reply With Quote
Old November 23rd, 2010, 01:16 AM   #14 (permalink)
Senior Member
 
bfksc's Avatar
 
Join Date: Aug 2010
Location: Canada
Posts: 1,253
 
Device(s): Rugby Pro LTE
Carrier: Not Provided

Thanks: 2
Thanked 200 Times in 169 Posts
Default

Quote:
Originally Posted by watafu View Post
I'm experiencing the same problem here, has anyone figured out if it is a hardware fault that needs to be replaced? Just picked my htc desire up today and other than the screen its running flawlessly but its something that will begin to grate very soon.
Since yours is showing this issue out of the box, then it's either a hardware fault or the firmware on the phone. A lot of users here do not post what part of the world they're in nor their carrier, so it's hard to say if it's related to firmware or not. I'm running the unbranded official ROM from HTC and have no issues with banding - screen quality is excellent.
bfksc is offline  
Reply With Quote
Old November 23rd, 2010, 09:01 AM   #15 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll have a go at updating the firmware first but it looks like a hardware fault to me. As for the phone, its a brand new UK t-mobile handset.
watafu is offline  
Reply With Quote
Old November 30th, 2011, 10:19 PM   #16 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry to dig this up....BUT can anyone tell me how to fix this!?

Running a regular htc desire z, on UK Vodaphone...the bad color resolution only happended when updating the OS.

Makes the camera usless!
Komster is offline  
Reply With Quote
Old December 1st, 2011, 03:01 PM   #17 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having the same issue on my HTC Desire S (Orange) Just got it back from service (system got frozen when turned on on HTC logo), they changed the motherboard and loaded latest Android 2.3.5 on it. When I came back home, I just realized that the color depth is very poor (seems like 256 colors only) Does anyone know how can this be fixed? I don't really want to go back to orange and wait another 3 weeks until they "repair" it again... Many thanks for any suggestions...
casty is offline  
Reply With Quote
Reply
Tags
256, color, colour, depth, desire, display, graphics, htc, issues, poor, problems, screen


Go Back   Android Forums > Android Phones > HTC Desire > Desire - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:09 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.