Go Back   Android Forums > Android Phones > HTC Desire > Desire - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old May 21st, 2010, 10:38 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Apr 2010
Location: London
Posts: 47
 
Device(s): HTC Sensation - Stock T-Mobile, HTC Desire Rooted with unrevoked 3.21, ROM LeeDroid 2.3d, Radio
Carrier: Not Provided

Thanks: 2
Thanked 9 Times in 8 Posts
Default "No SIM Card in Phone" Message

I've occasionally suffered from the issue whereby the Desire drops the network signal and never recovers from it unless you either turn airplane mode on and off (which sometimes works) or power the phone down completely for a few minutes, which has always worked so far.

However, I've had the problem 3 times already today coupled with the message "No SIM Card in Phone" ...... The only way around this is to power down the phone for at least 5 mins and restart.

Anyone have any ideas re this ? Is it a phone, network or even a sim card issue?

Can live with it if it happens once a week or so, but multiple times a day is a real pain!!

channelsurfer is offline  
Reply With Quote
sponsored links
Old May 21st, 2010, 10:43 AM   #2 (permalink)
Senior Member
 
DesireMe's Avatar
 
Join Date: May 2010
Location: Strathaven
Posts: 777
 
Device(s): HTC Desire. Miui XJ
Carrier: Not Provided

Thanks: 70
Thanked 79 Times in 62 Posts
Default

No help, but i've never had that issue, not once. I lose signal quite a few times too living in the sticks.
DesireMe is offline  
Reply With Quote
Old May 21st, 2010, 04:28 PM   #3 (permalink)
Senior Member
 
Join Date: Feb 2010
Location: UK
Posts: 2,278
 
Device(s): Nexus 7, Nexus 5, S3, Moto G,
Carrier: EE (Tmobile)

Thanks: 61
Thanked 160 Times in 143 Posts
Default

You could have a faulty SIM. Had one my self a few yaers back doing as you describe.
nx1977 is offline  
Reply With Quote
Old May 26th, 2010, 11:15 PM   #4 (permalink)
New Member
 
Join Date: May 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This happened to me today for the first time. But it automatically went to airplane mode and when I turned it off it came up with the no sim card detected notification. A reboot fixed it, however I did not have to wait 5 mins as you did. I am pretty sure it is not a sim card problem since it was from my old phone which never had similar problems. I currently have the HTC desire with Android 2.1. No idea what caused it though.
troj0 is offline  
Reply With Quote
Old May 26th, 2010, 11:39 PM   #5 (permalink)
New Member
 
Join Date: May 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, not sure if this is the fix ... but it seems to have fixed mine. I turned the sim lock to off, so there is no pin needed to unlock. I think there was a problem where it could not unlock the sim.
troj0 is offline  
Reply With Quote
Old May 27th, 2010, 08:08 AM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Apr 2010
Location: London
Posts: 47
 
Device(s): HTC Sensation - Stock T-Mobile, HTC Desire Rooted with unrevoked 3.21, ROM LeeDroid 2.3d, Radio
Carrier: Not Provided

Thanks: 2
Thanked 9 Times in 8 Posts
Default

Thanks for the input guys ......

troj0, I didn't have my sim card locked so hopefully your fix has solved your problem permanently.

nx1977, I took your advice and contacted T-Mobile who sent me a new SIM card which seems to have cured the issue completely!

The phone and original SIM card was only a month old and sourced from MobilePhonesDirect, so perhaps I just had a duff one.
channelsurfer is offline  
Reply With Quote
The Following 2 Users Say Thank You to channelsurfer For This Useful Post:
goon87 (April 19th, 2011), zenithlt (May 3rd, 2011)
Old May 27th, 2010, 02:52 PM   #7 (permalink)
Senior Member
 
Join Date: Feb 2010
Location: UK
Posts: 2,278
 
Device(s): Nexus 7, Nexus 5, S3, Moto G,
Carrier: EE (Tmobile)

Thanks: 61
Thanked 160 Times in 143 Posts
Default

Glad you got it sorted.
nx1977 is offline  
Reply With Quote
Old May 3rd, 2011, 11:18 AM   #8 (permalink)
New Member
 
Join Date: May 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by channelsurfer View Post
Thanks for the input guys ......

troj0, I didn't have my sim card locked so hopefully your fix has solved your problem permanently.

nx1977, I took your advice and contacted T-Mobile who sent me a new SIM card which seems to have cured the issue completely!

The phone and original SIM card was only a month old and sourced from MobilePhonesDirect, so perhaps I just had a duff one.
I have the same problem. I tryed to change sims and it was same problem, too... So now i`m wondering if tis sim card or the phone...
zenithlt is offline  
Reply With Quote
Old October 19th, 2011, 02:54 PM   #9 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Confused

Quote:
Originally Posted by channelsurfer View Post
I've occasionally suffered from the issue whereby the Desire drops the network signal and never recovers from it unless you either turn airplane mode on and off (which sometimes works) or power the phone down completely for a few minutes, which has always worked so far.

However, I've had the problem 3 times already today coupled with the message "No SIM Card in Phone" ...... The only way around this is to power down the phone for at least 5 mins and restart.

Anyone have any ideas re this ? Is it a phone, network or even a sim card issue?

Can live with it if it happens once a week or so, but multiple times a day is a real pain!!
Had the same with mine today. As it was out of warranty i took it apart to have a look.
As it turns out it is an issue with the design of the simcard reader as far as I can tell. At the back if it there isnt anything stopping the sim card from hitting the battery and going in to far (or at least there wasnt on mine).
After i realized this I put my sim card back in, ensuring that I didnt push it right the way back, It now works.
As far as i can tell there is a little bit of resistance when its in far enough but pushing it to much pushes it past where the reader can read it.
Hope this helps
codeccarus is offline  
Reply With Quote
Old November 6th, 2011, 05:36 AM   #10 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Dud

One of many problems i have encountered with my HD, failed GPS antenna, sent back to HTC for repair, random changes in app settings, ringtones and of course signal dropping out accompanied by the re-starting no sim card message. Im currently with Vodaplank, my wife has the HD with Treemobile works fine, no issues, put our phones together activate GPS hers locates within 3 seconds mine takes up to 30 seconds. Take my sim card out and put it in her phone works first time every time. I think i have a LEMON but i also think the network adaptive software has something to do with it, maybe. What i do know is HTC wont be my first choice at upgrade time and after 10 years with Vodaplank unless they can offer me something truly irresistible neither will they.
simonsca4 is offline  
Reply With Quote
sponsored links
Old June 25th, 2012, 04:34 PM   #11 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up it worked!!!

I love you, Codeccarus, it worked!! thanks a lot for this great tip! ))



Quote:
Originally Posted by codeccarus View Post
Had the same with mine today. As it was out of warranty i took it apart to have a look.
As it turns out it is an issue with the design of the simcard reader as far as I can tell. At the back if it there isnt anything stopping the sim card from hitting the battery and going in to far (or at least there wasnt on mine).
After i realized this I put my sim card back in, ensuring that I didnt push it right the way back, It now works.
As far as i can tell there is a little bit of resistance when its in far enough but pushing it to much pushes it past where the reader can read it.
Hope this helps
milivo is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC Desire > Desire - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:33 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.