Go Back   Android Forums > Android Tablets & MIDs > DoDo Pendo Pad

test: Reply
 
LinkBack Thread Tools
Old January 16th, 2011, 06:24 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 1
 
Device(s): Pendo pad, iphone 2,
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Angry pendo pad from dodo

Had it for over a week now, on it now actually. Just a few tech probs I. Need help with as I know bugger all about most things technical.

1. I can't change the time, tried to change the region in settings as well, keeps going back to taiwan?

2. Won't let me set up google account, keeps saying the data connection isn't secure enough and that I'm not set up for data services but the internet works excellent. Can't. Access Android market because of above reason.

3. The pad turns off all the time for no reason what so ever, is it faulty or a common problem?

Can anyone help me with these issues? Please?
Other than the above problems its a great little device and I use it more than my laptop

Cheers, jlee87.

P.s I tried a hard reset but it done nothing to help

Advertisements
jlee87 is offline  
Reply With Quote
sponsored links
Old January 24th, 2011, 06:30 PM   #2 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i would send it back to dodo, note; its 2.1 os (not 2.2) as previously incorrectly advertised, sounds faulty, my pad doesnt turn off and all good with google account, and settings for date/time
jazzmine66 is offline  
Reply With Quote
Old May 11th, 2011, 02:37 AM   #3 (permalink)
New Member
 
Join Date: May 2011
Posts: 2
 
Device(s): Dodo Pendo Pad
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Definitely sounds faulty, have either of you two had issues hooking your pad's up to the net? Mine connects for 3 seconds and then disconnects, restarts the modem and does it all again.
Eltombrae is offline  
Reply With Quote
Old November 1st, 2011, 10:18 PM   #4 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've had my pendo pad for three weeks and all was going well, none of the problems mentioned above but, this morning, it all happened! Kept on disconnecting, couldn't log on. Rang Dodo Support and eventually they suggested a Factory Reset. Did that, no improvement so they suggested I return it (the whole kit and caboodle)to them "for testing". If it's faulty they said they'd replace it so I'm hoping I get a new one. I really got to love my little Pendo Pad and had installed lots of apps etc (unfortunately all lost in the reset but I'll be able to get them back). Good luck with your problems.
Dragonwyk is offline  
Reply With Quote
Reply
Tags
dodo, pendo, pendo pad


Go Back   Android Forums > Android Tablets & MIDs > DoDo Pendo Pad
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:22 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.