Go Back   Android Forums > Android Phones > Motorola Droid > Droid - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old September 2nd, 2010, 08:07 AM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2010
Location: Texas
Posts: 172
 
Device(s): Moto Droid (OG), Nook Color, GNexus, Note 7.7, GSIII
Carrier: Not Provided

Thanks: 41
Thanked 6 Times in 6 Posts
Default paid apps don't update?

So I rooted and rommed (bb .4) about a month ago. No major issues, it all seems good, except for one thing-

When ever I update notice for one of my paid apps, it won't update - it goes to the google checkout and wants me to pay again. Should I e-mail the app developer? Or is this a known issue with root & roms, with a work around?

Help?

Jerry

Jerry-rigged is offline  
Reply With Quote
sponsored links
Old September 2nd, 2010, 03:36 PM   #2 (permalink)
Antidisestablishmentarian
 
johnlgalt's Avatar
 
Join Date: Oct 2009
Location: 3rd Rock
Gender: Male
Posts: 9,396
 
Device(s): Motorola® DROID® BIONIC®
Carrier: VZW

Thanks: 2,168
Thanked 1,918 Times in 1,362 Posts
Send a message via ICQ to johnlgalt Send a message via MSN to johnlgalt Send a message via Yahoo to johnlgalt Send a message via Skype™ to johnlgalt johnlgalt@gmail.com
Default

Not a known issue - your paid apps are connected to your Google account that you first registered your phone with.

If you performed a factory reset, and then use a different Google account when setting up the phone, your paid apps will not show as having been paid anymore.

You have to set up the same account as the primary account in order for that to work the way it is supposed to.
__________________

Files for the Motorola® DROID® BIONIC®:
Motorola USB drivers v5.9.0 | Motorola RSD Lite v5.7
My DropBox Referral link
johnlgalt is offline  
Reply With Quote
Old October 13th, 2010, 12:43 AM   #3 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 11
 
Device(s): Droid Incredible w/ AMOLED (who knew it would be a limited edition item)
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Notsure Paid app will not update, same problem here...

Ok, so I installed a Froyo Rom and restored a paid app from Titanium backup. I have two google accounts on the phone, one that I use for email and the other that I used to purchase this paid app. No matter what i've tried it always asks me to repurchase for an install or update.

I've tried to remove my other google (non paid app) account. - no luck
I've tried to uninstall and reinstall - no luck
(When I uninstall it even says I can reinstall again for free) Ha!
I've reinstalled from backup and tried to clear data - no luck
Ive sent an email to the developer and he just said to use the same account. - no luck.

I realize that the app is supposed to be tied to the google account I used for purchase but, why won't it let me update when the account is clearly connected and syncing? I did connect my (other) gmail account first and the paid app account second however that's why i tried to remove the mail account and that didn't seem to matter.

Is there a place to specify which google account is being used for authentication or something like that?

The app in question is Remote Wave by Walter Yongtao Wang.

Thanks for any help!

Droid Incredible
Rooted base froyo rom
hobie5 is offline  
Last edited by hobie5; October 13th, 2010 at 12:46 AM. Reason: forgot something
Reply With Quote
Old October 14th, 2010, 11:34 PM   #4 (permalink)
Antidisestablishmentarian
 
johnlgalt's Avatar
 
Join Date: Oct 2009
Location: 3rd Rock
Gender: Male
Posts: 9,396
 
Device(s): Motorola® DROID® BIONIC®
Carrier: VZW

Thanks: 2,168
Thanked 1,918 Times in 1,362 Posts
Send a message via ICQ to johnlgalt Send a message via MSN to johnlgalt Send a message via Yahoo to johnlgalt Send a message via Skype™ to johnlgalt johnlgalt@gmail.com
Default

Quote:
Originally Posted by hobie5 View Post
Ok, so I installed a Froyo Rom and restored a paid app from Titanium backup. I have two google accounts on the phone, one that I use for email and the other that I used to purchase this paid app. No matter what i've tried it always asks me to repurchase for an install or update.

I've tried to remove my other google (non paid app) account. - no luck
I've tried to uninstall and reinstall - no luck
(When I uninstall it even says I can reinstall again for free) Ha!
I've reinstalled from backup and tried to clear data - no luck
Ive sent an email to the developer and he just said to use the same account. - no luck.

I realize that the app is supposed to be tied to the google account I used for purchase but, why won't it let me update when the account is clearly connected and syncing? I did connect my (other) gmail account first and the paid app account second however that's why i tried to remove the mail account and that didn't seem to matter.

Is there a place to specify which google account is being used for authentication or something like that?

The app in question is Remote Wave by Walter Yongtao Wang.

Thanks for any help!

Droid Incredible
Rooted base froyo rom
Hmmm, perhaps it is the fact that it is being restored from TiBu? Normally that does not matter, but since it let's you reinstall it after uninstalling it, just uninstall it and then let the market allow you to reinstall it.
johnlgalt is offline  
Reply With Quote
Old October 15th, 2010, 10:16 PM   #5 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 11
 
Device(s): Droid Incredible w/ AMOLED (who knew it would be a limited edition item)
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by johnlgalt View Post
Hmmm, perhaps it is the fact that it is being restored from TiBu? Normally that does not matter, but since it let's you reinstall it after uninstalling it, just uninstall it and then let the market allow you to reinstall it.
Sorry for not being clear on that. No matter if I try to install or update it asks for payment again. This is the only app I've purchased so far so I have nothing else to test with. The only way I've been able to "reinstall" is by restoring from backup.
hobie5 is offline  
Last edited by hobie5; October 15th, 2010 at 10:19 PM. Reason: forgot something
Reply With Quote
Old October 16th, 2010, 03:29 PM   #6 (permalink)
Antidisestablishmentarian
 
johnlgalt's Avatar
 
Join Date: Oct 2009
Location: 3rd Rock
Gender: Male
Posts: 9,396
 
Device(s): Motorola® DROID® BIONIC®
Carrier: VZW

Thanks: 2,168
Thanked 1,918 Times in 1,362 Posts
Send a message via ICQ to johnlgalt Send a message via MSN to johnlgalt Send a message via Yahoo to johnlgalt Send a message via Skype™ to johnlgalt johnlgalt@gmail.com
Default

That's weird. Check your Google account settings online and see if it lists the app as being paid or not.

If not, then try to see if you perhaps purchased it at a third party site, rather than Android Market...
johnlgalt is offline  
Reply With Quote
Old October 16th, 2010, 04:29 PM   #7 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 11
 
Device(s): Droid Incredible w/ AMOLED (who knew it would be a limited edition item)
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by johnlgalt View Post
That's weird. Check your Google account settings online and see if it lists the app as being paid or not.

If not, then try to see if you perhaps purchased it at a third party site, rather than Android Market...
Yeah it's the strangest thing. I didn't even know you could see your purchase history inside the google account until you mentioned it. I looked online and it does show up there. I just tried to change the password on my account and did a battery pull out of desperation. Do you think it could have something to do with the fact that I cancelled the credit card I used to originally purchase? Walter got his money so I can't imagine that would be the case. It has to be related to the rom I used or the way I backed up.
hobie5 is offline  
Reply With Quote
Old October 17th, 2010, 10:20 PM   #8 (permalink)
Antidisestablishmentarian
 
johnlgalt's Avatar
 
Join Date: Oct 2009
Location: 3rd Rock
Gender: Male
Posts: 9,396
 
Device(s): Motorola® DROID® BIONIC®
Carrier: VZW

Thanks: 2,168
Thanked 1,918 Times in 1,362 Posts
Send a message via ICQ to johnlgalt Send a message via MSN to johnlgalt Send a message via Yahoo to johnlgalt Send a message via Skype™ to johnlgalt johnlgalt@gmail.com
Default

Hmmm, you could make a full TiBu backup, then perform a factory reset, then log in to your account and see if the apps restore automatically. It might be that TiBu doesn't play nicely with that particular app....

That is the only thing I can think of. Oh, since you canceled the credit card linked to the account, try just linking another card to it...

Since the payment has already been processed it really shouldn't matter, but since you don't ahve a card attached to the account, that *may* be causing you and issue - and that means it is time to contact Google, b/c that should never be a factor.
johnlgalt is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Motorola Droid > Droid - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:40 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.