Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - All Things Root
Droid X - All Things Root Rooting, ROMS, Overclocking, etc.

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old March 21st, 2012, 03:57 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default z4root apk crashing on rooting shell extension

I just SBF'd back to .621, then went to the milestone 604 through linux. Now, installed the z4root apk 1.3.0. It gets to the rooting shell extension then crashes. it then refuses to reopen. I tried it in airplane mode right off the bat. It say is does not root gingerbread, but the 604 build is not listed as one of the ones it will not work on. I have to do a factory reset through the recovery and not through the privacy/factory reset option in the phone because that crashes to,only after running the z4root apk. Any suggestions obn what to use to root milestone 604? I tried the link posted in the "wheres z4roo" thread, but it won't let me download the file, keeps wanting me to download avs video. I don't want avs video...lol I am on windows 7 64 bit if that helps. Maybe a link to the 64 bit pc version of z4root will work and not the apk? When I use the 32bit version for from the one included in the milestone 604 pack, it tells me it cant find the path....

Droidxxxxx is offline  
Reply With Quote
sponsored links
Old March 21st, 2012, 06:10 PM   #2 (permalink)
Member
 
WhoDoo Voodoo's Avatar
 
Join Date: Mar 2012
Location: Bad News
Posts: 283
 
Device(s): PLASMA ROM @ http://androidforums.com/verizon-galaxy-s3-all-things-root/696581-plasmarom-iv.html#pos
Carrier: Verizon

Thanks: 28
Thanked 98 Times in 71 Posts
Default Z4 root will not work on .604

Only Zerg will. If you got jacked up using Z4 then you probably have to start over again.
WhoDoo Voodoo is offline  
Reply With Quote
Old March 21st, 2012, 06:59 PM   #3 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Ok...so there is a difference then...its confusing because in the two sets of files listed in the skeleten thread, there is a folder inside the zip that is called DooMLoRD...inside is z4 to be ran from a pc I presume..it can't find the path..I am certain it is z4. Any knowledge on where to get the proper root program? Zerg is not z4 then correct?
Droidxxxxx is offline  
Last edited by Droidxxxxx; March 21st, 2012 at 07:03 PM.
Reply With Quote
Old March 21st, 2012, 07:04 PM   #4 (permalink)
Member
 
WhoDoo Voodoo's Avatar
 
Join Date: Mar 2012
Location: Bad News
Posts: 283
 
Device(s): PLASMA ROM @ http://androidforums.com/verizon-galaxy-s3-all-things-root/696581-plasmarom-iv.html#pos
Carrier: Verizon

Thanks: 28
Thanked 98 Times in 71 Posts
Default Doomlord is the one you want

What you do is make sure USB debugging is enabled in the settings, then set your phone to "charge only" when connected through USB. Unzip Doomlord Zergrush on your desktop. Go into the folder that is unzipped and double click the .bat file. It will attempt to recognize your phone. If it does, you should be good to go. Download Root Check from the market to verify.
WhoDoo Voodoo is offline  
Reply With Quote
Old March 21st, 2012, 07:11 PM   #5 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Ok, thanks for the info..will try again when I get home. The directions say to have usb debugging enabled not disabled but will give that a shot.

Edit: it say nothing about charge mod...that's where im going wrong, because I do have debuggingenabled...thanks again
Droidxxxxx is offline  
Last edited by Droidxxxxx; March 21st, 2012 at 07:22 PM.
Reply With Quote
Old March 21st, 2012, 07:20 PM   #6 (permalink)
Member
 
WhoDoo Voodoo's Avatar
 
Join Date: Mar 2012
Location: Bad News
Posts: 283
 
Device(s): PLASMA ROM @ http://androidforums.com/verizon-galaxy-s3-all-things-root/696581-plasmarom-iv.html#pos
Carrier: Verizon

Thanks: 28
Thanked 98 Times in 71 Posts
Default

No you DO want to have it enabled. And it must say charge only on your top of the screen pulldown. If you can see the sdcard in windows explorer, then Zergrush won't recognize the device.
WhoDoo Voodoo is offline  
Reply With Quote
Old March 21st, 2012, 07:30 PM   #7 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Gotchya..I had it in hard drive mod...will change to charge only and try again.. S~
Droidxxxxx is offline  
Reply With Quote
Old March 21st, 2012, 09:18 PM   #8 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Dang, tried it in charge only mode but still get the multiple wrong path errors. I am trying to post a screen shot of what the errors are..
Droidxxxxx is offline  
Reply With Quote
Old March 21st, 2012, 09:23 PM   #9 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Ok, maybe this will work.. here is a screen shot jpg.
Attached Images
File Type: jpg screeny.jpg (385.0 KB, 9 views)
Droidxxxxx is offline  
Reply With Quote
Old March 21st, 2012, 09:56 PM   #10 (permalink)
Member
 
WhoDoo Voodoo's Avatar
 
Join Date: Mar 2012
Location: Bad News
Posts: 283
 
Device(s): PLASMA ROM @ http://androidforums.com/verizon-galaxy-s3-all-things-root/696581-plasmarom-iv.html#pos
Carrier: Verizon

Thanks: 28
Thanked 98 Times in 71 Posts
Default Yikes

That was what it was doing to me before I reinstalled the .621 sbf. I would wipe it clean, re sbf .621 then re sbf .604. It will take about 45 minutes, but at least at that point you know it will take. If it makes you feel any better it took me about 6 hours on Sunday to figure it all out.
WhoDoo Voodoo is offline  
Reply With Quote
sponsored links
Old March 21st, 2012, 10:06 PM   #11 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Well, since Ubunto is new to me, it's kinda fun... I'll give it another whirl then.. at least someone else has gotten my same errors and made it through.
Droidxxxxx is offline  
Reply With Quote
Old March 22nd, 2012, 12:06 AM   #12 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Well, this thing is kicking my tail.. time for bed.. lol I wiped the phone through the recovery, sbf'd back to 621... immediatley shut it down, rebooted bootloader and sbf'd 604. I do notice it changes from 2.3.4 to version 2.3.5 once it is a milestone.. Is that right? Why would the newer 621 be version 2.3.4 and the older 604 be 2.3.5? Either way, if thats susposed to be like that, then I am stumped.. I tried to re run the DoomLord zip that came with the sbf download by clicking on therunme.bat... it keeps giving me that error I posted... even tried it on a different pc..... is anyone else having luck with the rooting part? I am sure I'm following the directions... Is there any way (VooDoo) that you could put the actual zerg file you used? I have downloaded it a few times.. not sure if maybe its messed up somehow... I was really hoping to be back on my r2d2 rom tonight..
Droidxxxxx is offline  
Last edited by Droidxxxxx; March 22nd, 2012 at 12:12 AM.
Reply With Quote
Old March 22nd, 2012, 03:26 PM   #13 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Still a no go.... same errors. Has this been successful for anyone else? I haven't really seen any "success" threads.. just won't take the root. Using the one downloaded called DooMLoRD v4...I tried wiping several times, then went to 621, restarted it, loaded google account, let it chill for a bit, the flashed 604... tried to immediatley root and the same results.. nothing.
Droidxxxxx is offline  
Reply With Quote
Old March 22nd, 2012, 03:39 PM   #14 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default 621 to 604 success, not with root though

Still getting the same errors even after a few wipes. Wiped it multiple times, went to 621, all good there, went to 604, all good there, but the DooMLoRD v4 is not rooting my device. Is it possible that some may work and others won't? Just has me baffled. Would flashing from a "live" usb not be as good as flashing from an installed copy of Ubunto? Seems to work fine from the usb... but when I go into windows to do the root, no dice..what am I missing?
Attached Images
File Type: jpg screeny.jpg (385.0 KB, 2 views)
Droidxxxxx is offline  
Reply With Quote
Old March 22nd, 2012, 03:45 PM   #15 (permalink)
Senior Member
 
ylexot's Avatar
 
Join Date: Apr 2010
Location: Saint Inigoes, MD
Posts: 2,336
 
Device(s): VZW Galaxy S3, Transformer Prime, Droid X (ret)
Carrier: Not Provided

Thanks: 17
Thanked 403 Times in 324 Posts
Default

There's no need to create a new thread for the same issue. In fact, it is counter-productive because people who have been helping in one thread may not see the new thread. Threads merged.
ylexot is offline  
Reply With Quote
Old March 22nd, 2012, 03:59 PM   #16 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Oh ok, my bad.. I just realized the title of this thread sounds like I am using the APK through the phone, which I did try, but it get half way then botches up the phone, needing a sbf. Only tried that a few times, but didn't want folks to think it was because of the APK. I have been trying it through the DoomLoRd v4 root that came in the zip. Has the method layed out worked for you?
Droidxxxxx is offline  
Reply With Quote
Old March 22nd, 2012, 04:01 PM   #17 (permalink)
Member
 
WhoDoo Voodoo's Avatar
 
Join Date: Mar 2012
Location: Bad News
Posts: 283
 
Device(s): PLASMA ROM @ http://androidforums.com/verizon-galaxy-s3-all-things-root/696581-plasmarom-iv.html#pos
Carrier: Verizon

Thanks: 28
Thanked 98 Times in 71 Posts
Default All I can think of is

A) You have a corrupt downloaded file somewhere
B) Reenable USB debugging
C) Double check before you root that you can install non market programs
D) And make sure that the USB connection is set to charge only.
WhoDoo Voodoo is offline  
Reply With Quote
Old March 22nd, 2012, 04:14 PM   #18 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Ok, rechecked all settings... installed a non market app just fine, toggled debugging, everything except redownload. I will try to do that and flash back. Do you do any wiping or factory resetting in between flashing the 621 to 604? I've tried not doing that and doing that. One thing I am noticing, when I do a factory data reset, it is not making me reactivate the phone.. I seem to remember it prompting for this after wiping and such.. could be the remenance you spoke of. I was also thinking, maybe it has been backing up my setting to google, so I tried it with and without google account active. One thread I read, said he flashed 621, loaded google account, flashed or patched to 604... when I do that I notice all settings roll over.
Droidxxxxx is offline  
Reply With Quote
Old March 22nd, 2012, 09:10 PM   #19 (permalink)
Senior Member
 
ylexot's Avatar
 
Join Date: Apr 2010
Location: Saint Inigoes, MD
Posts: 2,336
 
Device(s): VZW Galaxy S3, Transformer Prime, Droid X (ret)
Carrier: Not Provided

Thanks: 17
Thanked 403 Times in 324 Posts
Default

Quote:
Originally Posted by Droidxxxxx View Post
Oh ok, my bad.. I just realized the title of this thread sounds like I am using the APK through the phone, which I did try, but it get half way then botches up the phone, needing a sbf. Only tried that a few times, but didn't want folks to think it was because of the APK. I have been trying it through the DoomLoRd v4 root that came in the zip. Has the method layed out worked for you?
I can change the title for you if you'd like me to. Just let me know what you want to change it to.

Sent from my Transformer Prime TF201 using Tapatalk
ylexot is offline  
Reply With Quote
Old March 22nd, 2012, 09:38 PM   #20 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

Sure ok.. how about "621 to 604 root method cant find path"
Droidxxxxx is offline  
Reply With Quote
sponsored links
Old March 22nd, 2012, 09:46 PM   #21 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

OMG, I'm such an idiot.... Unzipping the file worked.... I was trying to run it from inside the zip... lol u can just delete the whole post..lol unless others can learn from my mistake... thanks a bunch for putting up w me..
Droidxxxxx is offline  
Reply With Quote
Old March 22nd, 2012, 09:49 PM   #22 (permalink)
Member
Thread Author (OP)
 
Join Date: Feb 2012
Posts: 174
 
Device(s): Droid 4
Carrier: Not Provided

Thanks: 55
Thanked 7 Times in 7 Posts
Default

root succesful!!!!
Droidxxxxx is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:43 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.