Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old July 15th, 2010, 07:17 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 28
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 7 Times in 1 Post
Default Computer won't recognize phone

I plugged my Droid X into my computer to try and transfer a video I took today.

It came up with a Motorola "CD ROM" drive. I clicked the setup file, installed it, then switched my phone to USB Storage. Windows tried installing the drivers and said there was an error. Now when I connect my phone to the computer nothing happens besides windows saying theres an unknown device.

Thoughts?

Kadgarth is offline  
Reply With Quote
sponsored links
Old July 15th, 2010, 07:49 PM   #2 (permalink)
Member
 
Join Date: May 2010
Location: Tennessee
Posts: 165
 
Device(s): Droid X
Carrier: Not Provided

Thanks: 59
Thanked 23 Times in 13 Posts
Default

I had to install this to get it all to work: Motorola Media Link - Motorola USA

Don't think it's suppose to be needed when you select 'USB Mass Storage' but with that, it installs all the drivers for "PC Mode" and all.
Sek0n is online now  
Reply With Quote
Old July 15th, 2010, 08:36 PM   #3 (permalink)
pdk
New Member
 
Join Date: Jul 2010
Posts: 12
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

see my response in this post.


http://androidforums.com/support-troubleshooting-droid-x/122660-charge-x-bettery-through-laptop-using-supplied-usb-cable.html
pdk is offline  
Reply With Quote
Old July 15th, 2010, 09:23 PM   #4 (permalink)
Member
 
Join Date: May 2010
Location: Tennessee
Posts: 165
 
Device(s): Droid X
Carrier: Not Provided

Thanks: 59
Thanked 23 Times in 13 Posts
Default

Just want to point out that mine charged when plugged in, but didn't detect the phone in windows for a drive, and it had that disabled by default already. (which should be disabled for everyone by default I would think)

Would rather have had that be my solution though, instead of installing that software.
Sek0n is online now  
Reply With Quote
Old July 16th, 2010, 06:48 AM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 28
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 7 Times in 1 Post
Default

Installing the Moto program worked for me. Debugging hadn't been enabled.
Kadgarth is offline  
Reply With Quote
Old July 20th, 2010, 02:01 PM   #6 (permalink)
New Member
 
Join Date: Jul 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Fix for computer won't see the droid

Try taking out the battery and putting it back in, that worked perfect for me. Came right up.
Cinderella77 is offline  
Reply With Quote
Old July 29th, 2010, 10:59 PM   #7 (permalink)
Be nice!
 
Steven58's Avatar
 
Join Date: Feb 2010
Location: New Jersey, USA
Gender: Male
Posts: 32,290
 
Device(s): AOKP 4.4.2 (Kit Kat)
Carrier: Verizon

Thanks: 8,567
Thanked 26,456 Times in 6,829 Posts
Default

I tried the software from motorola, pulling the battery, unchecking debug, uninstalling my task killer. NOTHING. sigh. I wanted to try root tonight. It's not meant to be, for now, at least. I've done all the steps and I'm clueless. I had no trouble with my dinc. Oh and btw, it won't charge via usb either.

Edit: the cord charges when it's plugged into the wall, but do you think something's wrong with the cord?

On another note, the PC says that "unknown device" returned a faulty message or something?

I was going to try to root tonight. I'm disappointed.
__________________
==============================


My old signature went here ^^
Steven58 is offline  
Last edited by Steven58; July 29th, 2010 at 11:14 PM.
Reply With Quote
Old July 30th, 2010, 07:00 PM   #8 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default disk not readable

When I connect my Droid X to my MacBook a message comes up that says "The disk you inserted was not readable by this computer".
I get the USB connection symbol at the top of the X but can not make a connection via the USB cable.
Suggestions please
par72 is offline  
Reply With Quote
Old July 30th, 2010, 07:12 PM   #9 (permalink)
Senior Member
 
jreed2560's Avatar
 
Join Date: Dec 2009
Location: Tennessee
Gender: Male
Posts: 3,914
 
Device(s): HTC Droid DNA Employee Edition
Carrier: Verizon Wireless

Thanks: 560
Thanked 448 Times in 303 Posts
jreed2560@gmail.com
Default

Quote:
Originally Posted by Steven58 View Post
I tried the software from motorola, pulling the battery, unchecking debug, uninstalling my task killer. NOTHING. sigh. I wanted to try root tonight. It's not meant to be, for now, at least. I've done all the steps and I'm clueless. I had no trouble with my dinc. Oh and btw, it won't charge via usb either.

Edit: the cord charges when it's plugged into the wall, but do you think something's wrong with the cord?

On another note, the PC says that "unknown device" returned a faulty message or something?

I was going to try to root tonight. I'm disappointed.
is there a chance at all that you have another micro usb cord? I know it sounds weird, but when I was rooting my eris(or rather unrooting it) I was using the standard cable that came with the phone. I couldn't get adb to work at all. I went thru all the steps over a dozen times. I gave up and the next day I tried again, this time I used a different cable (left the standard one in my room cuz I charged it over night) and everything worked the very first time. I used the same port, on the same pc, with the same settings, and same phone set up. The ONLY thing that was different with the cable. I later tried doing something thru adb again with the stock cable. No go. tried the other cable immediately after worked like a champ.
jreed2560 is offline  
Reply With Quote
Old April 24th, 2011, 12:51 AM   #10 (permalink)
New Member
 
Join Date: Apr 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

mine did that...said when iplugged it in, it was charging, and in removable disk M: / and when i went to find a picture, i checked M:/ and the computer said please insert disk into M: / ...it's making me mad, so solutions??
lexihoward is offline  
Reply With Quote
sponsored links
Old May 3rd, 2011, 12:11 PM   #11 (permalink)
New Member
 
Join Date: May 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a similar connection problem with my Droid 2. The USB cable that came with a charger wouldn't connect after trying numerous suggestions on this site. After seeing some cable references in this forum, I went back to the USB cable that came with my Droid and it instantly connected to my laptop.
Carol202 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:51 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.