Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - Support and Troubleshooting

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old September 25th, 2010, 03:44 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jul 2010
Posts: 30
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 5 Times in 4 Posts
Default The application settings (process com.android.settings) has stopped unexpectedly. please try again.

Interesting. On my Droid X, I get this message when I tap the battery icon while my phone is plugged in to the wall charger. Displays this message, then gives me the icon to force close. When I unplug the phone, it's normal and shows me the information such as time since unplugged as well as the normal information about percentages for what applications have used battery on the phone.

I am running (2.2 froyo stock). No modifications or leaked downloads have been used on this phone. Have not reached anywhere near a 70 application milestone as well. Also have done a factory reset once now, as to correct this problem...but still persists.

Curious if anyone else is experiencing this problem, as I have read of this for a few different android devices (i.e. evo 4g and an epic).

CCCC is offline  
Reply With Quote
The Following User Says Thank You to CCCC For This Useful Post:
sexylover1 (December 27th, 2011)
sponsored links
Old September 25th, 2010, 03:53 PM   #2 (permalink)
RHS
Junior Member
 
Join Date: Aug 2010
Posts: 36
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

I noticed mine doing that today, but with it unplugged. After waiting awhile, it works again.
RHS is offline  
Reply With Quote
Old September 30th, 2010, 11:44 PM   #3 (permalink)
New Member
 
Join Date: Sep 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

same problem, unplugged
dlim98 is offline  
Reply With Quote
Old October 4th, 2010, 01:00 PM   #4 (permalink)
New Member
 
Join Date: Oct 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem here

I also get this message, but it's when the phone is not charging. I did pull the battery for a minute and when I restarted the phone everything is working fine for the moment.
mpalsson is offline  
Reply With Quote
Old October 4th, 2010, 01:33 PM   #5 (permalink)
Senior Member
 
Join Date: May 2010
Posts: 3,335
 
Device(s): Moto X, Nexus 7
Carrier: Not Provided

Thanks: 89
Thanked 1,543 Times in 794 Posts
Default

This is a widespread problem and there are lots of threads on it.

Theories on why are varied but many people agree that if there is no battery data for the phone to show you (i.e. it is plugged in, or was only just unplugged), the application will force close.
binary visions is offline  
Reply With Quote
Old October 4th, 2010, 02:49 PM   #6 (permalink)
Senior Member
 
Hrethgir's Avatar
 
Join Date: Feb 2010
Location: Salem, OR
Gender: Male
Posts: 1,670
 
Device(s): Samsung Galaxy SIII, Motorola Droid X-retired, Apple iPhone 3Gs-retired, B&N Nook-rooted
Carrier: Verizon

Thanks: 96
Thanked 220 Times in 175 Posts
Default

I get this all the time, even after the phone has been off the charger for hours. Then it will suddenly work, and even though it had been FCing all day, it will know how long it had been unplugged and what apps had been using the battery. It seems like the underlying program is working fine, but whatever part of the battery monitor displays the info has a glitch of some kind.
__________________
Apple -> Android convert
Hrethgir is offline  
Reply With Quote
Old October 4th, 2010, 10:04 PM   #7 (permalink)
Wug
New Member
 
Join Date: Oct 2010
Posts: 6
 
Device(s): Model: DROID X Android Version: Froyo 2.2 OTA System Version: 2.3.15.MB810.Verizon.en.US Rooted
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Model: DROID X
Android Version: Froyo 2.2 OTA
System Version: 2.3.15.MB810.Verizon.en.US
Root status: Rooted

This problem has been really bugging me, with no solution posted anywhere on forums. I spent forever trying to figure out a way to fix the Force Close battery problem; "com.android.settings has stopped unexpectedly..."

I found a solution; at least I think so (it could just be a coincidence):

1. Download Super Battery by tobyyaa.
2. Install it
3. Charge with it open (or maybe not even, I haven't tried any other way):
4. When its done, unplug it with Super Battery still open.
5. Close out of Super Battery (via back key or home button)
6. Now try out the android battery monitor --> it should work now, and keep working!
7. The only drawback so far is it seems that super battery might actually drain the battery according to the android battery monitor (but I don't think its really accurate, because my battery is running really well, better than it ever has before; I think that maybe it displays this because the program was open when I was charging)

--Does this solution work for any of you, or did I just get lucky and the glitch randomly stopped for me?

Hope this helps.

Check out the other apps I use and love:
MyApps at AppBrain.com
Wug is offline  
Reply With Quote
Old October 24th, 2010, 11:28 PM   #8 (permalink)
Wug
New Member
 
Join Date: Oct 2010
Posts: 6
 
Device(s): Model: DROID X Android Version: Froyo 2.2 OTA System Version: 2.3.15.MB810.Verizon.en.US Rooted
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

UPDATE

Ignore my "solution" its false. It just happened to start working again for a little. Also superbattery is wack, dont download it.
Wug is offline  
Reply With Quote
Old November 15th, 2010, 03:57 PM   #9 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i am getting the same error message when i receive calls and when i go to sounds. I have a huawei ascend and i have only had it for a week and i can't hear anything on my phone through speaker it doesn't even ring or play music this is really making the phone useless do anyone have any idea how to get this working, i have already taken the battery out millions of times and i have uninstalled all apps that i downloaded!
TKWEBB4 is offline  
Reply With Quote
Old December 3rd, 2010, 10:45 AM   #10 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

I had the same issue. I've had the phone a week. When I'd get a call it would pop up and not let me answer it. I had to do a complete factory reset and so far it's fixed it. No issues. Hopefully it will stay that way. One possible reason might be an ap I downloaded called AVG antivirus. I installed it again, then read some bad posts on it and uninstalled it. Fingers crossed.
spankyward is offline  
Reply With Quote
sponsored links
Old December 16th, 2010, 08:44 PM   #11 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same issue.

When I get the error.

I went to my contacts. Found who i wanted to call. Tapped it. gets me to the details of the contact. tap the phone number. and thats when i got the error.

It seemed to be on only that contact. if it happens more I can post.

I really want to like this new android phone, but i am really beginning to wonder...............

I've been spending the last week trouble shooting...
cloud2or3 is offline  
Reply With Quote
Old December 23rd, 2010, 01:34 PM   #12 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can some one help me? I am using Froyo 2.2 and APN is not working any time I tried to connect it says process com.android. settings has stopped unexpectedly.
Pentil is offline  
Reply With Quote
Old December 31st, 2010, 07:38 PM   #13 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by spankyward View Post
I had the same issue. I've had the phone a week. When I'd get a call it would pop up and not let me answer it. I had to do a complete factory reset and so far it's fixed it. No issues. Hopefully it will stay that way. One possible reason might be an ap I downloaded called AVG antivirus. I installed it again, then read some bad posts on it and uninstalled it. Fingers crossed.

How long has it been since you did a factory reset?
MarvDawg is offline  
Reply With Quote
Old June 20th, 2011, 06:02 PM   #14 (permalink)
Junior Member
 
Join Date: Mar 2011
Posts: 21
 
Device(s): Samsung Galaxy GT I5500
Carrier: Not Provided

Thanks: 12
Thanked 3 Times in 3 Posts
Default The process com.android.phone has stopped unexpectedly.

Hey Guys,

I'm having the same error message when I try to add an Android Widget. I've tried to take out/in the battery, restart the phone, etc. but the error message is still appearing.

Is there any solution?

Thanks.
ppacie is offline  
Reply With Quote
The Following User Says Thank You to ppacie For This Useful Post:
Old June 23rd, 2011, 05:36 PM   #15 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by CCCC View Post
Interesting. On my Droid X, I get this message when I tap the battery icon while my phone is plugged in to the wall charger. Displays this message, then gives me the icon to force close. When I unplug the phone, it's normal and shows me the information such as time since unplugged as well as the normal information about percentages for what applications have used battery on the phone.

I am running (2.2 froyo stock). No modifications or leaked downloads have been used on this phone. Have not reached anywhere near a 70 application milestone as well. Also have done a factory reset once now, as to correct this problem...but still persists.

Curious if anyone else is experiencing this problem, as I have read of this for a few different android devices (i.e. evo 4g and an epic).
I get the message when I try to add a widget to my home screen on my Samsung Gem. It's a new phone for me, only had it a week, and I definately have nowhere NEAR 70 apps, I think I have 10!! I don't want to master reset it......seems like too much of a problem, especially if it doesn't work!!
traumajunky is offline  
Reply With Quote
Old July 11th, 2011, 12:55 PM   #16 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 5 Times in 1 Post
Default

I received the "process com.android.settings has stopped" error message whenever I tried to add widgets by long-pressing on Home screen then choosing "widget" from popup box. None of the other choices (Shortcuts, Folders, Wallpapers) caused this error, only Widgets.
The way I got rid of this annoying message was to go to Menu/Settings/Applications/Manage Applications/Map/Uninstall Updates
I had updated my Google maps a week or so before so I did not associated that as the cause of my error dialog box.
Now I can add widgets again but am back to the basic Google Map that came with phone. Seems Google map update causes the problem on my Samsung.
iagman is offline  
Reply With Quote
The Following 5 Users Say Thank You to iagman For This Useful Post:
ctar (July 14th, 2011), eltsirg (July 22nd, 2011), fear2falter (July 26th, 2011), ibanut (September 30th, 2012), moazzamkhan (July 19th, 2011)
Old July 22nd, 2011, 02:03 AM   #17 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Same symptom, same fix.
Using Telstra T3020.
eltsirg is offline  
Reply With Quote
Old July 25th, 2011, 12:53 PM   #18 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by iagman View Post
I received the "process com.android.settings has stopped" error message whenever I tried to add widgets by long-pressing on Home screen then choosing "widget" from popup box. None of the other choices (Shortcuts, Folders, Wallpapers) caused this error, only Widgets.
The way I got rid of this annoying message was to go to Menu/Settings/Applications/Manage Applications/Map/Uninstall Updates
I had updated my Google maps a week or so before so I did not associated that as the cause of my error dialog box.
Now I can add widgets again but am back to the basic Google Map that came with phone. Seems Google map update causes the problem on my Samsung.
Thank you very much, you saved me a lot of time, I always wipe data and make factory reset.I could not know why it gave me that annoying message with widget install
drtariko is offline  
Reply With Quote
Old July 26th, 2011, 01:53 PM   #19 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by iagman View Post
I received the "process com.android.settings has stopped" error message whenever I tried to add widgets by long-pressing on Home screen then choosing "widget" from popup box. None of the other choices (Shortcuts, Folders, Wallpapers) caused this error, only Widgets.
The way I got rid of this annoying message was to go to Menu/Settings/Applications/Manage Applications/Map/Uninstall Updates
I had updated my Google maps a week or so before so I did not associated that as the cause of my error dialog box.
Now I can add widgets again but am back to the basic Google Map that came with phone. Seems Google map update causes the problem on my Samsung.
Unistalling the updates fixed the problem up, for my little Samsung Gem. Guess we have to wait and hope google map's comes out with a patch to stop this problem.
fear2falter is offline  
Reply With Quote
Old July 27th, 2011, 05:05 AM   #20 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Happy

Quote:
Originally Posted by iagman View Post
I received the "process com.android.settings has stopped" error message whenever I tried to add widgets by long-pressing on Home screen then choosing "widget" from popup box. None of the other choices (Shortcuts, Folders, Wallpapers) caused this error, only Widgets.
The way I got rid of this annoying message was to go to Menu/Settings/Applications/Manage Applications/Map/Uninstall Updates
I had updated my Google maps a week or so before so I did not associated that as the cause of my error dialog box.
Now I can add widgets again but am back to the basic Google Map that came with phone. Seems Google map update causes the problem on my Samsung.
Thanks. it worked
flyonblueskyy is offline  
Reply With Quote
sponsored links
Old September 30th, 2012, 01:48 PM   #21 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

opps, it started again now when i use my usb button, ugh!
ibanut is offline  
Reply With Quote
Old November 9th, 2012, 02:56 AM   #22 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ppacie View Post
Hey Guys,

I'm having the same error message when I try to add an Android Widget. I've tried to take out/in the battery, restart the phone, etc. but the error message is still appearing.

Is there any solution?

Thanks.
my phone has no ring tone witha message PROCESS COM.ANDROID.SETTINGS
subhasunil is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:22 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.