Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old March 17th, 2011, 05:04 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default Home button just flashes black screen

Hey everyone,

I have an unrooted Droid X running Launcher Pro as my homescreen manager. Lately, whenever I press the home button, the screen just flashes black for a second. The only way for me to get out of an application is to keep hitting the back button. I have no idea what is causing this all of a sudden. The only way to fix it is to restart the whole phone a few times and after 5 or 6 tries, I get the home button functionality back. Also, I noticed once that if I try hitting the home button right after boot, before everything starts up, it works. But once the OS loads, the home button no longer works. The only programs that are intentionally set to load at boot are Lookout and SystemPanel, but disabling them has done nothing. I've also disabled Launcher Pro thinking that was the problem, but then the default home screen manager has the same problem. Any suggestions?

Thanks

junior24 is offline  
Reply With Quote
sponsored links
Old March 18th, 2011, 12:48 AM   #2 (permalink)
Be nice!
 
Steven58's Avatar
 
Join Date: Feb 2010
Location: New Jersey, USA
Gender: Male
Posts: 32,291
 
Device(s): AOKP 4.4.2 (Kit Kat)
Carrier: Verizon

Thanks: 8,568
Thanked 26,456 Times in 6,829 Posts
Default

1) Go into Settings-applications-manage applications-all-Launcher Pro

2) In Launcher pro, at the bottom of the screen select "clear defaults". This will unselect LP as your default launcher.

3) Hit home. It will now give you a choice of launchers. Select the other alternative. I think it's called "home?" I forget. Try using that. If you have no problems, you are having a problem with Launcher Pro, which wouldn't surprise me, since it's out of date and expecting a major overhaul. I had lots of problems with it.

4) If you seem to be running better, you can delete Lp or delete and try to reinstall it to see if the file was corrupted somehow.

5) I use "GoLauncher" which in my opinion is now more superior to LP. It's smooth and has more transition options.

6) If none of this works, try a complete factory data reset. You will have to reinstall all your apps from the market, though. To do that, you have to go into settings-privacy. Select Factory data reset and follow the direction.

If, at this point, your phone runs smoothly, you had a problem with software. Be careful with what you install going forward.

7) If this doesn't work, you have a bad phone. Take it back to Verizon.

Let us know how you do.


Steven
__________________
==============================


My old signature went here ^^
Steven58 is offline  
Reply With Quote
The Following User Says Thank You to Steven58 For This Useful Post:
junior24 (March 18th, 2011)
Old March 18th, 2011, 11:13 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

ok great thanks! I'm not having the problem right now, so when it appears again, I'll try disabling LP and go from there and report back. Thanks!
junior24 is offline  
Reply With Quote
Old April 23rd, 2011, 10:26 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Ok, so I tried changing home screen lauchers. I'm using GoLauncher now and it's awesome. I can set it up pretty much exactly like I had LauncherPro, but it's more stable. I just dont like the stock icons it comes with for the dock, and there's not as many of them, but that's ok. Anyway, this didn't fix the problem. So I decided to reset my phone to factory settings as suggested, and rooted my phone while doing so This seemed to fix the problem until my phone completely froze yesterday and I had to pull the battery to reboot. After that, every time I restarted the phone (probably 8 times), the home button would not work.

Then, I think I may have found a solution. I used an app called "Extended Controls" which I LOVE. It just creates a widget where you can toggle wifi/3G/ change brightness/ etc. There is a function on it where you can hit a button and it will disable auto-lock. I use this when I'm at home so that I dont have to keep putting in my password every time I want to use the phone. I need to test it more, but I think that by leaving the "disable auto-lock" button toggled on (so that I dont have to enter password), when I reboot the phone, it causes problems. I think that it might have something to do with the phone booting, then the widget taking over and disabling auto-lock before the phone is fully booted. So far, leaving auto-lock on and not using this feature has fixed the problem for me. I'll report back if the problem comes back.
junior24 is offline  
Reply With Quote
Reply
Tags
black, button, droid x, flash, home, homescreen, quit


Go Back   Android Forums > Android Phones > Motorola Droid X > Droid X - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:07 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.