Go Back   Android Forums > Android Phones > HTC EVO 4G > EVO 4G - All Things Root
EVO 4G - All Things Root Rooting, ROMS, Overclocking, etc.

test: Reply
 
LinkBack Thread Tools
Old March 28th, 2012, 07:23 AM   #1 (permalink)
The TechnoFrog
Thread Author (OP)
 
argedion's Avatar
 
Join Date: Jun 2011
Location: The Severed Garden
Posts: 5,828
 
Device(s): Nexus 7 (2012)
Carrier: Not Provided

Thanks: 6,012
Thanked 5,575 Times in 2,572 Posts
Default I need Advanced Help with Updater-Script

I have downloaded the latest Beats Audio Flash Zip I was wanting to change the updater-script file to mount system and then unmount system and reboot

This is the Original updater-script

Code:
ui_print(" Beats Audio ");
ui_print(" By: RockoDev ");
ui_print(" Installing... ");
package_extract_dir("system", "/system");
ui_print(" Installed ! ");
ui_print(" Reboot Now ! ");
This is what I am wanting to do:

Code:
ui_print(" Beats Audio ");
ui_print(" By: RockoDev ");
ui_print(" Installing... ");
mount("MTD", "system", "/system");
package_extract_dir("system", "/system");
unmount("/system");
ui_print(" Installed ! ");
ui_print(" Rebooting Now..... Goodbye! ");
run_program("/sbin/reboot");
I get the error "Mount is expecting 4 args got 3. I have tried adding a -w to it to hopefully be the argument it needs but I got Error 7 from that then last attemp I got Error 6 tried to take it back as it is above and got bad file so I figured I need to ask

I've tried changing the update-binary as well but get the bad file error message as well. The above mount has worked for me in the past on other projects

Advertisements
__________________
All My Links In one Convenient Place
Asking simple questions can keep us from doing dumb things.
argedion is online now  
Reply With Quote
sponsored links
Old March 28th, 2012, 11:37 AM   #2 (permalink)
Senior Member
 
CapThrowback's Avatar
 
Join Date: Mar 2011
Location: Pwnnsylvania
Gender: Male
Posts: 795
 
Device(s): HTC One (M8), HTC EVO 4G LTE, HTC EVO 4G, HTC EVO 3D
Carrier: Sprint

Thanks: 250
Thanked 1,553 Times in 634 Posts
Send a message via MSN to CapThrowback Send a message via Yahoo to CapThrowback Send a message via Skype™ to CapThrowback captainthrowback
Default

Quote:
Originally Posted by argedion View Post
I have downloaded the latest Beats Audio Flash Zip I was wanting to change the updater-script file to mount system and then unmount system and reboot

This is the Original updater-script

Code:
ui_print(" Beats Audio ");
ui_print(" By: RockoDev ");
ui_print(" Installing... ");
package_extract_dir("system", "/system");
ui_print(" Installed ! ");
ui_print(" Reboot Now ! ");
This is what I am wanting to do:

Code:
ui_print(" Beats Audio ");
ui_print(" By: RockoDev ");
ui_print(" Installing... ");
mount("MTD", "system", "/system");
package_extract_dir("system", "/system");
unmount("/system");
ui_print(" Installed ! ");
ui_print(" Rebooting Now..... Goodbye! ");
run_program("/sbin/reboot");
I get the error "Mount is expecting 4 args got 3. I have tried adding a -w to it to hopefully be the argument it needs but I got Error 7 from that then last attemp I got Error 6 tried to take it back as it is above and got bad file so I figured I need to ask

I've tried changing the update-binary as well but get the bad file error message as well. The above mount has worked for me in the past on other projects
I'll upload the file I created, and you can compare the script and binary, if you'd like (or I can just upload the binary and script). In mine, I also mount data, for those ROMs (Sense 3.5) where the libs reside on the data partition.

Your mount commands look fine, though.
__________________
Device 1: HTC One (M8)/831C | Hardware Version: 0005
Baseband: 1.08.20.0612_4 | PRI: 2.62_003 | PRL: 56019
Recovery: TWRP 2.7.1.0
CapThrowback is offline  
Reply With Quote
The Following 2 Users Say Thank You to CapThrowback For This Useful Post:
argedion (March 28th, 2012), Rxpert83 (March 29th, 2012)
Old March 28th, 2012, 01:26 PM   #3 (permalink)
The TechnoFrog
Thread Author (OP)
 
argedion's Avatar
 
Join Date: Jun 2011
Location: The Severed Garden
Posts: 5,828
 
Device(s): Nexus 7 (2012)
Carrier: Not Provided

Thanks: 6,012
Thanked 5,575 Times in 2,572 Posts
Default

Quote:
Originally Posted by CapThrowback View Post
I'll upload the file I created, and you can compare the script and binary, if you'd like (or I can just upload the binary and script). In mine, I also mount data, for those ROMs (Sense 3.5) where the libs reside on the data partition.

Your mount commands look fine, though.
Hmmm Well its the Nitrous ROM that I'm using with I think is 2.1 because its based of the 4.67 release. but yeah lets see whats going on. I know the mount command works for when building roms and I have changed the update-binary to the latest stock one but still get errors. so I'm just a bit dumbfounded
argedion is online now  
Reply With Quote
Old March 28th, 2012, 01:43 PM   #4 (permalink)
Senior Member
 
CapThrowback's Avatar
 
Join Date: Mar 2011
Location: Pwnnsylvania
Gender: Male
Posts: 795
 
Device(s): HTC One (M8), HTC EVO 4G LTE, HTC EVO 4G, HTC EVO 3D
Carrier: Sprint

Thanks: 250
Thanked 1,553 Times in 634 Posts
Send a message via MSN to CapThrowback Send a message via Yahoo to CapThrowback Send a message via Skype™ to CapThrowback captainthrowback
Default

Quote:
Originally Posted by argedion View Post
Hmmm Well its the Nitrous ROM that I'm using with I think is 2.1 because its based of the 4.67 release. but yeah lets see whats going on. I know the mount command works for when building roms and I have changed the update-binary to the latest stock one but still get errors. so I'm just a bit dumbfounded
When you say latest stock binary, where did you get it from? I was suggesting that you take one from a ROM or kernel zip, because the ones from an official OTA will also likely require 4 arguments. Maybe uploading mine will help you find the difference (but I think it's the update-binary).

P.S. The mounting data shouldn't make a difference either way. It just makes the zip work more universally.

EDIT: updater-script & update-binary attached.
CapThrowback is offline  
Last edited by CapThrowback; April 25th, 2012 at 10:14 AM.
Reply With Quote
The Following User Says Thank You to CapThrowback For This Useful Post:
argedion (March 28th, 2012)
Old March 28th, 2012, 03:51 PM   #5 (permalink)
The TechnoFrog
Thread Author (OP)
 
argedion's Avatar
 
Join Date: Jun 2011
Location: The Severed Garden
Posts: 5,828
 
Device(s): Nexus 7 (2012)
Carrier: Not Provided

Thanks: 6,012
Thanked 5,575 Times in 2,572 Posts
Default

Ok thanks i'll check that one out and see. The update-binary & script that are in the beats came from them, I changed the update-binary from a rom that I have been playing with which was based on the latest OTA and the mount command has worked fine with it for that so don't know
argedion is online now  
Reply With Quote
Old March 28th, 2012, 06:43 PM   #6 (permalink)
The TechnoFrog
Thread Author (OP)
 
argedion's Avatar
 
Join Date: Jun 2011
Location: The Severed Garden
Posts: 5,828
 
Device(s): Nexus 7 (2012)
Carrier: Not Provided

Thanks: 6,012
Thanked 5,575 Times in 2,572 Posts
Default

nope got the same thing. So I started thinking is it the files or is it my recovery (Amon RA Style 3.11) I'm going to flash 2.3 and see if it works then. One more thing I want to ask to make sure I'm not screwing up the Zip is in compression and not in Store mode correct?

EDIT: Flashed back to Amon RA 2.3 got the same error. So that wasn't the issue. Ok so running out of ideas here.
argedion is online now  
Last edited by argedion; March 28th, 2012 at 07:38 PM.
Reply With Quote
Old March 29th, 2012, 11:12 AM   #7 (permalink)
Senior Member
 
CapThrowback's Avatar
 
Join Date: Mar 2011
Location: Pwnnsylvania
Gender: Male
Posts: 795
 
Device(s): HTC One (M8), HTC EVO 4G LTE, HTC EVO 4G, HTC EVO 3D
Carrier: Sprint

Thanks: 250
Thanked 1,553 Times in 634 Posts
Send a message via MSN to CapThrowback Send a message via Yahoo to CapThrowback Send a message via Skype™ to CapThrowback captainthrowback
Default

Quote:
Originally Posted by argedion View Post
nope got the same thing. So I started thinking is it the files or is it my recovery (Amon RA Style 3.11) I'm going to flash 2.3 and see if it works then. One more thing I want to ask to make sure I'm not screwing up the Zip is in compression and not in Store mode correct?

EDIT: Flashed back to Amon RA 2.3 got the same error. So that wasn't the issue. Ok so running out of ideas here.
I don't ever touch the compression of the zip file. I literally just drag and drop the updated binary and script into the file using 7-zip, and I've never had a problem. I can give you my whole zip, if you want. You can try just dropping your script into it and see if it works. I know mine works as-is.
CapThrowback is offline  
Reply With Quote
The Following User Says Thank You to CapThrowback For This Useful Post:
Rxpert83 (March 29th, 2012)
Old March 29th, 2012, 05:20 PM   #8 (permalink)
The TechnoFrog
Thread Author (OP)
 
argedion's Avatar
 
Join Date: Jun 2011
Location: The Severed Garden
Posts: 5,828
 
Device(s): Nexus 7 (2012)
Carrier: Not Provided

Thanks: 6,012
Thanked 5,575 Times in 2,572 Posts
Default

Yeah go ahead and send it. Oh I hadn't messed with the zip other than updating I was just thinking about extracting and seeing if recompressing it would work
argedion is online now  
Reply With Quote
Old March 30th, 2012, 10:01 AM   #9 (permalink)
Senior Member
 
CapThrowback's Avatar
 
Join Date: Mar 2011
Location: Pwnnsylvania
Gender: Male
Posts: 795
 
Device(s): HTC One (M8), HTC EVO 4G LTE, HTC EVO 4G, HTC EVO 3D
Carrier: Sprint

Thanks: 250
Thanked 1,553 Times in 634 Posts
Send a message via MSN to CapThrowback Send a message via Yahoo to CapThrowback Send a message via Skype™ to CapThrowback captainthrowback
Default

Quote:
Originally Posted by argedion View Post
Yeah go ahead and send it. Oh I hadn't messed with the zip other than updating I was just thinking about extracting and seeing if recompressing it would work
Here you go!

BeatsAudiob0314.zip - update-binary & updater-script updated

Let me know if it doesn't work for you for some reason. Maybe it'll help you figure out what's going on with yours.
CapThrowback is offline  
Reply With Quote
The Following User Says Thank You to CapThrowback For This Useful Post:
argedion (March 30th, 2012)
Reply


Go Back   Android Forums > Android Phones > HTC EVO 4G > EVO 4G - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:55 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.