Go Back   Android Forums > Android Phones > HTC Evo 4G LTE > Evo 4G LTE - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree39Likes

test: Reply
 
LinkBack Thread Tools
Old December 12th, 2012, 02:13 AM   #201 (permalink)
Junior Member
 
Join Date: Jul 2010
Posts: 86
 
Device(s):
Carrier: Not Provided

Thanks: 28
Thanked 20 Times in 16 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Did you put the icon on courtesy of an app (for example, Quick System Info Pro does that)? If so, you can remove those in that app's settings.

There was a mod for 4x5 Rosie, but I'll have to check where that is and if it's compatible with this version. I'll also see if I can find out if it's going into the upcoming release. No guarantees but I'll check.
Hey EarlyMon,

I put the Icon on thru the Viper Hub just fooling with it but I can't find a way to remove it. Thanks for checking on the 4x5.

Chris Broderick is offline  
Reply With Quote
sponsored links
Old December 12th, 2012, 02:16 AM   #202 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Did you add an icon or change an existing one?

No problem on the 45.
__________________
|

Minutus cantorum, minutus balorum, minutus carborata descendum pantorum.

Links: Site Rules / Guidelines -and- Zero Tolerance Policy (All Members Read)


For right-on help, the Thanks button is on the right of the post.
For anything out in left field, the /!\ report button is to the left.

Remember, it's our forums and we're all in this together - so let's keep it cool!

Shoot the breeze at the best new gun forum!
EarlyMon is offline  
Reply With Quote
Old December 12th, 2012, 02:19 AM   #203 (permalink)
Junior Member
 
Join Date: Jul 2010
Posts: 86
 
Device(s):
Carrier: Not Provided

Thanks: 28
Thanked 20 Times in 16 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Well, there's this -

http://forum.xda-developers.com/showpost.php?p=32309284&postcount=5995

Still waiting to hear about any other details.
When you get to XDA and click on the link there it's dead.

Thanks for the search though.
Chris Broderick is offline  
Reply With Quote
Old December 12th, 2012, 02:32 AM   #204 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Quote:
Originally Posted by Chris Broderick View Post
When you get to XDA and click on the link there it's dead.

Thanks for the search though.
Sorry about that.
EarlyMon is offline  
Reply With Quote
Old December 12th, 2012, 06:58 AM   #205 (permalink)
Zercron Encrusted Tweezer
 
Granite1's Avatar
 
Join Date: Dec 2010
Location: Pittsburgh, PA
Gender: Male
Posts: 6,481
 
Device(s): EL TEvo, The OG (wife), Hero (retired)
Carrier: Sprint

Thanks: 11,195
Thanked 6,350 Times in 3,386 Posts
Default

I really need to learn to refine my searches. Mine didn't turn up that post.
__________________
"Not everything that counts can be counted, and not everything that can be counted counts." Albert Einstein
Granite1 is offline  
Reply With Quote
Old December 12th, 2012, 12:28 PM   #206 (permalink)
Junior Member
 
Join Date: Jul 2010
Posts: 86
 
Device(s):
Carrier: Not Provided

Thanks: 28
Thanked 20 Times in 16 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Did you add an icon or change an existing one?

No problem on the 45.
The funny thing is the only thing I remember being there was Sprint zone and I thought that was a notification, so I can't remember if I replace something or just put it there initially. Do you have an icon in at the very left of your notification bar?

I checked out my girlfriends phone and it has nothing there (though its running an old MeanRom).

Chris.
Chris Broderick is offline  
Last edited by Chris Broderick; December 12th, 2012 at 12:31 PM.
Reply With Quote
Old December 12th, 2012, 12:53 PM   #207 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Got a screen shot?
EarlyMon is offline  
Reply With Quote
Old December 13th, 2012, 12:16 PM   #208 (permalink)
Junior Member
 
Join Date: Jul 2010
Posts: 86
 
Device(s):
Carrier: Not Provided

Thanks: 28
Thanked 20 Times in 16 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Got a screen shot?
The status bar icon is the Android guy in the upper left hand corner.







I am trying to use Drive to post this but it seems to only give me a broken link so here is the URL:

https://docs.google.com/open?id=0BwYW1jhdv1qba2s5N3d4V2N4VVk
Chris Broderick is offline  
Last edited by Chris Broderick; December 13th, 2012 at 12:18 PM.
Reply With Quote
Old December 13th, 2012, 03:29 PM   #209 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

LoL - that's a new one on me.

I'll ask the guys in a little bit. Viperboy just posted the first stock rooted JB rom, so the team is a little busy at the moment... but soon, promise.
EarlyMon is offline  
Reply With Quote
The Following User Says Thank You to EarlyMon For This Useful Post:
Chris Broderick (December 13th, 2012)
Old December 13th, 2012, 07:53 PM   #210 (permalink)
Junior Member
 
Join Date: Jul 2010
Posts: 86
 
Device(s):
Carrier: Not Provided

Thanks: 28
Thanked 20 Times in 16 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
LoL - that's a new one on me.

I'll ask the guys in a little bit. Viperboy just posted the first stock rooted JB rom, so the team is a little busy at the moment... but soon, promise.
Thats Ok, I will be moving on to JB soon as well so I can deal with it until Viperboys Rom gets the ok.

Chris.
Chris Broderick is offline  
Reply With Quote
sponsored links
Old December 13th, 2012, 08:39 PM   #211 (permalink)
Senior Member
 
jl79's Avatar
 
Join Date: May 2011
Location: U.S.A.
Posts: 567
 
Device(s): HTC EVO 4G LTE
Carrier: Sprint

Thanks: 371
Thanked 134 Times in 89 Posts
Default

I hope Viper gets the Viper Hub & Tweaks into the new JB ROM...that would be so awesome!
jl79 is online now  
Reply With Quote
Old December 14th, 2012, 12:40 AM   #212 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

That will come in Viper4G 3.x - no ETA on that, naturally.

Tweaks needs to be updated by another team member needing to buy a newer HTC to continue the effort.
EarlyMon is offline  
Reply With Quote
Old December 14th, 2012, 12:42 AM   #213 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default mksh (1000) SuperUser Request??

Hi Everyone...

Been on the ROM for a few days...getting comfy...

I saw a SuperUser root request for the following:




I didn't recognize the requesting app/program so I denied temporarily. What is requesting root??

THANKS!!
scudder is offline  
Reply With Quote
Old December 14th, 2012, 03:04 AM   #214 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Ah, the infamous and nefarious mksh.

It's a shell process wanting to run as root to get network connections.

You can deny it.

Details here -

What is "mksh"?
EarlyMon is offline  
Reply With Quote
The Following 3 Users Say Thank You to EarlyMon For This Useful Post:
Granite1 (December 14th, 2012), ocnbrze (December 14th, 2012), scudder (December 14th, 2012)
Old December 14th, 2012, 07:56 PM   #215 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Ah, the infamous and nefarious mksh.

It's a shell process wanting to run as root to get network connections.

You can deny it.

Details here -

What is "mksh"?
Any harm in allowing it?? Just wasn't sure of source as most of the SuperUser permission popups I can understand where they are coming from.
scudder is offline  
Reply With Quote
Old December 14th, 2012, 07:57 PM   #216 (permalink)
Zercron Encrusted Tweezer
 
Granite1's Avatar
 
Join Date: Dec 2010
Location: Pittsburgh, PA
Gender: Male
Posts: 6,481
 
Device(s): EL TEvo, The OG (wife), Hero (retired)
Carrier: Sprint

Thanks: 11,195
Thanked 6,350 Times in 3,386 Posts
Default

I just got an update notification whilst on Viper?

I wonders if this is from Viper or some how from some kind of whitchcraft?

I'll wait and see if it pops back up and take a screenie.
Granite1 is offline  
Reply With Quote
Old December 14th, 2012, 08:53 PM   #217 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default SUGGESTION - Change Viper Quick Settings Icons for Volume and Silent Mode

Hi guys...

Thought I'd post here because I know there are a couple beta testers. I have a suggestion....

The Volume and Silent Mode Quick Settings icon toggles are IDENTICAL in the Viper Tweaks for certain toggle modes (OF COURSE the mode that I want on at the same time!):



I just wanted to suggest changing one of the icons. One could figure it out after a few tap tap taps in the notification pull down but would be nice to just tell the difference on first glance.

THANKS!!
scudder is offline  
Reply With Quote
Old December 20th, 2012, 12:42 PM   #218 (permalink)
Senior Member
 
CriticalCritic's Avatar
 
Join Date: Nov 2009
Location: Cary, NC
Posts: 1,884
 
Device(s): Home-OG Evo // Me-LTEvo // Wife-OG Evo // Son-LG Opt S
Carrier: Not Provided

Thanks: 980
Thanked 563 Times in 313 Posts
Default

So I've been running Viper 1.0.0 this entire time. Then two days ago my battery inexplicably drained dead in 7 hours (I was not using it), and when I restarted my phone a bunch of my apps were missing, and all of the rest do not work! I had not downloaded any apps within 24 hours of this occurrence.

I found that if I use mybackup pro to backup and reinstall them they work, however I cannot batch reinstall more than 2 or 3 apps at a time without my phone freezing and rebooting. Then it acts very glitchy and slow when it reboots.

I'm hesitant to go through the trouble of reinstalling everything without knowing the cause. I'd guess that my internal memory was corrupted somehow, but everything else in my phone work just fine, including my SMS and phone call history. So I really don't know what's going on. Anyone have any ideas?
__________________
SIMPLE MINDS THINK iLIKE
Evo 4G LTE Rooted - ROM: Viper4g 1.0.0, Tweaks: HTC Linkify Fix
2x Evo 4G Rooted - ROM: MikG3.11
CriticalCritic is offline  
Reply With Quote
Old December 20th, 2012, 12:50 PM   #219 (permalink)
Senior Member
 
Join Date: Aug 2011
Location: CT
Posts: 704
 
Device(s): Nexus 5 HTC Evo 4G LTE
Carrier: T-Mobile

Thanks: 1,152
Thanked 580 Times in 321 Posts
Default

Wow, sorry to hear. I don't know the reason but maybe a factory wipe and full reset may help?

Or first try a wipe of Cache and Dalvick in recovery.
If it doesn't help try the factory reset.
Then if still not I'd try a different rom I think.

If that doesn't help it's possible it's a hardware issue.


Naters
__________________
Nexus 5 - SlimKat
Samsung Galaxy Nexus - Sold ; Nexus S4G -Broken
HTC Evo 4G LTE Black (Sold) & White - SlimKat
Evo 4G - Sold
Nexus 7 - SlimKat
NaterTots is offline  
Reply With Quote
The Following User Says Thank You to NaterTots For This Useful Post:
CriticalCritic (December 20th, 2012)
Old December 20th, 2012, 01:54 PM   #220 (permalink)
Senior Member
 
CriticalCritic's Avatar
 
Join Date: Nov 2009
Location: Cary, NC
Posts: 1,884
 
Device(s): Home-OG Evo // Me-LTEvo // Wife-OG Evo // Son-LG Opt S
Carrier: Not Provided

Thanks: 980
Thanked 563 Times in 313 Posts
Default

Quote:
Originally Posted by NaterTots View Post
Wow, sorry to hear. I don't know the reason but maybe a factory wipe and full reset may help?

Or first try a wipe of Cache and Dalvick in recovery.
If it doesn't help try the factory reset.
Then if still not I'd try a different rom I think.

If that doesn't help it's possible it's a hardware issue.


Naters
Thanks for the quick response! Trying the Dalvick now...

I've been running Viper 1.0.0 for so long, I don't think that's the issue. But if this wipe doesn't work, I'll be going full-panda and flashing the newest Viper.

I am absolutely terrified that this might be a hardware issue. If it is, I may be going with an SIII as a replacement. The lack of RAM is really starting to get to me.
CriticalCritic is offline  
Reply With Quote
sponsored links
Old December 20th, 2012, 02:02 PM   #221 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Ever since the last update or so of MyBackup Root, I've gotten that exact same behavior - on a clean install.

Also - not a bad idea to hold the power button for 10 seconds to force the ram to get really cleared out in times like this.

If you go for the whole enchilada, please note my posts above flashing lagfix4 - in the later version of ICS, HTC borked a few things that create bloat and lag while you're running.

edit - decided to quote what you needed -

Quote:
Originally Posted by EarlyMon View Post

I recommend flashing the following two things with a clean install of Viper 2.0.2 -

#Fapple - http://forum.xda-developers.com/showthread.php?t=1947686 - be sure to grab the version for Viper

lagfix4 for #Fapple - will speed things up nicely - http://forum.xda-developers.com/showpost.php?p=35084694&postcount=9071

Wipe cache and Dalvik after you've finished flashing.

Note - in TWRP, you can stack those up and flash in one session - be sure to do them in that order though.

PS - also, not a bad idea to update PRL and Profile when done with all of that.
The #Fapple fix is optional - it restores your links to the way they've always been on our phones, not the Apple way that got shoved down on us.

There's a lagfix4 for with or without #Fapple, so that's your choice on that.

Me, I say, #Fapple.
CriticalCritic likes this.
EarlyMon is offline  
Last edited by EarlyMon; December 20th, 2012 at 02:07 PM.
Reply With Quote
The Following 3 Users Say Thank You to EarlyMon For This Useful Post:
CriticalCritic (December 20th, 2012), Granite1 (December 20th, 2012), NaterTots (December 31st, 2012)
Old December 20th, 2012, 02:55 PM   #222 (permalink)
Senior Member
 
CriticalCritic's Avatar
 
Join Date: Nov 2009
Location: Cary, NC
Posts: 1,884
 
Device(s): Home-OG Evo // Me-LTEvo // Wife-OG Evo // Son-LG Opt S
Carrier: Not Provided

Thanks: 980
Thanked 563 Times in 313 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Ever since the last update or so of MyBackup Root, I've gotten that exact same behavior - on a clean install.

Also - not a bad idea to hold the power button for 10 seconds to force the ram to get really cleared out in times like this.
Thanks! Also, Liked your post for consolidating all of the info, thanks for that too!

Well, the Cache/Dalvick Cache wipe didn't fix the problem, and I have run the 10 second reset several times (after several of the times that my phone froze from the mybackup pro restoration failures).

So, I'm going full panda and Viper 2.0.2 (plus all of the lag fix and #Fapple stuff ). I'll let you all know what happens...
CriticalCritic is offline  
Last edited by EarlyMon; December 20th, 2012 at 02:58 PM. Reason: lol - sorry, had to :D
Reply With Quote
The Following 2 Users Say Thank You to CriticalCritic For This Useful Post:
EarlyMon (December 20th, 2012), Granite1 (December 20th, 2012)
Old December 20th, 2012, 03:05 PM   #223 (permalink)
Senior Member
 
CriticalCritic's Avatar
 
Join Date: Nov 2009
Location: Cary, NC
Posts: 1,884
 
Device(s): Home-OG Evo // Me-LTEvo // Wife-OG Evo // Son-LG Opt S
Carrier: Not Provided

Thanks: 980
Thanked 563 Times in 313 Posts
Default

Interesting... I see that Panda is no longer supported and all of the files have been pulled...

Odd thing is that I downloaded all of the stuff a couple months ago when I was debating on whether to do it... The trouble is that the AF rooting guide says that Panda is for HBoot 1.12 and Raccoon is for 1.15&1.19, and I'm still on 1.12... so do I run with the old unsupported Panda or use the new Raccoon?
CriticalCritic is offline  
Reply With Quote
Old December 20th, 2012, 03:16 PM   #224 (permalink)
Member
 
Join Date: Apr 2010
Posts: 154
 
Device(s):
Carrier: Not Provided

Thanks: 292
Thanked 98 Times in 53 Posts
Default

Quote:
Originally Posted by CriticalCritic View Post
Interesting... I see that Panda is no longer supported and all of the files have been pulled...

Odd thing is that I downloaded all of the stuff a couple months ago when I was debating on whether to do it... The trouble is that the AF rooting guide says that Panda is for HBoot 1.12 and Raccoon is for 1.15&1.19, and I'm still on 1.12... so do I run with the old unsupported Panda or use the new Raccoon?
As I understand it, you can run the Lazy Panda if you have all the files and stuff. They just won't help you if you get stuck in the process. They aren't supporting it. The other choice is to do the DR, but you need to upgrade your hboot which I believe means running an RUU to the proper hboot.
__________________
Who is General Failure, and why is he reading my disk?
nullspace is offline  
Reply With Quote
The Following User Says Thank You to nullspace For This Useful Post:
CriticalCritic (December 20th, 2012)
Old December 20th, 2012, 04:04 PM   #225 (permalink)
Senior Member
 
CriticalCritic's Avatar
 
Join Date: Nov 2009
Location: Cary, NC
Posts: 1,884
 
Device(s): Home-OG Evo // Me-LTEvo // Wife-OG Evo // Son-LG Opt S
Carrier: Not Provided

Thanks: 980
Thanked 563 Times in 313 Posts
Default

Well, while I'm downloading Ubuntu, I have a 10 month old Nandroid from right after I installed Viper 1.0.0... lets see if this fixes the problem...

It works! Now to see if this old version of mybackup pro can bring my data back to where it was...

FYI, I am now setting a calendar reminder to go off every month to make a new Nandroid backup.
NaterTots likes this.
CriticalCritic is offline  
Last edited by CriticalCritic; December 20th, 2012 at 04:13 PM.
Reply With Quote
Old December 20th, 2012, 04:21 PM   #226 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Check your inbox.
EarlyMon is offline  
Reply With Quote
The Following 2 Users Say Thank You to EarlyMon For This Useful Post:
CriticalCritic (December 20th, 2012), Granite1 (December 20th, 2012)
Old December 20th, 2012, 04:35 PM   #227 (permalink)
Zercron Encrusted Tweezer
 
Granite1's Avatar
 
Join Date: Dec 2010
Location: Pittsburgh, PA
Gender: Male
Posts: 6,481
 
Device(s): EL TEvo, The OG (wife), Hero (retired)
Carrier: Sprint

Thanks: 11,195
Thanked 6,350 Times in 3,386 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Check your inbox.
I was going th do the same thing.

@Crit

Please make sure you have Ubuntu set up prior to starting.

If you get stuck, let us know.
Granite1 is offline  
Reply With Quote
The Following 2 Users Say Thank You to Granite1 For This Useful Post:
CriticalCritic (December 20th, 2012), EarlyMon (December 20th, 2012)
Old December 20th, 2012, 11:07 PM   #228 (permalink)
Senior Member
 
CriticalCritic's Avatar
 
Join Date: Nov 2009
Location: Cary, NC
Posts: 1,884
 
Device(s): Home-OG Evo // Me-LTEvo // Wife-OG Evo // Son-LG Opt S
Carrier: Not Provided

Thanks: 980
Thanked 563 Times in 313 Posts
Default

Thanks Guys!
But like I said, I have the main LP file downloaded from a while back, and the Nandroid worked for getting everything back to normal. Granted it's a setup from 10 weeks ago, but I have been so incredibly bogged down in school that my phone setup barely changed in those 10 weeks.

So I think I'm going to hold off on the LP until I see a need to upgrade, or maybe when Viper includes all the fixes stock, without the need for so much extra flashing. Does Viper 2.0.2 change the available RAM or anything that will help with memory management?
CriticalCritic is offline  
Reply With Quote
The Following 2 Users Say Thank You to CriticalCritic For This Useful Post:
EarlyMon (December 20th, 2012), Granite1 (December 21st, 2012)
Old December 20th, 2012, 11:13 PM   #229 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Yes, lagfix 4 changes that significantly.

This is the end of the line for Viper4G 2.0.2.

After this comes ViperROM, a JellyBean with as many fixes as available moving forward, but no tweaks.

After that comes Viper4G 3, with tweaks.
EarlyMon is offline  
Reply With Quote
The Following User Says Thank You to EarlyMon For This Useful Post:
Granite1 (December 21st, 2012)
Old December 21st, 2012, 05:52 PM   #230 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Yes, lagfix 4 changes that significantly.

This is the end of the line for Viper4G 2.0.2.

After this comes ViperROM, a JellyBean with as many fixes as available moving forward, but no tweaks.

After that comes Viper4G 3, with tweaks.
Any ETA on ViperROM or 3??
scudder is offline  
Reply With Quote
sponsored links
Old December 24th, 2012, 11:02 PM   #231 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default Annoying Lag on K-9 and ChompSMS with Viper 4G ROM??

Hiya...

Interestingly, I noticed a little lag on my EVO LTE running Viper 4G 2.0.2 lately with, it seems, just K-9 (email) and ChompSMS (texting). With K-9, I'll be viewing my list of 5 accounts. When I chose an account, I get the K-9 menu/notification bar area showing as normal but the rest of the entire screen is BLACK, blank, for a number of second until the list of messages appears. The delay does NOT seem to matter if there are 3 or 30 messages waiting to appear and does not have anything to do with the messages being downloaded from an incoming mail check. The app is not polling and getting the messages; they can already be downloaded for this to happen.

With ChompSMS, a similar situation...I'll have a list of conversations which can contain 3 messages or 53 messages. When I click on the conversation/number, another blank, black screen (or my background image) and a solid 10+ seconds of delay before I see the thread.

With both of the above, it happen often but not every time and, if a certain email account or text thread is slow to load it does NOT necessarily stay slow and can "fix" itself.

I also say "interesting" above because I flashed #FApple and also the lag fix for fapple and it appears I noticed the lag after flashing the above two items... Have NO CLUE if this was the type of "lag" that was supposed to be helped or not and just coincidental to my problem but that's when I seemed to notice it. Otherwise, haven't done much to my phone to have caused this to happen...

Any thoughts??...

THANKS!!
scudder is offline  
Reply With Quote
Old December 25th, 2012, 09:42 AM   #232 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

Assuming that you flashed Viper4G with #Fapple and lagfix 4 all in the same session, then your lag is because your contacts are being dumped from memory.

Try Autokiller Memory Optimizer.

AutoKiller Memory Optimizer - AndRS Studio
EarlyMon is offline  
Reply With Quote
Old December 25th, 2012, 09:58 AM   #233 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
Assuming that you flashed Viper4G with #Fapple and lagfix 4 all in the same session, then your lag is because your contacts are being dumped from memory.

Try Autokiller Memory Optimizer.

AutoKiller Memory Optimizer - AndRS Studio

Well, I ran Viper4G for a couple weeks. Then just a few days ago flashed #Fapple and lagfix 4.

With the AndRS studio app above, do I just set it and forget it...no need to tweak?? Or is there someone special I should do for me K-9 and ChompSMS issues??

THANKS!
scudder is offline  
Reply With Quote
Old December 25th, 2012, 10:21 AM   #234 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

No no.

Lagfix 4 does not work if you install it later.

HTC software base 2.13 came out with a new bug, that all Sense roms inherited and had to be addressed in various ways by various devs. The contacts database grows for no reason and gets dumped from memory.

So, you missed out on the clean slate before installing lagfix 4 so now you have to fix it.

It's not hard, but it's not optional.

Go to app manager, clear data on Contacts. Immediately boot to recovery and clear cache and Dalvik.

Don't flash other fixes or try that app.

Monitor and see if lag returns.
EarlyMon is offline  
Reply With Quote
Old December 25th, 2012, 12:59 PM   #235 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
No no.

Lagfix 4 does not work if you install it later.

HTC software base 2.13 came out with a new bug, that all Sense roms inherited and had to be addressed in various ways by various devs. The contacts database grows for no reason and gets dumped from memory.

So, you missed out on the clean slate before installing lagfix 4 so now you have to fix it.

It's not hard, but it's not optional.

Go to app manager, clear data on Contacts. Immediately boot to recovery and clear cache and Dalvik.

Don't flash other fixes or try that app.

Monitor and see if lag returns.
Ahahaaaahahaaaaaahhhh....when that #Fapple was suggested it was way after I had rooted and flashed the Viper4G ROM.

Going to try the wipe suggested above now. I can see this helping my ChompSMS as it scrolls through my contacts but this should help my email load too??

Thanks!
scudder is offline  
Reply With Quote
Old December 25th, 2012, 01:13 PM   #236 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

HTC uses a sqlite3 based database for contacts.

Anything that touches contacts get smacked by the bug - sms, MMS, mail, dialer, People, and probably a few others.
EarlyMon is offline  
Reply With Quote
The Following 2 Users Say Thank You to EarlyMon For This Useful Post:
Granite1 (December 25th, 2012), scudder (December 25th, 2012)
Old December 30th, 2012, 02:50 PM   #237 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
No no.

Lagfix 4 does not work if you install it later.

HTC software base 2.13 came out with a new bug, that all Sense roms inherited and had to be addressed in various ways by various devs. The contacts database grows for no reason and gets dumped from memory.

So, you missed out on the clean slate before installing lagfix 4 so now you have to fix it.

It's not hard, but it's not optional.

Go to app manager, clear data on Contacts. Immediately boot to recovery and clear cache and Dalvik.

Don't flash other fixes or try that app.

Monitor and see if lag returns.
Quote:
Originally Posted by EarlyMon View Post
HTC uses a sqlite3 based database for contacts.

Anything that touches contacts get smacked by the bug - sms, MMS, mail, dialer, People, and probably a few others.
So I tried the data clear on Contacts fix. Helped initially but lag has came back on, as expected, SMS, mail, dialer. On SMS I'll type in the first few letters of a name and the matches won't pop up for a while. Also get the same thing in K-9/mail (though not as long as my ChompSMS). Also black, blank screens waiting for sms and mail apps to load...even if I didn't even try to address an email/text yet.

Soooooo, what are my other options?? You said the fix is "not hard" but it appears to have come back for me. I would prefer NOT to wipe and fresh clean/install if that is a possibility...

THANKS!!
scudder is offline  
Reply With Quote
Old December 30th, 2012, 02:58 PM   #238 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 44,035
 
Device(s): LTEvo, 3vo, and Shift
Carrier: Sprint

Thanks: 41,696
Thanked 54,830 Times in 21,866 Posts
Default

How long before the lag returned?

Clear contacts again, reboot within half of the lag return time.

Some susceptible to it are ok with a reboot every two days for example.
EarlyMon is offline  
Reply With Quote
The Following User Says Thank You to EarlyMon For This Useful Post:
scudder (December 30th, 2012)
Old December 30th, 2012, 03:13 PM   #239 (permalink)
Senior Member
 
scudder's Avatar
 
Join Date: May 2010
Location: State of Confusion (FL too)
Posts: 1,267
 
Device(s): Rooted EVO LTE (Viper4G ROM), rooted HTC EVO (Mik3.11 ROM/Stock MikG) Kernal), Nexus S 4G
Carrier: Not Provided

Thanks: 427
Thanked 363 Times in 218 Posts
Default

Quote:
Originally Posted by EarlyMon View Post
How long before the lag returned?

Clear contacts again, reboot within half of the lag return time.

Some susceptible to it are ok with a reboot every two days for example.
Didn't keep track of how long until the lag returned but I haven't rebooted in days. I have no problem with a reboot like right before I go to bed or other time I'm not using the phone. I'll try again...thanks!!
scudder is offline  
Reply With Quote
The Following User Says Thank You to scudder For This Useful Post:
EarlyMon (December 30th, 2012)
Reply


Go Back   Android Forums > Android Phones > HTC Evo 4G LTE > Evo 4G LTE - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:20 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.