Go Back   Android Forums > Android Phones > HTC EVO 4G > EVO 4G - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 10th, 2010, 10:09 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Confused Bluetooth transfer Address Book to Car

Hi all,

My phone is having trouble transferring my contacts from the address book to the cars Nav system. Oddly enough, it worked once and never again. For some reason, it is only able to transfer 2 random contacts off of my phone, and stops there. For reference, it worked perfectly with my Blackberry and other non-Android phones.

Here is some information:
Phone: HTC Evo 4g
Software version: 1.32.651.6
Car: 2010 BMW 650i (comes with iDrive)

I have tried un-pairing and re-pairing the phone and it hasn't behaved any differently. I noticed the phone recognizes the car as a Bluetooth Headset, which I suspect may be causing a problem. I have also tried changing the phones Bluetooth name.

When I look at my Blackberry, it says the BMW supports the following services: Handsfree, Object Push, AVRCP. The Blackberry recognizes the car to be different from a normal headset.

Any help would be greatly appreciated!

zion800 is offline  
Reply With Quote
sponsored links
Old July 12th, 2010, 03:04 AM   #2 (permalink)
New Member
 
Join Date: Jul 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, I have a similar problem, using a Nexus One with Froyo, and an 2007 X5
My address book does sync, but not all the phonenumbers
I think this has to do with the limited space available in the BMW. How can I set the priorities of which contacts/phonenumbers to sync and which ones not?
thnx
reneve is offline  
Reply With Quote
Old July 12th, 2010, 07:17 AM   #3 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

NO WAY THIS HAS ANYTHING TO DO WITH THE BMW. Before I switched to the Evo 4G, my iPhone 3GS connected and synced perfectly each and every time. I have to admit my disappointment, that such a mundane thing (Blackberry does this perfectly as well) as Bluetooth integration is several generations behind even the simple Blackberry. Are we kidding? Ugh. My phone almost always connects, but the contacts download is a joke, leaving off names and importing the phone book with the names backwards. Very frustrating. Any help would be greatly appreciated, but I have a feeling we're stuck until HTC/Sprint decides to give us a modern Bluetooth stack.

Could this be due to the lack of a Handsfree profile showing up???
cjnyc is offline  
Last edited by cjnyc; July 12th, 2010 at 07:23 AM.
Reply With Quote
Old July 12th, 2010, 07:45 AM   #4 (permalink)
Under paid Sasquatch!
 
SamuraiBigEd's Avatar
 
Join Date: Nov 2009
Location: San Antonio, Texas
Posts: 4,098
 
Device(s): HTC One Max, waiting for root! Asus Transformer 16GB
Carrier: Not Provided

Thanks: 3,061
Thanked 1,988 Times in 1,047 Posts
Default

It may be a conflict between the Evo and the head unit in the BMW, mine syncs perfectly with my Kenwood DNX6140 which is running the latest bluetooth update.

On edit: Since the Froyo update my bluetooth is useless!
__________________
Have you seen me in a kilt?
Site Rules/Guidelines
Use the !Report button to report spam or objectionable posts.
If you find a post helpful please use the button!
SamuraiBigEd is offline  
Last edited by SamuraiBigEd; August 17th, 2010 at 11:15 PM.
Reply With Quote
Old August 16th, 2010, 01:44 PM   #5 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

Got some problems too with my htc wildfire running android 2.1. When synchronizing my contacts with my car (Toyota) contacts disappeared and names got weird. After trying almost everything i found out that it has to do with the contact pictures. After removing them from my contacts everything synchronized correctly.

Is there a way to solve this? or has this to do with my car's system?
klompie is offline  
Reply With Quote
Old November 8th, 2010, 05:35 PM   #6 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 13
 
Device(s): HTC Desire HD (Android 2.2)
Carrier: Not Provided

Thanks: 2
Thanked 2 Times in 2 Posts
Default Same

We all seem to be having the same problem.

I use the following:
HTC Desire HD, Android 2.2 (very similar to the EVO 4G)

Similarly I'm trying to connect to a BMW (although a bit older) 2005 E46 320I.
Similarly again my iPhone 3G (please excuse my language) worked just fine.
And again the Desire HD worked fine once but not again. I've tried the same pairing, unpairing, putting contacts on and off the phone.
(The very first time it only synced all my "Other Contacts" from Google/Gmail - very weird).

Anyway I note the thread is old but this is the most similar case to mine I've seen yet.
Any help would be much appreciated.
rocknrolla1 is offline  
Reply With Quote
Old November 8th, 2010, 05:38 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you have Facebook linked to your contacts? What about things written in the "Notes" section? I believe these 2 things can cause the address book to not sync properly with the car. I've given up with it...
zion800 is offline  
Reply With Quote
Old November 8th, 2010, 05:45 PM   #8 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 13
 
Device(s): HTC Desire HD (Android 2.2)
Carrier: Not Provided

Thanks: 2
Thanked 2 Times in 2 Posts
Default Same

We all seem to be having the same problem.

I use the following:
HTC Desire HD, Android 2.2 (very similar to the EVO 4G)

Similarly I'm trying to connect to a BMW (although a bit older) 2005 E46 320I.
Similarly again my iPhone 3G (please excuse my language) worked just fine.
And again the Desire HD worked fine once but not again. I've tried the same pairing, unpairing, putting contacts on and off the phone.
(The very first time it only synced all my "Other Contacts" from Google/Gmail - very weird).

Anyway I note the thread is old but this is the most similar case to mine I've seen yet.
Any help would be much appreciated.
rocknrolla1 is offline  
Reply With Quote
Old November 9th, 2010, 12:34 AM   #9 (permalink)
Senior Member
 
Mr. Ed's Avatar
 
Join Date: Jun 2010
Location: Over Yonder
Posts: 6,675
 
Device(s): S3, Evo LTE,Galaxy Note, Skyrocket, Aria, Nook Color Lg thrill,HTC EVO 4g, HTC Inspire,S7 slim,Acer
Carrier: Not Provided

Thanks: 1,008
Thanked 1,467 Times in 989 Posts
Default

Have you guys deleted the pairing from the vehicle? or just the phone?

also, while connected... menu.settings.wireless and networks.bluetooth settings , make sure discoverable is selected also click on the individual item (car headunit) and make sure the evo is connected to phone and audio


that is all i can think of to try right now
__________________
I'm back....
Mr. Ed is offline  
Last edited by Mr. Ed; November 9th, 2010 at 12:37 AM.
Reply With Quote
Old November 9th, 2010, 02:21 AM   #10 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 13
 
Device(s): HTC Desire HD (Android 2.2)
Carrier: Not Provided

Thanks: 2
Thanked 2 Times in 2 Posts
Default Sorted

Thanks Ed.

I tried a couple of things and what worked was the "Bluetooth File Transfer" application. (When in the app just click menu>more>Send contacts).

It actually worked out for the best as through all the faffing around I found out I can just call the names out in my car which I didn't know I could do before

(There is other advice regarding waiting for an option to come up on the phone regarding sending the contacts, but this didn't work for me).
rocknrolla1 is offline  
Reply With Quote
The Following User Says Thank You to rocknrolla1 For This Useful Post:
Mr. Ed (November 9th, 2010)
sponsored links
Old January 12th, 2012, 09:57 AM   #11 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have just bought a 2005 BMW 730D and tried to pair my wifes HTC Desire HD with no problems at all, but the tried to do the same with my HTC Desire and can make and receive calls, but address book just says reading sim card and does nothing. Checked all our settings and all apear to be the same. Tried repairing both, mine and hers and hers always works. Not long ago i was forced into doing a factory reset on mine. Does this have something to do with it?
Anyone know whats going wrong?
thanks for any sergertions
jointadventure is offline  
Reply With Quote
Reply
Tags
bluetooth address book, bluetooth contacts, bluetooth issue, bluetooth problems, bmw


Go Back   Android Forums > Android Phones > HTC EVO 4G > EVO 4G - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:49 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.