Go Back   Android Forums > Android Phones > HTC EVO Shift 4G > EVO Shift - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 6th, 2012, 02:30 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default HTC EVO Shift digitizer madness!

Hello forums,
I work for a small company repairing android phones and recently we've had some crazy issues with repairing the digitizers on EVO Shifts. I've replaced the digitizer on many of them (this means, different phones, different boards, different digitizers) and after every repair the digitizer goes nuts. By this, I mean some times it wont work at all (can't get past initial unlock sequence) and sometimes its buggy and clicks on random things or has severe key-press lag. This has come from 2 different batches of replacement digitizers (same supplier) and am dumbfounded. Also the digitizer seems not to be flush with the LCD housing only near the ribbon (in this case the top left corner where the ribbon is guided to the rear of the LCD). It pokes up about a quarter a centimeter and causes dust to get to the LCD after about 2 days. I understand that's more of an adhesive issue but I find it odd because it's only been recently the digi's I've had have the same issue with the crazyness that they aren't totally flush with the LCD housing. Anyways, what I desire to know is if anyone has had this problem or if possibly this is a case of bad digi's from a bad supplier etc. I know this is lenghty, but any help is much appreciated. Much thanks

MikeGause is offline  
Reply With Quote
sponsored links
Old June 6th, 2012, 02:52 PM   #2 (permalink)
AF Addict
 
Rush's Avatar
 
Join Date: Jan 2011
Location: Loganville, GA
Gender: Male
Posts: 18,533
 
Device(s): HTC ONE
Carrier: Sprint

Thanks: 2,853
Thanked 3,107 Times in 2,337 Posts
Default

Hopefully someone with this sort of knowledge will chime in to assist.

[Thread moved]
__________________
"Accept the things you cannot change, have the courage to change the things you can ...And have the Wisdom to know the difference".


Rush is offline  
Reply With Quote
Old June 22nd, 2012, 06:35 PM   #3 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

anyone have any sort of response on this? i am about to replace my digitizer and don't want a bad one...its my only phone and don't want to have it out of commission while i replace multiple digitizers till i find a good one hahaha.
dirtytony is offline  
Reply With Quote
Old September 16th, 2012, 05:12 PM   #4 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by MikeGause View Post
Hello forums,
I work for a small company repairing android phones and recently we've had some crazy issues with repairing the digitizers on EVO Shifts. I've replaced the digitizer on many of them (this means, different phones, different boards, different digitizers) and after every repair the digitizer goes nuts. By this, I mean some times it wont work at all (can't get past initial unlock sequence) and sometimes its buggy and clicks on random things or has severe key-press lag. This has come from 2 different batches of replacement digitizers (same supplier) and am dumbfounded. Also the digitizer seems not to be flush with the LCD housing only near the ribbon (in this case the top left corner where the ribbon is guided to the rear of the LCD). It pokes up about a quarter a centimeter and causes dust to get to the LCD after about 2 days. I understand that's more of an adhesive issue but I find it odd because it's only been recently the digi's I've had have the same issue with the crazyness that they aren't totally flush with the LCD housing. Anyways, what I desire to know is if anyone has had this problem or if possibly this is a case of bad digi's from a bad supplier etc. I know this is lenghty, but any help is much appreciated. Much thanks
I recently had this exact work done on my evo shift, the screen had blacked out, it took over a month to get it back from them, phone support was a complete ass, not to mention another 2weeks to get the new s/n on the sprint network!!! after I got it back I had the problem with the digitizer and still does, I recommend buying one yourself and see how it pays out!!! I've had the worst service with sprint and htc then I've ever had with any other carrier or company
Gorman44 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC EVO Shift 4G > EVO Shift - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:09 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.