Go Back   Android Forums > Android Phones > ZTE Force 4g LTE > Force 4g LTE - All Things Root

test: Reply
 
LinkBack Thread Tools
Old August 26th, 2013, 02:55 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Talking AUDIO SOLUTION (Much Louder Audio!!!) (FIXED)

I have come up with a solution to our quiet audio with headphones. After spending much time researching the audio system on our phone I learned that it uses ALSA and I learned where to make some changes in the config files for it. I have created a zip file that contains the updated files and a script to install the files to the correct location. I tried to make a flashable zip but could not get it working.

This changes values that alter the hardware volume. This is not an EQ adjustment. This is real amplification power!!! You should be able to use any EQ/DSP that you used before as long as it does not overwrite the ALSA system. I recommend Noozxoide EIZO-rewire PRO which is free on the android market.

Here is how to install my fix.

1) Download https://www.dropbox.com/s/dhz6s5e7sd70w7r/ztefix.rar
2) Extract the files into a folder called zteaudio in your sdcard
3) install Root Browser from the android marker
4) open Root Browser.
5) go into /sdcard/zteaudio
6) Tap on ztefix.sh
7) Make sure execute script as root is checked and click execute
8) reboot your phone.
9) enjoy much louder audio!

***I am not responsible for any damage to your phone or headphones. This will really turn up the volume and can damage cheap headphones. I tested with a pair of Beats Studio Pro's and they sound amazing with this mod.

***This is not tested with CM.
***If someone has an easier way to install or can make a flashable zip Please feel free to do so.

Advertisements
druble81 is offline  
Last edited by druble81; November 20th, 2013 at 04:16 AM. Reason: new info
Reply With Quote
sponsored links
Old August 27th, 2013, 12:46 AM   #2 (permalink)
The Computer Dude
 
AMOCO's Avatar
 
Join Date: Mar 2012
Location: Colorado Springs,CO.
Gender: Male
Posts: 735
 
Device(s): LG G2 (D800) Rooted,,,(Wife's) HTC Desire 610
Carrier: AT&T

Thanks: 31
Thanked 160 Times in 124 Posts
Default

So,If I was wanting to try this.
What would I have to remove from my phone?
MusicFX?
Also this would be great for using my (SRS) headphones and my car stereo,In which I have to turn up the volume for both.
__________________
AMD A6-6400K Black Edition (@ 4.69GHz),GA-F2A55M-HD2,XFX AMD Radeon R7 240 (@ 1015/1040),Crucial Ballistix Sports (8GB.) (DDR3-1600),Hitachi Deskstar (500GB.),Thermaltake TR2 430W,Thermaltake V3 Black Edition,Sharp 32" LED HDTV (1080p) + HP 2000-2C29WM
AMOCO is offline  
Last edited by AMOCO; August 27th, 2013 at 01:05 AM.
Reply With Quote
Old August 27th, 2013, 04:23 AM   #3 (permalink)
Senior Member
 
Join Date: Mar 2013
Location: Aurora, IL
Gender: Male
Posts: 696
 
Device(s): ZTE Force
Carrier: Boost Mobile

Thanks: 89
Thanked 88 Times in 70 Posts
Default

i prefer to just use an inline/external amp, clipping and distortion are not good things.
and I prefer play music over the stock "music"
donjuro is offline  
Reply With Quote
Old August 28th, 2013, 06:16 PM   #4 (permalink)
The Computer Dude
 
AMOCO's Avatar
 
Join Date: Mar 2012
Location: Colorado Springs,CO.
Gender: Male
Posts: 735
 
Device(s): LG G2 (D800) Rooted,,,(Wife's) HTC Desire 610
Carrier: AT&T

Thanks: 31
Thanked 160 Times in 124 Posts
Default

Installed it and it works great,But not using Walkman with it.
AMOCO is offline  
Reply With Quote
Old October 5th, 2013, 01:15 PM   #5 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Wow.. this is awesome. I was considering purchasing hundreds of dollars of vintage sound field equipment for my car - but this brought out all the frequencies and depth that were missing.

Although I had two issues...

It would hang in recovery on fixing permissions and I would get headset plugged notifications randomly.

So I ran the fix permissions script from busybox as root - then I could only play audio for 500ms before a plug event would occur.

I currently am running the 'universal' with clear+ and it is not the same, and doesn't appear to work at all unless the 'stock' SRS is enabled, and this adds a funny effect that is not desirable, as well the universal does not have the volume boost the OP link gave.

before I do a backup and try again, did anyone have the fix permissions issue?

Thanks!
fruitwerks is offline  
Reply With Quote
Old October 6th, 2013, 08:59 PM   #6 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hmm.. can't get this working with DroidSmith or Stock! well I can, but I can't make calls.

Those who are using this, what files did you download?

Thanks!
fruitwerks is offline  
Reply With Quote
Old October 7th, 2013, 04:26 PM   #7 (permalink)
Senior Member
 
Join Date: Mar 2013
Location: Aurora, IL
Gender: Male
Posts: 696
 
Device(s): ZTE Force
Carrier: Boost Mobile

Thanks: 89
Thanked 88 Times in 70 Posts
Default

Don't lie to your self, you don't get all the frequencies and depth unless you play uncompressed music and use a DAC with an external amp.
donjuro is offline  
Reply With Quote
Old October 7th, 2013, 04:46 PM   #8 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Glad to see I'm not the only audiophile left on the planet. Most of my portable library is in FLAC... Does the job.

On another note, I forgot exactly what one I flashed (engine v5 I think), it works, but not as awesome as the one that breaks calling functionality (v7&8) - for me at least. As well, the ClearAudio+ app doesn't change anything when I try to fine tune it, and definitely a difference when I turn it off. I have a huge issue in the 1.2kHz range in my car and that can be overcome with that addon.

A software fix is ideal.. it is very hard to find vintage and working DSP's such as the Alpine ERA G320 - at a reasonable price.

Although in a broken state, it helps, and I can make calls lol
fruitwerks is offline  
Reply With Quote
Old October 7th, 2013, 06:28 PM   #9 (permalink)
Senior Member
 
Join Date: Mar 2013
Location: Aurora, IL
Gender: Male
Posts: 696
 
Device(s): ZTE Force
Carrier: Boost Mobile

Thanks: 89
Thanked 88 Times in 70 Posts
Default

I've been using ac!d as a temp fix until I can buy a DAC + amp. As far as my car goes, you don't wanna hear about my plans for that 8) lol
donjuro is offline  
Reply With Quote
Old October 7th, 2013, 06:33 PM   #10 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 29
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Just went for a quick ride... and the ClearAudio+ thing does work, but it was not as awesome as before. Guess I'll stick with what I have for now.

Straying OT - I hope this mod will work on PandaBoard, Waiting until I can afford the screen and they have them in stock. It will be neat to see a 10in touch that is not a tablet mounted in an Acura Legend
fruitwerks is offline  
Reply With Quote
sponsored links
Old October 7th, 2013, 09:57 PM   #11 (permalink)
Senior Member
 
Join Date: Mar 2013
Location: Aurora, IL
Gender: Male
Posts: 696
 
Device(s): ZTE Force
Carrier: Boost Mobile

Thanks: 89
Thanked 88 Times in 70 Posts
Default

Never heard of this pandaboard, now I'm gonna have to do some more studying and see which one fits my needs better, pandaboard or raspberry pi. My main focus will be sound quality, but I'd also like to be able to use a really nice screen and add aux screens in the future.
donjuro is offline  
Reply With Quote
Old October 10th, 2013, 01:45 AM   #12 (permalink)
The Computer Dude
 
AMOCO's Avatar
 
Join Date: Mar 2012
Location: Colorado Springs,CO.
Gender: Male
Posts: 735
 
Device(s): LG G2 (D800) Rooted,,,(Wife's) HTC Desire 610
Carrier: AT&T

Thanks: 31
Thanked 160 Times in 124 Posts
Default

Well I did a system restore and I couldn't get the AC!D Audio Engine to work again.So I think it's the version 4.0 that wouldn't install properly.
And I found a Universal AC!D Audio Engine version 5.0 and it works.
Here is a link to it,
AC!D Audio Engine 5.0;; http://www.mediafire.com/?7t7fcacxm8uv1dr
AMOCO is offline  
Reply With Quote
The Following User Says Thank You to AMOCO For This Useful Post:
bcrichster (October 10th, 2013)
Old October 10th, 2013, 06:54 PM   #13 (permalink)
Member
 
Join Date: Mar 2013
Posts: 111
 
Device(s): Samsung Galaxy S3, Samsung Transform Ultra, ZTE Force 4g LTE
Carrier: Boost

Thanks: 4
Thanked 13 Times in 12 Posts
Default

Does it only work on stock?
GoatTheHero is offline  
Reply With Quote
Old October 10th, 2013, 07:41 PM   #14 (permalink)
The Computer Dude
 
AMOCO's Avatar
 
Join Date: Mar 2012
Location: Colorado Springs,CO.
Gender: Male
Posts: 735
 
Device(s): LG G2 (D800) Rooted,,,(Wife's) HTC Desire 610
Carrier: AT&T

Thanks: 31
Thanked 160 Times in 124 Posts
Default

Quote:
Originally Posted by GoatTheHero View Post
Does it only work on stock?
Not sure,try it.You can always go back to your backup if it doesn't work on none stock roms.But it should work on custom roms.
AMOCO is offline  
Reply With Quote
Old October 10th, 2013, 08:34 PM   #15 (permalink)
Member
 
Join Date: Mar 2013
Posts: 111
 
Device(s): Samsung Galaxy S3, Samsung Transform Ultra, ZTE Force 4g LTE
Carrier: Boost

Thanks: 4
Thanked 13 Times in 12 Posts
Default

I tried it on dsf 5 times and it wouldn't get past the android logo.
GoatTheHero is offline  
Reply With Quote
Old October 10th, 2013, 08:58 PM   #16 (permalink)
The Computer Dude
 
AMOCO's Avatar
 
Join Date: Mar 2012
Location: Colorado Springs,CO.
Gender: Male
Posts: 735
 
Device(s): LG G2 (D800) Rooted,,,(Wife's) HTC Desire 610
Carrier: AT&T

Thanks: 31
Thanked 160 Times in 124 Posts
Default

Well that sux.There are more I've seen and was gonna try,If I couldn't get AC!D to work.
One you could try Dre Beats driver.
AMOCO is offline  
Reply With Quote
Old October 10th, 2013, 10:14 PM   #17 (permalink)
Member
 
Join Date: Mar 2013
Posts: 111
 
Device(s): Samsung Galaxy S3, Samsung Transform Ultra, ZTE Force 4g LTE
Carrier: Boost

Thanks: 4
Thanked 13 Times in 12 Posts
Default

Beats did the same thing. I'm not really worried about it cuz my headphone jack is broken beyond repair and my Bluetooth headphones bit the dust. I would like get something working cuz music sounds like crap on this phone. I'm using my wife's old Samsung as an mp3 player and it's miles above in audio quality just stock.
GoatTheHero is offline  
Reply With Quote
Old October 16th, 2013, 09:45 PM   #18 (permalink)
Junior Member
 
Join Date: Aug 2013
Location: Stratford CT
Gender: Male
Posts: 19
 
Device(s): ZTE Boost Force
Carrier: Boost Mobile

Thanks: 6
Thanked 0 Times in 0 Posts
Default

Didn't work installed it and all it did was not let me listen to my music or watch video's had to do a restore
GodManGordo is offline  
Reply With Quote
Old October 16th, 2013, 10:01 PM   #19 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default wish i could figure this out

I haven't had much time to look into this, but I have invested some time. First I discovered if you install both the files you can go into the clear audio controls settings and lower the max output so when you turn your volume to max you will not get headset disconnects. As far as phone calls I have tried getting logcats of the errors that occur when the sound fails on a phone call because my phone totally locks up. If someone managed to get a log of from lords of whatever occurs when you place a call and the sound disconnects and phone pretty much crashes it would help to diagnose the full problem and be able to fix this. I have looked over most of the configuration and mappings for everything and I think this is repairable if the problem can be isolated.
druble81 is offline  
Reply With Quote
Old October 19th, 2013, 01:27 PM   #20 (permalink)
Member
 
Join Date: Mar 2013
Posts: 111
 
Device(s): Samsung Galaxy S3, Samsung Transform Ultra, ZTE Force 4g LTE
Carrier: Boost

Thanks: 4
Thanked 13 Times in 12 Posts
Default

Hey amoco, did you uninstall music fx and srs before or anything else? I'm back on stock so I want to get acid working... any help would be much appreciated.
GoatTheHero is offline  
Reply With Quote
sponsored links
Old October 19th, 2013, 06:38 PM   #21 (permalink)
The Computer Dude
 
AMOCO's Avatar
 
Join Date: Mar 2012
Location: Colorado Springs,CO.
Gender: Male
Posts: 735
 
Device(s): LG G2 (D800) Rooted,,,(Wife's) HTC Desire 610
Carrier: AT&T

Thanks: 31
Thanked 160 Times in 124 Posts
Default

Quote:
Originally Posted by GoatTheHero View Post
Hey amoco, did you uninstall music fx and srs before or anything else? I'm back on stock so I want to get acid working... any help would be much appreciated.
Nope,Just installed it.
AMOCO is offline  
Reply With Quote
Old October 23rd, 2013, 04:04 PM   #22 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2013
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Been trying to contact the Developers of Acid mod to get some help but no response yet Guys I really want to fix this for us. I know its possible, but we just need more information. Any useful logcats anyone can provide would be appreciated, and hopefully I can get a response from the Dev's on how I can properly reroute the audio system for the dialer, and cut down the volume to a level that will not cause headset disconnects. It's basically %95 working on our device and with some minor changes we could make this work flawlessly. It is probably a very simple matter, but I need the Dev's of ACID or enough logs to figure out where and what I need to modify in the configurations. I have not given up on this! I just don't always have a lot of time, and with no info coming in except for what I learn and find out I am pulling my hair out on where the problem lies. This can work!
druble81 is offline  
Reply With Quote
Old February 1st, 2014, 03:54 PM   #23 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Could not get the script to run on my Boost Force. I just barely rooted and have CWM, nothing else to the ROM etc was done. It exits with a code of 127 and has several 'could not find file' while pointing directly to the script, dunno if its just saying thats where the problem is or what.

Screenshots of all output here:

https://skydrive.live.com/redir?resid=5768A35287A9AE5!512&authkey=!AFKYaEBDc b2q1YI&ithint=folder%2c.png
Pazako is offline  
Last edited by Pazako; February 1st, 2014 at 03:58 PM. Reason: Added skydrive link to output screenshots
Reply With Quote
Old March 17th, 2014, 03:37 AM   #24 (permalink)
New Member
 
Join Date: Feb 2013
Gender: Male
Posts: 2
 
Device(s): Zte warp
Carrier: Boost Mobile

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Wow works great had to move the files myself tho
jeffcaccamisi is offline  
Reply With Quote
Old July 24th, 2014, 09:13 PM   #25 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 92
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by druble81 View Post
I have come up with a solution to our quiet audio with headphones. After spending much time researching the audio system on our phone I learned that it uses ALSA and I learned where to make some changes in the config files for it. I have created a zip file that contains the updated files and a script to install the files to the correct location. I tried to make a flashable zip but could not get it working.

This changes values that alter the hardware volume. This is not an EQ adjustment. This is real amplification power!!! You should be able to use any EQ/DSP that you used before as long as it does not overwrite the ALSA system. I recommend Noozxoide EIZO-rewire PRO which is free on the android market.

Here is how to install my fix.

1) Download https://www.dropbox.com/s/dhz6s5e7sd70w7r/ztefix.rar
2) Extract the files into a folder called zteaudio in your sdcard
3) install Root Browser from the android marker
4) open Root Browser.
5) go into /sdcard/zteaudio
6) Tap on ztefix.sh
7) Make sure execute script as root is checked and click execute
8) reboot your phone.
9) enjoy much louder audio!

***I am not responsible for any damage to your phone or headphones. This will really turn up the volume and can damage cheap headphones. I tested with a pair of Beats Studio Pro's and they sound amazing with this mod.

***This is not tested with CM.
***If someone has an easier way to install or can make a flashable zip Please feel free to do so.
Which ROM are you using/developing this on?

I want louder audio and have been using an audio booster from the play store, but don't want to bother with this if it will break something in DSF .7 or at least until it's confirmed working 100%.

Great idea though and thanks for taking the time to make this.

Cheers,
-SB
sawbones999 is offline  
Reply With Quote
Reply
Tags
audio, boost, force, loud, volume, zte boost force


Go Back   Android Forums > Android Phones > ZTE Force 4g LTE > Force 4g LTE - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:25 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.