Go Back   Android Forums > Android Phones > Huawei Ascend G300 > G300 - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old September 16th, 2012, 06:33 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default High CPU usage

Hey guys, just got my Huawei Ascend G300 a couple of days ago.
All was good until yesterday, when it got slow.
I installed OS Monitor and saw that RAM usage is ok, but the android system process uses too much CPU even when idle (30-70%), which also uses up the battery very quickly.
I tried to uninstall all the apps i had, as well as a hard reset with no improvement.
I also looked at the event logs with OS Monitor and I get quite a few ERRORS that I have no idea what they mean.
I rooted my phone to remove some bloat, but that didn't help either.

So if anyone has any idea about what I should do or can help me with those errors, please share you knowledge with me!

Thanks a lot.

vladrew is offline  
Reply With Quote
sponsored links
Old September 16th, 2012, 02:16 PM   #2 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, I've got closer to the cause of the problem.
I've found that when I plug my mobile into my PC via USB, the CPU usage drops to <10%, but as soon as I unplug it, it goes back up to 70%.

Any ideas?
vladrew is offline  
Reply With Quote
Old September 17th, 2012, 05:53 AM   #3 (permalink)
Junior Member
 
ReDDs3D's Avatar
 
Join Date: Apr 2012
Posts: 82
 
Device(s): HTC t328w DESIRE V (Current), HTC Imagio (retired, used in will it blend experiment) Droid X (retir
Carrier: Not Provided

Thanks: 14
Thanked 12 Times in 7 Posts
Default

Honestly the best thing you can try is to root the phone, and flash an aokp CM9 ROM. Because it's virtually bloat free and is based of stock android no frills, it should theoreticaly run the fastest without much problem
ReDDs3D is offline  
Reply With Quote
Old September 17th, 2012, 09:53 AM   #4 (permalink)
Some say...
 
Stigy's Avatar
 
Join Date: Nov 2009
Gender: Male
Posts: 4,086
 
Device(s): Verizon LG G2 Retired: Galaxy Nexus, OG Droid, TMobile G1
Carrier: Verizon Wireless

Thanks: 1,687
Thanked 3,595 Times in 1,619 Posts
Default

Hi Vladrew - one thing I would recommend doing is check out the G300 sub-forum to see if anyone there has had a specific answer for your issue:

Huawei Ascend G300 - Android Forums
__________________
It's kind of fun to do the impossible. - Walt Disney

If someone's out in left field, the /!\ Report button is to the left of their post.
If someone gives you right-on advice or positively contributes, the Thanks button is to the right.
Stigy is offline  
Reply With Quote
Old September 17th, 2012, 11:07 AM   #5 (permalink)
Fixing stuff is not easy
 
Join Date: May 2011
Location: Over there <points>
Gender: Male
Posts: 7,690
 
Device(s): Samsung Galaxy S3; Asus Infinity
Carrier: Sprint

Thanks: 2,117
Thanked 4,311 Times in 2,513 Posts
jerofld
Default

I don't know what would be a good ROM for your phone, but I'd recommend trying to flash something new to see if that clears it up. Sounds like the phone has a bad stock ROM flash.

Make sure to make backups of everything before flashing! Even in recovery.
jerofld is offline  
Reply With Quote
Old September 26th, 2012, 07:22 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Sep 2012
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I upgraded to ICS and yes it does work better, with much lower idle cpu usage. So thanks for that suggestion. However, it doesn't always run very smooth.

So one question. In developer tools, I enabled "Show CPU usage". What I don't really get is what the first line displays. There are 3 numbers separated by slashes. What do they mean?
vladrew is offline  
Reply With Quote
Old October 23rd, 2012, 08:04 PM   #7 (permalink)
Junior Member
 
Join Date: Oct 2012
Location: Arizona
Posts: 21
 
Device(s): Huawei m865 Nook
Carrier: Not Provided

Thanks: 0
Thanked 4 Times in 4 Posts
Default

The "applications running" doesn't list everything running. If you go to "all" and select some stuff, you'll see that it's still got an option to force it to stop, even though it didn't show up in running. Stopping it removes the option.

When mine starts, all sorts of unwanted garbage is in that hidden but running state. Some of it comes back, some doesn't. Look thru the list of all aps and check 'em.
actualsize is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Huawei Ascend G300 > G300 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:49 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.