Go Back   Android Forums > Android Phones > Samsung Galaxy Prevail > Galaxy Prevail - All Things Root

Like Tree3Likes

Closed Thread
 
LinkBack Thread Tools
Old October 7th, 2011, 04:07 PM   #451 (permalink)
Member
 
Bandaid's Avatar
 
Join Date: Aug 2011
Location: New York
Posts: 291
 
Device(s): Samsung Galaxy S4 (SGH-M919)
Carrier: Not Provided

Thanks: 108
Thanked 56 Times in 47 Posts
Default KMS File

After searching high and low I found the Original KMS file that worked for me. Its here incase someone needs its.

Here’s the link MEGAUPLOAD - The leading online storage and file delivery service

Advertisements
Bandaid is offline  
Last edited by Bandaid; October 7th, 2011 at 06:01 PM.
The Following User Says Thank You to Bandaid For This Useful Post:
oneme (October 10th, 2011)
sponsored links
Old October 7th, 2011, 07:24 PM   #452 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

yesterday I Tried for 4 hours to Root my Samsung Precedent from Straight with one click I was using Windows 7 64 bit comp. to run one click and had no luck at all. Today I tried with my mother's laptop it has 32 bit vista. I restarted my phone and waited till the model number came on the screen and then ran one click as administrator 15 to 20 seconds I had rooted my phone
Goucho247 is offline  
Old October 7th, 2011, 08:56 PM   #453 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Hi hope someone can help .. I have been trying to use the one click root for my sprint epic ..... every time I open the run bat file it says Rageagainstthecage-arm5.bin is missing .. PLEASE HELP BEEN AT THIS FOR 3 DAYS NOW ... THANKS... JIM
hammer422 is offline  
Old October 7th, 2011, 09:13 PM   #454 (permalink)
Member
 
danielmike's Avatar
 
Join Date: Jul 2011
Gender: Male
Posts: 154
 
Device(s): galaxy prevail , polaroid tablet 10
Carrier: Sprint , Boost

Thanks: 63
Thanked 40 Times in 33 Posts
Default

Quote:
Originally Posted by hammer422 View Post
Hi hope someone can help .. I have been trying to use the one click root for my sprint epic ..... every time I open the run bat file it says Rageagainstthecage-arm5.bin is missing .. PLEASE HELP BEEN AT THIS FOR 3 DAYS NOW ... THANKS... JIM

Are you using the root method from this thread?? Or from the epic 4g threads??
You should prolly check out the thread rooting in the epic section i just looked and it has the information you will need...
danielmike is offline  
Old October 7th, 2011, 10:11 PM   #455 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks I went there and downloaded the file .. still says Rageagainstthecage-arm5.bin is missing... posted over there hope they can help
hammer422 is offline  
Old October 8th, 2011, 12:50 AM   #456 (permalink)
Junior Member
 
Join Date: Oct 2011
Location: Ohio
Posts: 43
 
Device(s): ZTE Warp
Carrier: Not Provided

Thanks: 19
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by Bandaid View Post
After searching high and low I found the Original KMS file that worked for me. Its here incase someone needs its.
Thank you, been working all night, ran this program once, now rooted, 1:45AM time for bed. I will start removing some of the crap off the phone that I will never use to free up some memory. Thanks again :-)
ronk734 is offline  
Old October 8th, 2011, 08:18 AM   #457 (permalink)
Member
 
Bandaid's Avatar
 
Join Date: Aug 2011
Location: New York
Posts: 291
 
Device(s): Samsung Galaxy S4 (SGH-M919)
Carrier: Not Provided

Thanks: 108
Thanked 56 Times in 47 Posts
Default

Quote:
Originally Posted by ronk734 View Post
Thank you, been working all night, ran this program once, now rooted, 1:45AM time for bed. I will start removing some of the crap off the phone that I will never use to free up some memory. Thanks again :-)
Your welcome! I find Link2sd (from the Android Market) works nicely if you want to keep some of the crap your removing.

https://market.android.com/details?id=com.buak.Link2SD&feature=search_result
Bandaid is offline  
Old October 8th, 2011, 08:23 AM   #458 (permalink)
Member
 
Bandaid's Avatar
 
Join Date: Aug 2011
Location: New York
Posts: 291
 
Device(s): Samsung Galaxy S4 (SGH-M919)
Carrier: Not Provided

Thanks: 108
Thanked 56 Times in 47 Posts
Default

Quote:
Originally Posted by hammer422 View Post
Thanks I went there and downloaded the file .. still says Rageagainstthecage-arm5.bin is missing... posted over there hope they can help
I dont have your phone but here are things you can try safely.
  1. Turn anti virus off.
  2. Make sure you have USB debugging checked.
  3. Have you installed the Samsung Drivers?
  4. Try a different USB cable.
Good Luck...
Bandaid is offline  
Old October 8th, 2011, 03:36 PM   #459 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Doesn't work on my phone
KayteeKaboom12 is offline  
Old October 8th, 2011, 05:47 PM   #460 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks for all the help .. It was my anti virus . I turned it off it worked great ... a little info ... I downloaded Roam control from the market ,works great went from 1 bar up to 5
hammer422 is offline  
sponsored links
Old October 8th, 2011, 06:13 PM   #461 (permalink)
Member
 
Bandaid's Avatar
 
Join Date: Aug 2011
Location: New York
Posts: 291
 
Device(s): Samsung Galaxy S4 (SGH-M919)
Carrier: Not Provided

Thanks: 108
Thanked 56 Times in 47 Posts
Default

Quote:
Originally Posted by hammer422 View Post
Thanks for all the help .. It was my anti virus . I turned it off it worked great ... a little info ... I downloaded Roam control from the market ,works great went from 1 bar up to 5
Hey thats great news. Its tough to have a phone down for a few days. Happy Routing!
Bandaid is offline  
Old October 8th, 2011, 06:15 PM   #462 (permalink)
Member
 
Bandaid's Avatar
 
Join Date: Aug 2011
Location: New York
Posts: 291
 
Device(s): Samsung Galaxy S4 (SGH-M919)
Carrier: Not Provided

Thanks: 108
Thanked 56 Times in 47 Posts
Default

Quote:
Originally Posted by KayteeKaboom12 View Post
Doesn't work on my phone
Can you please be more specific?
Bandaid is offline  
Old October 8th, 2011, 07:00 PM   #463 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Sorry what would you like me to be more specific on ... the root or the roam control ?
hammer422 is offline  
Old October 8th, 2011, 08:18 PM   #464 (permalink)
Member
 
danielmike's Avatar
 
Join Date: Jul 2011
Gender: Male
Posts: 154
 
Device(s): galaxy prevail , polaroid tablet 10
Carrier: Sprint , Boost

Thanks: 63
Thanked 40 Times in 33 Posts
Default

Quote:
Originally Posted by hammer422 View Post
Sorry what would you like me to be more specific on ... the root or the roam control ?
lolz i think bandaid was refering to kayteekaboom12 post there!!!!!
danielmike is offline  
Old October 11th, 2011, 01:52 AM   #465 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default help i can get my prevail to flipn root

how in the heck is tihs work i tried so many time so many ways is the some one out there that can walk me through this.
lorita1976 is offline  
Old October 11th, 2011, 05:15 PM   #466 (permalink)
Junior Member
 
ittbattlesship's Avatar
 
Join Date: Oct 2011
Location: Lake Charles, LA
Posts: 18
 
Device(s): Samsung Galaxy Prevail, Samsung Transform Ultra
Carrier: Not Provided

Thanks: 14
Thanked 0 Times in 0 Posts
Default

I have been fighting with this batch script for days. win 7 x86. anyone recommend running it on xp media center?
ittbattlesship is offline  
Old October 11th, 2011, 06:38 PM   #467 (permalink)
Senior Member
 
Koumajutsu's Avatar
 
Join Date: Aug 2011
Location: Jurupa Valley(Rubidoux), Ca
Gender: Male
Posts: 1,443
 
Device(s): Samsung Galaxy Prevail, Samsung Galaxy Note 10.1, Samsung Galaxy Prevail 2
Carrier: Zombie Virus

Thanks: 136
Thanked 1,100 Times in 466 Posts
Default

I figured out the problem. The KillingMeSoftly file in version 4.0 is corrupt.
I sat down, stocked my phone, then steped through the batch file manually and here is what I found:

Quote:
$ ./KillingMeSoftly
./KillingMeSoftly[*] CVE-2010-743C Android local root exploit (C) 2010 743C[*] The Android Exploid Crew Gentlemens club - dominating robots since 2008.
[*] Donate to 7-4-3-C@web.de if you like


[*]Modified by interdpth for the prevail and possibly other phones
[+] Found prop area @ 0x40000000[*] ro.secure: 1
[+] ro.secure reset to 0
Whatever script can now execute!
$ mount -o remount,rw -t rfs /dev/stl12 /system
mount -o remount,rw -t rfs /dev/stl12 /system
mount: Operation not permitted
$ su
su
su: permission denied
$ sudo
notice that after running KMS, the prompt remains a "$"

whereas, with an older version of OCR:
Quote:
$ ./KillingMeSoftly
./KillingMeSoftly[*] CVE-2010-743C Android local root exploit (C) 2010 743C[*] The Android Exploid Crew Gentlemens club - dominating robots since 2008.
[*] Donate to 7-4-3-C@web.de if you like


[*]Modified by interdpth for the prevail and possibly other phones
[+] Found prop area @ 0x40000000[*] ro.secure: 0
[+] ro.secure resetted to 0[*] Restarting adb. Please reconnect for rootshell (adb kill-server; adb -d shel
l).

C:\Documents and Settings\...\Desktop\Phone\KMS>adb kill-server

C:\Documents and Settings\...\Desktop\Phone\KMS>adb shell
* daemon not running. starting it now *
* daemon started successfully *
#
KMS completed and restarted ADB on the phone's side. When reconnecting, we get the fabulous "#" root prompt. Everything works from there on out when done manually. The PrevailToxistence.bat still fails though, but that's an easy fix as well. I added "adb.exe wait-for-device" right after the reboot line that is between setting the permissions for KillingMeSoftly and executing the command. When executing the commands manually, I didn't need to reboot there, so it may be ok to omit it, but without the wait, ADB throws a device not found error for me.

I hope this helps
Koumajutsu is offline  
The Following 2 Users Say Thank You to Koumajutsu For This Useful Post:
Jerry in WA (October 14th, 2011), TNightshade (October 12th, 2011)
Old October 12th, 2011, 01:47 AM   #468 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default Got it to work

Windows 7, 64bit


Ok, here is what I did.
* I downloaded and installed the prevail drivers
* I downloaded one click root (KMS) and shabbymod.
* I unziped KMS to its own directory.
* I renamed KillingMeSoftly
* I opened the shabbymod zip and placed the KillingMeSoftly in KMS with the one from ShabbyMod
* I edited the PrevailToExistance.bat file
* I added the line "adb.exe wait-for-device" after
adb.exe shell chmod 777 /data/local/tmp/KillingMeSoftly
adb.exe reboot
* I replaced the line "adb.exe -d shell mount -o remount,rw -t rfs /dev/stl12 /system" with
adb.exe shell mount -o remount,rw -t rfs /dev/stl12 /system

apparently the -d might cause problems, atleast on Win7 64bit because it apparently wants
there to be no other USB devices plugged in.Did not test without it though so can't be sure,
all I know is this worked

* I used the menu system to to activate the USB debug mode
* I used the menu system on the phone to eject my MicroSDCard and then physicly removed it.
* I switched to airplane mode
* I shut down every program I could on my PC except the screens I was using to do this, and
disabled my firewall, antivirus, etc etc, including taskbar items
* I shut the phone down and started it up again.

In my case, I was working though the script by copy/pasting the lines into a Dos Window that
was in the KMS directory instead of running the script, but the script has every line I
used, just the way I used it

* In your case, run the script.

One problem seems that KillingMeSoftly that comes with one click root (KMS) has extra
whitespace in it vs the shabbymod version. While KillingMeSoftly shows it succeded,
the line remounting things,
"adb.exe -d shell mount -o remount,rw -t rfs /dev/stl12 /system" would come back
saying I couldn't use the mount command. This went away with just replaceing
killingmesoftly.

Oh, I should also say I got the info from a variety of sources. The instructions in the first post of the thread and two posts Koumajutsu provided, the one above and another one.
TNightshade is offline  
Last edited by TNightshade; October 12th, 2011 at 01:50 AM. Reason: added props to where I got the info I put together
The Following User Says Thank You to TNightshade For This Useful Post:
Jerry in WA (October 14th, 2011)
Old October 13th, 2011, 02:58 AM   #469 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default My new galaxy prevail.

Hi im new to this whole rooting thing and before i screw up my phone i was hoping to talk to somebody that is knowledgeable in this area. I believe my windows 7 is 64 bit. my prevail is through boost mobile. if i could facebook someone or something that would be awesome!
jayd420 is offline  
The Following User Says Thank You to jayd420 For This Useful Post:
joe1526 (January 9th, 2012)
Old October 14th, 2011, 07:30 AM   #470 (permalink)
Junior Member
 
Join Date: Oct 2011
Location: Bremerton, WA
Posts: 25
 
Device(s): Samsung Galaxy Prevail (CM7 mod), Asus Transformer Prime (ICS 4.0.3),
Carrier: Not Provided

Thanks: 9
Thanked 16 Times in 6 Posts
Default

I couldn't make root work until I followed the file modification instructions in TNightshade's post above. I've attached a new KMS folder zipped up with the files already modified to work on the newer Prevail.

When I tried before (like 20 times), nothing would make it root the phone. The attached version worked the first time for me.

I just bought my Prevail about 2-3 weeks ago, perhaps why root was being stubborn.

Thanks to all for sharing.

[edit] Forgot to mention I'm using Windows 7 (x64).
Attached Files
File Type: zip Prevail Root Oct-2011.zip (1.12 MB, 545 views)
aangel likes this.
Jerry in WA is offline  
Last edited by Jerry in WA; October 25th, 2011 at 01:47 PM. Reason: [Eyes Only] Top Secret
The Following 7 Users Say Thank You to Jerry in WA For This Useful Post:
crotchfist (October 18th, 2011), cyntalkz87 (November 5th, 2011), dthomas510 (November 4th, 2011), LakMobes (October 21st, 2011), Neolantis (November 29th, 2011), Richard R (November 4th, 2011), xopher425 (October 25th, 2011)
sponsored links
Old October 14th, 2011, 12:19 PM   #471 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Why didn't I started from here? it would have saved me 3 hours of frustration, the "-d " did the trick for me, thanks TNightshade. Awesome work all of you.
lenniscata is offline  
Old October 14th, 2011, 02:37 PM   #472 (permalink)
Junior Member
 
Join Date: Jun 2011
Location: Midwest
Posts: 56
 
Device(s): EVO 3D - FreEvo (current) - Senseless - Supra - Viper
Carrier: Not Provided

Thanks: 13
Thanked 2 Times in 2 Posts
Default

Just to confirm, after reading 471 posts, this method will root the Samsung Precedent just like the Prevail, right?

And am I better off with odin vs one click?

Thanks,

G
grepper is offline  
Old October 14th, 2011, 03:41 PM   #473 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Awesome i rooted my phone by reading all your guys information and i knew nothing on this subject before hand! Bravo
jayd420 is offline  
Old October 16th, 2011, 05:43 PM   #474 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Jerry in WA View Post
I couldn't make root work until I followed the file modification instructions in TNightshade's post above. I've attached a new KMS folder zipped up with the files already modified to work on the newer Prevail.

When I tried before (like 20 times), nothing would make it root the phone. The attached version worked the first time for me.

I just bought my Prevail about 2-3 weeks ago, perhaps why root was being stubborn.

Thanks to all for sharing.
Wow, I been trying to get this to work since like 6am. Note to self, check last page of replies first

With the files I downloaded from the OP I was getting

Code:
Press any key to continue . . .
                HERE WE GO

117 KB/s (5899 bytes in 0.049s)
error: device not found
Wait for phone to reconnect...
* daemon not running. starting it now *
* daemon started successfully *
mount: Operation not permitted
59 KB/s (4292 bytes in 0.071s)
Copying files onto phone...
failed to copy 'su' to '/system/xbin/su': No such file or directory
failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
stem
failed to copy 'busybox' to '/system/xbin/busybox': No such file or directory
failed to copy 'remount' to '/system/xbin/remount': No such file or directory
Setting permissions...
Unable to chmod /system/xbin/busybox: No such file or directory
Unable to chmod /system/xbin/remount: No such file or directory
Unable to chmod /system/xbin/su: No such file or directory
Unable to chmod /system/xbin/su: No such file or directory
link failed Read-only file system
Installing busybox...
/system/xbin/busybox: not found
Cleaning up files...
"You should have root!"

Press any key to continue . . .

This edited system worked on the first shot. Thank you.

EDIT: Almost forgot to mention that I was using the Galaxy Precedent on Straight Talk
Renegade631 is offline  
Last edited by Renegade631; October 16th, 2011 at 05:44 PM. Reason: Mention that I was using the Galaxy Precedent
Old October 17th, 2011, 03:19 PM   #475 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

I have been trying all afternoon to root my Prevail and it took one shot with this! You guys are great!
JulieM10199 is offline  
Old October 21st, 2011, 10:58 PM   #476 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Jerry in WA View Post
I couldn't make root work until I followed the file modification instructions in TNightshade's post above. I've attached a new KMS folder zipped up with the files already modified to work on the newer Prevail.
.
Thanks for the modified files, saved some time. This worked great, Had been having trouble on my win7 64bit OS, first time with these mods and it is now rooted
LakMobes is offline  
Old October 22nd, 2011, 10:38 PM   #477 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the new files....it worked first time!!
sebread is offline  
Old October 23rd, 2011, 06:43 AM   #478 (permalink)
Member
 
kingjay2012's Avatar
 
Join Date: May 2011
Posts: 333
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 27 Times in 20 Posts
Default

Quote:
Originally Posted by sebread View Post
Thanks for the new files....it worked first time!!
Where on gods green earth do i put the killingmesoftly file at on my computer after i extract it cause it really start to piss me off....

Further more if any body have time could they guide me through the entire process, cuz something is very wrong here, i cant even get my computer to acknowledge my device, yes i installed the USB Driver on my pc, yes downloaded the kms files, the new , the old, and the Oct.11, still the same S to me,yes i extracted it as i was i was told, and yes i went to prevailtoexistence.bat and what happened in there? apparently im missing my killingmesoftly file on the cpu, but i believe its two things holding me back from rooting it, killlingmesoftly file and my computer not acknowledging my phone, please help me someone!!!!!!!!!!
kingjay2012 is online now  
Last edited by kingjay2012; October 23rd, 2011 at 06:52 AM.
Old October 23rd, 2011, 08:35 AM   #479 (permalink)
Senior Member
 
Koumajutsu's Avatar
 
Join Date: Aug 2011
Location: Jurupa Valley(Rubidoux), Ca
Gender: Male
Posts: 1,443
 
Device(s): Samsung Galaxy Prevail, Samsung Galaxy Note 10.1, Samsung Galaxy Prevail 2
Carrier: Zombie Virus

Thanks: 136
Thanked 1,100 Times in 466 Posts
Default

Quote:
Originally Posted by kingjay2012 View Post
Where on gods green earth do i put the killingmesoftly file at on my computer after i extract it cause it really start to piss me off....

Further more if any body have time could they guide me through the entire process, cuz something is very wrong here, i cant even get my computer to acknowledge my device, yes i installed the USB Driver on my pc, yes downloaded the kms files, the new , the old, and the Oct.11, still the same S to me,yes i extracted it as i was i was told, and yes i went to prevailtoexistence.bat and what happened in there? apparently im missing my killingmesoftly file on the cpu, but i believe its two things holding me back from rooting it, killlingmesoftly file and my computer not acknowledging my phone, please help me someone!!!!!!!!!!
Did you put your phone into debugging mode?
Koumajutsu is offline  
Old October 25th, 2011, 01:39 PM   #480 (permalink)
Junior Member
 
Join Date: Oct 2011
Location: Chicago, IL
Gender: Male
Posts: 24
 
Device(s): Galaxy S II Galaxy Prevail, rooted but innactive
Carrier: Not Provided

Thanks: 10
Thanked 3 Times in 2 Posts
Default Many thanks

Many thanks, all. Debated for about a week on whether to do this on my new Prevail. I'm a bit of a noob at this, like so many others, and feared messing my phone up. Finally, last night, just took the plunge and did it. Didn't work at first, of course, redid it many times, then finally remembered the updated files I had read about above. Downloaded the fixed files, and it worked like a charm.

Got rid of the bloatware, will eventually begin to modify other things . . . .
xopher425 is offline  
sponsored links
Old October 25th, 2011, 01:55 PM   #481 (permalink)
Junior Member
 
Join Date: Oct 2011
Location: Bremerton, WA
Posts: 25
 
Device(s): Samsung Galaxy Prevail (CM7 mod), Asus Transformer Prime (ICS 4.0.3),
Carrier: Not Provided

Thanks: 9
Thanked 16 Times in 6 Posts
Default

Quote:
Originally Posted by xopher425 View Post
Many thanks, all. Debated for about a week on whether to do this on my new Prevail. I'm a bit of a noob at this, like so many others, and feared messing my phone up. Finally, last night, just took the plunge and did it. Didn't work at first, of course, redid it many times, then finally remembered the updated files I had read about above. Downloaded the fixed files, and it worked like a charm.

Got rid of the bloatware, will eventually begin to modify other things . . . .
I've tweaked iPhones, but I'm an Android noob as well. I was sure I'd root my phone, but I debated about using the (only?) custom rom awhile. I'm glad I did. Alot more features with the interface now and less bloatware.

Be sure you back up your contacts if you customize after rooting. I forgot to prior to loading Shabbymod and had to redo them all again. Oops.
Jerry in WA is offline  
Old October 27th, 2011, 03:00 AM   #482 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i must be ******ed... ive been messing with this for 2 hours.. ive read the readme, watched the video... lol and when i go into the command prompt to do the adb reboot... it does nothign

idk i saw another guy was getn a file moved fail thing to my screen is the exact same as hime but trying it at the samsung screen is doing nothing for me
sjhogan11 is offline  
Old October 27th, 2011, 03:08 AM   #483 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Jerry in WA View Post
I couldn't make root work until I followed the file modification instructions in TNightshade's post above. I've attached a new KMS folder zipped up with the files already modified to work on the newer Prevail.

When I tried before (like 20 times), nothing would make it root the phone. The attached version worked the first time for me.

I just bought my Prevail about 2-3 weeks ago, perhaps why root was being stubborn.

Thanks to all for sharing.

[edit] Forgot to mention I'm using Windows 7 (x64).


used this!!! worked amazingly! thankyou, was almost to the point of giving up, u do have to manually dowload busy box tho jus thought id throw that in there
sjhogan11 is offline  
Last edited by sjhogan11; October 27th, 2011 at 03:18 AM.
Old October 27th, 2011, 11:02 AM   #484 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 30
 
Device(s):
Carrier: Not Provided

Thanks: 17
Thanked 1 Time in 1 Post
Default

It shouldn't be this difficult to uninstall shit you don't want or need on your phone. That being said, I downloaded that root thing and it installed. Not sure what was accomplished. Everything I don't want is still on the phone Youtube, that twitter shit, etc.).

Why is it again they call these things 'smart phones'?

Quote:
Originally Posted by Necrotoxin View Post
I had an issue at first. I rebooted my phone and killed all unnecessary apps and it went fine. Be patient and don't give the phone any input.
jb59 is offline  
Old October 30th, 2011, 11:29 AM   #485 (permalink)
ROM Developer
 
Shabbypenguin's Avatar
 
Join Date: Mar 2011
Gender: Male
Posts: 5,289
 
Device(s): Nexus 5
Carrier: Sprint

Thanks: 353
Thanked 4,951 Times in 2,041 Posts
Default

guys making a new thread so it doesnt get confused but there is a new one click
__________________
Enjoy my work?
Donate here

Know an unloved device? swing by our new forums
Shabbypenguin is offline  
The Following User Says Thank You to Shabbypenguin For This Useful Post:
wyelkins (October 31st, 2011)
Old October 30th, 2011, 07:21 PM   #486 (permalink)
New Member
 
Join Date: Oct 2011
Location: Redmond, OR 97756
Gender: Male
Posts: 3
 
Device(s): Samsung Galaxy Prevail, Toshiba Excite AT300/64GB, ASUS TF101
Carrier: Boost

Thanks: 0
Thanked 0 Times in 0 Posts
jeepman28@gmail.com
Default

I get stuck when I when I try to root the device in Linux mint 11 I am not a beginner at this but this is bugging me that I even have to ask if I am doing something wrong. but it get stuck at that last command and I have let it set for days thinking it just needs time so can someone please help me. I am using the boost mobile version of the Prevail.
Lazybones KMS # sh run.sh
[: 8: x86_64: unexpected operator
[: 15: Linux: unexpected operator
...[*] I think we failed....
Wait for phone to reconnect...
Mount system as r/w, cleanup old files, do some basic configuration
jeepman28 is offline  
Old October 30th, 2011, 10:30 PM   #487 (permalink)
New Member
 
Join Date: Oct 2011
Location: Redmond, OR 97756
Gender: Male
Posts: 3
 
Device(s): Samsung Galaxy Prevail, Toshiba Excite AT300/64GB, ASUS TF101
Carrier: Boost

Thanks: 0
Thanked 0 Times in 0 Posts
jeepman28@gmail.com
Angry found the issue

The Device will not mount I have tried force mounting it using dmesg to find out where it is mounted, then I used fdisk -l /dev/scsi and it did not mount the device so what am I doing wrong
jeepman28 is offline  
Old October 30th, 2011, 10:35 PM   #488 (permalink)
New Member
 
Join Date: Oct 2011
Location: Ohio
Posts: 4
 
Device(s): Galaxy Prevail
Carrier: Not Provided

Thanks: 7
Thanked 0 Times in 0 Posts
Default

Thanks once I've read all instructions,I will try this
deacshel is offline  
Old November 4th, 2011, 12:07 PM   #489 (permalink)
Member
 
Tank2211's Avatar
 
Join Date: Nov 2011
Location: Indiana
Gender: Male
Posts: 133
 
Device(s): Samsung Galaxy S III
Carrier: Boost

Thanks: 32
Thanked 18 Times in 14 Posts
Send a message via Skype™ to Tank2211
Default

Okay so ive followed this step by step... listened to the video I dont even know how many times.... I cant get it to work. Dont insult my intelligence, this just simply means I somehow missed something or something isnt working right. If someone could help me that would be great. I need to get my phone rooted so I can tether to my computer for work.
Tank2211 is offline  
Old November 4th, 2011, 02:02 PM   #490 (permalink)
Senior Member
 
Koumajutsu's Avatar
 
Join Date: Aug 2011
Location: Jurupa Valley(Rubidoux), Ca
Gender: Male
Posts: 1,443
 
Device(s): Samsung Galaxy Prevail, Samsung Galaxy Note 10.1, Samsung Galaxy Prevail 2
Carrier: Zombie Virus

Thanks: 136
Thanked 1,100 Times in 466 Posts
Default

Quote:
Originally Posted by Tank2211 View Post
Okay so ive followed this step by step... listened to the video I dont even know how many times.... I cant get it to work. Dont insult my intelligence, this just simply means I somehow missed something or something isnt working right. If someone could help me that would be great. I need to get my phone rooted so I can tether to my computer for work.
Dude, read the thread. This one's broken. There are fixed versions later in the thread, or you can just go use the new one that works here.

http://androidforums.com/galaxy-prevail-all-things-root/437314-acs-one-click-root-samsung-prevail-replenish-shabbyfied.html
Koumajutsu is offline  
sponsored links
Old November 5th, 2011, 07:15 AM   #491 (permalink)
Junior Member
 
Join Date: Sep 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 16
Thanked 0 Times in 0 Posts
Default

I like others on here have been trying to root their (mine) phone for hours and I run your version 1 time and it works !! I can't thank you enough ....this is amazing ...well gotta go tweek and play ...thank you so much for all the help you guys give in here !! ....Cyn :O)
cyntalkz87 is offline  
Old November 6th, 2011, 10:19 AM   #492 (permalink)
New Member
 
Join Date: Jul 2011
Location: Ohio
Posts: 3
 
Device(s): samsung galixy prevail
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Root

This is sweet i have been tring for weeks now and today with your new version it worked great! you rock dude!!
fstasme is offline  
Old November 6th, 2011, 01:24 PM   #493 (permalink)
ROM Developer
 
Shabbypenguin's Avatar
 
Join Date: Mar 2011
Gender: Male
Posts: 5,289
 
Device(s): Nexus 5
Carrier: Sprint

Thanks: 353
Thanked 4,951 Times in 2,041 Posts
Default

if the new version worked then use teh new versions thread ;P

this one is interdpths root method, the other is mine
Shabbypenguin is offline  
Old November 15th, 2011, 10:06 PM   #494 (permalink)
Junior Member
 
Join Date: Nov 2011
Posts: 56
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Question Need step by step instructions

I am new to the concept of rooting and have NO idea what I am doing. Is there a link to step by step instructions (where to find the downloads included)? I've downloaded a few things on my phone that I thought would help (Titanium Backup, Rom Toolbox, and Busybox Installer) but they all say I need to root first. Please help.
MDykstra is offline  
Old November 16th, 2011, 09:23 AM   #495 (permalink)
Senior Member
 
Join Date: Mar 2011
Location: Jax Fl
Posts: 4,183
 
Device(s): LG Nexus 4, HTC EVO 4G Sold, LG Esteem Wifes, Samsung Galaxy Prevail, Samsung Nexus S 4G, LG Optimus
Carrier: Not Provided

Thanks: 391
Thanked 1,457 Times in 1,005 Posts
Default

http://androidforums.com/galaxy-prevail-all-things-root/437314-acs-one-click-root-samsung-prevail-replenish-shabbyfied.html

That should answer most of your questions
new optimus is offline  
Old November 21st, 2011, 08:41 AM   #496 (permalink)
Junior Member
 
Join Date: Nov 2011
Location: Mechanicville, New York
Posts: 36
 
Device(s): Prevail and Prevail 2
Carrier: Boost

Thanks: 20
Thanked 4 Times in 4 Posts
Laugh Thank you all !

My Prevail updated to GB last week, I searched for a way to root and remove the junk, I found all I needed supplied right here in this forum, I used oneclick, busybox, minitool, link2SD, Titanium backup, open garden wifi. I have to say I was a little worried about rooting my phone, never did anything like this before, but I read every post I could find and followed the instructions and had to learn how to use some of the programs like minitool to create 2 primary partions on an SD card, did not know you could do that, but I did and it works. I am very impressed with my new phone and all of the hard work everyone here has done, I now have friends asking me to find a way to root thier phones, I send them here to look for the answers, I will end up finding what they need and I will do it for them, knowing I can get the correct answers and for the first time I was able to wifi tether my laptop to my phone and it was amazing to see how fast it really was and my girlfriend also connected to my phone at the same time with no performance issues at all. As soon as I have some money I will donate. Thank you all for a great job, a great new phone, well done.
bill236 is online now  
Old December 3rd, 2011, 10:38 PM   #497 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

Ok, someone please help. I have been trying this forever. I opened prevail to existence. I went through the process. At the end it said "you should have root". What do I do from there? I do not have root on my phone. I tried to shut it off and back on, nothing happened.

Have I missed something? Busy box and other programs say that I do not have root. Do I need to re-mount the SD card first? Should I have done something to the SD card before unmounting it?

Any help will be greatly appreciated. I am going out of town next week and I need to get my phone rooted so that I can use it for a hotspot for my Kindle Fire.

P.S, I know these are basic questions, but I am new to this rooting stuff.
Bramvill is offline  
Old December 4th, 2011, 01:15 PM   #498 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

I think my phone is not connecting to my computer. I just realized that the root program will run and say "you should have root" no matter what. (dumb of me I know)

My phone says it is in debug mode and the drivers are downloaded, put it does not seem like the root program is doing anything to my phone. Any ideas?
Bramvill is offline  
Old December 5th, 2011, 04:51 AM   #499 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 46,385
 
Device(s): M8, LTEvo, 3vo, and Shift - Evo retired
Carrier: Sprint

Thanks: 42,734
Thanked 57,191 Times in 22,982 Posts
Default

This root method has been superseded by new root methods.

Please see the sticky threads at the top of this forum to find the new threads. I think you'll find the answers to your questions and the right root methods.

Thanks!
__________________
|

Minutus cantorum, minutus balorum, minutus carborata descendum pantorum.

Links: Site Rules / Guidelines -and- Zero Tolerance Policy (All Members Read)


For right-on help, the Thanks button is on the right of the post.
For anything out in left field, the /!\ report button is to the left.

Remember, it's our forums and we're all in this together - so let's keep it cool!

Shoot the breeze at the best new gun forum!
EarlyMon is offline  
Closed Thread


Go Back   Android Forums > Android Phones > Samsung Galaxy Prevail > Galaxy Prevail - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://androidforums.com/galaxy-prevail-all-things-root/346918-one-click-root.html
Posted By For Type Date
I dont know what USB drivers need for my samsung galaxy prevail to root it? - Yahoo! Answers This thread Refback January 17th, 2012 12:00 PM


All times are GMT -5. The time now is 01:15 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.