Go Back   Android Forums > Android Development > Developer Forums > Getitnowmarketing

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree2Likes

test: Reply
 
LinkBack Thread Tools
Old November 18th, 2010, 04:10 PM   #1 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default Custom recovery Optimus One P500/Thunderg

Outdated : New thread http://androidforums.com/getitnowmarketing/330813-all-one-recovery-thread.html


Attached Files
File Type: zip flash_image.zip (4.9 KB, 9299 views)
xd groetaers and Jefferson13 like this.

getitnowmarketing is offline  
Last edited by getitnowmarketing; November 9th, 2011 at 12:48 PM.
Reply With Quote
The Following 22 Users Say Thank You to getitnowmarketing For This Useful Post:
angel_garcia (December 26th, 2010), anotherloony (January 10th, 2011), azrael911 (December 23rd, 2010), chichacorn (April 22nd, 2011), divyanshu308 (July 25th, 2011), dryhte (November 21st, 2010), experimentxx (June 20th, 2011), JeeHoonTyler (June 12th, 2011), ldawn88 (December 29th, 2010), LuvStry (November 21st, 2010), neneanaie (January 23rd, 2011), ot3pch4n (July 5th, 2011), ravoyd36 (February 13th, 2011), serkaneker (April 24th, 2011), smart2smart (December 2nd, 2010), tejaslok (March 26th, 2011), Vinc (March 28th, 2011)
sponsored links
Old November 20th, 2010, 05:44 AM   #2 (permalink)
Member
 
Join Date: Mar 2010
Location: Belgium
Posts: 186
 
Device(s): Samsung Galaxy I7500 (Froyo - GAOSP nightlies since 09182010) & LG P500 Optimus One
Carrier: Not Provided

Thanks: 8
Thanked 31 Times in 15 Posts
Default

getitnowmarketing = drellisdee?

If so, is this version identical to RC2 on XDA?

If not, is this some sort of co-operation?

thanks
dryhte is offline  
Reply With Quote
Old November 20th, 2010, 07:43 AM   #3 (permalink)
Member
 
Join Date: Mar 2010
Location: Belgium
Posts: 186
 
Device(s): Samsung Galaxy I7500 (Froyo - GAOSP nightlies since 09182010) & LG P500 Optimus One
Carrier: Not Provided

Thanks: 8
Thanked 31 Times in 15 Posts
Default

re: xda-developers - View Single Post - Section for the LG Optimus One P500

Quote:
with the extra part for swap try this and post feedback in android forums post.

on

echo /dev/block/mmcblk0p1 > /sys/devices/platform/msm_hsusb/gadget/lun0/file

off

echo "" > /sys/devices/platform/msm_hsusb/gadget/lun0/file
Yup, that works fine.

Quote:
do you have a p500 or a p509 optimus t?
P500 Optimus One

Thanks I'll update my script soon so other's that have enabled swap on sd can mass-storage mount sdcard in recovery untill then use the above commands if you have partitoned sd card for swap.
dryhte is offline  
Last edited by getitnowmarketing; November 20th, 2010 at 04:17 PM.
Reply With Quote
The Following User Says Thank You to dryhte For This Useful Post:
divyanshu308 (July 25th, 2011)
Old November 30th, 2010, 11:46 PM   #4 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Lg vortex??

I have the new Verizon LG Vortex which I understand used to be the Optimus One. If this is correct, can I apply these root programs, etc for the Optimus One onto my Vortex? Thanks.
dwvenus is offline  
Reply With Quote
Old December 1st, 2010, 10:01 AM   #5 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by dwvenus View Post
I have the new Verizon LG Vortex which I understand used to be the Optimus One. If this is correct, can I apply these root programs, etc for the Optimus One onto my Vortex? Thanks.
You must use vortex recovery. You can use the enable jit one though. Diff devices.
getitnowmarketing is offline  
Reply With Quote
Old December 1st, 2010, 02:45 PM   #6 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Where is the file "install-recovery.sh" adb returns me:
mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
failed on '/system/etc/install-recovery.sh' - No such file or directory

I guess this is because the file "install-recovery.sh" is missing. Where can i find it ? And how do i put it in my Lg O1 ?
lgromb is offline  
Reply With Quote
Old December 2nd, 2010, 08:39 AM   #7 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by lgromb View Post
Where is the file "install-recovery.sh" adb returns me:
mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak
failed on '/system/etc/install-recovery.sh' - No such file or directory

I guess this is because the file "install-recovery.sh" is missing. Where can i find it ? And how do i put it in my Lg O1 ?
You dont want that file there as it keeps recovery from "sticking" its not in all roms usually there ater you do an ota update. That command removes it. If its not there move on to next step.
getitnowmarketing is offline  
Reply With Quote
Old December 2nd, 2010, 01:08 PM   #8 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you very much, problem solved
lgromb is offline  
Reply With Quote
Old December 4th, 2010, 12:04 AM   #9 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

How come I can't see the picture above when I do "reboot recovery" on CMD, and when I do Power + Vol. Down + Home key while off? Is there something I still need to do....?
Jamelly is offline  
Reply With Quote
Old December 4th, 2010, 01:24 AM   #10 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by Jamelly View Post
How come I can't see the picture above when I do "reboot recovery" on CMD, and when I do Power + Vol. Down + Home key while off? Is there something I still need to do....?
Did you flash it as per the entire instructions?
getitnowmarketing is offline  
Reply With Quote
sponsored links
Old December 4th, 2010, 09:30 PM   #11 (permalink)
New Member
 
Join Date: Jul 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

Only one question before I do this: how do I get back to the original recovery ? Just in case I have to take the phone to waranty or something like that

Thanks.
SeerKan is offline  
Reply With Quote
Old December 4th, 2010, 10:52 PM   #12 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nevermind, I installed it now on my phone. For backing up nand, do I need the phone to be USB plugged?
Jamelly is offline  
Reply With Quote
Old December 5th, 2010, 12:34 PM   #13 (permalink)
Premium Member
 
death2all110's Avatar
 
Join Date: Jun 2010
Location: Illinois, US
Gender: Male
Posts: 1,979
 
Device(s): Samsung Galaxy S4; LG Spectrum
Carrier: Verizon Wireless

Thanks: 162
Thanked 1,190 Times in 479 Posts
Send a message via Yahoo to death2all110 deatheatergrim@gmail.com
Default

No you do not. it goes to your sd card
__________________
I help maintain CM11 for the LG Spectrum.

LG VX8300>LG Decoy>LG Dare>LG Ally>Droid2>LG Ally>HTC Droid Incredible>HTC Thunderbolt>HTC Droid Incredible>Samsung Galaxy Nexus>LG Spectrum>Moto Droid RAZR Maxx>Samsung Galaxy S4


I'm located in: Computers&IT, LG Spectrum, XDA Developers; AllyIRC My Blog


Please press button, and please consider donating to my energy drink fund.Thanks!
death2all110 is online now  
Reply With Quote
Old December 7th, 2010, 05:19 AM   #14 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I tried this, but i get the warning

"mount permission not granted"

I have tried issuing the commands through ADB and through droid explorer.

Im using win 7 x64.

please can you advise...I have root access through z4root.

thanks

MG
mysticgenius is offline  
Reply With Quote
Old December 7th, 2010, 01:45 PM   #15 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Recovery flashed - but not able to boot into

Hi

I followed these instructions and was able to flash 1.1 recovery image to LG OPTIMUS S.

From adb shell, I was able to do reboot recovery and get to recovery menu and I was able to take backups successfully

However, I am not able to get into recovery mode when I press Vol Down or Home Button during Power ON cycle.

Is there a way to get into recovery mode during switching ON the phone

Also, I tried to flash 1.2 version of this. I got bad mount sector error.

1.1 works good, but cannot go into recovery mode during power ON.

I just want to fix this before I flash custom ROM.

Any help is appreciated.

Thanks
forum_user_99 is offline  
Reply With Quote
Old December 9th, 2010, 06:11 PM   #16 (permalink)
New Member
 
r0cc0's Avatar
 
Join Date: Dec 2010
Posts: 2
 
Device(s): Acer LiquidE
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to r0cc0 Send a message via Skype™ to r0cc0
Default

Hello everyone, I wanted to know how to do a reset after putting the smartphone Custom recovery and jit.
menu backup / restore you can do a reset to bring the smartphone to factory settings, keeping the recovery and jit

Thanks to all for replies and sorry if the text is garbled, but I use google translator!
r0cc0 is offline  
Reply With Quote
Old December 9th, 2010, 09:32 PM   #17 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mysticgenius View Post
Hi,

I tried this, but i get the warning

"mount permission not granted"

I have tried issuing the commands through ADB and through droid explorer.

Im using win 7 x64.

please can you advise...I have root access through z4root.

thanks

MG
Bump Bump,

I have tried everything, I can run the mount command and this gives me output, but when i try to run:

mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system

I get mount permission denied
EDIT:

I have tried to use root explorer to mount RW then i manually copyed in the flash_image which worked, I now have the flash_image in /system/bin/

but when i issue chmod /system/bin/flash_image i get:

unable to chmod /system/bin/flash_image : Operation not permitted

PLEASE CAN SOMEONE HELP WITH THIS
mysticgenius is offline  
Last edited by mysticgenius; December 9th, 2010 at 10:59 PM.
Reply With Quote
Old December 12th, 2010, 02:30 AM   #18 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

When i try to restore a nandroid backup, the recovery says: run "nandroid-mobile.sh recovery" from adb... why? i can make a backup but i can't restore it... Wow
orymd is offline  
Reply With Quote
Old December 15th, 2010, 03:13 PM   #19 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,

After installing this and rebooting the mobile phone, I'm getting this message on the screen:

Fastboot mode started
udc_start()
-- suspend --
-- reset --
-- portchange --
STALL GET_DESCIPTOR 128 6 3840 o 5
fastboot: processing commands

What am I supposed to do now?

Thanks for the helping
magicknot is offline  
Reply With Quote
Old December 21st, 2010, 03:10 PM   #20 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

same problem for me as for magicknot followed the instructions but ended up with fastboot mode on boot and nothing happens. please help (a)
salte_eskil is offline  
Reply With Quote
sponsored links
Old December 23rd, 2010, 08:58 AM   #21 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same problem with me also ,i think i bricked my device,plsease help me
rakesh_4utoo is offline  
Reply With Quote
Old December 23rd, 2010, 01:20 PM   #22 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default run "nandroid-mobile.sh recovery" from adb

I had problems with restoring from backups with message

run "nandroid-mobile.sh recovery" from adb"

but when I did this the script complained that it could not mount the sdcard.

It turns out that my sdcard was formatted with no partitioning and hence incorrect partition names were being used in the script.

The solution was:-

1. save the whole contents of the sdcard on my PC.

2. repartition the sdcard, using either the recovery program's built-in tools or a linux box with an sdcard adapter (don't forget to format your partition if going the linux route).
You will want a FAT partition for your storage, an ext2 partition for later use by app2sd, and some swap space too. I also added via linux a fourth partition for the debian linux distribution at some point. :-)

3 Add your saved data back to the card.

3. reboot recovery mode with the new sdcard and and you should now be able to restore backups.
skycat61 is offline  
Reply With Quote
Old December 24th, 2010, 03:50 PM   #23 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Doesn't work for me, I did everything as mentioned, but it opens up a LG recovery ( I think) which asks me to set Language,date etc :/ and all my apps and stuff is gone :/.What is this, can someone help?
Siddhesh222 is offline  
Reply With Quote
Old December 26th, 2010, 01:20 PM   #24 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 3
 
Device(s): LGP500
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default Problems with recovery

Hi, I have problems making the recovery, here's how I did it if anyone knows where I could be wrong:

z4root.1.3.0.apk I installed the file and I run, it has created the icon z4root "I opened and I put" Permanent Root "with prior activation of" USB debugging "because it will not let me root , while doing the "Permanent Root" the terminal rein) and after reinciciar I turn to get into the "z4root" and verify that this root because it makes (your device is Already rooted) in the notifications I get (# superuser z4root Superuser Has Been Granted permission), also has created an icon called "superuser" when you open this program "z4root" I select and I put afford. Having done all this I run the program "Terminal Emulator" and putting the first two lines I get the following in the mobile:

$ # mount-o remount, rw-t yaffs2 / dev/block/mtdblock1 / system

$ cat / sdcard / flash_image> / system / bin / flash_image

cat / sdcard / flash_image> / system / bin / flash_image: Operation not permitted



If I put the # on each line as shown below do nothing:

$ # mount-o remount, rw-t yaffs2 / dev/block/mtdblock1 / system

$ # cat / sdcard / flash_image> / system / bin / flash_image

$ # chmod 755 / system / bin / flash_image

$ # mv / system / etc / install-recovery.sh / system / etc / install-recovery.sh.bak

$ # mount-o remount, ro-t yaffs2 / dev/block/mtdblock1 / system

$ # flash_image recovery / sdcard/recovery-RA-GNM-thunderg-1.1.0.img

$ # reboot recovery

I sorry, my English is very bad, I translated with google translator.
angel_garcia is offline  
Reply With Quote
Old December 26th, 2010, 01:49 PM   #25 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Dont type the "#" thats just the cursor prompt showing you have a root # shell not a user $ shell. To change the $ to # you have to type su first.

Quote:
Originally Posted by angel_garcia View Post
Hi, I have problems making the recovery, here's how I did it if anyone knows where I could be wrong:

z4root.1.3.0.apk I installed the file and I run, it has created the icon z4root "I opened and I put" Permanent Root "with prior activation of" USB debugging "because it will not let me root , while doing the "Permanent Root" the terminal rein) and after reinciciar I turn to get into the "z4root" and verify that this root because it makes (your device is Already rooted) in the notifications I get (# superuser z4root Superuser Has Been Granted permission), also has created an icon called "superuser" when you open this program "z4root" I select and I put afford. Having done all this I run the program "Terminal Emulator" and putting the first two lines I get the following in the mobile:

$ # mount-o remount, rw-t yaffs2 / dev/block/mtdblock1 / system

$ cat / sdcard / flash_image> / system / bin / flash_image

cat / sdcard / flash_image> / system / bin / flash_image: Operation not permitted



If I put the # on each line as shown below do nothing:

$ # mount-o remount, rw-t yaffs2 / dev/block/mtdblock1 / system

$ # cat / sdcard / flash_image> / system / bin / flash_image

$ # chmod 755 / system / bin / flash_image

$ # mv / system / etc / install-recovery.sh / system / etc / install-recovery.sh.bak

$ # mount-o remount, ro-t yaffs2 / dev/block/mtdblock1 / system

$ # flash_image recovery / sdcard/recovery-RA-GNM-thunderg-1.1.0.img

$ # reboot recovery

I sorry, my English is very bad, I translated with google translator.
getitnowmarketing is offline  
Last edited by getitnowmarketing; December 26th, 2010 at 01:52 PM.
Reply With Quote
The Following User Says Thank You to getitnowmarketing For This Useful Post:
angel_garcia (December 26th, 2010)
Old December 26th, 2010, 02:05 PM   #26 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 3
 
Device(s): LGP500
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by getitnowmarketing View Post
Dont type the "#" thats just the cursor prompt showing you have a root # shell not a user $ shell. To change the $ to # you have to type su first.
then if don't show # as root in the "Terminal Emulator", how could she change $ to #?
Thanks in advance.
angel_garcia is offline  
Reply With Quote
Old December 26th, 2010, 03:32 PM   #27 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by angel_garcia View Post
then if don't show # as root in the "Terminal Emulator", how could she change $ to #?
Thanks in advance.
su
getitnowmarketing is offline  
Reply With Quote
The Following User Says Thank You to getitnowmarketing For This Useful Post:
angel_garcia (December 27th, 2010)
Old December 27th, 2010, 07:09 AM   #28 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default

I managed to do a nandroid backup, but I cannot restore.

I get an error message, something with ADB. Sorry I haven't kept in my mind the entire sequence.

Any help would be apreciated.
badeaioan is offline  
Reply With Quote
Old December 27th, 2010, 02:17 PM   #29 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Angry How to start after copying the file

I am new to android and i have optimus one i have rooted my phone using z4root. I am a complete noob pleae tell me how to use the code in adb shell

i cannnot understand how to do this step
Quote:
"to flash: Via adb shell or terminal type this from root # shell"
sahilisburman is offline  
Reply With Quote
Old December 27th, 2010, 02:42 PM   #30 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default

Go to market and download Terminal Emulator.

After that launch it and type SU. Click Allow. After that type all the commands listed above.

Good luck !
badeaioan is offline  
Reply With Quote
The Following 2 Users Say Thank You to badeaioan For This Useful Post:
Djinn Moto (December 27th, 2010), sahilisburman (December 29th, 2010)
sponsored links
Old December 28th, 2010, 01:20 AM   #31 (permalink)
Junior Member
 
Join Date: Dec 2010
Posts: 20
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 10 Times in 3 Posts
Default

My Lg Optimus Ones will not boot. Might this be able to fix the problem?

I have no back ups as phone died whiling trying to do first back up.

I am guessing the emulator lets you type commands on the phone??

If so it is probably not what I need.
4wd vege is offline  
Reply With Quote
Old December 28th, 2010, 05:09 PM   #32 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This tutorial is easily the most frustrating thing i've ever had to follow. I'm typing these comands into the terminal emulator with no errors, yet it just doesn't work.

I have the two image files on my SD card, I rooted with z4root before that, and it doesn't work.

# mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system

# cat /sdcard/flash_image > /system/bin/flash_image

# chmod 755 /system/bin/flash_image

# mv /system/etc/install-recovery.sh /system/etc/install-recovery.sh.bak

Here it says now, failed on this, no such file or directory. But the first time I did it, this worked.

# mount -o remount,ro -t yaffs2 /dev/block/mtdblock1 /system

# flash_image recovery /sdcard/recovery-RA-GNM-thunderg-1.1.0.img

I did this, then it said it failed part way through because something was missing or corrupt, then I went back to start again and it doesn't work now. what the hell.

# reboot recovery
thesmoth is offline  
Reply With Quote
Old December 28th, 2010, 08:38 PM   #33 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem flashing the image PLEASE HELP!!!!

someone please help ms as i am desperate here trying to flash custom recovery on my p500 optimus one.I did everithing correctly as mentioned but it get stuck on flash_image recovery /sdcard/recovery-RA-GNM-thunderg-1.1.0.img does nothing from this point i have tried at least 30 times and nothing if i restrat pushing down home+pwr+vol key it will delete all my apps and everything.I will make a big donation if can help me get thru with this i spent a lot of nights trying to do this.
claudiutou is offline  
Reply With Quote
Old December 29th, 2010, 04:15 AM   #34 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by orymd View Post
When i try to restore a nandroid backup, the recovery says: run "nandroid-mobile.sh recovery" from adb... why? i can make a backup but i can't restore it... Wow
Bump ! I experience this too. Any ideas ?
badeaioan is offline  
Reply With Quote
Old December 29th, 2010, 01:00 PM   #35 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

followed all the steps mentioned. when i hit

# reboot recovery

my phone re boots normally and all the data is wiped off and i get the LG P500 basic 1st time set up screen! can anyone tell what went wrong?

EDIT: While using the ADB commands i had mounted my SD card which i guess caused the problem.
manekbhavin is offline  
Last edited by manekbhavin; December 29th, 2010 at 01:29 PM.
Reply With Quote
Old December 29th, 2010, 01:29 PM   #36 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Jamelly View Post
Nevermind, I installed it now on my phone. For backing up nand, do I need the phone to be USB plugged?
Can you elaborate how your problem got solved?
manekbhavin is offline  
Reply With Quote
Old December 29th, 2010, 02:59 PM   #37 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

When i boot into recovery mode, i don't get a menu or anything just the splash screen in the background of the OP's picture and it reboots.
404 Not Found is offline  
Reply With Quote
Old December 29th, 2010, 03:22 PM   #38 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation E: Bad boot message

SUCCESS! ATLAST I OPENED MY O1 IN RECOVERY MODE BUT THERE IS A PROBLEM.
1) when recovery mode opens background has a pic with exclamation mark on it ind in the last line a message is written "E: bad boot message.

Please tell me how to resolve it
Thanks in advance
sahilisburman is offline  
Reply With Quote
Old December 29th, 2010, 05:52 PM   #39 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 404 Not Found View Post
When i boot into recovery mode, i don't get a menu or anything just the splash screen in the background of the OP's picture and it reboots.
Update: Now it either won't let me because of a lack of a signature, or no update script
404 Not Found is offline  
Last edited by getitnowmarketing; January 1st, 2011 at 08:40 AM.
Reply With Quote
Old December 29th, 2010, 09:57 PM   #40 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Post how to move apps 2 ext

i know you will find this question stupid but still help me out

I partitioned the sd card with 512 mb ext partition. but now what to do further? i mean to say how to move all apps to the ext??
sahilisburman is offline  
Last edited by sahilisburman; December 30th, 2010 at 02:34 PM. Reason: change in forrmatting
Reply With Quote
sponsored links
Old January 1st, 2011, 08:36 AM   #41 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by sahilisburman View Post
SUCCESS! ATLAST I OPENED MY O1 IN RECOVERY MODE BUT THERE IS A PROBLEM.
1) when recovery mode opens background has a pic with exclamation mark on it ind in the last line a message is written "E: bad boot message.

Please tell me how to resolve it
Thanks in advance
Quoted from 1st post

"Note this recovery and the one for the LG Vortex have a service that instantly reboots out of recovery once you load it & I disabled it and thats why you get a E: "Bad Boot Message" on inital startup. Its completely fine."
getitnowmarketing is offline  
Reply With Quote
Old January 1st, 2011, 08:37 AM   #42 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by sahilisburman View Post
i know you will find this question stupid but still help me out

I partitioned the sd card with 512 mb ext partition. but now what to do further? i mean to say how to move all apps to the ext??
Requires custom scripts and or rom. Look for custom roms available for device.
getitnowmarketing is offline  
Reply With Quote
Old January 1st, 2011, 08:41 AM   #43 (permalink)
ROM Developer
Thread Author (OP)
 
Join Date: Apr 2010
Posts: 477
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 792 Times in 168 Posts
Default

Quote:
Originally Posted by 404 Not Found View Post
Update: Now it either won't let me because of a lack of a signature, or no update script
Thats stock recovery. You didn't flash custom recovery properly or didnt remove the install-recovery.sh.
getitnowmarketing is offline  
Reply With Quote
Old January 1st, 2011, 01:56 PM   #44 (permalink)
New Member
 
S3nd41's Avatar
 
Join Date: Dec 2010
Gender: Male
Posts: 11
 
Device(s): LG Optimus One P500
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Question Step-by-step explanation

Hello,

I want to make a backup of my current default rom before messing around with custom ones and deleting default system apps. That flash_image and the recovery .img you provided will simply enable me to get into debugging mode from where I can make a backup of my current default rom, right? It will not flash my rom with any custom roms or will it? Also, afterwards how can I restore my default debugging mode if I need to reclaim my cell phone warranty or something?

If you could explain step-by-step what all of those commands do it would be nice also. I'd like to understand the whole procedure before trying this out.

Thanks!
S3nd41 is offline  
Reply With Quote
Old January 1st, 2011, 08:27 PM   #45 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

how to add languages to this rom ??

i already have my arabic fonts , there is any way to put it in the system ??

This rom is fantastic !!
HellGate is offline  
Reply With Quote
Old January 3rd, 2011, 07:33 AM   #46 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

# mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
# cat /sdcard/flash_image > /system/bin/flash_image
/sdcard/flash_image: invalid length
#
ccdreadcc is offline  
Reply With Quote
Old January 4th, 2011, 12:43 AM   #47 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Cool

It worked beautifully. I am now the proud owner of an Optimus T P509 rooted and custom ROM'd. I installed Amber Home V 1.1 on it. Thanks guys!
Omnichron is offline  
Reply With Quote
Old January 4th, 2011, 01:24 PM   #48 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 3
 
Device(s): LGP500
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

I too work well in my LGP500, I only had a small problem with some commands enter spaces, but now is ok. I too installed Amber Home V1.1 and work ok. Thanks.

some question more,
when I download an application, where default is saved, in phone memory or partition ext3 Memory Card (512 mb)?
Can I know how much memory as ext3 microsd card I am using.
angel_garcia is offline  
Last edited by angel_garcia; January 5th, 2011 at 01:14 PM.
Reply With Quote
Old January 6th, 2011, 09:57 PM   #49 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Ti++ies or your other favorite piece of anatomy!!!

Fabulous method! I would suggest adding that one needs to unzip the necessary files that you provide: the recovery image and the flash_zip. I would also clarify that if the install-recovery.sh script is not found its still a go for those that aren't down with linuz and his CLI speak. Thanks!
Sigma47 is offline  
Reply With Quote
Old January 6th, 2011, 10:25 PM   #50 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Can someone please help me. I'm basically a newbie and don't know how to install this, I just don't get every thing after "To use copy flash_image and recovery-RA-GNM-thunderg-1.1.0.img to the root of your sdcard." and then im stuck on flashing with adb and terminal and shit like that, and people at school call me a nerd hahhaa
johno168 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Development > Developer Forums > Getitnowmarketing
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://androidforums.com/getitnowmarketing/221388-custom-recovery-optimus-one-p500-thunderg.html
Posted By For Type Date
Android Corner: Guide to Installing Android 2.3 Gingerbread on the LG Optimus One This thread Refback May 22nd, 2011 09:47 PM
<??>LG P500 Custom recovery - Mobile01 ???? This thread Refback February 12th, 2011 10:28 PM


All times are GMT -5. The time now is 12:04 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.