Go Back   Android Forums > Android Phones > HTC Hero > Hero - Support and Troubleshooting

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old November 21st, 2009, 03:35 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default HTC Hero !! No Service !!

Hello,

I am facing a strange problem. Today I purchased an unlocked Hero. I have to different SIM cards from different service providers. I installed the first one and worked w/o any problem.

Later on, I tried the other provider's SIM and on the screen it says No Service. Sometimes, I see the reception bars but cannot make and receive any calls.

What may be the reason ? I assume that there is no problem with the hardware as it is working with one of my SIM cards.

TIA..

aedemirci is offline  
Reply With Quote
sponsored links
Old November 21st, 2009, 03:57 PM   #2 (permalink)
Member
 
Join Date: Sep 2009
Posts: 109
 
Device(s): Nexus One on Orange UK
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

The hero isn't no good if you have a weak signal from your provider.
markie-m8 is offline  
Reply With Quote
Old November 21st, 2009, 04:04 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

But as I mentioned, no prob with my other simcard. Can it be related with the unlocking procedure ??
aedemirci is offline  
Reply With Quote
Old November 21st, 2009, 05:03 PM   #4 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by aedemirci View Post
Hello,

I am facing a strange problem. Today I purchased an unlocked Hero. I have to different SIM cards from different service providers. I installed the first one and worked w/o any problem.

Later on, I tried the other provider's SIM and on the screen it says No Service. Sometimes, I see the reception bars but cannot make and receive any calls.

What may be the reason ? I assume that there is no problem with the hardware as it is working with one of my SIM cards.

TIA..
me too!
I ordered an unlock code from the Orange( my hero is locked on orange)
today I got the code, and input it.
It says the phone unlock completely.
I use the Vodafone Sim, it says not registered on network. and I tried 3 Sim, the same.

but these two sim works well in my old phone.

I called the orange service, they don't know what's the problem.
hjcamel is offline  
Last edited by hjcamel; November 21st, 2009 at 05:14 PM.
Reply With Quote
Old November 21st, 2009, 05:37 PM   #5 (permalink)
Junior Member
 
Join Date: Sep 2009
Posts: 44
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by aedemirci View Post
But as I mentioned, no prob with my other simcard. Can it be related with the unlocking procedure ??
you said the sim cards are from different providers. so the one that works means you have good service in your area, and the one that doesn't work means you have bad service in your area, what don't you understand? just because one carrier has good service where you are, doesn't mean all carriers will.
Gabe is offline  
Last edited by Gabe; November 21st, 2009 at 05:39 PM.
Reply With Quote
Old November 21st, 2009, 05:55 PM   #6 (permalink)
Check six!
 
Slug's Avatar
 
Join Date: Aug 2009
Location: Inverness, UK
Gender: Male
Posts: 17,415
 
Device(s): Sony Xperia Z
Carrier: EE

Thanks: 2,651
Thanked 10,864 Times in 5,524 Posts
Send a message via Skype™ to Slug slugbrem@gmail.com
Default

Quote:
Originally Posted by hjcamel View Post
I ordered an unlock code from the Orange

I called the orange service, they don't know what's the problem.
Keep on at them and insist on a solution. They took your money and provided a non-working code, so the onus is on them to sort out their mistake.
Slug is offline  
Reply With Quote
Old November 21st, 2009, 06:00 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2009
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried the simcard with a different phone w/o any problem. So, it is not a reception problem.
aedemirci is offline  
Reply With Quote
Old November 23rd, 2009, 06:00 AM   #8 (permalink)
Senior Member
 
daveybaby's Avatar
 
Join Date: Sep 2009
Location: UK
Posts: 919
 
Device(s): HTC Hero (FroydVillain), Sony Ericsson Xperia Arc
Carrier: Not Provided

Thanks: 29
Thanked 101 Times in 84 Posts
Default

Is it a 3G SIM? You need a 3G SIM for the hero.
__________________
Sony Ericsson Xperia Arc : GiffGaff : UK
daveybaby is offline  
Reply With Quote
Old November 23rd, 2009, 01:45 PM   #9 (permalink)
New Member
 
Join Date: Nov 2008
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check your APN setting when switching SIM's.

You might need to manually alter them.
Headsh0x is offline  
Reply With Quote
Old November 26th, 2009, 06:41 PM   #10 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by daveybaby View Post
Is it a 3G SIM? You need a 3G SIM for the hero.
yes, it's 3 mobile sim card.

and I also tried vodafone and nomi and O2. they all didn't work.

It's not sim card problem, it's phone.

I think because the IMEI number problem.

If the 9th and 10th IMEI number is 12, these HTC Hero have the same problem
hjcamel is offline  
Reply With Quote
sponsored links
Old November 26th, 2009, 06:44 PM   #11 (permalink)
New Member
 
Join Date: Nov 2009
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Slug View Post
Keep on at them and insist on a solution. They took your money and provided a non-working code, so the onus is on them to sort out their mistake.
en~
yes, I called orange service again, they said they will give me refund. but they can not refund my calling fee. WTF.

and I found if the 9th and 10th IMEI number is 12, these HTC hero suffered the same problem.

T_T~~
hjcamel is offline  
Reply With Quote
Old December 2nd, 2009, 07:47 PM   #12 (permalink)
New Member
 
Join Date: Dec 2009
Location: Europe
Posts: 1
 
Device(s): HTC Hero White
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi all,

I have a different solution for this problem. It happened to me, as well, several times, to get a "No service" or "Insert SIM card" error randomly, while being in an area with full coverage. Most of the time I was just rebooting the phone and things were getting back to normal.

One day this trick did not work anymore so I had to look more in depth to see what is the problem. Surprise! MECHANICAL PROBLEM!

The SIM slot needs to be properly locked after inserting the SIM. You would expect, like I did, that the SIM tray will lock itself in place just by pushing it down. No... You need to move the upper side fully to the left just by using your nails.

Due the vibrations if the SIM card is not properly locked in place there is no full contact with the connector ... or there is random contact. Once the SIM is lost even if the contact is restored by vibration it will not recover unless you do a reboot....

So, in conclusion, if that happens to you make sure you have the SIM card securely locked in its tray!
bend is offline  
Last edited by bend; February 2nd, 2010 at 03:12 PM.
Reply With Quote
Old April 9th, 2012, 12:32 PM   #13 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bend View Post
MECHANICAL PROBLEM!

The SIM slot needs to be properly locked after inserting the SIM. You would expect, like I did, that the SIM tray will lock itself in place just by pushing it down. No... You need to move the upper side fully to the left just by using your nails.

Due the vibrations if the SIM card is not properly locked in place there is no full contact with the connector ... or there is random contact. Once the SIM is lost even if the contact is restored by vibration it will not recover unless you do a reboot....

Thanks for this advice,I had same promlem with hTC, and it worked.
MeMuFe is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC Hero > Hero - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:07 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.