Go Back   Android Forums > Android Tablets & MIDs > HP TouchPad

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old March 18th, 2012, 07:52 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Location: New Jersey
Posts: 14
 
Device(s): HP Touchpad
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default Can't connect to wifi

Sorry for the long post.

I have had the HP Touchpad for about a month now and love it. My problem is that I can't connect to wifi and need help. I have the latest webos that seems to connect fine. I loaded cm7 which sometimes got the internet, it seems only if webos wifi was turned off. I upgraded to cm9 alpha 2 by using ACMEInstaller2 without deleting anything and was able to connect to the internet only 1 time. I have tried to forget, start new connection etc. on my home network but get no bars even though it says signal strength is excellent. I also tried these steps with my results in ():

1. Boot into WebOS and make sure your wifi connects. Use your browser for a sec and then boot back to CM.
(Wifi works on webos not android)

2. Delete your wifi profile:

start the terminal app

type su and tap enter
the pound sign # turns to a dollar sign $
type rm -rf data/misc/wifi && reboot and tap enter

For clarity that's rm(space)-rf(space)/data/misc/wifi(space)&&(space)

Reboot your TouchPad.

After your TP reboots, you will have to reestablish the SSID and password for every AP you use.

(when I go to terminal app and do rm etc.. it said read only and will not execute)

3. Go to Settings -->WiFi --> Menu --> Advanced --> Keep wifi on during sleep --> Always

4. Download Clock Sync, configure it for your timezone and set it to sync on boot.(An incorrect date or time can screw up
wifi and several other things in Android)

The last thing is I can't side load any fix apps since I can't seem to get android recognized by my computer. I read somewhere on the net about adb and got all the java requirement for android onto my computer but when I try to do an adb from touchpad it says device not found so I may be doing something wrong there as well.

Anyway any help would be appreciated.

bha19 is offline  
Last edited by bha19; March 18th, 2012 at 07:55 AM. Reason: typo
Reply With Quote
sponsored links
Old March 18th, 2012, 08:58 AM   #2 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,852
 
Device(s): HP TouchPad, Samsung Galaxy Note II, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 833
Thanked 1,810 Times in 1,403 Posts
Default

Hi bha, sorry you're having so much trouble.

First, is the problem your TP or your router? Can you connect to ANY router? If you can't connect to ANY wireless (public, coffee, restaurant, library) then concentrate on your touchpad.



For starts, it's been recommended in many places not to upgrade CM7 to CM9 for the touchpad. Many of us have had a lot less trouble once we booted into recovery and formatted data. (Make a backup in Titanium Backup and recovery first.)

You might want to flash this wifi fix: [ROM] CM9 Tenderloin nightlies

wifi settings: some say that a lower channel on your router, like 1-6 is best, but I don't buy that. Setting your router to use "G" (not "N" exclusively) helps. (Mine says "up to 54 mps.) Also change security using WPA or WPA2 with TKIP.

How old is your router? If it's more than 3 years old or doesn't do "N", replace it. You can get a Netgear N150 for $45 at Walmart. I've had lots of routers and that's the best.

This is good if you're in a apartment/condo or congested area: Wifi channel optimizing
colchiro is offline  
Last edited by colchiro; March 18th, 2012 at 09:01 AM.
Reply With Quote
Old March 18th, 2012, 09:17 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Location: New Jersey
Posts: 14
 
Device(s): HP Touchpad
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

I think it is anywhere but wil try the library today, although webos even has trouble at the library sometimes. I did try the router thing. My router is dual band 2.4 and 5 and under security the options were:

Security mode:
disabled
64 bit wep
128 bit web
wpa/wpa2-personal(psk)

Authentication:
wpa-psk
wpa2-psk
wpa-psk+wpa2-psk

I did not see tpik so I did not mess with it.

I guess I will try a clean install of cm9
bha19 is offline  
Reply With Quote
Old March 18th, 2012, 09:26 AM   #4 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,852
 
Device(s): HP TouchPad, Samsung Galaxy Note II, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 833
Thanked 1,810 Times in 1,403 Posts
Default

Try the patch first.
colchiro is offline  
Reply With Quote
The Following User Says Thank You to colchiro For This Useful Post:
bha19 (March 18th, 2012)
Old March 18th, 2012, 10:49 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Location: New Jersey
Posts: 14
 
Device(s): HP Touchpad
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by colchiro View Post
Try the patch first.
tried the patch and it worked. The 1st thing I downloaded was FXR WIFI FIX.
Thanks for your help. I will let you know if it goes out again.
bha19 is offline  
Reply With Quote
Old March 18th, 2012, 06:09 PM   #6 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,852
 
Device(s): HP TouchPad, Samsung Galaxy Note II, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 833
Thanked 1,810 Times in 1,403 Posts
Default

I don't know much about the patch, (like is it included with nightlies or compatible with them)?
colchiro is offline  
Reply With Quote
Old March 18th, 2012, 06:33 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2012
Location: New Jersey
Posts: 14
 
Device(s): HP Touchpad
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

So here is what happened. I have been in android all day so I don't if problems may arise when I go back to webos. Wifi has been strong all day so it is looking good.
bha19 is offline  
Reply With Quote
Old March 18th, 2012, 06:41 PM   #8 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,852
 
Device(s): HP TouchPad, Samsung Galaxy Note II, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 833
Thanked 1,810 Times in 1,403 Posts
Default

In the past, I found that going into webOS often fixed my wifi issues. I suspect my date might have been off, webOS fixed it and everything was good when I booted back into CM7.
colchiro is offline  
Reply With Quote
Old March 30th, 2012, 06:05 PM   #9 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default hp touchpad CM9 daily build

rm /data/misc/wifi/wpa_supplicant.conf
reboot
worked
alexkrat is offline  
Reply With Quote
Old April 1st, 2012, 10:01 PM   #10 (permalink)
Member
 
Join Date: Sep 2011
Posts: 135
 
Device(s): Droid Incredible 2 (stock), HP Touchpad (cm9 a2)
Carrier: Not Provided

Thanks: 5
Thanked 27 Times in 24 Posts
Default

What worked for me was changing my router to channel 1 any g only instead of mixed b/g.
bioforce is offline  
Reply With Quote
sponsored links
Old April 2nd, 2012, 08:29 AM   #11 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Must agree. Tried every fix I could find on the forums, but could not keep wifi consistent. I always avoided channel 1 because analysis showed neighbor congestion. However, when I finally tried channel 1 in desperation, wah la, worked like a charm. Sometome simple is best.
ricklynchcore is offline  
Reply With Quote
The Following User Says Thank You to ricklynchcore For This Useful Post:
Ed. (April 4th, 2012)
Old April 2nd, 2012, 04:01 PM   #12 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,852
 
Device(s): HP TouchPad, Samsung Galaxy Note II, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 833
Thanked 1,810 Times in 1,403 Posts
Default

I'm on channel 4 only b/c I'm in a congested building and that's the best open spot. Turning off wireless-n (5 mhz) also helps.
colchiro is offline  
Reply With Quote
The Following User Says Thank You to colchiro For This Useful Post:
layka (April 5th, 2012)
Old April 24th, 2012, 07:23 AM   #13 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bioforce View Post
What worked for me was changing my router to channel 1 any g only instead of mixed b/g.
This worked for me, thanks.
devrit is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Tablets & MIDs > HP TouchPad
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:21 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.