Go Back   Android Forums > Android Tablets & MIDs > HP TouchPad

New Forums: Nexus Player | Nexus 9
Like Tree2Likes
  • 1 Post By Nevertells
  • 1 Post By Nevertells

test: Reply
 
LinkBack Thread Tools
Old October 11th, 2012, 04:26 PM   #1 (permalink)
Member
Thread Author (OP)
 
Nevertells's Avatar
 
Join Date: Oct 2012
Location: Florida
Gender: Male
Posts: 195
 
Device(s): HP TouchPad
Carrier: Not Provided

Thanks: 8
Thanked 43 Times in 35 Posts
Default Latest Version of CM10(Test Drive)

Well, I just finished most of the afternoon taking O.a.T.'s 10/10 rom of CM10, build 4.1.2 for a spin around the block. I believe this is supposed to be the lastest and greatest release of CM10 from Google.

He built this version of CM10 from the current merged additions to the CM repository which means that it is hundeds and hundreds of changes, additions, improvements ahead of the preview version released by J.C. Sullins back on August 2. This is a straight build from CM. O.a.T. does put out a custom rom
he calls LnT. Shoot, go read the thread and you can find out all about it. It started out as a place to post about J.C.'s preview, but in the last ten pages or so it has turned to discussion about O.a.T.'s roms.

For you flashaholics, you can read about it's evolution here:

http://forum.xda-dev...d.php?t=1811480

If you are dying to try it out you can download it and it's MD 5 here:

Rom:
http://www.mediafire...9bfq7kknksx37kd

MD5:
http://www.mediafire...g1o59q44rsv25pc


Here is what happened on my test drive:

Flashed the rom and JB gapps using GooManager and TWRP. Wiped both caches and waited while JB to setup the apps and then start.
At first glance, all appeared normal for about three minutes. I was browsing around the settings when I lost virtually all touchscreen functions.
I tried holding the power button to either reboot or turn the TP off and the lack of touchscreen would not allow me to do so. So a power/home button hard reset got me back to Moboot and tried it again. This time I never got past the boot animation. After a few minutes of watching that, which BTW is a cool new CyanogenMod animation, hard reset again. Third time was the charm. I looked through the settings again to see what looked different. First thing I found was CM finally fixed the clock am/pm function that never did work in ICS. All my settings appeared to be the same and I saw some new stuff I am not going to try to explain here.

After around 30 minutes, I lost Google, wifi icon turned gray. Turning wifi off and back on corrected that and it never happened again while testing things out. Bench marks were all about the same as my ICS install. Screen response is definitely smoother and quicker. Wifi speed is about the same. Any game I tried that has H/W acceleration F/C's. Of course YouTube does not work. And of course the known missing functions of audio, mic are real obvious. Chrome works, but has some strange issues I won't try to explain here. Firefox was crashing until I download an update and now seems to be working OK.

I had to stop as the charge was running low. I did test the fact that if one plugs in the charger while the TP is turned off, it will boot up and start charging correctly, so that fix remains intact. I'll update this post once it is charged back up and I can let it sleep for a few hours and see how the battery usage compares. I seem to remember reading somewhere that it was supposed to be much improved in JB.
untitled1 likes this.

Advertisements
Nevertells is offline  
Reply With Quote
The Following User Says Thank You to Nevertells For This Useful Post:
colchiro (October 11th, 2012)
sponsored links
Old October 11th, 2012, 04:48 PM   #2 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

You're braver than me.

Couple questions...

Did you wipe data or upgrade CM9?
Did you use acme3 to expand the partitions?

Sounds like another alpha build. I think I'll wait until it's more stable. I've got JB on two other devices I use more so know what it looks like.
colchiro is offline  
Reply With Quote
Old October 12th, 2012, 10:40 AM   #3 (permalink)
Member
Thread Author (OP)
 
Nevertells's Avatar
 
Join Date: Oct 2012
Location: Florida
Gender: Male
Posts: 195
 
Device(s): HP TouchPad
Carrier: Not Provided

Thanks: 8
Thanked 43 Times in 35 Posts
Default

Quote:
Originally Posted by colchiro View Post
You're braver than me.

Couple questions...

Did you wipe data or upgrade CM9?
Did you use acme3 to expand the partitions?

Sounds like another alpha build. I think I'll wait until it's more stable. I've got JB on two other devices I use more so know what it looks like.
Just wiped both caches and used GooManager/TWRP to flash over the top of my CM9 install.

My understanding of ACME3 is it isn't really needed right now. When the full nightly builds become available, if ever, they will be upwards of 250MB in size. This build I flashed comes in at around 147MB. So at that point will have to use ACME3 to expand the partition to accommodate Jelly Bean.

Actually, I would not even call it an alpha. O.a.T. is a very knowledgeable guy who likes to build his own and sometimes makes them available over on XDA. Like I said in my post, it has all the latest merges compared to J.C.'s preview from two and a half months ago. He is even talking about trying to merge Dorregaray's camera code into one of his custom CM10 builds. The one I flashed is just a straight gerrit build. If you remember eyeballer's unofficial nightlies, he did some cherry picking and tweaking of his builds. O.a.T. does the same thing with his. I think he calls his custom roms LnT.

Personally, I don't see that much difference between ICS and JB other than what I mentioned in my post. But now that I mention that, I left my TP asleep last night and battery drain was averaging 100mA. Hope that gets fixed before it hits nightly status. They also left out my favorite screen off animation. I liked that.
Nevertells is offline  
Reply With Quote
Old October 12th, 2012, 10:40 PM   #4 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

I already ran acme3 in preparation for being able to wipe everything, and flash cm10 when it was time.

I still have that goofy discharge with my TP powered off. I think it might be CM9 b/c sometimes I'm able to go 24 hours with no battery loss. Might be time for me to run the uninstaller and start over.
colchiro is offline  
Reply With Quote
Old October 15th, 2012, 03:18 PM   #5 (permalink)
Member
Thread Author (OP)
 
Nevertells's Avatar
 
Join Date: Oct 2012
Location: Florida
Gender: Male
Posts: 195
 
Device(s): HP TouchPad
Carrier: Not Provided

Thanks: 8
Thanked 43 Times in 35 Posts
Default

Quote:
Originally Posted by colchiro View Post
I already ran acme3 in preparation for being able to wipe everything, and flash cm10 when it was time.

I still have that goofy discharge with my TP powered off. I think it might be CM9 b/c sometimes I'm able to go 24 hours with no battery loss. Might be time for me to run the uninstaller and start over.

When you say wipe everything, do you mean running ACMEUninstaller? That resets all the memory to their original settings.

I can't imagine how CM is affecting your TouchPad when it is turned off. One's TouchPad is not running anything until the HP bios looks for the boot loader, which in our case is moboot. It's only when one selects an OS from there is either WebOS or Android running. I think you have some kind of hardware issue, specifically the battery. I can turn mine off for days and it will still be at 100% when I turn it back on. You can try a clean install. I'll be really surprised if that helps. I suppose it's worth a try.
Nevertells is offline  
Reply With Quote
Old October 15th, 2012, 04:41 PM   #6 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

Quote:
Originally Posted by Nevertells View Post
When you say wipe everything, do you mean running ACMEUninstaller? That resets all the memory to their original settings.
I ran acme3 now so when cm10 comes out I can just install it and wipe data, etc from recovery.

Besides, I was bored.

Quote:
Originally Posted by Nevertells View Post
I can't imagine how CM is affecting your TouchPad when it is turned off. One's TouchPad is not running anything until the HP bios looks for the boot loader, which in our case is moboot. It's only when one selects an OS from there is either WebOS or Android running. I think you have some kind of hardware issue, specifically the battery. I can turn mine off for days and it will still be at 100% when I turn it back on. You can try a clean install. I'll be really surprised if that helps. I suppose it's worth a try.
It appears it's not shutting down completely and that's what's running the battery down.

I have had a couple times where I shutdown and battery was still 100% the next day, but that's not very often. One of those times was when I booted soley into webOS. I'm going to check several days with just webOS and checking battery in TWRP and see if I can see some consistency. Meanwhile I still have that new battery I bought a few weeks ago.
colchiro is offline  
Reply With Quote
Old November 5th, 2012, 08:34 PM   #7 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

New battery fixed the problem.
colchiro is offline  
Reply With Quote
Old November 6th, 2012, 06:26 AM   #8 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 91
 
Device(s): Samsung Galaxy Note 3 Asus Transformer Prime Nexus 7
Carrier: T-Mobile

Thanks: 11
Thanked 15 Times in 14 Posts
Default

w00t!
wncken is offline  
Reply With Quote
The Following User Says Thank You to wncken For This Useful Post:
colchiro (November 6th, 2012)
Old November 6th, 2012, 08:07 AM   #9 (permalink)
Member
Thread Author (OP)
 
Nevertells's Avatar
 
Join Date: Oct 2012
Location: Florida
Gender: Male
Posts: 195
 
Device(s): HP TouchPad
Carrier: Not Provided

Thanks: 8
Thanked 43 Times in 35 Posts
Default

Quote:
Originally Posted by colchiro View Post
New battery fixed the problem.
Hot damn! Now if you could just find those replacement clips.
colchiro likes this.
Nevertells is offline  
Reply With Quote
Old November 6th, 2012, 03:59 PM   #10 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

It might be possible to glue them, but since I already snapped it back together, that's not happening any time soon.

I went >48 hours and still had 100% battery. Next step is to check again next Monday evening (7 days) and if still close to 100%, I'm calling this issue closed. My wife will lose about 1% per week with her TP.
colchiro is offline  
Reply With Quote
sponsored links
Old November 6th, 2012, 05:24 PM   #11 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

Back on topic....

I see there's another CM10 preview build: Goo.im Downloads - Browsing preview

This is still a very experimental alpha build with lots of broken stuff. I have not tried it.
colchiro is offline  
Reply With Quote
Old November 8th, 2012, 06:42 AM   #12 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

Nov 7 build is up (3rd preview). Goo.im Downloads - Browsing preview
colchiro is offline  
Reply With Quote
Old November 16th, 2012, 07:13 PM   #13 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

p4 build is up. Goo.im Downloads - Browsing preview
colchiro is offline  
Reply With Quote
Old November 18th, 2012, 09:15 AM   #14 (permalink)
Member
Thread Author (OP)
 
Nevertells's Avatar
 
Join Date: Oct 2012
Location: Florida
Gender: Male
Posts: 195
 
Device(s): HP TouchPad
Carrier: Not Provided

Thanks: 8
Thanked 43 Times in 35 Posts
Default

I posted the following in the How to update CM7/9/10, however there seems to be a lot more folks following this thread at the moment, so my apologies for double posting:

Well, if you have been reading the ACMEInstaller3 and How to install CM10(by RolandDeschain79) threads in the Rootzwiki HP TouchPad forum, you've seen a lot of discussion about folks having issues using ACME3, myself included. The Reader's Digest version is this, developer Green advised that using cwm to install(flash) a nightly or format the /data and /system partitions, introduces corruption into the file system. He flat out stated that he avoids using cwm for that reason. We are not so sure if twrp does the same thing. I tested twrp by installing a nightly over a clean install and then updating again using ACME3 and did not get the 15 minutes of inode errors scrolling up the screen. Until this is all sorted out, I would suggest that once you get your CM install cleaned up by uninstalling via ACMEUninstaller and using ACME3 to install CM9 or 10, that you use ACME3 to install any further nightly updates. It's only when updating a nightly that the damage is done. Installing Gapps or other flashable zips does not format the /system partition, so using cwm or twrp for this Green advises is safe.

Most of you already have your PC setup to run ACMEInstallers and the uninstaller, so it's not a big leap to use that instead of cwm to install a nightly. Roland and I have been testing the process and it does it's job very nicely. If you are absolutely terrified of using ACME3 for routine installing of a nightly, I would recommend you use twrp rather than cwm. Just keep in mind that backups made using cwm are not compatible with twrp and older backups made with twrp are not compatible with the newest version of twrp, version 3.2.1.

This is where we are at right now. Roland or myself will keep you posted on the latest developments.
Nevertells is offline  
Reply With Quote
Old November 18th, 2012, 09:26 AM   #15 (permalink)
Senior Member
 
colchiro's Avatar
 
Join Date: Jun 2010
Gender: Male
Posts: 8,886
 
Device(s): HP TouchPad, HTC One Max, Dell Venue 11 Pro
Carrier: Verizon

Thanks: 840
Thanked 1,820 Times in 1,413 Posts
Default

I've also had no errors with acme3 after using TWRP. It appear to be the safer way to go.
colchiro is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Tablets & MIDs > HP TouchPad
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:23 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.