Go Back   Android Forums > Android Phones > HTC EVO 3D

test: Reply
 
LinkBack Thread Tools
Old March 26th, 2012, 03:26 PM   #1 (permalink)
Senior Member
Thread Author (OP)
 
ArmageddonX's Avatar
 
Join Date: May 2011
Location: Arizona, USA
Gender: Male
Posts: 1,541
 
Device(s): Nexus5 - Nexus10
Carrier: Sprint

Thanks: 369
Thanked 840 Times in 417 Posts
Default Battery Problem

I've been having a strange battery issue lately. When my phone drops to 20% or 25% I usually plug it in. It charges up to 78% VERY quickly and then after moderate use will drop to 40% or so again very quickly. Often when charging it will jump from 78% to 100% instantaneously. Combined with how quickly it is discharging, I just can't figure out what is going on.

I tried a battery pull and then charged to 100% again. Seems to still be happening. =\

Any advice?

Advertisements
__________________
Note that thoughts expressed here are merely my personal opinions and will hopefully
share my thoughts on the matter to stimulate a respectful discussion.
"There are in fact two things, science and opinion; the former begets knowledge, the latter ignorance." ~ Hippocrates
"If anyone's head is acting an antenna, seek help or wear tin foil." ~ EarlyMon
ArmageddonX is offline  
Last edited by marctronixx; March 26th, 2012 at 09:22 PM. Reason: split into seperate threads.
Reply With Quote
sponsored links
Old March 26th, 2012, 03:30 PM   #2 (permalink)
Member
 
Join Date: Sep 2011
Posts: 184
 
Device(s): EVO3D
Carrier: Not Provided

Thanks: 8
Thanked 65 Times in 50 Posts
Default

are you using the HTC charger or a different one? Whenever I use a different brand charger, this seems to happen a lot
Corpse11 is offline  
Reply With Quote
Old March 26th, 2012, 03:37 PM   #3 (permalink)
Fixing stuff is not easy
 
Join Date: May 2011
Location: Over there <points>
Gender: Male
Posts: 7,690
 
Device(s): Samsung Galaxy S3; Asus Infinity
Carrier: Sprint

Thanks: 2,117
Thanked 4,314 Times in 2,513 Posts
jerofld
Default

Quote:
Originally Posted by ArmageddonX View Post
I've been having a strange battery issue lately. When my phone drops to 20% or 25% I usually plug it in. It charges up to 78% VERY quickly and then after moderate use will drop to 40% or so again very quickly. Often when charging it will jump from 78% to 100% instantaneously. Combined with how quickly it is discharging, I just can't figure out what is going on.

I tried a battery pull and then charged to 100% again. Seems to still be happening. =\
Charge it up to full and let it discharge down to 3%. 3% is the threshold where it'll shut off. Then charge it back to 100% without interruption. Your indication could be some odd glitch in battery_stats.bin. It's supposed to get reset after a full charge up, down, and back up.

The second problem is strange. If it were just the sounds, I'd think that you have sounds on the SD card.

Considering both problems, I'd think you should try factory resetting to clear out the phone.
jerofld is offline  
Last edited by marctronixx; March 26th, 2012 at 09:23 PM.
Reply With Quote
Old March 26th, 2012, 09:27 PM   #4 (permalink)
HTC User
 
Join Date: Oct 2009
Posts: 5,220
 
Device(s):
Carrier: Not Provided

Thanks: 21,193
Thanked 3,068 Times in 1,798 Posts
Default

battery could also have a faulty cell that is shorting. a shorted cell can produce widely varying charge and discharge rates. i would install a battery monitor and note the changes.
marctronixx is offline  
Reply With Quote
Old March 26th, 2012, 09:43 PM   #5 (permalink)
Senior Member
Thread Author (OP)
 
ArmageddonX's Avatar
 
Join Date: May 2011
Location: Arizona, USA
Gender: Male
Posts: 1,541
 
Device(s): Nexus5 - Nexus10
Carrier: Sprint

Thanks: 369
Thanked 840 Times in 417 Posts
Default

I discharged the battery until the phone shut itself down. It has been charging 2 hours still turned off and the light is still red. Seems like it's been charging forever... I can't believe the light isn't green already...
ArmageddonX is offline  
Reply With Quote
Old March 26th, 2012, 11:12 PM   #6 (permalink)
Member
 
Wiley_11's Avatar
 
Join Date: May 2011
Location: SoCal
Posts: 259
 
Device(s): Nexus 5
Carrier: Sprint

Thanks: 219
Thanked 133 Times in 86 Posts
Default

Sprint Repair Store can test your battery in about 10 minutes.
__________________

Wiley_11 is online now  
Reply With Quote
The Following User Says Thank You to Wiley_11 For This Useful Post:
marctronixx (March 27th, 2012)
Old March 27th, 2012, 01:23 PM   #7 (permalink)
Senior Member
Thread Author (OP)
 
ArmageddonX's Avatar
 
Join Date: May 2011
Location: Arizona, USA
Gender: Male
Posts: 1,541
 
Device(s): Nexus5 - Nexus10
Carrier: Sprint

Thanks: 369
Thanked 840 Times in 417 Posts
Default

It seems as if the discharge & recharging process has fixed my problem. Thanks guys.
ArmageddonX is offline  
Reply With Quote
The Following 2 Users Say Thank You to ArmageddonX For This Useful Post:
jerofld (March 27th, 2012), marctronixx (March 27th, 2012)
Old April 22nd, 2012, 12:38 PM   #8 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ArmageddonX View Post
I discharged the battery until the phone shut itself down. It has been charging 2 hours still turned off and the light is still red. Seems like it's been charging forever... I can't believe the light isn't green already...
I am having kinda same probs. when i recharge my phone, it charges upto 99% but dont get the green.
but everything else is ok. giving a 10-12 hours of moderate use.
should I worry about this? if yes then what should I do?
any kind suggestion from anybody?
lively35 is offline  
Reply With Quote
Old April 22nd, 2012, 02:57 PM   #9 (permalink)
Fixing stuff is not easy
 
Join Date: May 2011
Location: Over there <points>
Gender: Male
Posts: 7,690
 
Device(s): Samsung Galaxy S3; Asus Infinity
Carrier: Sprint

Thanks: 2,117
Thanked 4,314 Times in 2,513 Posts
jerofld
Default

Quote:
Originally Posted by lively35 View Post
I am having kinda same probs. when i recharge my phone, it charges upto 99% but dont get the green.
but everything else is ok. giving a 10-12 hours of moderate use.
should I worry about this? if yes then what should I do?
any kind suggestion from anybody?
That last 1% can be the slowest. It's completely normal. Get "Battery Monitor Widget" and watch it report your charge/discharge currents. When you get to 99%, it's charging very very slowly. But if you leave it charging over night, it'll get green.
jerofld is offline  
Reply With Quote
Old April 22nd, 2012, 03:21 PM   #10 (permalink)
♡ Spidey Sense !! ♡ ™
 
DonB's Avatar
 
Join Date: Nov 2009
Location: 18th Hole Of the Golf Course
Gender: Male
Posts: 18,626
 
Device(s): Moto X 16 GB Cricket Wireless®/ Stock Galaxy Note 10.1 ®
Carrier: Crickets Wireless ®

Thanks: 6,674
Thanked 7,080 Times in 4,173 Posts
Default

And another note to be aware of, when it is fully charged, it will stop charging and once it gets to 97% it will start charging again, that is also normal.
__________________


Site Rules/Guidelines
If something needs attention, Report it .
If someone helped you, hit to show it.

CRICKET Referral Program Bonus $ PM me if you need a referral



DonB is online now  
Reply With Quote
sponsored links
Reply

HTC EVO 3D
Current Rating:
Rate this Phone:

Sprint continues their EVO line of Android Phones with what is certainly a first for them - a 3D phone. The HTC EVO 3D boasts 3D technology on a beautiful 4.3-inch screen and get this: you don't even need glasses to enjoy the 3D experience! B... Read More



Go Back   Android Forums > Android Phones > HTC EVO 3D
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:45 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.