Go Back   Android Forums > Android Phones > HTC Evo 4G LTE

New Forums: Nexus Player | Nexus 9
Like Tree3Likes
  • 1 Post By falconey
  • 1 Post By 3vodroid
  • 1 Post By Vampire2009

test: Reply
 
LinkBack Thread Tools
Old June 5th, 2012, 07:51 PM   #1 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default Weather clock widget shows wrong location

Ok so the first day I had my EVO the location on my weather clock widget worked fine.. Always was on point.. Then for a day or so it would only show "current location" and the weather even seemed to be off (compared to a buddies 3vo) then this morning it began to work but now the location is "stuck " on Pleasantville which is where I work.. Even if I refresh it.. . But I'm now home in Somers point.. I have checked my widget and Gps settings extensively but it seems everything is set just fine... Don't know what my problem could be.. Even when the location is correct the weather just doesn't seem correct until I refresh it.. Any help would be awesome!

On a side note.. When I post on Facebook the location is dead on.. Maybe even more accurate than my 3vo was.. Which makes this even more puzzling...

Advertisements
3vodroid is offline  
Reply With Quote
sponsored links
Old June 6th, 2012, 06:46 AM   #2 (permalink)
Senior Member
 
falconey's Avatar
 
Join Date: Dec 2010
Location: Atlanta
Posts: 647
 
Device(s): 2 x Note 3, Note 2 Blackberry Curve
Carrier: Sprint

Thanks: 421
Thanked 408 Times in 252 Posts
Default

This is an HTC issue. Same thing happens with my 3vo and has happened since I've had it. One way I can usually fix it is by opening google maps, waiting for the gps to lock in on my location and then refreshing the weather widget. You would think this would have been fixed though.
falconey is offline  
Reply With Quote
The Following User Says Thank You to falconey For This Useful Post:
marctronixx (June 7th, 2012)
Old June 6th, 2012, 10:59 AM   #3 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Wrong Current Location

I had the same problems and I re-provisioned my phone. Now all is okay. You'll need your MSL but Sprint usually will give that to you if you ask. Sprint will go thru this whole process if you want them to. Just tell them you have no internet connection ;-)

From the dialpad, dial ##72786#, enter your MSL, Menu, Reset, OK.

The phone will go thru it's process then everything should be okay.
adz1966 is offline  
Last edited by adz1966; June 6th, 2012 at 11:02 AM.
Reply With Quote
Old June 6th, 2012, 05:01 PM   #4 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

Quote:
Originally Posted by falconey View Post
This is an HTC issue. Same thing happens with my 3vo and has happened since I've had it. One way I can usually fix it is by opening google maps, waiting for the gps to lock in on my location and then refreshing the weather widget. You would think this would have been fixed though.



Quote:
Originally Posted by adz1966 View Post
I had the same problems and I re-provisioned my phone. Now all is okay. You'll need your MSL but Sprint usually will give that to you if you ask. Sprint will go thru this whole process if you want them to. Just tell them you have no internet connection ;-)

From the dialpad, dial ##72786#, enter your MSL, Menu, Reset, OK.

The phone will go thru it's process then everything should be okay.
Thanks guys I will definetly try both of these fixes and post back some results! I'm guessing the MSL reset is the fix that everyone is talking about in the "worried about signal thread".. So I'm definetly going to give it a shot.. Thanks

As for the Google maps trick I'm going to try that right now :-)

Quote:
Originally Posted by falconey View Post
This is an HTC issue. Same thing happens with my 3vo and has happened since I've had it. One way I can usually fix it is by opening google maps, waiting for the gps to lock in on my location and then refreshing the weather widget. You would think this would have been fixed though.
So after trying this when I went back toy home screen It was the correct location and weather! Awesome! I'm still going to do the MSL thing tomorrow to be on the safe side.. Once again.. Will post results.. Thanks again fellas!
3vodroid is offline  
Last edited by marctronixx; June 7th, 2012 at 02:11 AM.
Reply With Quote
Old June 7th, 2012, 12:31 PM   #5 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

So yesterday. The Google maps trick worked just fine.. But the widget would still not update automatically.. I would have to go to maps.. Let it lock in and the widget would show the correct location.. But today while google maps locks in correctly.. The weather clock widget doesn't change and says unable to detect current location.... Calling sprint now

Just got off the phone with sprint... I got denied my MSL by two different people including a supervisor.all they wanted to do was hard reset even though I explained numerous times about the Google wallet security element... So they were useless.. Going to my sprint store now..
3vodroid is offline  
Last edited by marctronixx; June 7th, 2012 at 02:06 PM.
Reply With Quote
Old June 7th, 2012, 01:58 PM   #6 (permalink)
Senior Member
 
falconey's Avatar
 
Join Date: Dec 2010
Location: Atlanta
Posts: 647
 
Device(s): 2 x Note 3, Note 2 Blackberry Curve
Carrier: Sprint

Thanks: 421
Thanked 408 Times in 252 Posts
Default

You are wasting your time with Sprint. It's an HTC issue. Even if you correct the problem it will come back. I suggest using a different weather app/widget if it bothers you or making the location static. And if you want to contact someone I'd suggest HTC.
marctronixx likes this.
falconey is offline  
Reply With Quote
The Following 3 Users Say Thank You to falconey For This Useful Post:
3vodroid (June 9th, 2012), marctronixx (June 7th, 2012), WifiMaxed (June 9th, 2012)
Old June 9th, 2012, 01:46 AM   #7 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

Quote:
Originally Posted by falconey View Post
You are wasting your time with Sprint. It's an HTC issue. Even if you correct the problem it will come back. I suggest using a different weather app/widget if it bothers you or making the location static. And if you want to contact someone I'd suggest HTC.
Yeah I've been messing and messing with it for days.. So now I just use a different widget.. It's actually a nice change of scenary


Oh and I contacted HTC about it as well
falconey likes this.
3vodroid is offline  
Last edited by marctronixx; June 9th, 2012 at 03:16 AM.
Reply With Quote
Old June 25th, 2012, 06:38 AM   #8 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Default I may have found an answer to this quite by accident...

And if this has already been covered then I apologize but I have not been able to find an answer on line anywhere.

I received my new evo lte on the Saturday release date. I dont remember if it ever showed a city name of where I was. I do remember seeing the "current location" over and over again and being frustrated at it not showing a city name like my old evo 4g. I started looking on line and could not find an answer.

As the title says I may have found the answer by accident. I was on vacation in Anna Maria Island Fl over the last 5 days. Arrived on Thursday June 21st. Plugged in the usb 110v to 5v charger part to the wall and plugged in the usb cable to the phone. Friday morning get up and head out to breakfast. Stopped to take a pic at the beach and could not wake up phone. I figured it did not charge for some reason. Get back from breakfast and sure enough I had not plugged the usb cable into the charger. So i remedied that and started the charge process again. After two or three hours I took phone off charger and powered up. Later in the day I notice it says "Holmes Beach" (where I was) instead of "current Location". I tell my wife it must have fixed itself not realizing at the time that the phone running completely dead must have accomplished this. It is now Monday morning and I have been to 8-10 central Florida cities since Friday and it has consistently showed the correct cities as my location.

Hope this helps someone else...

Quote:
Originally Posted by 3vodroid View Post
Ok so the first day I had my EVO the location on my weather clock widget worked fine.. Always was on point.. Then for a day or so it would only show "current location" and the weather even seemed to be off (compared to a buddies 3vo) then this morning it began to work but now the location is "stuck " on Pleasantville which is where I work.. Even if I refresh it.. . But I'm now home in Somers point.. I have checked my widget and Gps settings extensively but it seems everything is set just fine... Don't know what my problem could be.. Even when the location is correct the weather just doesn't seem correct until I refresh it.. Any help would be awesome!

On a side note.. When I post on Facebook the location is dead on.. Maybe even more accurate than my 3vo was.. Which makes this even more puzzling...
1madbaddog is offline  
Last edited by 1madbaddog; June 25th, 2012 at 06:57 AM. Reason: Correct spelling
Reply With Quote
The Following User Says Thank You to 1madbaddog For This Useful Post:
EarlyMon (June 25th, 2012)
Old June 25th, 2012, 09:54 AM   #9 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

Quote:
Originally Posted by 1madbaddog View Post
And if this has already been covered then I apologize but I have not been able to find an answer on line anywhere.

I received my new evo lte on the Saturday release date. I dont remember if it ever showed a city name of where I was. I do remember seeing the "current location" over and over again and being frustrated at it not showing a city name like my old evo 4g. I started looking on line and could not find an answer.

As the title says I may have found the answer by accident. I was on vacation in Anna Maria Island Fl over the last 5 days. Arrived on Thursday June 21st. Plugged in the usb 110v to 5v charger part to the wall and plugged in the usb cable to the phone. Friday morning get up and head out to breakfast. Stopped to take a pic at the beach and could not wake up phone. I figured it did not charge for some reason. Get back from breakfast and sure enough I had not plugged the usb cable into the charger. So i remedied that and started the charge process again. After two or three hours I took phone off charger and powered up. Later in the day I notice it says "Holmes Beach" (where I was) instead of "current Location". I tell my wife it must have fixed itself not realizing at the time that the phone running completely dead must have accomplished this. It is now Monday morning and I have been to 8-10 central Florida cities since Friday and it has consistently showed the correct cities as my location.

Hope this helps someone else...
Mine seemed to fix itself after a charge also... But then it went right back to its old ways... current location... So I just use different widgets... htc is no help so I'm left to just forget my weather clock widget...
3vodroid is offline  
Reply With Quote
Old June 25th, 2012, 12:23 PM   #10 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 46,464
 
Device(s): M8, LTEvo, 3vo, and Shift - Evo retired
Carrier: Sprint

Thanks: 42,774
Thanked 57,266 Times in 23,021 Posts
Default

Welcome to the forums, 1madbaddog!

HTC uses Accuweather, I've long believed that that's the problem here. Once when my widget got my location wrong while in California, I went to the Accuweather web site and entered the city name - it gave me weather for Venezuela. I then put in the city, state and zip - and it told me no such city. Six hours later, Accuweather decided the city existed again, and lo and behold, my HTC widget was fine again.

I use a clock widget by Droid27 (search for that in the Store if interested) - he makes a 3D one that's skinable and one that looks like the stock HTC widget. They still refer to your HTC world clock under the hood but let you choose between Google or MSN as your weather source. I opted for Google weather, Google knows where I am.

I'm sure that there are other great widgets out there, so if you're having this issue and for any reason don't like my Droid27 suggestion, then look for ones that access something other than Accuweather.
EarlyMon is online now  
Reply With Quote
sponsored links
Old June 25th, 2012, 06:11 PM   #11 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Default

Thanks Earlymon,

I did check that app, looks good. I'm gonna stick with my "working" HTC one for now and see how long this last, I'm still good as of 7:00PM Eastern time.
1madbaddog is offline  
Reply With Quote
The Following User Says Thank You to 1madbaddog For This Useful Post:
EarlyMon (June 25th, 2012)
Old June 27th, 2012, 09:32 AM   #12 (permalink)
Member
 
Join Date: Mar 2010
Location: Massachusetts
Posts: 303
 
Device(s): Motorola Photon 4G Samsung Infuse 4G HTC Inspire 4G HTC Evo 4g for Sprint Former user of Nexus O
Carrier: Not Provided

Thanks: 20
Thanked 26 Times in 21 Posts
Default

I don't believe it's an accuweather issue. I was having the same issue (my buddy has the one x for ATT and his location was working fine) sometime my location would show my state, or current location or the town. I decided to go back to Beautiful widgets. This per usual works great, and I use accuweather. HOWEVER when I changed the weather service to Google using BW, I received the same results as the stock HTC weather widget. So I am thinking there is an issue with google weather and maybe even with sprint as a combo as mentioned earlier my buddy's One X on ATT was working fine.
jsward12 is offline  
Reply With Quote
The Following User Says Thank You to jsward12 For This Useful Post:
EarlyMon (June 27th, 2012)
Old June 27th, 2012, 12:11 PM   #13 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 46,464
 
Device(s): M8, LTEvo, 3vo, and Shift - Evo retired
Carrier: Sprint

Thanks: 42,774
Thanked 57,266 Times in 23,021 Posts
Default

Wrong location in weather is a problem on HTC phones across the world, we have lots of threads on this problem going back over 2 years.

Every new release we get new victims but the problem is old.

Gets a lot of attention because it should, it's a real grind, but it doesn't hit that many people, relatively speaking.

As for the ATT One X not having the problem, give it time. This hits all HTC, just not all users.
EarlyMon is online now  
Reply With Quote
Old June 27th, 2012, 12:30 PM   #14 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

contact htc if your having issues with this... over a few emails they walked me through a bunch of troubleshooting and my weather clock widget is now operational and has been for a day now... All I had to do was clear the cache in a few applications but I love my current setup which doesn't use the weather clock widget too much to change it.... go figure lol
3vodroid is offline  
Reply With Quote
The Following User Says Thank You to 3vodroid For This Useful Post:
EarlyMon (June 27th, 2012)
Old June 27th, 2012, 12:47 PM   #15 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 46,464
 
Device(s): M8, LTEvo, 3vo, and Shift - Evo retired
Carrier: Sprint

Thanks: 42,774
Thanked 57,266 Times in 23,021 Posts
Default

Any chance you recall which app caches they had you clear?
EarlyMon is online now  
Reply With Quote
Old June 27th, 2012, 04:10 PM   #16 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Default Update...

Day 6 and still going good. Shows every city I'm in and no prompts for zone or time...
1madbaddog is offline  
Reply With Quote
Old June 27th, 2012, 04:32 PM   #17 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 46,464
 
Device(s): M8, LTEvo, 3vo, and Shift - Evo retired
Carrier: Sprint

Thanks: 42,774
Thanked 57,266 Times in 23,021 Posts
Default

Quote:
Originally Posted by 1madbaddog View Post
Day 6 and still going good. Shows every city I'm in and no prompts for zone or time...
Probably you're fine now. In two years, I've had it happen only two days. Others, more often, others, never.

Glad it's sorted out for you.
EarlyMon is online now  
Reply With Quote
The Following User Says Thank You to EarlyMon For This Useful Post:
1madbaddog (June 27th, 2012)
Old June 28th, 2012, 10:27 AM   #18 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Default Others successful with this method...

Just a quick note... I posted this on the Sprint forums also and at least two others tried this method and had it work for them.
1madbaddog is offline  
Reply With Quote
The Following User Says Thank You to 1madbaddog For This Useful Post:
EarlyMon (June 28th, 2012)
Old July 11th, 2012, 11:14 PM   #19 (permalink)
Junior Member
 
Ralith's Avatar
 
Join Date: May 2012
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 4 Times in 2 Posts
Default Weather App/Widget

Anyone else having an issue where the weather app/widget doesn't update but stays at "Current Location" no matter what I do? I have my set to update every hour and in real time, but it doesn't seem to do this correctly.
Ralith is offline  
Reply With Quote
The Following User Says Thank You to Ralith For This Useful Post:
3vodroid (July 12th, 2012)
Old July 12th, 2012, 12:51 AM   #20 (permalink)
The PearlyMon
 
EarlyMon's Avatar
 
Join Date: Jun 2010
Location: New Mexico, USA
Posts: 46,464
 
Device(s): M8, LTEvo, 3vo, and Shift - Evo retired
Carrier: Sprint

Thanks: 42,774
Thanked 57,266 Times in 23,021 Posts
Default

I believe that this is supposed to be corrected in today's OTA update.

Could be wrong, please let me know.
EarlyMon is online now  
Reply With Quote
The Following 2 Users Say Thank You to EarlyMon For This Useful Post:
3vodroid (July 12th, 2012), marctronixx (July 12th, 2012)
sponsored links
Old July 12th, 2012, 01:02 AM   #21 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

Quote:
Originally Posted by EarlyMon View Post
I believe that this is supposed to be corrected in today's OTA update.

Could be wrong, please let me know.
I hope sooo!
3vodroid is offline  
Reply With Quote
Old July 12th, 2012, 04:16 AM   #22 (permalink)
HTC User
 
Join Date: Oct 2009
Posts: 5,256
 
Device(s):
Carrier: Not Provided

Thanks: 21,272
Thanked 3,082 Times in 1,808 Posts
Default

reading the sprint BAW forums seems to suggest it has.

I never had the issue but it was mentioned a couple times there.. those cats seemed to agree with EM that the fix was included.
marctronixx is offline  
Reply With Quote
The Following User Says Thank You to marctronixx For This Useful Post:
3vodroid (July 12th, 2012)
Old July 12th, 2012, 01:32 PM   #23 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

After a manual check for the update and completion of the update it seems like my weather clock widget is working perfect for now... Just for testing purposes I have it on a unused Window.. If it keeps up the good work it might just make it back to my main him screen. But I'm liking my current setup too
3vodroid is offline  
Reply With Quote
Old July 12th, 2012, 01:35 PM   #24 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

Oh yeah... And Google wallet is back wahoo!
3vodroid is offline  
Reply With Quote
Old August 20th, 2012, 07:35 AM   #25 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 3vodroid View Post
Ok so the first day I had my EVO the location on my weather clock widget worked fine.. Always was on point.. Then for a day or so it would only show "current location" and the weather even seemed to be off (compared to a buddies 3vo) then this morning it began to work but now the location is "stuck " on Pleasantville which is where I work.. Even if I refresh it.. . But I'm now home in Somers point.. I have checked my widget and Gps settings extensively but it seems everything is set just fine... Don't know what my problem could be.. Even when the location is correct the weather just doesn't seem correct until I refresh it.. Any help would be awesome!

On a side note.. When I post on Facebook the location is dead on.. Maybe even more accurate than my 3vo was.. Which makes this even more puzzling...
I came here, because I had the same problem with my new HTC One V - ICS. The home screen got stuck to the location (Karur) that I roamed/travelled. After coming back home, the home screen Location wouldn't change to my place Chennai.

Steps to Change:
1. Long Press the Weather Widget. On top of the screen, you will notice EDIT and REMOVE Options.
2. Click EDIT, with a second finger
3. Add Your Home Location - in my case Chennai

Save and Go!

The Home Screen now shows, Chennai :-)
nrganeshbabu is offline  
Reply With Quote
Old October 13th, 2012, 03:16 AM   #26 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

In my experienced, I went into task manager and deleted all the running apps including the weather and that's how it got screwed up..... The weather app should not be deleted because it needs to run update from time to time....... Restart the device by holding down the power button and select restart.....
LazyT likes this.
Vampire2009 is offline  
Reply With Quote
Old October 16th, 2012, 10:47 AM   #27 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default HTC Weather Widget not showing correct location

My evo 4g lte only says "current location" it will not give an actual location. I did a hard reset yesterday and it said proper location. within an hour it was back to "current location". Now, I have to "redo" all my apps for nothing. Nothing helped.
Tink3296 is offline  
Reply With Quote
Old October 16th, 2012, 10:58 AM   #28 (permalink)
~30% Carbon Black
 
Mikestony's Avatar
 
Join Date: Sep 2010
Location: N/W Indiana
Gender: Male
Posts: 22,910
 
Device(s): LG G3 (rooted)
Carrier: Verizon

Thanks: 18,186
Thanked 14,915 Times in 9,222 Posts
Default

Quote:
Originally Posted by Tink3296 View Post
My evo 4g lte only says "current location" it will not give an actual location. I did a hard reset yesterday and it said proper location. within an hour it was back to "current location". Now, I have to "redo" all my apps for nothing. Nothing helped.
Welcome to AF!!!
I moved your post here to better help with your phone model.

If I understand correctly, your weather/clock widget should say "My City, State" instead of it saying "current location" correct?
Mikestony is online now  
Last edited by marctronixx; October 16th, 2012 at 01:29 PM.
Reply With Quote
Old October 16th, 2012, 12:09 PM   #29 (permalink)
Senior Member
Thread Author (OP)
 
3vodroid's Avatar
 
Join Date: Mar 2012
Location: New Jersey
Gender: Male
Posts: 1,174
 
Device(s): Rooted EVO 4G LTE ( MeanRom 4.6),Rooted Toshiba THRiVE (Dalepl's ICS)
Carrier: Not Provided

Thanks: 1,561
Thanked 695 Times in 373 Posts
Send a message via Skype™ to 3vodroid
Default

Quote:
Originally Posted by Tink3296 View Post
My evo 4g lte only says "current location" it will not give an actual location. I did a hard reset yesterday and it said proper location. within an hour it was back to "current location". Now, I have to "redo" all my apps for nothing. Nothing helped.
Hey, I had the same problem a while back. Are you stock? Have you taken all the latest updates? One of the latest updates should have fixed that issue.

When I rooted it fixed it for me.

Go into Google maps and let it lock on your location then go back to the home screen and see if it's displaying the correct location.
3vodroid is offline  
Last edited by 3vodroid; October 16th, 2012 at 12:12 PM.
Reply With Quote
Old December 8th, 2012, 05:31 AM   #30 (permalink)
New Member
 
Join Date: Dec 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Vampire2009 View Post
In my experienced, I went into task manager and deleted all the running apps including the weather and that's how it got screwed up..... The weather app should not be deleted because it needs to run update from time to time....... Restart the device by holding down the power button and select restart.....
The restart worked for me. I tried opening Google maps, but my One V still was stuck on "current location". I had shut down and restarted, but choosing "restart" worked and now it shows my town again.
LazyT is offline  
Reply With Quote
sponsored links
Old February 7th, 2013, 08:05 PM   #31 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

i just ran across this issue over the last couple weeks with my evo shift and found that it can also happen if you have an airrave that your phone is connected to. i have no idea why, but nothing worked until i turned that off.
*harbinger* is offline  
Reply With Quote
Old September 14th, 2013, 08:57 PM   #32 (permalink)
Member
 
Join Date: Jan 2011
Posts: 494
 
Device(s): HTC ONE M8
Carrier: Sprint

Thanks: 341
Thanked 79 Times in 57 Posts
Default Location showing "Current Location"

Suddenly my LTEvo's Sense Calendar/Widget merely says "Current Location" rather than the community in which I am. I have changed nothing! I tried to reboot, update prl and update profile - all without success. I use "network" for location and the GPS is off. Phone is not rooted.

Ant thoughts??

EDIT - FOLLOW UP:

This morning my HTC EVO LTE is displaying the correct location and not "Current location". I have not made any changes to the phone, and I charged the phone last night as usual with the phone "on".

Interesting; is the phone "possessed" by some gremlins?
smitty543 is offline  
Last edited by marctronixx; September 18th, 2013 at 10:34 AM. Reason: merged threads.
Reply With Quote
The Following User Says Thank You to smitty543 For This Useful Post:
marctronixx (September 18th, 2013)
Old September 14th, 2013, 09:08 PM   #33 (permalink)
HTC User
 
Join Date: Oct 2009
Posts: 5,256
 
Device(s):
Carrier: Not Provided

Thanks: 21,272
Thanked 3,082 Times in 1,808 Posts
Default

just temporary. your location is based on the data the phone is getting at the time.

sometimes there is temporary issues with the network.
marctronixx is offline  
Reply With Quote
The Following User Says Thank You to marctronixx For This Useful Post:
smitty543 (December 8th, 2013)
Old December 8th, 2013, 10:29 AM   #34 (permalink)
Member
 
Join Date: Jan 2011
Posts: 494
 
Device(s): HTC ONE M8
Carrier: Sprint

Thanks: 341
Thanked 79 Times in 57 Posts
Default

Thanx. I had contacted Sprint CS, and they reprovisioned the phone after a reboot did not correct the problem. This also did not correct the problem. The rep said there was no information about service problems in my area. Hopefully this will correct itself. (Interestingly, WeatherBug & Raindar show the correct location. It is only the Sense widget that shows "Current location".)

--

UPDATE:

Interestingly today (in my home), the phone is going from stating "Current location" to the actual location and back to "current location' when it is now stuck. Yesterday, I was in different locales, and the phone seemed to indicate the proper communities. Sprint must be "doing things" on the towers/network around my home. (Interestingly in my home the phone only indicates 3G with WiFi turned off, but a brief walk from home the phone indicates 4G.)

--

EDIT: UPDATE:

For past week phone has indicated proper location. Still no 4G although phone indicates 4G in areas surrounding my home location. Sprint must be "doing things" with towers in the environs, and the CS reps were not able to access the information. (Hopefully it will include 4G support since I am surrounded by 4G, but appear to reside in a 'donut hole'.)

---

EDIT: UPDATE

The same problem has reappeared: HTC 2x1 clock widget says "current location" although other apps show correct location.
I did the following steps (without correcting the problem):
1.Turned on GPS
2. Opened 'GPS Status and Toolbox' and pressed "reset"
3 Removed the HTC 2x1 clock widget from home screen
4. Under settings went to all apps and cleared data from weather
5. Did soft reset of device
6. re-added the HTC 2x1 clock widget

The location still states "Current Location"

Any ideas?
smitty543 is offline  
Last edited by marctronixx; February 9th, 2014 at 01:10 PM. Reason: added updated info
Reply With Quote
The Following User Says Thank You to smitty543 For This Useful Post:
marctronixx (December 8th, 2013)
Old January 31st, 2014, 02:37 PM   #35 (permalink)
Junior Member
 
Join Date: Jul 2012
Location: Alton, IL
Posts: 95
 
Device(s): Samsung Galaxy Victory LTE
Carrier: Virgin Mobile

Thanks: 12
Thanked 5 Times in 4 Posts
Default

My Virgin Mobile Samsung Galaxy does this as well with the stock clock/widget app. Likes to constantly tell me I am in Fairmont, IL, a town about 30 miles away. The widget also uses Accuweather
mscheaf is offline  
Reply With Quote
Old February 9th, 2014, 01:14 PM   #36 (permalink)
HTC User
 
Join Date: Oct 2009
Posts: 5,256
 
Device(s):
Carrier: Not Provided

Thanks: 21,272
Thanked 3,082 Times in 1,808 Posts
Default

these are intermittent issues. as you can see from your post history on this, it comes and goes. it has nothing to do with your device most likely and has more to do with your geo location, the data polling from the internet, you could be on a tower with issues, etc etc.

you are not the only one to see this. this also happens on other htc sense devices that uses this.





marctronixx is offline  
Reply With Quote
The Following User Says Thank You to marctronixx For This Useful Post:
smitty543 (February 9th, 2014)
Reply

HTC EVO 4G LTE
Current Rating:
Rate this Phone:

The HTC EVO 4G LTE is Sprint's version of the HTC One X. It comes with all the same specs, except for the processor, internal storage and radios (includes LTE). And aesthetics are also significantly different. While many users have complaine... Read More



Go Back   Android Forums > Android Phones > HTC Evo 4G LTE
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:16 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.