Go Back   Android Forums > Android Phones > HTC EVO 4G

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old June 25th, 2010, 10:22 AM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default Why are 3G speed tests so slow?

I've tried Xtremelabs Speedtest (which seems more reliable) and Speedtest.net's app (which uses Kansas City as the server due to Sprint's proxy). I haven't been able to get over 800Kbps down no matter what. This morning I hit a new low and couldn't go over 350 with full service. My Touch Pro would consistently get about 1.2 - 1.5MBps. I would tether with it and use it as a hot spot with no issues. Friends would comment on how fast the 3G speeds on Sprint are. I don't feel I can have the same confidence in the Evo's speed.

I'm thinking either there is some aggressive power saving happening on the phone or Sprint's network has been heavily congested since the release of the phone.

Are there other speed tests people are doing? I'm going to try dslreports but I know that one has issues on accuracy sometimes.

coolguy949 is offline  
Reply With Quote
sponsored links
Old June 25th, 2010, 10:23 AM   #2 (permalink)
Senior Member
 
Join Date: Mar 2010
Location: Washington, DC
Posts: 608
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 93
Thanked 198 Times in 139 Posts
Default

when you use speedtest.net app turn your gps on so it can find the closest server
__________________
Finally a Senior Member!!!!
Dont forget to use that Thanks button, its there for a reason
THEFORCE is offline  
Reply With Quote
Old June 25th, 2010, 10:25 AM   #3 (permalink)
 
Join Date: Mar 2010
Location: In exile
Posts: 1,716
 
Device(s):
Carrier: Not Provided

Thanks: 177
Thanked 1,255 Times in 484 Posts
Default

Try speakeasy it get a consistent 1.5-2.5 mbps.

Why is it about confidence of speed? That seems really weird to me. Your internet speed will change to many different factors, including server load, solar flares, and time of day.
RiverOfIce is offline  
Last edited by RiverOfIce; June 25th, 2010 at 10:29 AM.
Reply With Quote
Old June 25th, 2010, 10:33 AM   #4 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 22
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 2 Times in 2 Posts
Default

Ironic timing for this thread. I have been testing 3G here in seattle and can't get over 500k consistantly. A lot of the time, it stays around 200-300. My upload speeds vary from horrible to great (700k). 4g speeds are 2.5 meg down and about 1 up, but I'm on 3G more than 4G.

Hoping this gets fixed.
TravyEvo is offline  
Reply With Quote
Old June 25th, 2010, 10:37 AM   #5 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by THEFORCE View Post
when you use speedtest.net app turn your gps on so it can find the closest server
Bingo! That worked at picking the closest server, but the results are....odd.... :P

coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 10:41 AM   #6 (permalink)
Senior Member
 
Join Date: Mar 2010
Location: Washington, DC
Posts: 608
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 93
Thanked 198 Times in 139 Posts
Default

Quote:
Originally Posted by coolguy949 View Post
Bingo! That worked at picking the closest server, but the results are....odd.... :P

lol...how mant tests have u ran
THEFORCE is offline  
Reply With Quote
Old June 25th, 2010, 10:43 AM   #7 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by THEFORCE View Post
lol...how mant tests have u ran
They all have the same result. I just did one now that got 183 down and 3086 up. Something's definitely wrong. The gauge jumps around a bit too during the upload.
coolguy949 is offline  
Last edited by coolguy949; June 25th, 2010 at 10:45 AM.
Reply With Quote
Old June 25th, 2010, 10:46 AM   #8 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Just switched servers to San Diego, CA - same thing. I'm rebooting my phone since it hasn't been rebooted in about a week.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 10:47 AM   #9 (permalink)
Senior Member
 
Join Date: Mar 2010
Location: Washington, DC
Posts: 608
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 93
Thanked 198 Times in 139 Posts
Default

see what u get at mobilespeedtest.com and try the 1mb download test
THEFORCE is offline  
Reply With Quote
Old June 25th, 2010, 10:53 AM   #10 (permalink)
ecb
Junior Member
 
Join Date: Nov 2009
Posts: 67
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 3 Times in 3 Posts
Default

I'm glad to see this thread because I was wondering if my slow 3G speeds were the EVO or just Sprint's 3G network (this my first Sprint phone).

I'm in an area that gets good Sprint coverage and I seem to get a decent EVDO signal (between -80 and -90) but I rarely manage to get over 600KB down (upload speeds are pretty good at between 500 - 700KB)

I've got a Verizon phone (HTC Incredible) and an ATT phone (iPhone 3GS) and they both get much better download speeds (1.2 - 1.7MB).

I do know from comparing signal strength that Ia slightly stronger Verizon signal (-70 - 85) but I'd still expect to be pretty close to 1MB download speed at home.

If there longer tenured Sprint customers that are reporting that the EVO has poor 3G speeds then the phone must be the source of the problem.
ecb is offline  
Reply With Quote
sponsored links
Old June 25th, 2010, 10:56 AM   #11 (permalink)
Senior Member
 
Join Date: Mar 2010
Location: Washington, DC
Posts: 608
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 93
Thanked 198 Times in 139 Posts
Default

it may be the speedtest app...have u noticed slow speeds on the internet?
THEFORCE is offline  
Reply With Quote
Old June 25th, 2010, 10:57 AM   #12 (permalink)
Member
 
Join Date: Jun 2010
Posts: 300
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 33 Times in 22 Posts
Default

I was going to post the same thing recently, except my speeds have been MUCH worse. My average download speeds over EVDO seem to be around 0.10 Mbps (100 kbps), and uploads of 0.25 up. No matter where I am, I am getting the same speeds. What do I do here.
Yankees368 is offline  
Reply With Quote
Old June 25th, 2010, 10:58 AM   #13 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by THEFORCE View Post
see what u get at mobilespeedtest.com and try the 1mb download test
90Kbps

Something is definitely up. Ran Speedtest again as well and got 158.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 11:00 AM   #14 (permalink)
Senior Member
 
Join Date: Mar 2010
Location: Washington, DC
Posts: 608
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 93
Thanked 198 Times in 139 Posts
Default

um maybe a prl and profile update...the only thing i can think of right now
THEFORCE is offline  
Reply With Quote
Old June 25th, 2010, 11:06 AM   #15 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

I did the new PRL update yesterday already. Just checked now and it downloaded one again. No improvement. Getting the same speeds. Trying profile update now.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 11:06 AM   #16 (permalink)
Member
 
thaprinze's Avatar
 
Join Date: Apr 2010
Location: Denver, CO
Posts: 116
 
Device(s): Treo 700wx > HTC Evo 4G
Carrier: Not Provided

Thanks: 235
Thanked 57 Times in 27 Posts
Default

I see the same results from time to time, where the upload speed is far greater than the download speed. I have no idea why.

Edit: Just got 151kbps up, 581kbps down with 466ms latency on Speedtest.net app

On top of that, anytime I use orb & it runs a speed test to play files, it always returns a constant 250kb/s. My wife's BB Bold normally in the ~1,200kb/s range.
thaprinze is offline  
Last edited by thaprinze; June 25th, 2010 at 11:13 AM.
Reply With Quote
Old June 25th, 2010, 11:07 AM   #17 (permalink)
Member
 
Join Date: Jun 2010
Posts: 300
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 33 Times in 22 Posts
Default

Something is up with our evo's, people. Activate the crisis response team!
Yankees368 is offline  
Reply With Quote
Old June 25th, 2010, 11:14 AM   #18 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Did the profile update. Got up to 400 download and 350 upload. Ugh.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 11:14 AM   #19 (permalink)
Senior Member
 
Join Date: Mar 2010
Location: Washington, DC
Posts: 608
 
Device(s): Samsung Galaxy Nexus
Carrier: Not Provided

Thanks: 93
Thanked 198 Times in 139 Posts
Default

maybe sprint made the evdo slower so it would make wimax look faster lol
THEFORCE is offline  
Reply With Quote
The Following User Says Thank You to THEFORCE For This Useful Post:
huffman6977 (May 8th, 2011)
Old June 25th, 2010, 11:16 AM   #20 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Another nail in the coffin for this phone.

Oh that's great, as I was typing this the phone rebooted itself. :\ First time that's ever happened.
coolguy949 is offline  
Reply With Quote
sponsored links
Old June 25th, 2010, 11:22 AM   #21 (permalink)
Member
 
Join Date: Apr 2010
Location: Residin in Florida
Posts: 432
 
Device(s): HTC Evo 4G
Carrier: Not Provided

Thanks: 57
Thanked 103 Times in 58 Posts
Send a message via AIM to ThatNewAndroidGuy Send a message via Yahoo to ThatNewAndroidGuy
Default

Quote:
Originally Posted by coolguy949 View Post
Another nail in the coffin for this phone.

Oh that's great, as I was typing this the phone rebooted itself. :\ First time that's ever happened.

You have background data unchecked? I think that's what's causing the reboots. My GF never had that unchecked, and never had a problem, but she was having horrible battery life. I always had it unchecked, but never had it restart till yesterday once. Then hers restarted yesterday as well for the first time. So something needs to be fixed about that background data being unchecked.
ThatNewAndroidGuy is offline  
Reply With Quote
Old June 25th, 2010, 11:22 AM   #22 (permalink)
 
Join Date: Mar 2010
Location: In exile
Posts: 1,716
 
Device(s):
Carrier: Not Provided

Thanks: 177
Thanked 1,255 Times in 484 Posts
Default

Go to speakeasy.net, select san francisco.

Post what happens.

If the phone is rebooting you need to do a hard reset. Something is really wrong. That is like 2g speeds.
RiverOfIce is offline  
Reply With Quote
Old June 25th, 2010, 11:26 AM   #23 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by ThatNewAndroidGuy View Post
You have background data unchecked? I think that's what's causing the reboots. My GF never had that unchecked, and never had a problem, but she was having horrible battery life. I always had it unchecked, but never had it restart till yesterday once. Then hers restarted yesterday as well for the first time. So something needs to be fixed about that background data being unchecked.
I've always had it checked.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 11:27 AM   #24 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by RiverOfIce View Post
Go to speakeasy.net, select san francisco.

Post what happens.

If the phone is rebooting you need to do a hard reset. Something is really wrong. That is like 2g speeds.
Yeah. I'm not sure where it went wrong. I haven't really been downloading apps or messing with the phone settings much.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 11:40 AM   #25 (permalink)
ecb
Junior Member
 
Join Date: Nov 2009
Posts: 67
 
Device(s):
Carrier: Not Provided

Thanks: 9
Thanked 3 Times in 3 Posts
Default

i just did a PRL and Profile update and ran the SpeedTest.net app.

I got 341K download, 53K upload. My EVDO signal strength was -85 (unless I'm wrong -85 is a decent signal)

I also tried using the speed test on dslreports.com (in case there was an issue with the SpeedTest app) and I got 400K down and my EVDO signal strength was -88

I'll give the EVO until the update comes out on 6/28 but those speeds make the EVO useless as a HotSpot, which is one of the main reasons I purchased the phone.
ecb is offline  
Reply With Quote
Old June 25th, 2010, 11:40 AM   #26 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Here's my speed test history. The two large ones are Wifi. I wanted to make sure the app wasn't having issues. It's amazing to see the difference between 1 bar and 3 bars of Wifi. My 3G tests are dismal.

coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 11:48 AM   #27 (permalink)
Member
 
Join Date: Jun 2010
Posts: 300
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 33 Times in 22 Posts
Default

I did several tests around town in the last hour, some within line of sight of a sprint tower, and my tests never broke 500 kbps, and usually hovered around 200-300. what could be causing this
Yankees368 is offline  
Reply With Quote
Old June 25th, 2010, 11:56 AM   #28 (permalink)
Member
 
Join Date: Mar 2010
Location: Massachusetts
Posts: 303
 
Device(s): Motorola Photon 4G Samsung Infuse 4G HTC Inspire 4G HTC Evo 4g for Sprint Former user of Nexus O
Carrier: Not Provided

Thanks: 20
Thanked 26 Times in 21 Posts
Default

The real question here is, do you have any issues with your phone running on 3g? Can you load apps,download apps, browse web pages with out issue? If so then try the pdanet tether app and see what kind of performance you get and go from there.
jsward12 is offline  
Reply With Quote
Old June 25th, 2010, 11:57 AM   #29 (permalink)
Member
 
Join Date: Apr 2010
Location: Residin in Florida
Posts: 432
 
Device(s): HTC Evo 4G
Carrier: Not Provided

Thanks: 57
Thanked 103 Times in 58 Posts
Send a message via AIM to ThatNewAndroidGuy Send a message via Yahoo to ThatNewAndroidGuy
Default

Hmmm, I wonder if it could be the "data throttling" we saw a while back. I doubt it though. I remember my one speed restult on launch day, 10 mbps down and 5.52 up. I was amazed lol. Screenshot:

Its the last one as its sorted from newest to oldest.



Then things just got worse from there
ThatNewAndroidGuy is offline  
Reply With Quote
Old June 25th, 2010, 11:58 AM   #30 (permalink)
Member
 
Join Date: Jun 2010
Posts: 300
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 33 Times in 22 Posts
Default

Quote:
Originally Posted by jsward12 View Post
The real question here is, do you have any issues with your phone running on 3g? Can you load apps,download apps, browse web pages with out issue? If so then try the pdanet tether app and see what kind of performance you get and go from there.
I was attempting to load facebook pages over 3g this past tuesday, but they would not load 100%, the green bar never finished. I flipped wifi on, and there was no issue.
Yankees368 is offline  
Reply With Quote
sponsored links
Old June 25th, 2010, 12:33 PM   #31 (permalink)
Member
 
Join Date: Mar 2010
Location: Massachusetts
Posts: 303
 
Device(s): Motorola Photon 4G Samsung Infuse 4G HTC Inspire 4G HTC Evo 4g for Sprint Former user of Nexus O
Carrier: Not Provided

Thanks: 20
Thanked 26 Times in 21 Posts
Default

Ouch ok yeah so a legit problem. My speeds are up and down but never have an issue with 3g which is why I question these tests.
jsward12 is offline  
Reply With Quote
Old June 25th, 2010, 12:41 PM   #32 (permalink)
New Member
 
Join Date: Jun 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

So...I've been lurking on the forums for a few months now and this post finally got me to register.

I updated my PRL to the 60667 version Wednesday night. Thursday I woke up to a bunch of Error 67's and 104's on both my wife's EVO and my own EVO. Tried a bit of troubleshooting on my own before finally calling Sprint. Checked programing, restored the data profile, did an RTN on my phone, checked for network outages, opened a ticket, etc, etc. Basically I spent most of my day yesterday talking to Sprint (including advanced tech support).

During this time my 3G speeds (if I could connect at all) were garbage...like <100 kbps down. Usually I'm getting somewhere in the 2 Mbps range (I'm in Seattle for what it's worth). This morning they supposedly cancelled and reactivated my service...so far no problems, but speeds still suck.

So...could any of this have something to do with the PRL update to 60667? Now that a few more of you have updated it seems like there are a few more reports of problems.

I'm hoping this gets figured out. I don't care about screen seperation, 30 fps caps, grounding issues, different screens, or any of that nonsense. I do care that I can use the data I'm paying for.
karp is offline  
Reply With Quote
Old June 25th, 2010, 12:43 PM   #33 (permalink)
 
Join Date: Mar 2010
Location: In exile
Posts: 1,716
 
Device(s):
Carrier: Not Provided

Thanks: 177
Thanked 1,255 Times in 484 Posts
Default

Quote:
Originally Posted by ThatNewAndroidGuy View Post
Hmmm, I wonder if it could be the "data throttling" we saw a while back. I doubt it though. I remember my one speed restult on launch day, 10 mbps down and 5.52 up. I was amazed lol. Screenshot:

Its the last one as its sorted from newest to oldest.



Then things just got worse from there
That is not possible. Not on 3g and not on 4g, you can not go faster then 10mbps on 4g and 3.1 mbps on 3g. It is a radio hardware cap.




Coolguy, please go to http://www.speakeasy.net/speedtest/ select San Francisco post the results.
RiverOfIce is offline  
Reply With Quote
Old June 25th, 2010, 12:43 PM   #34 (permalink)
Member
 
Join Date: Jun 2010
Posts: 221
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 22 Times in 17 Posts
Default

Did a trick that I found on a xda thread, the one where you hack the phone to work on VZ network. Worked great, got consistent speeds above 1mb at home where before i was getting only about 200-350kbps. but lost 3g after a day and a half, guess went over the roaming limit. But in the same thread there was another post about changing the SID, looks like most evos are set to Kansas city, changed mine to where i am, Providence, RI, and I am getting a bit better speeds. still hovers around the old speed some times, but more near or above 500kpbs most of the time, and sometimes jumps up to about 800kbs, only got that one time before at 2am, lol.

[6/16]*techknowfile's* - Hack the HTC EVO - 3G w/o Sprint EVDO coverage! - xda-developers

here is where i found the sid if anyone wants to try and not read the whole thread, it is somewhere in the middle. Sprints seems to be in the 4000-4999 range, just make sure you find the closest to you and that it is a sprint one.
The Roaming Zone-System ID (SID) List
You need your MSL to be able to do it, ##DATA#, Edit mode, enter MSL, go to advanced and scroll down to Home SID/NID, leave NID alone and just change SID, the first set of numbers. Hit menu, and commit changes. If it lists 4139 that means it was set to Kansas City. This is not the hack for VZ 3g, thats a whole other process, lol.

And just to add, been using sprint tv since the change back to sprint 3g with the SID fix, and it is running much better, little lag and no to little pixilation, much better than before at the same location.
Jonhern is offline  
Last edited by Jonhern; June 25th, 2010 at 12:49 PM.
Reply With Quote
Old June 25th, 2010, 12:44 PM   #35 (permalink)
Premium Member
 
Join Date: Jun 2010
Location: Phoenix
Gender: Male
Posts: 2,233
 
Device(s): EVO LTE & EVO 4G & Nexus S 4G
Carrier: Sprint

Thanks: 1,961
Thanked 881 Times in 524 Posts
Default

Im in Phoenix and run random tests with the speedtest.net app.. 90% of the time i get better than 1.2down and .7up (average is probably about 1.5 down, but seen as high as 2.2down) on 3G. Im happy with these numbers. its been very consistant too.
BenChase7 is offline  
Reply With Quote
Old June 25th, 2010, 12:49 PM   #36 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by RiverOfIce View Post
That is not possible. Not on 3g and not on 4g, you can not go faster then 10mbps on 4g and 3.1 mbps on 3g. It is a radio hardware cap.




Coolguy, please go to Speakeasy - Speed Test select San Francisco post the results.

I did, I get:

SF: 374 down, 160 up
LA: 662 down, 139 up (I'm in the LA area)
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 12:54 PM   #37 (permalink)
Member
 
Join Date: Jun 2010
Posts: 221
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 22 Times in 17 Posts
Default

Quote:
Originally Posted by coolguy949 View Post
I did, I get:

SF: 374 down, 160 up
LA: 662 down, 139 up (I'm in the LA area)
Thats kbps, not mbps. That would translate to .3mbps and .6mbps
Jonhern is offline  
Reply With Quote
Old June 25th, 2010, 12:54 PM   #38 (permalink)
Senior Member
 
Join Date: May 2010
Location: Charlotte, NC
Posts: 1,493
 
Device(s): Galaxy Nexus i9250
Carrier: Not Provided

Thanks: 50
Thanked 232 Times in 147 Posts
Default

i get about 1000-1400 but i'm on a different PRL. with Sprint's PRL, i was getting ~400
__________________
Galaxy Nexus i9250 unlocked and rooted
mrvirginia is offline  
Reply With Quote
Old June 25th, 2010, 12:57 PM   #39 (permalink)
 
Join Date: Mar 2010
Location: In exile
Posts: 1,716
 
Device(s):
Carrier: Not Provided

Thanks: 177
Thanked 1,255 Times in 484 Posts
Default

Quote:
Originally Posted by Jonhern View Post
Did a trick that I found on a xda thread, the one where you hack the phone to work on VZ network. Worked great, got consistent speeds above 1mb at home where before i was getting only about 200-350kbps. but lost 3g after a day and a half, guess went over the roaming limit. But in the same thread there was another post about changing the SID, looks like most evos are set to Kansas city, changed mine to where i am, Providence, RI, and I am getting a bit better speeds. still hovers around the old speed some times, but more near or above 500kpbs most of the time, and sometimes jumps up to about 800kbs, only got that one time before at 2am, lol.

[6/16]*techknowfile's* - Hack the HTC EVO - 3G w/o Sprint EVDO coverage! - xda-developers

here is where i found the sid if anyone wants to try and not read the whole thread, it is somewhere in the middle. Sprints seems to be in the 4000-4999 range, just make sure you find the closest to you and that it is a sprint one.
The Roaming Zone-System ID (SID) List
You need your MSL to be able to do it, ##DATA#, Edit mode, enter MSL, go to advanced and scroll down to Home SID/NID, leave NID alone and just change SID, the first set of numbers. Hit menu, and commit changes. If it lists 4139 that means it was set to Kansas City. This is not the hack for VZ 3g, thats a whole other process, lol.

And just to add, been using sprint tv since the change back to sprint 3g with the SID fix, and it is running much better, little lag and no to little pixilation, much better than before at the same location.
If you do this and you go above 300mb per month, sprint will kick you off. Period. Please read and understand your terms of service. What you are promoting can and will get a lot of people in some very serous problems. Please refrain from posting material that will cause people to get kicked from there carrier.

Quote:
Originally Posted by terms of service
Off-network Roaming: The primary use of your Device must be for domestic purposes within the Sprint-owned network. Domestic means use in the 50 United States and U.S. Territories (except Guam). Sprint reserves the right, without notice, to deny, terminate, modify, disconnect or suspend service if off-network usage in a month exceeds: (1) voice: 800 min. or a majority of minutes; or (2) data: 300 megabytes or a majority of kilobytes. The display on your device may not always be on and will not indicate whether you will incur roaming charges. You can monitor usage online through My Account. Roaming is not available with single-band phones, or to customers who reside or whose primary use is outside an area covered by the Nationwide Sprint Network. Sprint may limit or terminate service if you move outside of the Sprint owned-network.
https://manage.sprintpcs.com/output/en_US/manage/MyPhoneandPlan/ChangePlans/popLegalTermsPrivacy.htm
RiverOfIce is offline  
Reply With Quote
Old June 25th, 2010, 12:58 PM   #40 (permalink)
Member
 
Join Date: Jun 2010
Posts: 221
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 22 Times in 17 Posts
Default

Quote:
Originally Posted by mrvirginia View Post
i get about 1000-1400 but i'm on a different PRL. with Sprint's PRL, i was getting ~400
Are you doing the VZ thing? Got the same, but stopped working after a day and a half.
Jonhern is offline  
Reply With Quote
sponsored links
Old June 25th, 2010, 12:59 PM   #41 (permalink)
 
Join Date: Mar 2010
Location: In exile
Posts: 1,716
 
Device(s):
Carrier: Not Provided

Thanks: 177
Thanked 1,255 Times in 484 Posts
Default

Quote:
Originally Posted by coolguy949 View Post
I did, I get:

SF: 374 down, 160 up
LA: 662 down, 139 up (I'm in the LA area)
Take your phone to a service center, something is really wrong.
RiverOfIce is offline  
Reply With Quote
Old June 25th, 2010, 12:59 PM   #42 (permalink)
Member
 
Join Date: Jun 2010
Posts: 221
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 22 Times in 17 Posts
Default

Quote:
Originally Posted by RiverOfIce View Post
If you do this and you go above 300mb per month, sprint will kick you off. Period. Please read and understand your terms of service. What you are promoting can and will get a lot of people in some very serous problems. Please refrain from posting material that will cause people to get kicked from there carrier.



https://manage.sprintpcs.com/output/en_US/manage/MyPhoneandPlan/ChangePlans/popLegalTermsPrivacy.htm
Yeah, I am not promoting the roaming one, but changing the SID is a different thing, does not have to do with using VZ network. It has improved coverage on the Sprint Network.
Jonhern is offline  
Last edited by Jonhern; June 25th, 2010 at 01:06 PM.
Reply With Quote
Old June 25th, 2010, 01:01 PM   #43 (permalink)
Member
Thread Author (OP)
 
Join Date: Jun 2010
Location: Orange County, CA
Posts: 165
 
Device(s): Samsung Vibrant HTC EVO 4G (Returned)
Carrier: Not Provided

Thanks: 18
Thanked 17 Times in 10 Posts
Default

Quote:
Originally Posted by Jonhern View Post
Thats kbps, not mbps. That would translate to .3mbps and .6mbps
Yep. I took those numbers from the summary the shows up in kbps.
coolguy949 is offline  
Reply With Quote
Old June 25th, 2010, 01:06 PM   #44 (permalink)
Member
 
Join Date: May 2010
Posts: 182
 
Device(s):
Carrier: Not Provided

Thanks: 4
Thanked 7 Times in 7 Posts
Default

Finally people are posting with the same experiences I've seen since I got this phone. I had assumed Sprint's network is just horribly slow, but now I'm hearing that might not be the case from people with other phones on Sprint. I average 500kbps down, every now and then I'll break 1mbps. 4G (when I can get it) has yet to break 2.8mbps down.

This isn't just in speedtest apps, either. I don't store media on my phone, I stream it from my home server using Subsonic. I can see exactly how fast (or not as the case may be) those files are transferring.

By comparison, I always got over 1.2mbps on my iPhone 3G and my co-workers are consistently getting 2.5mbps and even 3.0 at times on 3G.
Headcase_Fargone is offline  
Reply With Quote
Old June 25th, 2010, 01:07 PM   #45 (permalink)
Senior Member
 
Join Date: May 2010
Location: Charlotte, NC
Posts: 1,493
 
Device(s): Galaxy Nexus i9250
Carrier: Not Provided

Thanks: 50
Thanked 232 Times in 147 Posts
Default

Quote:
Originally Posted by Jonhern View Post
Are you doing the VZ thing? Got the same, but stopped working after a day and a half.
yes, but there's multiple PRL's and i tried quite a few before i found one that worked well with my location.

i use 40050 which is older.

i tried 40060, 30045, 40055, 01337, 31337, and 00001 before i realized 40050 was the best for me. some of the others would work, but then i'd go to a certain area and there would be no 3G, or some wouldn't work with 3G at all.
mrvirginia is offline  
Reply With Quote
Old June 25th, 2010, 01:08 PM   #46 (permalink)
Senior Member
 
Join Date: May 2010
Location: Charlotte, NC
Posts: 1,493
 
Device(s): Galaxy Nexus i9250
Carrier: Not Provided

Thanks: 50
Thanked 232 Times in 147 Posts
Default

Quote:
Originally Posted by Jonhern View Post
Yeah, I am not promoting the roaming one, but changing the SID is a different thing, does not have to do with using VZ network. It has improved coverage on the Sprint Network.
how are you changing your sid and where might i find an sid for charlotte, nc? i just want a better signal is all. thanks
mrvirginia is offline  
Reply With Quote
Old June 25th, 2010, 01:12 PM   #47 (permalink)
Senior Member
 
Join Date: Apr 2010
Location: Bat Cave
Posts: 1,065
 
Device(s): Motorola StarTac
Carrier: Not Provided

Thanks: 154
Thanked 826 Times in 287 Posts
Default

Are your phones actually running slower?
eieio is offline  
Reply With Quote
Old June 25th, 2010, 01:16 PM   #48 (permalink)
Member
 
Join Date: Jun 2010
Posts: 221
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 22 Times in 17 Posts
Default

Quote:
Originally Posted by mrvirginia View Post
yes, but there's multiple PRL's and i tried quite a few before i found one that worked well with my location.

i use 40050 which is older.

i tried 40060, 30045, 40055, 01337, 31337, and 00001 before i realized 40050 was the best for me. some of the others would work, but then i'd go to a certain area and there would be no 3G, or some wouldn't work with 3G at all.
How long have you been using it? How much data have you used?
Jonhern is offline  
Reply With Quote
Old June 25th, 2010, 01:26 PM   #49 (permalink)
Senior Member
 
Join Date: May 2010
Location: Charlotte, NC
Posts: 1,493
 
Device(s): Galaxy Nexus i9250
Carrier: Not Provided

Thanks: 50
Thanked 232 Times in 147 Posts
Default

Quote:
Originally Posted by Jonhern View Post
How long have you been using it? How much data have you used?
almost a month. i can't check data usage anymore because i just merged my account with my moms. i'll see if i can email her and get her account info and get back to you.

no info on changing the SID?
mrvirginia is offline  
Reply With Quote
Old June 25th, 2010, 01:29 PM   #50 (permalink)
Member
 
Join Date: Jun 2010
Posts: 221
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 22 Times in 17 Posts
Default

Quote:
Originally Posted by mrvirginia View Post
almost a month. i can't check data usage anymore because i just merged my account with my moms. i'll see if i can email her and get her account info and get back to you.

no info on changing the SID?
posted above #34, you need to get your MSL first, but since you have been changing your PRL guessing you already have it, if not dial *2 to get it, i just asked and they gave it, just say you don't want to reprogram with them, that you want to do it yourself. Its a dix digit pass-code.
Jonhern is offline  
Reply With Quote
Reply

HTC EVO 4G
Current Rating:
Rate this Phone:

When Sprint announced their first ever 4G handset at CTIA in March 2010, they dropped a bombshell on the mobile world. The HTC Evo 4G is a device that introduces a lot of firsts when compared to other North American handsets. This is the first Andr... Read More

Tags
evo, slow, speed, sprint, test


Go Back   Android Forums > Android Phones > HTC EVO 4G
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:03 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.