Go Back   Android Forums > Android Phones > HTC Hero

test: Reply
 
LinkBack Thread Tools
Old February 2nd, 2010, 04:52 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default usb device not recognized

Have just downloaded the new windows 7 sync for my hero and installed. Pluged phone into usb and nothing, all i get is a windows message saying device drivers could not be installed properley, then usb device not recognized. Have uninstalled and reinstalled software and that hasnt helped.

Also when i do plug phone into the usb, absolutely nothing happens on my hero.

Please help as i have been waiting ages for the windows 7 sync software to come out as i couldnt get my head round the old work around, and want to start getting the full benifits from my hero.

Advertisements
sally cinnamon is offline  
Reply With Quote
sponsored links
Old February 3rd, 2010, 12:24 PM   #2 (permalink)
Senior Member
 
Ziani's Avatar
 
Join Date: Sep 2009
Location: Norfolk, UK
Posts: 825
 
Device(s): Samsung Galaxy S5
Carrier: EE

Thanks: 68
Thanked 121 Times in 48 Posts
Default

Just a thought, did you pull down the notification bar and tap on mount?
__________________
Ciao for Now
Ziani is offline  
Reply With Quote
Old February 3rd, 2010, 04:47 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for replying was giving up hope for a while.

Well i would if their was one, thats the weird thing nothing happens on the phone, it just starts charging and i get the windows does not recognize mass storage device on my laptop. It did work on my old laptop which was also running windows 7, well at least i could mount the sd card, but got new laptop a few weeks ago and the first time i tried it was yesterday when i noticed htc had relesed windows 7 compatible sync. So i download the sync package from htc website and i get nothing. Have tried reformating sd card and doing a factory reset but still nothing happens on phone.
sally cinnamon is offline  
Reply With Quote
Old February 4th, 2010, 01:52 AM   #4 (permalink)
Junior Member
 
zaffy's Avatar
 
Join Date: Nov 2009
Location: Norfolk, UK
Posts: 37
 
Device(s): Rooted Hero
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Try this, I did and mine works OK with 7, but you must have MS Outlook installed to sync with.

1. Open Control Panel / Devices and Printers

2. Right click the 'Android Phone' and select properties

3. Click on the hardware tab

4. Probably be listed as 'HTC Dream composite interface' or similar.

5. Highlight this entry and click on properties.

6. In the properties dialogue box under the general tab at the bottom click 'change settings'.

7. When the dialogue box reappears click on the 'Driver' tab.

8. Select the 'Update Driver' option.

9. On the first screen select the second option 'Browse my computer for driver software'.

10. In the next screen select the second option 'Let me pick from a list of device drivers on my computer'.

11. You should then be faced with 2 options on the next screen under Model, either 'HTC Dream Composite ADB Interface' or 'My HTC'.

12. Select 'My HTC' and that will install the correct drivers and then you should be good to go.
zaffy is offline  
Reply With Quote
Old February 4th, 2010, 02:13 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can't do that as all there is in devices is "unknown device". It will not recognize the hero at all.
sally cinnamon is offline  
Reply With Quote
Old February 4th, 2010, 06:25 AM   #6 (permalink)
Junior Member
 
zaffy's Avatar
 
Join Date: Nov 2009
Location: Norfolk, UK
Posts: 37
 
Device(s): Rooted Hero
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

If in device manager your Hero is shown as "unknown device", download a driver from Download HTC Hero Drivers for Android - Windows drivers that enable HTC Sync to recognize HTC Hero. - Softpedia, select the unknown device / properties / driver / update driver, and point it to the downloaded driver. It should install correctly.
zaffy is offline  
Reply With Quote
Old February 4th, 2010, 04:40 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok tried this but windows tells me that the most up to date drivers for this are already installed, but still won't recognise the hero. This is the error message im getting from windows "Windows has stopped this device because it has reported problems. (Code 43)"
sally cinnamon is offline  
Reply With Quote
Old February 4th, 2010, 05:48 PM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Getting a tad annoying now. Just pluged phone in again and the hero recognized that it was connected to pc and started to search for sync, only to come back with "cannot find htc sync please download from htc" but its their running in task bar, and still no option to just mount the phone.
sally cinnamon is offline  
Reply With Quote
Old February 4th, 2010, 06:53 PM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Its sorted!

Found another post where a user was having similar problems and they suggested removing battery from hero with usb pluged in and then putting battery back in, so i did this thinking it wouldn't work and hey presto, mounting option became available. I was then able to follow your first set of intructions to install the drivers through devices and sync is now working!

Thanks for the help, im now off to install the latest orange rom.
sally cinnamon is offline  
Reply With Quote
Old February 4th, 2010, 08:19 PM   #10 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

aHHHHHH god dam you HTC! Back to the same old problem, it worked untill i tried to update the orange rom then got connection failed so unplugged and started again and nothing. So did the whole phone on off thing again and this time i can mount the card but sync wont work, have checked the drivers and its still saying "my htc" so that cant be the problem. Im tearing my hair out here and its 2 in the morning.
sally cinnamon is offline  
Reply With Quote
sponsored links
Old February 23rd, 2010, 09:51 AM   #11 (permalink)
New Member
 
Join Date: Feb 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've the same problem in XP pro. Have re-installed updated drivers, switched off and on while tethered, re-started bith to no avail... Help!

Firmware's v1.5.

it worked without a hitch until I unmounted the SD card, also of note is that i'm not using the USB cable that came with the phone so I'll try that tomorrow.

Sync starts on the phone but I get the ubiquitous "usb device not recognized" message.

edit... ahah! I wonder whether I can get a spare cable?
smelly is offline  
Last edited by smelly; February 23rd, 2010 at 09:55 AM.
Reply With Quote
Old February 24th, 2010, 02:18 AM   #12 (permalink)
Senior Member
 
Ziani's Avatar
 
Join Date: Sep 2009
Location: Norfolk, UK
Posts: 825
 
Device(s): Samsung Galaxy S5
Carrier: EE

Thanks: 68
Thanked 121 Times in 48 Posts
Default

Quote:
Originally Posted by smelly View Post
I've the same problem in XP pro. Have re-installed updated drivers, switched off and on while tethered, re-started bith to no avail... Help!

Firmware's v1.5.

it worked without a hitch until I unmounted the SD card, also of note is that i'm not using the USB cable that came with the phone so I'll try that tomorrow.

Sync starts on the phone but I get the ubiquitous "usb device not recognized" message.

edit... ahah! I wonder whether I can get a spare cable?
It has been known to be the USB cable if not using stock one, worth a try.
Ziani is offline  
Reply With Quote
Old May 4th, 2010, 12:38 AM   #13 (permalink)
New Member
 
Join Date: May 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by smelly View Post
I've the same problem in XP pro. Have re-installed updated drivers, switched off and on while tethered, re-started bith to no avail... Help!

Firmware's v1.5.

it worked without a hitch until I unmounted the SD card, also of note is that i'm not using the USB cable that came with the phone so I'll try that tomorrow.

Sync starts on the phone but I get the ubiquitous "usb device not recognized" message.

edit... ahah! I wonder whether I can get a spare cable?

Wow, Hooray for you!!!!

Thanks for saving my sanity, kind anonymous interweb person. I just wish I could get that hour back...
I succeeded with a generic cable at work and didn't even suspect its brother here at home, but sure enough it was the swap from generic to HTC cable that brought my Hero back into heroism.

Yay, I'll be able to sleep tonight...
king10208 is offline  
Reply With Quote
Old May 15th, 2010, 09:45 AM   #14 (permalink)
New Member
 
Join Date: May 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Solution!!
I had the same problem.
With the USB cable connected, click Home -> Menu -> Notifications.
Tap 'Turn on USB Storage'
And off you go it's that easy , worked for me with Windows XP!
Hope this helps someone!
basscollection is offline  
Reply With Quote
Old May 24th, 2010, 08:28 AM   #15 (permalink)
New Member
 
Join Date: May 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem for weeks and weeks...... turns out it was the actual HERO usb cable as it no longer mounted at all.
I changed the cable to my external hd one and it mounted immediately. Once i had been able to mount it was a case of unistalling HTC drivers and sync. I downloaded the lastest sync and installed. With my phone connected i then rang the sync and it still didnt recognise my phone but at least it mounted so you must with the phone connected switch of the phone and then switch it back on. Once the phone powers up it will then allow you from the drop down to sync and it immediately synced.

So for my my problem was the actual HTC usb cable which i cannot use now for some reason but with my external HD's cable its fine!!
Sanchez_old is offline  
Reply With Quote
Old October 12th, 2011, 04:31 AM   #16 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Angry htc usb not recognized

i have an htc evo 4g an everytime i connect the usb in to the computer i get USB Device Not Recognized messages any help please...
dontaegray21 is offline  
Reply With Quote
Old October 18th, 2011, 10:02 PM   #17 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Try connecting with headphones plugged in

I have this issue (phone charges, but not recognized by windows) and tried absolutely everything, cables (incl original), different PCs, even flashed to a custom ROM.

On one PC the whole computer would freeze and not respond until I unplugged the USB cable again.

Anyway, by chance I have discovered that if (and only if) I have headphones plugged in, the USB functions perfectly!!! Mounting and even HTC Sync works

So worth a try if you have this problem. I hope this helps someone.
innomatics is offline  
Reply With Quote
Old December 20th, 2011, 12:33 PM   #18 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default USB Device Not Recognized

This is the message I always get when connecting my HTC EVO 4G to my Windows Vista Fujitsu Tablet T5010 via USB cable:
"One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it."

I've tried selecting each of the four options in "Connect to PC" settings on my phone as well as all of the methods mentioned above in this thread. The USB cable is not the problem, as I've tried connecting my phone via the same cable to my friend's computer, which is a Mac if that's worth mentioning, and when I connect it to his computer, it works fine. For whatever reason, the cable just won't work with my computer. However, I have come up with an alternative. I bought microSD adapters (made by Kingston). Now instead of just plugging my phone in via USB cable, I unmount my SD card from my phone, turn off my phone, take out the SD card from my phone, put the SD card in the adapter, and then put the adapter in computer. This takes much longer than just plugging in a USB cable, but it now allows me to transfer files from my phone and my computer. When I am done, I put my SD card back in my phone and turn my phone back on for use.
XgenDLC is offline  
Last edited by XgenDLC; December 20th, 2011 at 12:39 PM.
Reply With Quote
Old January 23rd, 2012, 02:09 PM   #19 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry to but in guys, but I have exactly the same problem.
And nothing seems to be fixing it.
I've tried to install the drivers once more, with the links provided. Doesn't work. It's just "uninstalls" the previous drivers, which were probably non existent, and "installs" the ones provided. However, my HTC Hero is still unrecognised. I've removed the battery whilst charging, used both a genuine and non genuine microusb cables. I've used different USB ports. I'm not able to get onto the SD card either. The phone does charge whilst plugged in, and it does hold that charge. The phone however, except it charging, is completely unaware that it is connected to a USB port.

Any advice?

+ On a side note, I got the headphone glitch as well today. When I unplug a headphone, or a mic, the notification stays there, and directs all sound information to the headphone; thus not any sound to the speaker. So I can't hear anything when there is no headphone plugged in. Any help for that as well? D:
Oxidium is offline  
Reply With Quote
Old January 23rd, 2012, 04:30 PM   #20 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is a Hero hardware fault that no cable or amount of driver installation on device or PC is going to remedy.

For syncing you can try with headphones connected.

For phone thinking that headphones/headset are connected when they aren't try using an app to switch headphones on/off e.g. "Toggle Headset 2". Painful workaround I know, unfortunately it's time to look at a new phone.
innomatics is offline  
Reply With Quote
sponsored links
Old January 24th, 2012, 11:36 AM   #21 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply bro, one question is there no way to fix this without using the 2 year EU warranty, and 1 year warranty that the phone network gave me, to fix this problem?

i.e. Can I get this repaired at a phone shop, or something similar?

P.S. This was a refurmished phone that I reviced around 5/6 months back.
+ Thank you! ToggleHeadset2 works perfectly. Appreciated!
Oxidium is offline  
Reply With Quote
Old January 24th, 2012, 05:46 PM   #22 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey wow if your phone is still under warranty then return it for sure.

Not sure if it would be worth trying to get a phone shop to fix a subtle problem like this...
innomatics is offline  
Reply With Quote
Old January 25th, 2012, 04:03 PM   #23 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Laugh

I have no idea, how, where, or why but my HTC Hero can now be detected by my computer, and the connection is also recognised by my phone.

Everything is working now, thanks guys for the help. Much appreciated.
Oxidium is offline  
Reply With Quote
Old May 16th, 2012, 04:12 AM   #24 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem with the HTCevo 4G I have try everything I am running windows vista 64 bit it use to work on this computer all the time now is not recognize it is such a problem. my wife have the same phone and when I connect hers it works fine I dont get why is this I connect her phone thru the same cable and every thing she have a 8gb card I have a 32gb card but the thing is that it use to work fine up to last week am getting ready to reset my phone i have try everything but that
sweetnote777 is offline  
Reply With Quote
Reply

HTC Hero
Current Rating:
Rate this Phone:

For tech lovers dreaming of a magical phone, HTC's 3rd Android Phone - the HTC Hero - seems poised to rescue the masses from mobile phone boredom. The design is a more sleek, sexy version of the HTC Dream and HTC Magic and both hardware and sof... Read More



Go Back   Android Forums > Android Phones > HTC Hero
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:21 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.