Go Back   Android Forums > Android Phones > HTC Hero

test: Reply
 
LinkBack Thread Tools
Old February 16th, 2010, 08:31 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default No ear-speaker sound

I'm having problems with the ear-speaker of my HTC Hero. It has been working great for near 4 months now then out of nowhere the ear-speaker stopped working yesterday. Whenever I try to make or receive a call I cannot hear the other person speaking. If I switch to speaker or headset then I can hear them just fine, but if I try to use the ear-speaker there's nothing.

Anyone got any bright ideas on what's wrong/how to fix it?

I have the newest firmware (2.73) and it's not rooted or anything else.

Advertisements
Armadill is offline  
Reply With Quote
sponsored links
Old February 16th, 2010, 08:54 AM   #2 (permalink)
Member
 
jimeller's Avatar
 
Join Date: Aug 2009
Location: East Riding
Posts: 410
 
Device(s): Samsung Galaxy S2 Orange UK
Carrier: Not Provided

Thanks: 9
Thanked 22 Times in 21 Posts
Default

Have you tried adjusting the volume when speaking on the phone. It's the same button, but different function than ringer volume.
jimeller is offline  
Reply With Quote
Old February 16th, 2010, 09:07 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, I've tried that and it didn't do anything.

There's a small update though.

The sound just came back on miraculously a moment ago. Strange thing is the phone did the exact same thing yesterday. I tried calling a number several times and couldn't hear a thing, put down my Hero, called from my girlfriends phone to check nothing was wrong with the number I was calling to, took my Hero and tried again and this time there was sound without me apparently doing anything.

Same thing just happened. I have been trying to get the sound working for about an hour and then after I gave up and were backing up my settings to do a reset it started working without me doing anything since I last checked there were no sound... this is weird!

So it seems it's solved for now, but if anyone have any ideas of what it could and how to handle it be please give it a go as I will no doubt run into it again soon.
Armadill is offline  
Reply With Quote
Old February 18th, 2010, 07:32 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Feb 2010
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Small update:

Sound gone again on the ear-speaker. Contacted HTC support and they suggested a factory reset. Tried it and it didn't bring the sound back. Might be a loose connection in the ear-speaker?

When the sound was on there was no noise or anything implying the speaker was broken or about to (if that is indeed what has happened).
Armadill is offline  
Reply With Quote
Old March 15th, 2010, 04:52 AM   #5 (permalink)
New Member
 
Join Date: Mar 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the exact same problem. Sometimes the ear speaker works but most of the time it doesn't. Restarting the phone or doing a factory reset sometimes gets the speaker to work but mostly it stops working again after an hour or so. I guess there's nothing left to try but to send it in under warranty. Have you solved the problem in any other way?
cespen is offline  
Reply With Quote
Old March 15th, 2010, 06:57 AM   #6 (permalink)
Senior Member
 
daveybaby's Avatar
 
Join Date: Sep 2009
Location: UK
Posts: 919
 
Device(s): HTC Hero (FroydVillain), Sony Ericsson Xperia Arc
Carrier: Not Provided

Thanks: 29
Thanked 101 Times in 84 Posts
Default

Hmmmm.... there have been people with the opposite problem: cant get headphones to work - sound remains routed through speaker when phones are plugged in. Basically the audio routing is done via software and sometimes this fails (or the hardware that detects the headphones are inserted has failed).

There is an app on the market which fixes this: i.e. a toggle that forces audio out of either the headphones or the speaker. There's a paid one here (couldve sworn there was a free one somewhere too, but you could always get a refund on this if it doesnt work).

Try that app, see if you can force it to route audio through the speaker.
__________________
Sony Ericsson Xperia Arc : GiffGaff : UK
daveybaby is offline  
Reply With Quote
Old April 2nd, 2010, 04:46 PM   #7 (permalink)
New Member
 
Join Date: Apr 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am also having this problem.

Randomly all sound will stop working, and apparently my mic to, and the only way I've found to fix it is a power cycle. And this only works half the time, and the problem usually comes back within the hour.

basically...
My phone will be on loud and someone will call, and it wont ring, just vibrate, then when I pick it up I hear nothing. Or I could call someone, and it connects, but I never even hear it ring, just silence until I hang up or they do.Testing it out with another phone I found that the person on the other end hears nothing from me, indicating the mic stops working too.

If it matters, I have a Sprint "w/ google" Hero, rooted, running DamageControl v2.05 from XDA, and while I have experienced this intermittently (about once a week) for a while, It is not until the last 24 hours that it has gotten like this. No one else on the ROM is reporting issues like this. And i tried ToggleHeadset, didnt work.

Any information would be appreciated.
teddypepper52 is offline  
Reply With Quote
Old April 5th, 2010, 12:04 AM   #8 (permalink)
New Member
 
Join Date: Apr 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

If you are having the problem i described too, here is some info/ possible fix.

(fix) audio-loss i need testers! - Page 11 - xda-developers
teddypepper52 is offline  
Reply With Quote
Old January 18th, 2011, 08:58 AM   #9 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Free app is toggleheadset2

toggleheadset2 - This app only works for Android 1.6. A version for 2.1 is being tested but developers are saying the audio bugs should be fixed in 2.1, negating the need for this app.

Download ToggleHeadset2 1.3 for Android Free - Headset toggle widget for Android. - Softpedia
codestripper is offline  
Reply With Quote
Old October 5th, 2011, 08:24 AM   #10 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I am using SE Xperia Arc for last 6 months, me too experiencing the same problem for last 2 days.
Seems like android platform have this issue. (gonna install toggleheadset2 hope it will works)

Thanks,
SriniK
SrinivasanK is offline  
Reply With Quote
sponsored links
Reply

HTC Hero
Current Rating:
Rate this Phone:

For tech lovers dreaming of a magical phone, HTC's 3rd Android Phone - the HTC Hero - seems poised to rescue the masses from mobile phone boredom. The design is a more sleek, sexy version of the HTC Dream and HTC Magic and both hardware and sof... Read More

Tags
ear speaker, sound problem


Go Back   Android Forums > Android Phones > HTC Hero
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:37 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.