Go Back   Android Forums > Android Phones > HTC Hero

New Forums: Nexus 6 | Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old August 28th, 2009, 11:03 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2009
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to access disk via USB

Hi,

I got my HTC Hero this morning - its my first smartphone and I am very impressed. I saw some fairly damning reviews online, but when I trialled it I was hooked. Superb device A+ so far, except for this little problem which I think is probably linked to my Laptop rather than the Hero...

I have plugged it into my Laptop via USB. Vista found the drivers, installed all well and good. However, if I click on Removable Disk (F I get an error stating that there is no disk in the drive and please insert one.

I've tried re-installing the drivers using the ones available online, and nothing.

I've also installed HTC Sync which simply doesn't find the device despite being plugged in.

The Hero reckons it is connected, complete with USB symbol and HTC sync symbol.

So what have I done wrong? I've tried all the obvious ones - reinstalling drivers, different USB port, turning both off and on again (many times), uninstalling, reinstalling etc etc....

Advertisements
TheRecklessEngineer is offline  
Reply With Quote
sponsored links
Old August 28th, 2009, 11:11 AM   #2 (permalink)
Member
 
Join Date: Aug 2009
Posts: 107
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Smile

HEY

1) Go to the home screen and press the "MENU" button

2) Then press the "NOTIFICATIONS" icon

3) Press the "USB CONNECTED - SELECT TO COPY FILES" message

4) Then press "MOUNT" message to mount the drive and then you can access it on your computer (don't forget to unmount before when you finish doing your things)
computerboyo is offline  
Last edited by computerboyo; August 28th, 2009 at 11:17 AM.
Reply With Quote
Old August 28th, 2009, 11:18 AM   #3 (permalink)
Premium Member
 
justjimjpc's Avatar
 
Join Date: Nov 2008
Location: Washington DC, USA
Posts: 10,560
 
Device(s): G1(2ea) 1 rooted, MT3G v1.0, Samsung Vibrant, Samsung III, LG SLATE Tablet
Carrier: T-Mobile

Thanks: 5
Thanked 220 Times in 104 Posts
Default

Quote:
Originally Posted by TheRecklessEngineer View Post
Hi,

I got my HTC Hero this morning - its my first smartphone and I am very impressed. I saw some fairly damning reviews online, but when I trialled it I was hooked. Superb device A+ so far, except for this little problem which I think is probably linked to my Laptop rather than the Hero...

I have plugged it into my Laptop via USB. Vista found the drivers, installed all well and good. However, if I click on Removable Disk (F I get an error stating that there is no disk in the drive and please insert one.

I've tried re-installing the drivers using the ones available online, and nothing.

I've also installed HTC Sync which simply doesn't find the device despite being plugged in.

The Hero reckons it is connected, complete with USB symbol and HTC sync symbol.

So what have I done wrong? I've tried all the obvious ones - reinstalling drivers, different USB port, turning both off and on again (many times), uninstalling, reinstalling etc etc....
You did not say specifically that you had done what is done to access the SDCARD as a USB Drive.

Connect cable.

A USB symbol will appear in the Notifications Bar ..

Swipe that bar down to open it..

Touch the USB Connected item in the list and a popup will open that will allow
you mount the drive.

The drive will now appear in you "MyComputer" or Explorer Section of your laptop ...

You can now copy drag and drop files and folders just like and USB drive...

When you are finished ... just be sure to go back to the phone and swipe the notifications again .. select the USB and "Turn Off" the usb drive ... this UnMounts the drive from the PC ...
__________________
Help Us: Submit FAQ's You have answered over and over! Will add them to OUR FAQ LIB. Check out our FAQ's.... Also Check out our Tag Search. \\\ Running 2 G1's & a MT3G, Vibrant(rooted), Galaxy S: <<< OLD New >>> JUST Samsung S3-32GB & LG GSlate Tablet /// Link for --> G1 Dream ROOT GUIDE ///// Link for --> UN-ROOT GUIDE
.
justjimjpc is offline  
Reply With Quote
Old August 28th, 2009, 11:32 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2009
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Doh!

Cheers chaps. I look forward to finding my way round this thing properly...
TheRecklessEngineer is offline  
Reply With Quote
Old August 28th, 2009, 12:32 PM   #5 (permalink)
Junior Member
 
Join Date: Aug 2009
Location: San Antonio, TX, USA
Posts: 22
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to daleoffret Send a message via MSN to daleoffret Send a message via Yahoo to daleoffret Send a message via Skype™ to daleoffret
Default

That's funny. I had that same problem not 7 hours ago. I totally forgot to swipe the notification bar down and select mount the sd card to the pc.

I was trying to get the CyanogenMod-4.0.3.1 rom moved over from my PC to the sd card.

How I installed the CM 4.0.3.1 ROM without PC:

1) 1-Click FlashRec installed and ran 2 weeks earlier.

2) This morning downloaded Opera Mini.

3) Emailed myself the CM 4.0.3.1 ROM download link from the computer.

4) Opened Gmail on MyTouch 3G and copied the link.

5) Opened download link in Opera Mini.

6) Save ROM to sd card.

7) 5 minutes later file was downloaded. (Over home WiFi.)

8) Wiped phone.

9) Applyed ROM from Flash Recovery.

10) Rebooted into CM - 4.0.3.1 this morning.

Great stuff!
daleoffret is offline  
Reply With Quote
Old August 4th, 2010, 03:00 PM   #6 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default Funny thing

I had the very same issue today, after enjoying a fully functional device for several weeks.

In my case, scrutinizing the USB port on the phone itself under an exceptionally bright lamp, I noticed what appeared to maybe possibly be some pocket lint crammed deep inside the plug. Yep, it was pocket lint alright, and after carefully fishing it all out with a tiny staple, it connects fine!

Since yours is new, it is most likely not pocket lint yet at this stage, but it never hurts to check - and besides, there is possibly another person out there with an HTC Hero and linty pockets who will find this knowledge useful!
lord_nougat is offline  
Reply With Quote
The Following User Says Thank You to lord_nougat For This Useful Post:
Haiz (August 5th, 2010)
Reply

HTC Hero
Current Rating:
Rate this Phone:

For tech lovers dreaming of a magical phone, HTC's 3rd Android Phone - the HTC Hero - seems poised to rescue the masses from mobile phone boredom. The design is a more sleek, sexy version of the HTC Dream and HTC Magic and both hardware and sof... Read More



Go Back   Android Forums > Android Phones > HTC Hero
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:59 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.