Go Back   Android Forums > Android Phones > HTC Magic

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old August 12th, 2009, 04:26 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2009
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Android market problem, application hold on starting download

Hi,
I got my HTC Magic yesterday and I can surf internet using wifi normally, gmail , browser, google maps all work perfectly.

but when I go to the android market, I can see and select application and when hit install, it freez on the starting dowload message and never start!

I saw in other forums that starting google talk will help, but my problem is that Google Talk also can't sign in at all

please help!

martani is offline  
Reply With Quote
sponsored links
Old August 12th, 2009, 07:35 AM   #2 (permalink)
Member
 
Join Date: Aug 2009
Location: Cambridge, UK
Posts: 135
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you check your router's firewall log?

I think then when on a cell network, Market downloads are done via TCP to a server port 5228, so that needs to be open for it to start. But I thought that when on wifi it used a "regular" port?
cdmackay is offline  
Reply With Quote
Old August 12th, 2009, 07:42 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2009
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by cdmackay View Post
Did you check your router's firewall log?

I think then when on a cell network, Market downloads are done via TCP to a server port 5228, so that needs to be open for it to start. But I thought that when on wifi it used a "regular" port?
thank you for reaply,
actually it never connect to my secured network or any other secured network, I'm using public wifi so I can't do a check for the TCP port!

I hope I'll find a way to connect to secured networks otherwise I'll make my router's wifi unsecured , no choice
martani is offline  
Reply With Quote
Old August 12th, 2009, 10:06 AM   #4 (permalink)
Member
 
Join Date: Aug 2009
Location: Cambridge, UK
Posts: 135
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had problems with my home router (WRT54G) until I reflashed it to run the Tomato firmware, and now my Hero connects fine; it would barely connect at all, before.
cdmackay is offline  
Reply With Quote
Old August 26th, 2009, 02:41 PM   #5 (permalink)
New Member
 
Join Date: Aug 2009
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem here

Martani,

I have exact the same problem. Please let me know if you find a sollution.

With kind regards,

Tim Ruijters
tim.ruijters@gmail.com
timbo is offline  
Reply With Quote
Old August 26th, 2009, 02:47 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2009
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by timbo View Post
Martani,

I have exact the same problem. Please let me know if you find a sollution.

With kind regards,

Tim Ruijters
tim.ruijters@gmail.com
yes now it's working for me,
I found that it never downloads when I'm connected to public wifis, so when I connect to protected networks with password there are two cases :

1. it starts downloading immediately
2. it doesn't : in that case you choose the application you want to download, hit start download, then disable and enable wifi again and it will start immediately.

some other start Google Talk and that worked for them
I hope this will work for you!
martani is offline  
Reply With Quote
Old August 24th, 2010, 03:45 AM   #7 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've experienced similar problems on my HTC Desire.

The problem:
- Downloads in Market hang on "Starting download"
- Google talk crashes immediately after opening it

The problems gets fixed if you clear data and cache from Talk, Market and Mail (also clear Agenda to be sure). You'll need to re-add your mail accounts etc. A sync icon will appear above and Market and Talk will also resume working.

Though... this proved to be a temporary fix. One day later the same problem occured. I also noticed that the synchronization of my accounts stopped working. Triggering it manually didn't resolve te problem.

I noticed Android gave me a warning that my internal phone memory space was running low. I removed a few applications until the warning went away and voila ... sync, talk and market suddenly resumed working again !
skyhawk10x is offline  
Reply With Quote
Old August 24th, 2010, 10:00 AM   #8 (permalink)
New Member
 
Join Date: Aug 2010
Location: Panama (Clayton)
Posts: 14
 
Device(s): Samsung Galaxy S
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
If only I get it to work
Default

well, this didn't work for me on my new Galaxy S. I've opened the ports on my Wifi router as indicated on other forums and still nothing.

Amazing Google doesn't step in with a clear and consise explication and fix.
panamathor is offline  
Reply With Quote
Old September 27th, 2010, 05:19 AM   #9 (permalink)
Junior Member
 
Join Date: Sep 2010
Location: Kernow - Caboolture - Kernow - Perth?
Posts: 21
 
Device(s): Galaxy S
Carrier: Not Provided

Thanks: 3
Thanked 3 Times in 3 Posts
Default

I want to add my experience to this.

I can connect no problem via the mobile network, however when I connect via wifi I am having problems. I can browse the web with no issues. Youtube gives me a server connect error as does trying to connect to Android Market.

My wifi is a Linksys WRT54G running DD-WRT firmware, my firewall is clearOS.

I think that certain ports need opening however I am unable to find a difinative answer to this, can anyone enlighten me.
edie209 is offline  
Reply With Quote
Old November 2nd, 2010, 11:48 PM   #10 (permalink)
Junior Member
 
Join Date: Sep 2010
Location: Calgary, Alberta, Canada
Posts: 27
 
Device(s): TELUS Motorola Milestone, Acer Iconia A500
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 3 Posts
Send a message via ICQ to Green1
Default

well... I'm stuck in the same place... after searching a lot I have discovered 2 things
1) it's a common problem affecting thousands of people, and has been for 2 years
2) google doesn't care

The fixes I have found listed are:
- sign in to google talk (I can't it just force-closes the app)
- clear the cache on various applications (doesn't help)
- roll-back the update to the market app (doesn't help)
- switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
- switch to wifi (doesn't help)
- toggle airplane mode (doesn't help)
- reboot phone (doesn't help)
- change google account password (doesn't help)
- switch to googlemail instead of gmail (google doesn't give me the option)
- factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)

Anyone have a solution NOT on the list?
Green1 is offline  
Reply With Quote
sponsored links
Old November 6th, 2010, 05:55 AM   #11 (permalink)
Member
 
Baz8755's Avatar
 
Join Date: Jul 2010
Location: South Coast UK
Posts: 128
 
Device(s): HTC Desire
Carrier: Not Provided

Thanks: 2
Thanked 7 Times in 7 Posts
Default

I'm having the same problem with my wife's Magic.

Market used to work fine on both the Magic and Desire and about a month ago the Desire started having intermittant problems downloading.

A couple of weeks ago I tried to use the market on the Magic and nothing downloads, have been trying nearly every day. Have tried all the usual tricks of clearing data/cache/force stop.

My Desire seems to be working OK most of the time now.

Both phones are connected to exactly the same Wi-Fi network.

I suspect the Marketplace is having issues but they are affecting Magic more than Desire (probably because it's and older product).

Baz
Baz8755 is offline  
Reply With Quote
Old November 6th, 2010, 06:43 PM   #12 (permalink)
Junior Member
 
Join Date: Sep 2010
Location: Calgary, Alberta, Canada
Posts: 27
 
Device(s): TELUS Motorola Milestone, Acer Iconia A500
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 3 Posts
Send a message via ICQ to Green1
Default

well... as a last ditch effort I did a factory reset on the phone... that left the phone completely unbootable.

I then restored a nandroid backup from 2 days after I got the phone (apparently I should do backups more often!)

After restoring the backup the phone is completely working again.

So I don't know what originally caused the issue for me, but whatever it was must have been on my phone.

It seems that there are many different causes for this same problem, possibly as many as there are people reporting the issue. Unfortunately what works for 1 person rarely seems to work for the next, but I hope that someone finds the info useful.
Green1 is offline  
Reply With Quote
Old November 8th, 2010, 03:49 PM   #13 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 7
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Smile

Right peeps, I dont know if this helps any of you but I plugged my phone into the PC and selected disk drive and installed the HTC sync app from the SD card. I let that update then suddenly all 4 downloads I had in the market app started downloading!!! Dont know if this helps :-) Ant
leddra2k is offline  
Reply With Quote
Old November 18th, 2010, 02:53 PM   #14 (permalink)
New Member
 
Join Date: Nov 2010
Location: France
Gender: Male
Posts: 3
 
Device(s): HTC One X
Carrier: Free

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had the same problem with my wifi WRT54GL --Firmware: DD-WRT v23 SP2 (09/15/06) vpn-- router @home.
Application download from market could take up to 5 mins to start download.

But with the wifi @work it downloaded instantly (Cisco Router)

I corrected the problem @home with forwarding 5228 (udp&tcp port) to my htc desire ip
i guess it could work also with upnp but i prefer knowing whats going on with my ports ;-)
i supose that my works wifi router is using upnp thus i didn have any problem there...

Now market works like a charm it downloads instantly like i used to at work or over 3G coverage

Hope it helps
ianarus is offline  
Last edited by ianarus; November 18th, 2010 at 03:04 PM.
Reply With Quote
Old December 1st, 2010, 12:37 PM   #15 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default accepting the Conditions?

I have reset my phone to factory standtard, and when Im trying to open the Android market, at first it loads on the page it is suppose to be, but then suddently it jumpes to an internet reader and the identicall page appears on some google page. The problem there, is that I can't accept the conditions! And when Im trying to press "back" button i come to my HOME screen..

Ive tried to uinstall the updates and so on nothing works.. now, im stuck!
Can anyone help me please!
Stigsmann is offline  
Reply With Quote
Old December 29th, 2010, 09:33 PM   #16 (permalink)
New Member
 
Join Date: Dec 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Solution

Hi All,

I just received my phone a day ago and was having the same problem; it just sat at "Starting Download" when I tried to pull down apps. I noticed I had no issue when connected to 3G or 4G network, so I figured the issue was related to my wireless network. Once I made the change in my firewall to allow traffic on certain ports it totally fixed the issue.

Here is what worked for me:

Set your firewall to allow UDP and TCP traffic for port 5228 (this is the port the android market uses). Make sure you allow in and outbound traffic. If you also notice you are having problems with Google Talk after allowing port 5228, you might want to play around with allowing port 443 and 5222, which are the google talk ports, but I really don't think you should have to do that.

Hope this helps, good luck!
epuser99 is offline  
Reply With Quote
Old January 7th, 2011, 08:44 AM   #17 (permalink)
Junior Member
 
Join Date: Oct 2010
Posts: 18
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have this exact same problem on my brand new captivate. I still have yet to find the solution but I do know what the problem is. Sadly, my phone is brand new, so I have NO apps at all and can't get any.

As soon as android market updates itself, I get the "download unseccesful" error for everything I try. If I uninstall the android market update, it goes to "starting download" but sits indefinitely.

I've done many many factory resets and it is definitely a problem with the new market update. I can get in a d/l or two on the old interface, as soon as the market updates, it's toast.

I've tried all the same things(and then some) as an above poster so I will just copy his list...

The fixes I have tried:
- sign in to google talk (I can't it just force-closes the app)
- clear the cache on various applications (doesn't help)
- roll-back the update to the market app (doesn't help)
- switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
- switch to wifi (doesn't help)
- toggle airplane mode (doesn't help)
- reboot phone (doesn't help)
- change google account password (doesn't help)
- switch to googlemail instead of gmail (google doesn't give me the option)
- factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)
-created a new google account


Does anyone know if google is working on a fix or if there is some way to stop the market from updating?

My brand new phone is useless!!!!!
Nodnerb is offline  
Last edited by Nodnerb; January 7th, 2011 at 09:18 AM.
Reply With Quote
Old January 7th, 2011, 09:45 PM   #18 (permalink)
Junior Member
 
Join Date: Sep 2010
Location: Calgary, Alberta, Canada
Posts: 27
 
Device(s): TELUS Motorola Milestone, Acer Iconia A500
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 3 Posts
Send a message via ICQ to Green1
Default

if it's brand new, and a factory reset doesn't fix it, I'd check 2 things, the first is your google account, try changing the password, or even creating a different google account.

If that still doesn't work, I'd take it back to where you got it and say something's defective...

Unfortunately Google is not well known for their customer service, up until android most of their stuff didn't really require much. It is yet to be seen what they do with android, but the few bugs that people really seem to be upset about don't seem to be getting much traction...
Green1 is offline  
Reply With Quote
Old January 11th, 2011, 11:07 AM   #19 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s): Samsung galaxy s
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Green1 View Post
well... I'm stuck in the same place... after searching a lot I have discovered 2 things
1) it's a common problem affecting thousands of people, and has been for 2 years
2) google doesn't care

The fixes I have found listed are:
- sign in to google talk (I can't it just force-closes the app)
- clear the cache on various applications (doesn't help)
- roll-back the update to the market app (doesn't help)
- switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
- switch to wifi (doesn't help)
- toggle airplane mode (doesn't help)
- reboot phone (doesn't help)
- change google account password (doesn't help)
- switch to googlemail instead of gmail (google doesn't give me the option)
- factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)

Anyone have a solution NOT on the list?
I had exactly the same problem with my galaxy which worked fine initially. Tried all in your list except factory reset. I connected the phone to Kies and upgraded to latest s/w (2.2) and all sorted. Though I did lose my 3g connection there are lots of threads to show you how to reset your APN details very quickly.
citydodge is offline  
Reply With Quote
Old February 11th, 2011, 07:02 AM   #20 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is one solution which worked for me. I did not come across this solution anywhere online. I think I figured this out as I was having this issue and it was annoying.

For me this issue happens after I download an app from market which corrupts my market app or screws up my sd card.

Solution -

Switch-off the phone, and remove the SD card.
(P.S Side note: Market downloads and installs from market work fine without sd card. )

After the SD card is removed I was able to uninstall the rogue app(Most probably the last installed app before the issue started). Then switch off the phone and reinstall the sd card and when the phone is powered again everything is back to normal. But this issue seems to recur frequently. I have Sprint EVO 4g.
sanrocz is offline  
Last edited by sanrocz; February 11th, 2011 at 07:08 AM. Reason: Improved the description
Reply With Quote
sponsored links
Old June 30th, 2011, 01:48 PM   #21 (permalink)
New Member
 
Join Date: Jun 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was having this issue as well: 4 downloads that were stuck at "download starting" and not going anywhere. The solutions for me was in restarting the phone (turn off the phone, select restart). After that, the downloads started and installed properly. Seems easier than reinstalling SD card or resetting everything :-)
blago is offline  
Reply With Quote
Old July 3rd, 2011, 10:35 AM   #22 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 26,674
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,059
Thanked 15,878 Times in 8,530 Posts
Default

Deleting the android_secure and LOST.DIR folders on your SD Card, then rebooting should resolve the issue.
__________________
Site Rules & Guidelines / Staff List / Ask the Staff
Want to bring naughty posts to our attention? Use:
Be respectful to each other - That's what we're all about.
El Presidente is offline  
Reply With Quote
Old July 30th, 2011, 01:46 AM   #23 (permalink)
New Member
 
Join Date: Jul 2011
Location: Defence, Karachi
Posts: 2
 
Device(s): Samsung Galaxy Note
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by martani View Post
yes now it's working for me,
I found that it never downloads when I'm connected to public wifis, so when I connect to protected networks with password there are two cases :

1. it starts downloading immediately
2. it doesn't : in that case you choose the application you want to download, hit start download, then disable and enable wifi again and it will start immediately.

some other start Google Talk and that worked for them
I hope this will work for you!


I tried disabling, re-enabling my wifi but nothing happened. I have xperia x10. Same problems regarding downloading.
Addie90 is offline  
Reply With Quote
Old August 2nd, 2011, 03:02 PM   #24 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have this problem:
I bought HTC Wildfire S last week. The problem is that when i go to android market to download some apps (library's WiFi), they just keep saying: "starting download" so i don't get them. This is a new phone, so i don't have any apps... so what's the solution?
Ensiferumize is offline  
Reply With Quote
Old August 4th, 2011, 02:14 PM   #25 (permalink)
New Member
 
Join Date: Aug 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

ahhh! im having the same problem :@
mzrv is offline  
Reply With Quote
Old September 1st, 2011, 08:02 AM   #26 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem SOLVED

I SOLVED the problem. If you have installed DD-WRT firmware. Add the same ip address of your router to the gateway ip like in the picture.

LINK : h t t p : / / sm.andyrosemary.com/solution.PNG
smichaud is offline  
Reply With Quote
Old October 16th, 2011, 05:07 AM   #27 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I cant even start the market app..it just starts and show "loading..." on the screen then it shuts down, just goes back to home screen...
I installed newer version, but when I start it, it asks for authentication, and sign in to google account, I'm already signed in and can use my g-mail and talk...but market wont start...
can any one help??
Shamaloka is offline  
Reply With Quote
Old October 18th, 2011, 01:04 PM   #28 (permalink)
New Member
 
Join Date: Mar 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default no download problem, no solution, need help too

Quote:
Originally Posted by Green1 View Post
well... I'm stuck in the same place... after searching a lot I have discovered 2 things
1) it's a common problem affecting thousands of people, and has been for 2 years
2) google doesn't care

The fixes I have found listed are:
- sign in to google talk (I can't it just force-closes the app)
- clear the cache on various applications (doesn't help)
- roll-back the update to the market app (doesn't help)
- switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
- switch to wifi (doesn't help)
- toggle airplane mode (doesn't help)
- reboot phone (doesn't help)
- change google account password (doesn't help)
- switch to googlemail instead of gmail (google doesn't give me the option)
- factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)

Anyone have a solution NOT on the list?
Hi, I too am having market app update or download problems. It says download, but nothing happens. I have tried some of the above remedies to the best of my ability, but others not tried are over my head to do. I have a 3G My Touch, T Mobile phone. It is an HTC Magic I think. T Mobile could not help.
I've signed out of Google talk, the next time I look at it, I'm signed in again, so that must happen automatically.
I've powered the phone off and on, Taken the battery out and reinstalled.
I've unmounted the SD card and taken it out. There are no directions to remount it, I just put it back in the phone. I've not Formatted the SD Card as it says it will erase everything.
I've not done a factory reset on the phone, as I am rooted and my WiFi running my computer comes from my phone, I bought the phone like that am afraid to loose that feature if a do a factory reset. My WiFi is not secure. I don't want to loose all other things that might be lost with a factory reset.
I have plenty MB and gig available.
I've uninstalled some apps giving more space for more apps if needed, that did not help.
I've deleted some contacts, even though I've not gotten a warning about having too many.
App downloads and updates worked fine till about a week ago. Don't know what I've done to cause this problem.
I've lost my anti virus protection as I was trying to update it, one of the suggestions was cancel downloads when logging out of Google talk and then starting them over. When I cancelled that update the app was erased.
I hope someone out there can help with this problem and maybe walk me through some of the remedies suggested that I was not able to do as they were over my head.
Have a great day and thank you ahead of time if anyone can help.
jasneskis is offline  
Reply With Quote
Old October 20th, 2011, 03:04 AM   #29 (permalink)
New Member
 
Join Date: Mar 2011
Location: Wanganui, NZ
Posts: 2
 
Device(s): LG Optimus One P500
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
power4x4nz@gmail.com
Default

Quote:
Originally Posted by Green1 View Post
well... I'm stuck in the same place... after searching a lot I have discovered 2 things
1) it's a common problem affecting thousands of people, and has been for 2 years
2) google doesn't care

The fixes I have found listed are:
- sign in to google talk (I can't it just force-closes the app)
- clear the cache on various applications (doesn't help)
- roll-back the update to the market app (doesn't help)
- switch to "2g only" mode (there is no 2g coverage for TELUS phones in Canada)
- switch to wifi (doesn't help)
- toggle airplane mode (doesn't help)
- reboot phone (doesn't help)
- change google account password (doesn't help)
- switch to googlemail instead of gmail (google doesn't give me the option)
- factory reset phone (every single person who has reported trying this has been left with a wiped phone and the problem still there, so I won't risk my apps for this)

Anyone have a solution NOT on the list?
I have had this problem before but I cant remember the file that caused it....i had to install original apk files as the ones i had seemed corrupted. Possibly the marketupdater.apk or vending.apk. If you can get the original copies off the net and overwrite exisiting ones on phone.
genie4x4 is offline  
Reply With Quote
The Following User Says Thank You to genie4x4 For This Useful Post:
jasneskis (October 20th, 2011)
Old October 20th, 2011, 08:28 AM   #30 (permalink)
New Member
 
Join Date: Mar 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default try this market application fix

I don't know how to do this....
roll-back the update to the market app (doesn't help)
Can you help, I'll try it.
Found on U Tube some ideas:
Menu, settings, applications, manage applications, filter (bottom button),running, download manager, clear data, force stop,(scroll down).
It hasn't worked for me as my data wouldn't clear and it would not force close. Others on the site say it worked.
jasneskis is offline  
Reply With Quote
sponsored links
Old October 22nd, 2011, 11:29 PM   #31 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Shamaloka View Post
I cant even start the market app..it just starts and show "loading..." on the screen then it shuts down, just goes back to home screen...
I installed newer version, but when I start it, it asks for authentication, and sign in to google account, I'm already signed in and can use my g-mail and talk...but market wont start...
can any one help??
I have the same issue. Was working fine for the last several months, then suddenly a week or so ago, the market app just stopped opening. When I restart my phone, it will check for updates, and I can use the shortcut to access my apps and update them, but when I exit that and try to get back into the market, it crashes at startup all over again.

I've tried clearing data on the market app and a few other apps, hasn't helped. Unwilling to do a factory reset, so either I get it fixed somehow or I'll be abandoning this phone when the 2 year contract is up. Shame, too, HTC EVO 4G and it worked great for a long time, but have had a few instances of bugginess ever since Gingerbread 2.0 updated. HTC has really turned me off, won't be buying another one of their phones...
Bledee10 is offline  
Reply With Quote
The Following User Says Thank You to Bledee10 For This Useful Post:
jasneskis (October 24th, 2011)
Old October 24th, 2011, 10:15 AM   #32 (permalink)
New Member
 
Join Date: Mar 2010
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default I think the market problem is google, nogt HTC

Quote:
Originally Posted by Bledee10 View Post
I have the same issue. Was working fine for the last several months, then suddenly a week or so ago, the market app just stopped opening. When I restart my phone, it will check for updates, and I can use the shortcut to access my apps and update them, but when I exit that and try to get back into the market, it crashes at startup all over again.

I've tried clearing data on the market app and a few other apps, hasn't helped. Unwilling to do a factory reset, so either I get it fixed somehow or I'll be abandoning this phone when the 2 year contract is up. Shame, too, HTC EVO 4G and it worked great for a long time, but have had a few instances of bugginess ever since Gingerbread 2.0 updated. HTC has really turned me off, won't be buying another one of their phones...
I can't download anything, so I'm not trying. I think the market problem is google android not the brand name of the phone. It may make me want to switch to an i phone and forget the android.
jasneskis is offline  
Reply With Quote
Old October 29th, 2011, 01:16 AM   #33 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by jasneskis View Post
I can't download anything, so I'm not trying. I think the market problem is google android not the brand name of the phone. It may make me want to switch to an i phone and forget the android.
I just wish I saw more evidence of others with the same problem. I keep trying to remember what I was doing between the time it was working, and when it first started failing, to see if I did something that caused it. If it was a major network issue, I would think many others would have the problem. Like when Gingerbread was updated and thousands were ticked off by glitches and failures (that might have been mostly an EVO thing, not sure).

But this problem that we're having, I don't see too many people experiencing it. What the heck?
Bledee10 is offline  
Reply With Quote
Old October 29th, 2011, 01:41 AM   #34 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default

So I went here:
Download: New Android Market Version 3.1.3 – New +1 Button and PIN Protection for Purchases - Droid Life: A Droid Community Blog

To download the new market app, and so far, so good. Appears to be working... for now... if it fails, I'll post about it again.
Bledee10 is offline  
Reply With Quote
Old November 5th, 2011, 11:47 AM   #35 (permalink)
New Member
 
Join Date: Nov 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Sad Maybe the Router?

Hello,

i changed my Router from Asus to Draytek Vigor 2900V. Since them, i am not be able to download from Marktet (all other Internet things works quite fine).

1. Two different Android Devices (Motorola Zoom and Huawei X3).
2. Both devices with an other Google Account.
3. Two different internet connections.
4. Three differen router

Both devices work fine on two of three router and both internet connections. Both devices on both connections have problems with the Vigor 2900V.

I hope to solve the problem... and then i post it.

If someone has a resultion for this: Give it to me... fast

smi
developmentsmi is offline  
Reply With Quote
Old November 13th, 2011, 10:52 AM   #36 (permalink)
New Member
 
Join Date: Apr 2011
Location: Cornwall
Posts: 12
 
Device(s): google nexus one
Carrier: Not Provided

Thanks: 5
Thanked 1 Time in 1 Post
Default downloads hanging

Hi I was having the same problem on htc sensation.
I stopped the downloads then went to market place via the phone app.
when i started the "new" download this way , they removed the old apps (google maps, adobe flashplayer 11 and soundhound) and downloaded and installed the new versions with no problems.
Hope this helps .
patsyc is offline  
Last edited by patsyc; November 13th, 2011 at 10:53 AM. Reason: miss spelling!
Reply With Quote
The Following User Says Thank You to patsyc For This Useful Post:
wcutler (February 15th, 2012)
Old November 24th, 2011, 04:05 AM   #37 (permalink)
New Member
 
Join Date: May 2011
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 1 Post
Default Similar problem, HTC Desire S

I have a number of apps stalling on the download; tried clearing the cache, rebooting, no dice - also, some updates went ahead fine so pretty sure it wasn't a network issue.

I found an annoying workaround that enabled me to do the stalled ones individually:

1. Go to Market - My Apps to see the stalled downloads.
2. Click on one to get to the details screen
3. You will see a greyed out "Downloading" button and a "Cancel" button
4. Click the "Cancel" button. Now, one of two things will happen:

5a: The cancel will work and the "Downloading" button will change to the "Update" button, and you can go ahead as normal with a manual update.

5b: The cancel will appear not to work - the "Downloading" button will remain the same however many times you click "Cancel". In this case:
5b.1: Hit the phone's "Home" button to close the Market.
5b.2: Open the Market again. You should return to the app details screen but now you should see the "Update" button rather than the "Downloading" button and you can proceed with a manual update as normal.

I have just done all my outstanding updates like that, hopefully will help someone else who the other tips don't work for!

EDIT: It seems to be Google's own apps that you need to do 5b for, at least with the issue I had.
Whelkaholism is offline  
Last edited by Whelkaholism; November 24th, 2011 at 04:08 AM. Reason: New info
Reply With Quote
The Following 2 Users Say Thank You to Whelkaholism For This Useful Post:
glenncoombs (December 5th, 2011), Threesails (January 10th, 2012)
Old December 5th, 2011, 05:46 PM   #38 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Had this on my Desire S and the tip from Whelkaholism worked for. GMail and Google Voice updated with 5a and FlashPlayer 11 needed the 5b option.
glenncoombs is offline  
Reply With Quote
Old December 27th, 2011, 06:10 AM   #39 (permalink)
New Member
 
Join Date: Feb 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have problem with Android Market / Samsung Galaxy S2 for a long time on my home wifi network. I have tried all possibilities including the following:
(1) Open port 5228
(2) Set the phone IP to DMZ
(3) Set phone as vertual server on port 5228

All other internet applications work with no problem on the phone. The Market works fine when connected with 3G. Market works fine when connected to my work wifi network.

The other details: Modem: TP-Link 8960N. Telstra ADSL. I have noticed that the hostname of my Galaxy S2 appears as blank on the modem. All other devices show their hostnames. The phone responds ping no problem.

Any relevant suggests would be appreciated. My ideas have all exhausted.
yangys is offline  
Reply With Quote
Old December 28th, 2011, 01:54 AM   #40 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Guys, I have a Liberty Tab (The Acer's Iconia dressed by Packard Bell), and I solved the issue relatively painlessly.

First I will describe my exact problem and what caused it:
I have noticed that the phenomena of apps "refusing to download" has started after I started to download an app, and then navigated away from the Market app (while hoping that the download will continue). The download of the app has stopped, and I couldn't re-download it, or anything. It just "marked" that app as "uninstallable", and that was the end of it.

How I solved it:
1. I singed out of google talk.
2. I made sure that no apps are running in the background (apart from what is necessary for the proper functioning of the tablet). No email, no youtube, nothing.
3. I cleared the cache and data files of the Market app, and the Download Manager.
4. Then, I rebooted my tab (I mean a proper shut down, not a stand by mode or anything).
5. After turning it back on, and with the operating system running - I singed in to Google Talk.
6. Then I launched the Market app (I had to sign in again to the market, as the data files were cleared), and was able to download without any problem.

I hope this helps.
shkedi is offline  
Reply With Quote
sponsored links
Old January 29th, 2012, 01:13 PM   #41 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Market v1.8 works fine on wifi

I have a HTC Desire. The Market app v1.8 (the original that came with my device) works fine with wifi downloads, however when it automatically upgrades it to 3.4.4, it does not work, gets stuck when starting to download. The problem also occurs with other Market versions such as 2.5, etc. If I remove the update, go back to the initial Market v1.8, it works just fine. I wonder what the difference is between these versions. Any ideas??
vpolat is offline  
Reply With Quote
Old February 15th, 2012, 10:38 PM   #42 (permalink)
New Member
 
Join Date: Sep 2011
Location: Vancouver, Canada
Posts: 4
 
Device(s): HTC Desire
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by patsyc View Post
Hi I was having the same problem on htc sensation.
I stopped the downloads then went to market place via the phone app.
when i started the "new" download this way , they removed the old apps (google maps, adobe flashplayer 11 and soundhound) and downloaded and installed the new versions with no problems.
Hope this helps .
This totally worked for me on the HTC Desire, and required no fancy understanding of anything.

I had been able to update some apps, but not Facebook, Maps or Flash Player. I did just what patsyc said: Cancelled the download, went back to the Marketplace, selected the app again (it was at the top of the list) and clicked Update. I had to click OK to two things - maybe that's where they got hung up before, not having the OK and not being able to issue the prompts for some reason. All three of them updated in under a minute.
wcutler is offline  
Reply With Quote
Reply

HTC Magic
Current Rating:
Rate this Phone:

The HTC Magic is the second EVER Android Phone and first launched on Vodafone in Europe on May 1st. With a sexy, slim form factor, 3.2 inch touchscreen and beautiful HVGA resolution, the Magic greatly increased the physical attraction to Android. ... Read More

Tags
android market, google talk, problem


Go Back   Android Forums > Android Phones > HTC Magic
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:26 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.