Go Back   Android Forums > Android Phones > HTC One S

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old April 20th, 2012, 06:21 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Apr 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Car Bluetooth problems

Got a One-s this week but having some extremely infuriating issues when trying to use it on my in-car Bluetooth (Audi MMI). The phone pairs fine with the car and happily sends across phone book and call information. However, every so often the phone will drop the Bluetooth connection with the car. This seems to happen at any time, but is more likely to occur in the first 15 minutes after both are connected.

Sometimes the phone will reconnect automatically, but most of the time the only way to reconnect is to go into Bluetooth settings on the phone and manually reconnect.

Having done a bit of research, this seems to be a very common problem with HTC phones. If I can't find a way to fix this problem, the phone will have to be returned as it is essential that I can use it reliably with the car.

venomizer is offline  
Reply With Quote
sponsored links
Old April 20th, 2012, 09:25 AM   #2 (permalink)
Member
 
Join Date: Feb 2010
Location: DC Metro Area - USA
Posts: 252
 
Device(s): Nexus 4 Nexus One HTC Flyer
Carrier: T-Mobile

Thanks: 7
Thanked 14 Times in 14 Posts
Default

Do you have other BT devices connected? A headset that might be on, or something in your home that might still be connected before you drive away?

Do you have multiple phones connected to the car BT?

Do you leave BT on all the time (on the phone) or do you toggle it off when not in use?

I don't know off hand but is there a new version of bluetooth out that might not be fully supported by Audi yet? I don't have a One (yet) so I can't verify.

Sorry about the questions, but it might help someone troubleshoot for you.




Quote:
Originally Posted by venomizer View Post
Got a One-s this week but having some extremely infuriating issues when trying to use it on my in-car Bluetooth (Audi MMI). The phone pairs fine with the car and happily sends across phone book and call information. However, every so often the phone will drop the Bluetooth connection with the car. This seems to happen at any time, but is more likely to occur in the first 15 minutes after both are connected.

Sometimes the phone will reconnect automatically, but most of the time the only way to reconnect is to go into Bluetooth settings on the phone and manually reconnect.

Having done a bit of research, this seems to be a very common problem with HTC phones. If I can't find a way to fix this problem, the phone will have to be returned as it is essential that I can use it reliably with the car.
Dolmangar is offline  
Reply With Quote
Old April 20th, 2012, 02:48 PM   #3 (permalink)
Junior Member
 
Blue Thunder's Avatar
 
Join Date: Apr 2012
Location: Yorkshire, UK
Gender: Male
Posts: 57
 
Device(s): HTC One S, HTC Desire
Carrier: O2 UK

Thanks: 3
Thanked 18 Times in 15 Posts
Default

I've had my HTC One S for two weeks and I am using it Parrot Bluetooth hands-free device and I am not having an issue. When I got my Desire I had problems holding a connection with my previous Parrot, but a software upgrade for the Parrot sorted it out.

As Dolmangar said, maybe you should contact Audi to see if there is a software upgrade available
Blue Thunder is offline  
Reply With Quote
Old April 20th, 2012, 04:40 PM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Apr 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Funnily enough the car was in for service a couple of weeks ago and they did a software update on it then.

In answer to your questions Dolmangar:

1. No
2. No
3. On all the time (and visible all the time)
4. Not sure... It's weird because when it's connected, everything works perfectly. The connection just drops out every so often. Sometimes it picks itself back up again within a few seconds, sometimes you have to manually reconnect via the settings on the phone.
venomizer is offline  
Reply With Quote
Old April 23rd, 2012, 09:10 AM   #5 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

You are not alone. I am getting the same issues with my Audi car kit. I spoke to HTC customer services and they thought it might be something to do with the One S being Bluetooth 4, but it should be backwards compatible.
I suggest you give them a call, hopefully it'll be a software fixable problem.
adfrad is offline  
Reply With Quote
Old May 4th, 2012, 02:38 PM   #6 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default No bluetooth voice command support

I just got a HTC One S and while mine pairs fine with a Motorola Roadster IIs speakerphone. The speakerphone works ok however neither the action button nor the Android voice response works.

It was my understanding that in 2.2 Android implemented voice commands for bluetooth. It work fine in my old 2.2 phone. I could push the action button and after it hooked in say something like "Call John" and the phone would say "John mobile" and I would say yes and it would dial. I've tried it with two Motorola speaker phones, the Roadster 2 and an older model. Both work perfectly with my old phone neither with the HTC One S.

Any thoughts and has anyone else run into this problem?
djsxx is offline  
Reply With Quote
Old May 7th, 2012, 10:17 AM   #7 (permalink)
Member
 
Join Date: Aug 2010
Location: Nor Cal
Posts: 136
 
Device(s): HTC One S, Samsung Vibrant, LG Optimus-T, HTC G1, iPhone4
Carrier: Not Provided

Thanks: 7
Thanked 13 Times in 10 Posts
Default

My wife's One S has the plastic grey body from T-Mobile. I'm curious if those with Bluetooth connection issues have the black (MAO-coated aluminum) body? They cite the metal body as the reason for excluding NFC but it stands to reason it might affect other RF signals. Duh. It just seemed like a dumb idea from the start, and now the MAO chipping problem just tops it off.
duc916 is offline  
Reply With Quote
Old May 8th, 2012, 08:42 AM   #8 (permalink)
Junior Member
 
Join Date: Mar 2012
Posts: 15
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by duc916 View Post
My wife's One S has the plastic grey body from T-Mobile. I'm curious if those with Bluetooth connection issues have the black (MAO-coated aluminum) body? They cite the metal body as the reason for excluding NFC but it stands to reason it might affect other RF signals. Duh. It just seemed like a dumb idea from the start, and now the MAO chipping problem just tops it off.
I have the MAO finish and bluetooth works perfectly.
hype313 is offline  
Reply With Quote
Old May 8th, 2012, 09:01 AM   #9 (permalink)
Daleks Über Alles
 
agentc13's Avatar
 
Join Date: Aug 2011
Location: Skaro
Posts: 7,839
 
Device(s): HTC One S, Kindle Fire
Carrier: T-Mobile USA

Thanks: 4,106
Thanked 5,382 Times in 2,789 Posts
Default

I have heard of similar issues stemming from phonebook sync. They solved the issues by not accepting the request to sync contacts when they connect to the car via Bluetooth.
agentc13 is offline  
Reply With Quote
Old May 8th, 2012, 02:49 PM   #10 (permalink)
Member
 
bigt's Avatar
 
Join Date: May 2010
Location: Hereford
Posts: 236
 
Device(s): Nexus 5 (32 GB Black)
Carrier: ThreeUK

Thanks: 13
Thanked 38 Times in 34 Posts
Default

Quote:
Originally Posted by hype313 View Post
I have the MAO finish and bluetooth works perfectly.

Loads better than the bluetooth on my old htc desire, I have the black one s too
bigt is offline  
Reply With Quote
sponsored links
Old May 15th, 2012, 06:42 AM   #11 (permalink)
New Member
Thread Author (OP)
 
Join Date: Apr 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Still having these issues. Anyone else seem to get it? A quick browse in the One X forum shows that a couple of the users with that phone are having an identical issue. I imagine HTC use the same BT chip on both phones.

Phoned HTC and they were completely unhelpful (they told me to speak to Audi, who in turn told me to speak to HTC - I'm fairly sure its nothing wrong with the car, it never had this problem before).
venomizer is offline  
Reply With Quote
Old July 20th, 2012, 11:27 AM   #12 (permalink)
New Member
 
Join Date: Oct 2010
Location: CHELTENHAM
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default No incoming on One X

Hello,

My one X works fine with my Audi A1 MMI unit, until someone calls.

I answer, 1/2 of working then no sound call says connected until one of us hangs up.

Anyone found a fix yet?

Fine = Dial by name, out bound calls, music player to media in car

Dealers Samsung Android phone works fine on mine & lots of other Audi's
cjatcti is offline  
Last edited by cjatcti; July 20th, 2012 at 11:29 AM.
Reply With Quote
Old July 25th, 2012, 10:49 AM   #13 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by cjatcti View Post
Hello,

My one X works fine with my Audi A1 MMI unit, until someone calls.

I answer, 1/2 of working then no sound call says connected until one of us hangs up.

Anyone found a fix yet?

Fine = Dial by name, out bound calls, music player to media in car

Dealers Samsung Android phone works fine on mine & lots of other Audi's
cjatcti, I am having the same problem when receiving calls in a 2011 Audi A4 with MMI, with my HTC One V. However, I can receive calls when the radio/media is not switched on.

I was wondering if there is an issue with HTC/MMI/Media because when I use the SatNav using MMI, the radio/media always comes on as well.

I also have access to an HTC One X, so will try that to see if there is a similar problem.

Nick
NickRay is offline  
Reply With Quote
Old August 31st, 2012, 10:34 AM   #14 (permalink)
Junior Member
 
Join Date: Sep 2010
Location: Norfolk UK
Posts: 55
 
Device(s): HTC One X Plus
Carrier: Vodafone

Thanks: 20
Thanked 4 Times in 4 Posts
Default

Hi, I used to have exactly the same with my HTC Desire bluetoothed to my Nissan Pathfinder. I deleted the connection, switched phone off and reset up the connection again, never had another problem. Sorry for stating the obvious if you have already tried this, worked for me though.
greatsnoring is offline  
Reply With Quote
Old September 23rd, 2012, 09:26 PM   #15 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 3
 
Device(s):
Carrier: AT&T

Thanks: 0
Thanked 0 Times in 0 Posts
Default HTC One X - Audi 2010 A4 Connectivity Issues

Hi all,
Misery loves company and I am sad to say that from your postings it looks like I am in your company.

I got an HTC One X the other day and I really like the phone. Having moved from a small screen iPhone 4 it was a relief for old eyes. I was able to pair it with my Audi's MMI system but that is where the problems started. I can safely say that you might be able to dial from the phone but dialing through MMI is a no go even though you see the names and recent calls, etc. The system will also hang with a "Disconnecting Call" for about 2-3mins before returning back to the dial screen in the main display. I did contact HTC and they informed me that they did not have any updates that would fix the issue that I described and told me to check with Audi. Well, I found the link to an online page that displays the phones which are compatible and of course the HTC One X is not listed as compatible. You can find the link on Audi's Bluetooth technology page of their main website.

I am really sad as I don't want to get a Galaxy S3 as I think it is not as nice as the HTC One X. I have not heard of any issues with Audi's with the Galaxy S3 but the site that I mentioned doesn't have it on the comapatibility list either. I either take my chances or back to the iPhone 4 which was perfect with my Audi's MMI system.

I figured by now "Bluetooth" compatibility meant just that.... but guess I should know better.
HomeInLakeO is offline  
Reply With Quote
Old September 28th, 2012, 07:14 PM   #16 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 3
 
Device(s):
Carrier: AT&T

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Samsung Galaxy S3 - Audi A4 2010

Well, I made the switch today to the Samsung Galaxy S3. Ahhhhh... all works as it should in my car. Much happier but sad to see the HTC One X go as I really like the form but certainly not the function.

I can't help but think that the HTC One X is sort of like a hot woman. Attracted to her but once you get to know her you are let down by oh so many things. Well, that's not to say all hot women are like that but I have known my share. To me, while not as "hot", the Samsung satisfies and WORKS!
HomeInLakeO is offline  
Reply With Quote
Old December 19th, 2012, 11:02 PM   #17 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 3
 
Device(s):
Carrier: AT&T

Thanks: 0
Thanked 0 Times in 0 Posts
Talking Broken But Now Fixed... Sort of...

Last time I posted to this forum I stated that my S3 was working perfectly fine with my 2010 Audi A4 MMI system. An update from AT&T messed that up and started to give me intermittent bluetooth connections to the car. I could see it as the bluetooth symbol and signal strength meter would come on indicating paring and then off... and then on again... then off at not regular intervals. I was going to downgrade the OS to what I had out of the box but decided to wait for Jelly Bean to be pushed by AT&T hoping that would fix the problem. No dice. Just as bad as it was before.

I looked at the Audi bluetooth compatibility site and sure enough the Galaxy S3 is not listed for the 2010 A4 (US site). So, I contacted my local Audi service department and they told me that it was not compatible as well. Honestly, I was hoping for a "hey, we have a firmware upgrade for your car's bluetooth that will fix you right up!"... didn't happen.

So, I was doing some more searching... and came up with a solution and it has to do with Android supporting rSAP bluetooth profile which it doesn't do... or perhaps once did but then no longer does. The solution is the following:

1. Let your phone initially pair with the MMI system
2. On the S3, go to "Settings > Application Manager" and swipe to get to the "Running" tab showing all the running apps.
3. Find "Bluetooth" or "Bluetooth Services". Tap on it to expand. You should see 2 or 3 services running, one of them being BluetoothPbapService.
4. Tap to select each one and tap the "Stop" button

You should loose bluetooth connectivity to the MMI system at this point. Be patient as the MMI system will reconnect to the S3. In my case it did. Everything now works!!!! Control from the steering wheel, selecting numbers, voice dialing, Address book, etc. If you go back in and check out what bluetooth services are running you won't find any. I believe only the base level bluetooth services are running and they don't show the additional services that are messing up the MMI bluetooth connection.

If you reboot your phone or stop the bluetooth radio on your S3 you will have to go in and kill the bluetooth service processes again.

I have been driving my car around and exited and re-entered my car 6 times and every time it simply pairs and works! I hope this keeps up and works. Hope this works for others out there who have been having the same pain I was.
HomeInLakeO is offline  
Reply With Quote
Old January 6th, 2013, 04:50 PM   #18 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 3
 
Device(s): HTC one S (S4)
Carrier: T-mobile

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is your WiFi also on? If you tried to use Bluetooth while WiFi is on, the phone won't connect properly. I have the same problem when trying to connect to my car, but when I disable WiFi, the phone works just fine.
350n350 is offline  
Reply With Quote
Old January 24th, 2013, 03:51 PM   #19 (permalink)
Junior Member
 
nanobis's Avatar
 
Join Date: Feb 2010
Location: North West
Gender: Male
Posts: 23
 
Device(s): HTC One S (Current), S.E. Xperia PRO. (Dead), Milestone with offical fubar'd 2.2 update, Moto Dext (
Carrier: GiffGaff

Thanks: 1
Thanked 1 Time in 1 Post
Default

I Have a similar issue with my Hyundai ix35 Bluetooth kit. I can connect fine to it, but about 30 seconds in the whole in car system freezes. None of buttons work apart from the power button on the radio. I figure its a issue with the Hyundai Bluetooth, even though it should be backwards compatible right?

The One S is BT V4.0 were as the cars is BT V2.0
nanobis is offline  
Reply With Quote
Old January 26th, 2013, 07:53 PM   #20 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default HTC One X Bluetooth Issues

I recently purchased a Kenwood car audio system (model KDC-BT852HD which has the Parrott brand bluetooth) to work with my HTC One X. At first, it paired fine and played well. However, all it does now is send across a high pitch ringing noise when my Bluetooth connects with the audio system. Also, it tends to randomly unpaid with my phone.

Does anyone know of any updates I need to download or if this is a lost cause?
Audrey321 is offline  
Reply With Quote
sponsored links
Old May 25th, 2013, 04:47 PM   #21 (permalink)
New Member
 
Join Date: May 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default It's not just HTC

I have A5 and Samsung Galaxy III with same issues...have connection sometimes and works fine with address book and Caller ID function and then the next call I hear the voices coming out of my phone and not the MMI. I cannot even hang up the phone using MMI at times.
The message on screen says "Maybe your phone is not connected" even though it is. Sometimes restarting the phone or turning off and back on the Bluetooth works for the moment, but it's never reliable.

Audi dealer told me the same about non-compatibility of Android phones and Audi cars and gave me a print out he had found on different error messages. T-Mobile checked it out and didn't have any newer updates or single solutions on phone software side. But put me in touch with someone who is apparently good at solving such issues. Even though his first solution for me did not work, it may work for some of you.
He said download Bluetooth Auto Connect app by Jakub Klos which would reconnect you Bluetooth connection if it's lost for any reason. Good luck, hope it works for you.

So now I'm going to try someone's solution at the bottom of this discussions that seems to have had the same issue as mine.


Quote:
Originally Posted by adfrad View Post
You are not alone. I am getting the same issues with my Audi car kit. I spoke to HTC customer services and they thought it might be something to do with the One S being Bluetooth 4, but it should be backwards compatible.
I suggest you give them a call, hopefully it'll be a software fixable problem.
zoehoss is offline  
Last edited by zoehoss; May 25th, 2013 at 04:49 PM.
Reply With Quote
Reply

HTC One S
Current Rating:
Rate this Phone:

The HTC One S is HTC's mid-tier line of One handsets running both Android 4.0 and Sense 4.0. The One S has a 4.3-inch qHD screen (as opposed to the One X's 720p display), 8MP camera, 1080p video capture, and Beats audio processing among H... Read More



Go Back   Android Forums > Android Phones > HTC One S
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:56 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.