Go Back   Android Forums > Android Phones > HTC One X/XL

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old May 9th, 2012, 01:24 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: May 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default HTC ONE X Problems

Hi all,

Just wondering if anyone else has experienced similar issues to the ones I have experienced today...
I picked up the HTC ONE X from O2 yesterday lunchtime and installed a couple of games last night and set up my email etc.

Unfortunately I have been experiencing a few issues with the phone and was wondering whether it is just me...
  • Zen pinball THD is very slow and jerky, unplayable as the flippers have too much lag - Same with Pinball Arcade
  • GTA3 plays very well, no problems here
  • Only getting a 2G connection, I was getting a 3G connection on my previous mobile (Iphone)
  • The time reset itself today to 6 hours behind for no obvious reason, I am wondering if this has something to do with the GPS
  • At one point today I couldn't get mobile internet at all and had to reboot the phone, this fixed the problem
  • Crashed earlier when playing a video and had to do a hard reboot
Please don't take it that I am slagging off the phone, I have just upgraded from an Iphone and assumed as it has a tegra 3 chip (The same as my Asus transformer prime) it would also have the same power when playing games.
The screen is amazing and generally I am very happy with it and certainly have no intentions to go back to an iphone, but I guess I wasn't expecting the problems.

Just one last thought, I called O2 about the lack of mobile internet and they said that it should be perfect as I am very close to a mast and there are no problems reported.

Thanks all

silverghost123 is offline  
Reply With Quote
sponsored links
Old May 9th, 2012, 01:37 PM   #2 (permalink)
Member
 
Join Date: May 2010
Location: Dundee
Posts: 344
 
Device(s): HTC Desire, HTC One X, G8 Archos 101 :/
Carrier: Not Provided

Thanks: 30
Thanked 19 Times in 18 Posts
Default

Around 10am I could not get on the internet (mobile not WiFi) even though a connection was showing.

Quick reset sorted it but was a bit strange as it had been working all morning.

First time it has happened in the best part of a week (got it last Friday).

Phone is on T-Mob btw.
Dudditz is offline  
Reply With Quote
Old May 9th, 2012, 02:23 PM   #3 (permalink)
Junior Member
 
Join Date: Nov 2011
Posts: 16
 
Device(s): htc one x htc desire(rooted) insertcoin
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 1 Post
Default

Ive had the no mobile data problem too, phone will show a 3g or an H signal but get no connection, seems to be when it reconects to the network from having no signal (i can go from no signal to full in a matter of meters at work) again a restart fixes this annoying though, other than that great phone makes my old desire feel small and fat
spicyrider is offline  
Reply With Quote
The Following 2 Users Say Thank You to spicyrider For This Useful Post:
Dudditz (May 9th, 2012), wrigglesworth (May 25th, 2012)
Old May 9th, 2012, 02:38 PM   #4 (permalink)
Member
 
Join Date: May 2010
Location: Dundee
Posts: 344
 
Device(s): HTC Desire, HTC One X, G8 Archos 101 :/
Carrier: Not Provided

Thanks: 30
Thanked 19 Times in 18 Posts
Default

Spicy, that was the exact issue I had, walked through a hall in work, no signal, went outside, the phone showed an H but the internet would not connect.
Dudditz is offline  
Reply With Quote
Old May 9th, 2012, 05:29 PM   #5 (permalink)
New Member
 
Join Date: May 2012
Location: Wales, UK
Posts: 5
 
Device(s): HTC One X on 3
Carrier: Not Provided

Thanks: 1
Thanked 1 Time in 1 Post
Default

Turning airplane mode on then off seems to work too.
crware is offline  
Reply With Quote
The Following User Says Thank You to crware For This Useful Post:
Dudditz (May 9th, 2012)
Old May 9th, 2012, 05:59 PM   #6 (permalink)
Member
 
Join Date: May 2010
Location: Dundee
Posts: 344
 
Device(s): HTC Desire, HTC One X, G8 Archos 101 :/
Carrier: Not Provided

Thanks: 30
Thanked 19 Times in 18 Posts
Default

Will keep that in mind, saves restarting the device.
Dudditz is offline  
Reply With Quote
Old May 11th, 2012, 05:19 AM   #7 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, i haven't had any problems with the data connection lately but i had another issue that was strange, my three buttons on the bottom of the phone stopped vibrating as you pressed on them, they still do their job but just doesn't vibrate don't know if thats a settings thing or not.
ahmediby is offline  
Reply With Quote
Old May 16th, 2012, 02:05 PM   #8 (permalink)
New Member
 
Join Date: Oct 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm also having some problems with my brand new HTC One X. I bought it in Switzerland as a SIM free device, and started using it yesterday, in Brazil, where I live. I am having the same problems with my mobile data. Sometimes it just stops working out of nowhere! And sometimes it also doesn't turn on the mobile data. Has anyone found a fix for this problem? And I've already checked that the phone works in the same radio band as my network. Please help!
eduardovitalin is offline  
Reply With Quote
Old May 19th, 2012, 03:30 AM   #9 (permalink)
New Member
 
Join Date: May 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down HTC One X - No mobile data connection

Quote:
Originally Posted by spicyrider View Post
Ive had the no mobile data problem too, phone will show a 3g or an H signal but get no connection, seems to be when it reconects to the network from having no signal (i can go from no signal to full in a matter of meters at work) again a restart fixes this annoying though, other than that great phone makes my old desire feel small and fat
Same here, even my HOX show 3G or H no data connection at all. I use "Network Signal Info" app to check. It shows good connection but not able to get IP address. Have to turn on/off the flight mode with reset to get data connection again. It is really annoying here.
CasperTheOne is offline  
Reply With Quote
Old May 24th, 2012, 01:50 AM   #10 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I see similar issues after losing signal, most apparent when on a train. Signal drops, should come back but doesnt. I still have my old iPhone which recovers the signal immediately. Very frustrating when travelling as it is reasonable for the signal to drop now and then, but essential that it does come back without a reboot. As a guess, it might be a battery saving side effect; perhaps the radio doesn't attempt to establish mobile data connection often enough?
Hotcoder is offline  
Reply With Quote
sponsored links
Old May 31st, 2012, 02:23 PM   #11 (permalink)
New Member
 
Join Date: May 2012
Location: Seattle
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm experiencing the same exact issues with reconnecting to data on the AT&T US version.. this problem seems so widespread that I'm wondering if it is software vs hardware, especially if it ranges through both the Tegra 3 and Snapdragon models.. but I'm not sure if the people that aren't reporting the problem are experiencing it as well... (are ALL of the devices doing this or just some of them??)
ksea2340 is offline  
Reply With Quote
Old May 31st, 2012, 03:02 PM   #12 (permalink)
New Member
 
Join Date: May 2010
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Sad

i have a Rogers HTC one X (Canada) and I am having the same problem with the internet connection. it doesnt matter where i am, when i try to connect to 4G it shows the bars as it is loading data but i cannot load any page. sometimes it works for about 10 seconds and then stop again. of someone knows how to fix this please post it. i have about two weeks with the phone and i had this problem from day one. i tried soft reset, airplane mode on/off, and i get it to work only for 10 sec.

thanks
jreyes_27 is offline  
Reply With Quote
Old June 1st, 2012, 04:39 AM   #13 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same problem as jreyes_27! Also with rogers, in Canada. It seems to be connecting to the actual network, but no internet is accessible. It connects to 4G most of the time, but when I'm near an LTE hotspot, it connects to LTE. Upload/Download arrows both remain unlit though. Trying to access internet pages result in "Webpage not Found." The connection bars are there, though....

Have already tried turning off and on, Removing Sim card, using airplane mode... So sad, after two weeks only. :/
SimplyBK is offline  
Reply With Quote
Old June 1st, 2012, 10:16 PM   #14 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same problem here.. sometimes a simple restart fixes it. And sometimes I have to leave my phone off for a while before turning it back on. Either way its annoying and shouldn't happen.Also does this with WiFi too... Really annoying otherwise this phone is the best android
greenbackz is offline  
Reply With Quote
Old June 2nd, 2012, 03:38 PM   #15 (permalink)
Member
 
Ironclad's Avatar
 
Join Date: Feb 2012
Location: Norf Devun
Gender: Male
Posts: 129
 
Device(s): Nexus 7, HOX, Aspire 5553, quadcore a-gogo!
Carrier: 3 mobile

Thanks: 8
Thanked 2 Times in 2 Posts
Default

The biggest problem I see you have, OP, is your provider. Why would you go with the worst deal offerings in the entire world, evah?

ps the 'airplane mode' does work.
Ironclad is offline  
Reply With Quote
Old June 3rd, 2012, 05:26 AM   #16 (permalink)
Junior Member
 
Join Date: Nov 2009
Posts: 43
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Default

I am having problems (HTC One X..with dual core S4 cpu) with losing phone connection and not getting calls, but getting voicemail (when in low signal areas). I cannot call out either....restart cures problem.
cb2000a is offline  
Reply With Quote
Old June 3rd, 2012, 05:31 AM   #17 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey does anyone else have a messed up screen...its flickering like crazy and won't turn on from standby...it's the htc one x
Blubell is offline  
Reply With Quote
Old June 5th, 2012, 07:22 AM   #18 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I also have the same data connection issues on AT&T. My iPhone never had this problem so I don't think it is the provider and it happens way too often. Read that a factory reset cures the issue, but does it cure it for good? I find the restart works, but the airplane mode trick has not worked for me.

Has anyone done the factory reset and had the problem completely go away? I love this phone, but this is a very annoying bug that may prompt a return since it seems this is the phone and not the carrier causing the issue.
melousch is offline  
Reply With Quote
Old June 7th, 2012, 09:55 PM   #19 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Having a similar problem, especially coming from my classroom which gets no signal to the outside. Losing 4G (won't reconnect), phone/text connectivity (won't reconnect), and today I lost all 3 without the phone relocating the signals. Any solutions? I don't want to return this thing...I like it. But the airplane mode on and off is ridiculous.
wxdave is offline  
Reply With Quote
Old June 11th, 2012, 08:43 AM   #20 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

My HTC One X from Rogers has the same issue; once it loses signal it doesn't come back until I restart or manage to enable/disable airplane mode. This makes receiving and making calls impossible during that time.
Ritesign is offline  
Reply With Quote
sponsored links
Old June 11th, 2012, 12:56 PM   #21 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I bought a HTC One X from UAE and I have a mixed review. Leaving the Positive ones , few below are the worst experience I have ever had with my Mobiles.
a. Phone is heating up like anything. This was noticed during playing games like Temple Run, browsing Internet and Charging .
Massive heating lead me to drop the phone from hand yesterday......
b. 3G data signal / loading of webpage is very slow. Wifi is good so far.

Please advice or suggest......
JAmar364 is offline  
Reply With Quote
Old June 12th, 2012, 04:33 AM   #22 (permalink)
Junior Member
 
Join Date: Apr 2010
Posts: 68
 
Device(s):
Carrier: Not Provided

Thanks: 7
Thanked 8 Times in 6 Posts
Default

Same problem for me. T-mobile UK, no problems for the last 2 years on my old Hero.
I lost signal for a whole day once, only noticed when a text come through about 16 hours after!
It was fine before the first (1.28) update though.
The most annoying thing was not getting a signal yesterday when everyone else was in the pub.
The longer I have this phone the more I think HTC released an unfinished phone to get the jump on Samsung. Sorry HTC but you are losing a longtime customer
coney is offline  
Reply With Quote
Old June 12th, 2012, 02:08 PM   #23 (permalink)
Member
 
Join Date: Jul 2011
Posts: 207
 
Device(s): HTC One, HTC Evo 3D, Samsung Galaxy S II Epic 4G Touch, HTC Hero
Carrier: Sprint

Thanks: 7
Thanked 91 Times in 63 Posts
Default

I just bought 2 One X's for mom and Stepdad, on AT&T. Went to a movie theater and lost signal. Afterwards, could not make or receive calls. Showed full bars and 4g but it would not make or receive any calls until I rebooted them.
Adar is offline  
Reply With Quote
Old June 14th, 2012, 10:55 PM   #24 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default I have a very similar problem

When I got my HTC One S about two weeks ago, everything worked perfectly...including the internet. Now out of nowhere my internet is soo slow! Things take longer to load and sometimes it says I don't have a network connection and can't load the page?? This is all weird and its making me upset At first I thought it was because I used too much usage data but I reseted my phone and cleared the date and the internet is still slow! Any ideas what this could be anyone??

Thank you
tini4444 is offline  
Reply With Quote
Old July 18th, 2012, 07:56 AM   #25 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb Maybe fixed

I had luck fixing the issue by doing what alphawave7 suggested on this page: 3G problems

Quote:
Try Settings->Wireless & Networks->Mobile Networks and toggle Network Mode..try GSM Only, then reboot the phone. No joy, try GSM/WCDMA Auto, and reboot the phone
jesperb is offline  
Reply With Quote
Old July 21st, 2012, 01:29 PM   #26 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Dudditz View Post
Will keep that in mind, saves restarting the device.
I have the same issues with signal drops and canals cutting out. I'm with O2. Tried all te resetting to 2 g etc. no change. Signal drops out for no reason. I'm 500 meters from the O2 mast. Went to the shop today they replaced my sim card. Still same issues so must be a faulty phone.great phone but useless if it does not do what it's meant to...
Spin2012 is offline  
Reply With Quote
Old July 21st, 2012, 01:42 PM   #27 (permalink)
 
Join Date: Jun 2012
Posts: 76
 
Device(s): iPad 3rd gen (white); HTC One X (brown gray); SGS3 (pebble blue); SGS3 (marble white)
Carrier: Not Provided

Thanks: 5
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by Spin2012 View Post
I have the same issues with signal drops and canals cutting out. I'm with O2. Tried all te resetting to 2 g etc. no change. Signal drops out for no reason. I'm 500 meters from the O2 mast. Went to the shop today they replaced my sim card. Still same issues so must be a faulty phone.great phone but useless if it does not do what it's meant to...
Yeah immediately after inserting my sim, i already noticed poor signal reception. The floor unit is having the same issue as well. I guess it's a design problem (ultimately build quality issue).
PaxtonPetty is offline  
Reply With Quote
Old July 21st, 2012, 01:46 PM   #28 (permalink)
Senior Member
 
Rusty's Avatar
 
Join Date: Jan 2010
Location: Pompey, UK
Posts: 1,635
 
Device(s): Google Nexus 4
Carrier: Not Provided

Thanks: 2
Thanked 193 Times in 165 Posts
Default

No signal problems for me, using O2 via Giffgaff
__________________
Google Nexus 4 on Giffgaff UK
Speed Test Result
Rusty is offline  
Reply With Quote
Old July 23rd, 2012, 01:29 AM   #29 (permalink)
Member
 
Kuhns787's Avatar
 
Join Date: Oct 2010
Location: Oregon
Gender: Female
Posts: 247
 
Device(s): Samsung S4
Carrier: Not Provided

Thanks: 41
Thanked 9 Times in 9 Posts
Default

I have a At&t One X and I am having signal issues. I have it in my hand and the signal drops to one bar and the wi-fi does this often as well. It takes a while to reconnect when it looses signal. I tried to change to gsm only but for some reason I do not have this option? Any help would be appriciated. I am about ready to ditch this phone because of this.
Kuhns787 is online now  
Reply With Quote
Old July 23rd, 2012, 04:51 AM   #30 (permalink)
 
Join Date: Jun 2012
Posts: 76
 
Device(s): iPad 3rd gen (white); HTC One X (brown gray); SGS3 (pebble blue); SGS3 (marble white)
Carrier: Not Provided

Thanks: 5
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by Kuhns787 View Post
I have a At&t One X and I am having signal issues. I have it in my hand and the signal drops to one bar and the wi-fi does this often as well. It takes a while to reconnect when it looses signal. I tried to change to gsm only but for some reason I do not have this option? Any help would be appriciated. I am about ready to ditch this phone because of this.
It's a hardware/design problem. I just posted an Ad online selling mine.
PaxtonPetty is offline  
Last edited by El Presidente; July 24th, 2012 at 03:22 AM.
Reply With Quote
sponsored links
Old July 23rd, 2012, 03:13 PM   #31 (permalink)
Member
 
Kuhns787's Avatar
 
Join Date: Oct 2010
Location: Oregon
Gender: Female
Posts: 247
 
Device(s): Samsung S4
Carrier: Not Provided

Thanks: 41
Thanked 9 Times in 9 Posts
Default

You would think if this is such a problem that HTC would step up and fix the issue. Just a thought.
Kuhns787 is online now  
Reply With Quote
Old August 9th, 2012, 07:28 PM   #32 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Am having same issues. and today people were calling me and don't get the calls. tested and the phone ring from their side but my HTC one x is idle no indication.

i have HTC ONE X Quad core from UAE, its now 4 month and been having lots of internet and work problems due not knowing people called me.

Now stock what to do , i have to replace it , dealer will not commit to problem that hard to show or replicate.

What phone should i replace it with, S3?? i don't like it and gave it to my son. iphone no way i go back.
toprpm is offline  
Reply With Quote
Old August 13th, 2012, 06:39 PM   #33 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Blubell View Post
Hey does anyone else have a messed up screen...its flickering like crazy and won't turn on from standby...it's the htc one x
Yes, my new htc one x screen started a constant flickering. What worked for me and might work for you is to do the following: gently shake your phone up and down about 3 to 4 times. This action stopped the flickering and so far I have not have anymore flickering problems.
smrobinson is offline  
Reply With Quote
Old September 1st, 2012, 09:18 AM   #34 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the "HTC Desire" V (sic). This problem seems to only occur in marginal reception areas.

When the signal gets weak it may drop out all together and just show an x for each sim (yes the Desire V is a dual-sim model). A reboot then may restore 4-5 bars on both sims, depending on the location. It does mean that I miss a few incoming calls.

I have not tried in and out of Airplane mode yet but I will. It is as if the signal strength gradually fades and a reboot improves it? It sounds like it affects the other late model HTCs based on this forum.

The phone is great apart from this feature.
mikegraham4440 is offline  
Reply With Quote
Old September 3rd, 2012, 01:14 PM   #35 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello guys,
I took an image on htc one x and then it turned off immediately and its not turning on again..
plzzz...... help
irfankhann2 is offline  
Reply With Quote
Old September 3rd, 2012, 03:02 PM   #36 (permalink)
Senior Member
 
Rusty's Avatar
 
Join Date: Jan 2010
Location: Pompey, UK
Posts: 1,635
 
Device(s): Google Nexus 4
Carrier: Not Provided

Thanks: 2
Thanked 193 Times in 165 Posts
Default

Does it charge up still?
Rusty is offline  
Reply With Quote
Old September 19th, 2012, 12:54 AM   #37 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Angry my HTC goes black

My very first htc the screen went black 2 miles from att. Just 30 minuts ago this one done it. Ive had it for a week. Im bringing it back in morning. Im using my moms phone now.
billie81 is offline  
Reply With Quote
Old September 20th, 2012, 04:17 AM   #38 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

My HTC One X has also just randomly stopped working like Billie81 's. It won't respond to charging, switching on... completely dead.
HTC have offered to collect and repair but will only repair it if they consider whatever is wrong not to be my fault. Having taken such good care of the phone, I will be very upset if they ask me to pay for it to be fixed.
LAP1309 is offline  
Reply With Quote
Old September 20th, 2012, 04:24 AM   #39 (permalink)
Member
 
jimbobcook's Avatar
 
Join Date: Jun 2012
Location: UK
Gender: Male
Posts: 197
 
Device(s): HTC One X, iPhone 3GS, iPad 4
Carrier: EE (Orange/T-Mobile)

Thanks: 21
Thanked 15 Times in 14 Posts
Default

I'm sure if you take good care of your phone they will fix it for you...

Sounds like your guilty until proven innocent... Not great :/
__________________
For the next 60 seconds, I will conduct a test of my emergency broadcast equipment. AAAAHHHHH!!! Had this been a real emergency, the scream you just heard would be followed by lots more just like it. This concludes My test of my emergency broadcast equipment.
jimbobcook is offline  
Reply With Quote
Reply

HTC One X
Current Rating:
Rate this Phone:

The HTC One X is the first quad-core Android smartphone, not only by HTC but from any manufacturer. It'll have a Tegra 3 chipset inside by NVIDIA alongside 1GB of RAM, an 8 megapixel HD camera with flash, front-facing camera, a 4.7 inch 720p di... Read More



Go Back   Android Forums > Android Phones > HTC One X/XL

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:15 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.