Go Back   Android Forums > Android Phones > Huawei Mercury

test: Reply
 
LinkBack Thread Tools
Old August 4th, 2012, 06:41 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Huawei Mercury Screen Not Responding?? No Water Damage!!

I was texting fine then screen timed out pressed button tried to slide and no response. Removed Bsttery hard reset already and still wont respond. phone was fine no water damage ever and hasnt been dropped! Any ideas pls?? Thanks

Advertisements
gomezalexis3 is offline  
Reply With Quote
sponsored links
Old August 4th, 2012, 09:41 PM   #2 (permalink)
Junior Member
 
rodawg71's Avatar
 
Join Date: Dec 2009
Location: IL. Side
Posts: 78
 
Device(s): HTC T-Bolt.Rooted/Thunderstick BB ROM
Carrier: Not Provided

Thanks: 7
Thanked 8 Times in 7 Posts
Default

Are you rooted? Running ATK? Have you ran an OTA?
rodawg71 is offline  
Reply With Quote
Old August 5th, 2012, 06:08 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

not rooted or anything no updates no changes everything was fine -.- have no idea what couldve caused it
gomezalexis3 is offline  
Reply With Quote
Old August 5th, 2012, 06:09 PM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i know there was an issue with the evo if u got moisture on the screenn the touch response would fail till u reset it but dont know if it couldve been something like that
gomezalexis3 is offline  
Reply With Quote
Old August 5th, 2012, 06:14 PM   #5 (permalink)
Senior Member
 
Gmash's Avatar
 
Join Date: Feb 2011
Location: neither Here nor There
Gender: Male
Posts: 5,657
 
Device(s): Samsung Galaxy S3, Huawei Mercury (stock/rooted), Huawei Ascend (CM7 2.3.5 @710mhz)
Carrier: Cricket

Thanks: 2,221
Thanked 1,509 Times in 1,156 Posts
Default

If you've already tried a hard reset I don't know what else to suggest. Take it to a corporate store and try to get a warranty replacement. Good luck!
__________________
"Machete don't text"
Gmash is offline  
Reply With Quote
Old August 5th, 2012, 07:06 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks i got one already just wondered what couldve happened to a brand new phone ;/
gomezalexis3 is offline  
Reply With Quote
Old August 6th, 2012, 12:14 AM   #7 (permalink)
Senior Member
 
Gmash's Avatar
 
Join Date: Feb 2011
Location: neither Here nor There
Gender: Male
Posts: 5,657
 
Device(s): Samsung Galaxy S3, Huawei Mercury (stock/rooted), Huawei Ascend (CM7 2.3.5 @710mhz)
Carrier: Cricket

Thanks: 2,221
Thanked 1,509 Times in 1,156 Posts
Default

Quote:
Originally Posted by gomezalexis3 View Post
thanks i got one already just wondered what couldve happened to a brand new phone ;/
Just chalk it up to the electronics gods lol. Sometimes they like to smite perfectly innocent devices.
Gmash is offline  
Reply With Quote
Old August 6th, 2012, 10:33 AM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 9
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Lol
gomezalexis3 is offline  
Reply With Quote
Old August 17th, 2012, 02:51 PM   #9 (permalink)
Junior Member
 
Join Date: Mar 2011
Posts: 50
 
Device(s): Huawei Merc
Carrier: Not Provided

Thanks: 6
Thanked 4 Times in 3 Posts
Default

i had this happen to me just yesterday .. it seems that the terminals on the battery werent pressing up against the terminals on the phone right.. insert the battery & kinda push the batter up into so that u know for sure that the leads are contacting each other.. i did this & it began working.. put the cover back on & no problems since.. & it actually have after doing a cold restart of my phone.. (pulling battery off while phone is powered)..
gixxer_751 is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Huawei Mercury
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:01 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.