Go Back   Android Forums > Android Phones > Huawei U8150 Ideos

test: Reply
 
LinkBack Thread Tools
Old November 7th, 2011, 11:13 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 24
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Default Ideos U8510: Enabling WiFi

Hi all.

The Huawei U8150 Ideos is my first smart phone, so I don't know much about them, and the lack of detailed documentation is driving me crazy.

Right now I want to enable WiFi, so...

On the phone I go into Settings --> Wireless and networks --> WiFi (it is checked) --> WiFi turned on (checked) --> WiFi settings --> network notification is checked

My in-home wireless router is displayed in the list.

Still on the phone, I touch the entry for my router and I'm asked for the password, which I assume is the router's WPA Shared Key, which is 12 mixed alphanumeric characters. I find it quite impossible to type that password into the phone using the on-screen keyboard.

If I go into HiSuite and type the WPA Shared Key into the Security Code box at the bottom of the Home screen, I get "Connection Failed".

Can anyone set me on the right path here please.

Advertisements
Soporose is offline  
Reply With Quote
sponsored links
Old November 8th, 2011, 01:38 AM   #2 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Planet Earth
Gender: Male
Posts: 561
 
Device(s): Xiaomi Hongmi
Carrier: Vodafone CZ, 230 03

Thanks: 8
Thanked 121 Times in 104 Posts
Default

Welcome to the forums,
the described procedure is right.
If you use WPA, enable the "Show password" (or similar) tickbox to see you type the right password without misspelling. Do you have some additional security enabled on the router (MAC filter - then you have to add the phone to MAC-address list)?
kejlyCZ is offline  
Reply With Quote
Old November 9th, 2011, 01:13 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 24
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Default

Nope, no additional security on the router other than WPA.

The IP of the router is 192.168.2.1 and my three PCs are all fixed addresses of 192.168.2.X. one of them is hardwired and two have wireless cards, so I know the router communication is OK.

I tried assigning a fixed IP address of the same format to the phone (192.168.2.11) but still no joy.
Soporose is offline  
Reply With Quote
Old November 9th, 2011, 10:14 AM   #4 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Planet Earth
Gender: Male
Posts: 561
 
Device(s): Xiaomi Hongmi
Carrier: Vodafone CZ, 230 03

Thanks: 8
Thanked 121 Times in 104 Posts
Default

Strange.
I've heard about problems with some Zyxel routers years ago and my phone was unable to connect to one T-Mobile router, even if my notebook does. What router do you have?
One stupid question : have you set also subnet mask and gateway? IP is not enough, you also have to set subnet-mask (255.255.255.0) and gateway (192.168.2.1) and maybe also DNS server (check your computer, but it should be also 192.168.2.1).
Maybe you can also try to enable different Wi-Fi channels (shouldn't help, but I use all, maybe it will work better on another channels) in Wi-Fi settings "Regulatory domain" (or similar, I'm lazy to switch to english).
kejlyCZ is offline  
Reply With Quote
Old November 9th, 2011, 09:00 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Nov 2011
Posts: 24
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 3 Times in 3 Posts
Thumbs up

Thanks, I hadn't entered the subnet mask correctly. But even after that was fixed I still had a problem. I'll explain in detail so that anyone else who encounters this will have a better chance of finding the explanation

After correctly configuring the phone's WiFi settings, it then reported that it is connected to the router.
Settings --> Wireless & networks --> WiFi (checked)
Says "Connected to [router name]"

So back to HiSuite...

Trying to enable a WiFi connection in HiSuite still results in the message: "Connection failed. Can't connect your device via WiFi, please check:"

A: Whether the security code you entered is the same as your device.
YES.

B: Whether the Computer and Device Are on the Same Network.
YES: IP=192.168.2.1 Mask=255.255.255.0.

C: Whether HiSuite daemon is running on your service.
THIS IS THE PROBLEM! SEE BELOW.

D: Whether WiFi sleep policy has been specified in WiFi settings.
Set to NEVER.

The problem was that the Security Code that HiSuite asks for in its WiFi connection section is NOT the WPA security code of the router, which is what I had been trying to use. What HiSuite is asking for is a code that you get from the HiSuite daemon (i.e. app) on the phone.

Run the HiSuite app on the phone, tell it to enable WiFi, and the app will then give you a short security code (mine is 4 characters) to be typed into HiSuite where it asks for a Security Code.

Thanks for your assistance, and I hope this might help someone else.
Soporose is offline  
Reply With Quote
Reply

Huawei U8150 IDEOS
Current Rating:
Rate this Phone:

The Huawei U8150 IDEOS is the company's newest addition to their Android lineup. Although being released already, there aren't many specs available on this phone. What we do kknow is that it sports a 2.8 inch touchscreen, Android 2.2, ... Read More

Tags
wifi


Go Back   Android Forums > Android Phones > Huawei U8150 Ideos
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:16 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.