Go Back   Android Forums > Android Phones > LG Ignite > Ignite - All Things Root

test: Reply
 
LinkBack Thread Tools
Old March 21st, 2012, 05:59 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 216
 
Device(s):
Carrier: Not Provided

Thanks: 42
Thanked 90 Times in 63 Posts
Default CM7 Project for LG Ignite AS855

I have started working on building CM7 for the Ignite. Still really new at this and still running into errors. My repo is https://github.com/Craptorman

If anyone want's to help out with project feel free.

Advertisements
Craptorman is offline  
Reply With Quote
sponsored links
Old March 21st, 2012, 11:41 PM   #2 (permalink)
Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 216
 
Device(s):
Carrier: Not Provided

Thanks: 42
Thanked 90 Times in 63 Posts
Default

Here's the latest error I can't figure out. Any ideas?

LG Ignite CM7 Build Error - Pastebin.com
Craptorman is offline  
Reply With Quote
Old March 24th, 2012, 06:14 AM   #3 (permalink)
turbo drinker
 
D-U-R-X's Avatar
 
Join Date: Apr 2011
Location: Sheffield, South Yorkshire
Posts: 16,738
 
Device(s): Nexus 4 (Stock, rooted, 4.4.2), Nexus 7 1st Gen (Stock, rooted, 4.4.2)
Carrier: EE

Thanks: 11,177
Thanked 6,973 Times in 4,281 Posts
Default

it seems that there's not a lot of traffic in here at the moment. You might have more luck speaking to one of the other Dev's about this in Android Development - Android Forums
__________________
See something that needs Mod attention? Hit and let us know
Free online storage @ Dropbox - use my link & we both get 500MB extra (when you install Dropbox)
D-U-R-X is offline  
Reply With Quote
Old March 26th, 2012, 07:17 AM   #4 (permalink)
ROM Developer
 
PlayfulGod's Avatar
 
Join Date: Jan 2011
Location: NW Georgia
Gender: Male
Posts: 8,107
 
Device(s): LG G Flex, LG Spirit, LG Motion, LG F3
Carrier: AT&T

Thanks: 238
Thanked 4,931 Times in 2,075 Posts
Default

Quote:
Originally Posted by Craptorman View Post
Here's the latest error I can't figure out. Any ideas?

LG Ignite CM7 Build Error - Pastebin.com
try pulling the files from the AS855 LG android src and adding them to your device tree and borrow lines from the LG BoardConfig.mk
__________________
Official Donate link if you like my work and would like to show your appreciation and support. All donations are greatly appreciated!!

PlayfulDroidz Wiki
UPP
PlayfulGod is offline  
Reply With Quote
Old April 1st, 2012, 06:32 PM   #5 (permalink)
Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 216
 
Device(s):
Carrier: Not Provided

Thanks: 42
Thanked 90 Times in 63 Posts
Default

Build enviroment got hosed up for some reason. Wiped everything out and started from scratch. Now I can't get any project to even start building. Keep getting "brunch: command not found" not matter what I do. I don't see the function brunch() in envsetup.sh. About ready to throw in the towel.
Craptorman is offline  
Last edited by Craptorman; April 1st, 2012 at 06:36 PM.
Reply With Quote
Old April 15th, 2012, 11:53 AM   #6 (permalink)
Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 216
 
Device(s):
Carrier: Not Provided

Thanks: 42
Thanked 90 Times in 63 Posts
Default

Well, I've put a hold on building from source and tried my luck at porting the LG Black P970's CM7 to the Ignite.

Finally got it to boot into the home screen. However:

No sound. (ALSA Module not found!!!)
Wifi can see networks but reboots when trying to connect.
With wifi off it rarely reboots.
USB works, mounts SD Card, adb works.
Camera locks up when you take a pick.
Phone doesn't work - Anyone know of all the radio files that need to be inplace? The Black is GSM and Ignite is CDMA.

Now to dig thru logcat output to see what I can find.
Craptorman is offline  
Reply With Quote
Old April 21st, 2012, 06:09 PM   #7 (permalink)
Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 216
 
Device(s):
Carrier: Not Provided

Thanks: 42
Thanked 90 Times in 63 Posts
Default

@Playful
Ok, I commented out:
BOARD_CAMERA_LIBRARIES := libcamera

The camera libs and wpa_supplicant files are pulled from phone, the setup-makefiles.sh is updated and builds ignite-vendor-blobs.mk like it should.

Is the above what you meant when you say use the camera libs and wpa_suppilcant from the stock rom?

I notice this at the very start of the build. Not sure if this is right or not.
Code:
build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/lib/hw/lights.omap3.so'
build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/lib/hw/lights.omap3.so'
build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/bin/rild'
build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/bin/rild'
build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/lib/libril.so'
build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/lib/libril.so'
build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/bin/wpa_supplicant'
build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/bin/wpa_supplicant'
build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/obj/lib/libcamera.so'
build/core/dynamic_binary.mk:141: warning: ignoring old commands for target `out/target/product/ignite/obj/lib/libcamera.so'
build/core/Makefile:32: warning: overriding commands for target `out/target/product/ignite/system/lib/libcamera.so'
build/core/base_rules.mk:474: warning: ignoring old commands for target `out/target/product/ignite/system/lib/libcamera.so'
Here's the error it stops on now:
Code:
make: *** No rule to make target `out/target/product/ignite/obj/lib/libicapture.so', needed by `out/target/product/ignite/obj/SHARED_LIBRARIES/libcamera_intermediates/LINKED/libcamera.so'.  Stop.
Edit: I believe I figured this out.

Now I'm back at the same error/errors prior to the changes above. Don't think I actually did what you asked.
Code:
make: *** [out/target/product/ignite/obj/SHARED_LIBRARIES/libcamera_intermediates/CameraHal.o] Error 1
make: *** Waiting for unfinished jobs....
hardware/ti/omap3/camera-omap3/CameraHal_Utils.cpp:1201: error: 'IPP_ProcessImage' was not declared in this scope
hardware/ti/omap3/camera-omap3/CameraHal_Utils.cpp:1208: error: 'struct android::OMX_IPP' has no member named 'hIPP'
hardware/ti/omap3/camera-omap3/CameraHal_Utils.cpp:1208: error: 'IPP_StopProcessing' was not declared in this scope
make: *** [out/target/product/ignite/obj/SHARED_LIBRARIES/libcamera_intermediates/CameraHal_Utils.o] Error 1
Craptorman is offline  
Last edited by Craptorman; April 21st, 2012 at 08:38 PM.
Reply With Quote
Old April 24th, 2012, 12:53 AM   #8 (permalink)
Member
Thread Author (OP)
 
Join Date: Mar 2012
Posts: 216
 
Device(s):
Carrier: Not Provided

Thanks: 42
Thanked 90 Times in 63 Posts
Default

Update. Got it to build from sources now and boots fine. Wifi is now working! Still no audio or bluetooth. Camera FC's. I guess that's progress.

Ok now have audio working. Getting constant sensor errors. Still can't get Phone to work. Anyone have any ideas on what to check to get phone working?
Craptorman is offline  
Last edited by Craptorman; April 24th, 2012 at 01:51 AM.
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > LG Ignite > Ignite - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:53 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.