Go Back   Android Forums > Android Phones > Samsung Galaxy Nexus > (International / GSM) Galaxy Nexus - All Things Root

test: Reply
 
LinkBack Thread Tools
Old December 18th, 2011, 01:37 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 92
 
Device(s):
Carrier: Not Provided

Thanks: 13
Thanked 0 Times in 0 Posts
Default having trouble installing the adt plugin

I open eclipse and go to Help/ install new software and I get an error message..........

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)
Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found


what did I do Wrong. Im dying to umlock my nexus before I activate it and Im going crazy trying to install this.

Advertisements
tsanborn79 is offline  
Reply With Quote
sponsored links
Old December 18th, 2011, 02:08 PM   #2 (permalink)
not really so scary
 
scary alien's Avatar
 
Join Date: Mar 2010
Location: Indy
Posts: 17,291
 
Device(s): LG Nexus 5, Samsung Galaxy Nexus, Asus Nexus 7, Moto Droid X, HTC Droid Eris
Carrier: T-Mobile

Thanks: 32,648
Thanked 14,895 Times in 7,290 Posts
Default

Quote:
Originally Posted by tsanborn79 View Post
I open eclipse and go to Help/ install new software and I get an error message..........

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)
Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found


what did I do Wrong. Im dying to umlock my nexus before I activate it and Im going crazy trying to install this.
tsanborn79,

You don't need the ADT plug-in just for the adb.exe utility in the platform-tools.

Look at this thread http://androidforums.com/faqs/443072-adb-guide-updated-12-05-2011-a.html for information about getting that (there are references to this thread in the how-to root guide (http://androidforums.com/galaxy-nexus-all-things-root/452146-how-root-samsung-galaxy-nexus.html)).

Cheers and good luck!
scary alien is online now  
Reply With Quote
Old December 20th, 2011, 09:42 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2010
Posts: 92
 
Device(s):
Carrier: Not Provided

Thanks: 13
Thanked 0 Times in 0 Posts
Default

So I can just install the sdk?
tsanborn79 is offline  
Reply With Quote
Old December 20th, 2011, 09:49 AM   #4 (permalink)
Usually off topic
 
Join Date: Jul 2010
Location: FG
Posts: 10,471
 
Device(s): Gnex N7
Carrier: Not Provided

Thanks: 2,169
Thanked 4,980 Times in 3,271 Posts
Default

Yes just the sdk is needed. Eclipse is a development environment
__________________
Forum Gaming
Yeahha is offline  
Reply With Quote
Old December 20th, 2011, 09:53 AM   #5 (permalink)
not really so scary
 
scary alien's Avatar
 
Join Date: Mar 2010
Location: Indy
Posts: 17,291
 
Device(s): LG Nexus 5, Samsung Galaxy Nexus, Asus Nexus 7, Moto Droid X, HTC Droid Eris
Carrier: T-Mobile

Thanks: 32,648
Thanked 14,895 Times in 7,290 Posts
Default

Quote:
Originally Posted by tsanborn79 View Post
So I can just install the sdk?
Yes, if you are just going to root, you don't need the development pieces (i.e,. the ADT plug-in, Eclipse, etc.).

If you are just going after the adb utility for rooting purposes, then you'll have to install the platform-tools portion of the SDK setup.

However, if your goal is to root, you'll also need the fastboot utility, which is no longer part of the SDK.

Check out the FAQ thread I posted below (referencing http://androidforums.com/faqs/443072-adb-guide-updated-12-05-2011-a.html) for different methods of installing the SDK to get adb.

The "Mini-SDK" portion in the middle will also tell you how you get just get adb and fastboot utilities.

Cheers!
scary alien is online now  
Reply With Quote
The Following User Says Thank You to scary alien For This Useful Post:
tsanborn79 (December 20th, 2011)
Old December 21st, 2011, 12:56 AM   #6 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Check this

Expand the tree for http with dl-ssl.google.com/android/eclipse (note http, not https.)

It should not be https dl-ssl.google.com/android/eclipse
It should be http dl-ssl.google.com/android/eclipse
hetvi is offline  
Reply With Quote
Old December 21st, 2011, 09:59 AM   #7 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Question Same error message but im not trying to Root anything just want a devel environ

im a little new to the forums i usually find what i need by just looking around but now i have a question i have the exact same error message trying to install the ADT for eclipse i have the oracle JDK installed im running Ubuntu 11.10 with unity.. dont understand ive never had trouble doing this before... all help appreciated
droiddoug65 is offline  
Reply With Quote
Old December 21st, 2011, 01:40 PM   #8 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default ADT Plugin not working

Quote:
Originally Posted by droiddoug65 View Post
im a little new to the forums i usually find what i need by just looking around but now i have a question i have the exact same error message trying to install the ADT for eclipse i have the oracle JDK installed im running Ubuntu 11.10 with unity.. dont understand ive never had trouble doing this before... all help appreciated


I' m having a similar issue. When I go into Eclipse & click on Help - Install New Software - then add adt-plugin & go to dl-ssl.google.com/android/eclipse it comes up with developer tools & when I go to install them it says Cannot complete the install because of a conflicting dependency Cannot satisfy dependency:
From: Pulsar for Mobile Developers 1.3.1.20100916-1202 (epp.package.pulsar 1.3.1.20100916-1202) Thank You for any help you can give.
nbcc is offline  
Reply With Quote
Old December 22nd, 2011, 06:25 AM   #9 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nbcc View Post
I' m having a similar issue. When I go into Eclipse & click on Help - Install New Software - then add adt-plugin & go to dl-ssl.google.com/android/eclipse it comes up with developer tools & when I go to install them it says Cannot complete the install because of a conflicting dependency Cannot satisfy dependency:
From: Pulsar for Mobile Developers 1.3.1.20100916-1202 (epp.package.pulsar 1.3.1.20100916-1202).
Thank You for any help you can give.
I should add that this worked fine on Friday Dec 16 but didn't work on Monday Dec 19
nbcc is offline  
Reply With Quote
Old January 7th, 2012, 09:06 PM   #10 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Smile Solution For eclipse plugin Error..

I had the same problem yesterday...and I wasted the whole day..I tried to find the solution, but I couldn't

At last today, I downloaded eclipse again and re-installed it....and now the error has gone...

If you are starting new one..then before that delete the previous one...by removing Workspace folder from your C drive...and then start it...

If you have downloaded recently or have latest version, then try to start it again..after removing the workspace folder and all connected folders....even then, if you don't find solution...Disable your Firewall and Antivirus...and try, you will find the solution....

You can also see this video on youtube "How to install Eclipse / android adt plugin ubuntu/kubuntu 11.10"...Or visit this link for this video "ww.youtube.com/watch?v=HCNC34BflOo"...that might help you.
Star123 is offline  
Reply With Quote
sponsored links
Old January 27th, 2012, 01:55 AM   #11 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 1 Post
Default

If running Windows you need to run eclipse as admin, this solved it for me.
plaukit is offline  
Reply With Quote
The Following 3 Users Say Thank You to plaukit For This Useful Post:
Aikunle (March 9th, 2012), aom336 (February 20th, 2012)
Old February 8th, 2012, 02:54 PM   #12 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Angry Can't Install ADT

I hate to say me too, but I can't get the adt package to install into eclipse

message reads :

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)
Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found


I'm using dl-ssl.google.com/android/eclipse on a fedora f16 x86 box
firewall has been disabled but either way same error message.

I've also tried downloading and installing as an archive, same results
This issue is spread across several machines so it's not machine specific.

I've even tried F16 running in a Vm on vbox. And the obvious uninstall everything, reinstall everything




any one got a workaround or other ideas?
toddbailey is offline  
Last edited by toddbailey; February 8th, 2012 at 02:56 PM.
Reply With Quote
Old February 8th, 2012, 08:15 PM   #13 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Cool

Quote:
Originally Posted by toddbailey View Post
I hate to say me too, but I can't get the adt package to install into eclipse

message reads :

Cannot complete the install because one or more required items could not be found.
Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534)
Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found


I'm using dl-ssl.google.com/android/eclipse on a fedora f16 x86 box
firewall has been disabled but either way same error message.

I've also tried downloading and installing as an archive, same results
This issue is spread across several machines so it's not machine specific.

I've even tried F16 running in a Vm on vbox. And the obvious uninstall everything, reinstall everything

any one got a workaround or other ideas?
Have you read Star123 post?? In the video is te solution for your problem, you just have to install linux tools from update site for your eclipse version and you're set.

I hope this can help but all the kudos por Star123 who posted the video
cristianpark is offline  
Reply With Quote
Old February 9th, 2012, 01:07 AM   #14 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Cry

If you are referring to star123's post about reinstalling eclipse and turning off the firewall.


been there done that, didn't fix problem.
toddbailey is offline  
Reply With Quote
Old February 12th, 2012, 02:52 PM   #15 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default Fix

if you are using ubuntu and have installed eclipse try running

sudo eclipse

it will ask for your password

now add the repository and walla, you are good to go.
mazwoz is offline  
Reply With Quote
The Following User Says Thank You to mazwoz For This Useful Post:
scary alien (February 12th, 2012)
Old February 12th, 2012, 04:40 PM   #16 (permalink)
not really so scary
 
scary alien's Avatar
 
Join Date: Mar 2010
Location: Indy
Posts: 17,291
 
Device(s): LG Nexus 5, Samsung Galaxy Nexus, Asus Nexus 7, Moto Droid X, HTC Droid Eris
Carrier: T-Mobile

Thanks: 32,648
Thanked 14,895 Times in 7,290 Posts
Default

Quote:
Originally Posted by mazwoz View Post
if you are using ubuntu and have installed eclipse try running

sudo eclipse

it will ask for your password

now add the repository and walla, you are good to go.
mazwoz, thank you for that excellent tip and welcome to the AndroidForums .

Cheers!
scary alien is online now  
Reply With Quote
Old February 21st, 2012, 09:24 AM   #17 (permalink)
New Member
 
Join Date: Feb 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Solved in Windows VISTA

Run Eclipse "as Administrator" Solved trouble in my case (Windows VISTA)
unforgiven6666 is offline  
Reply With Quote
Old March 9th, 2012, 06:20 AM   #18 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 3
 
Device(s):
Carrier: Not Provided

Thanks: 3
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by plaukit View Post
If running Windows you need to run eclipse as admin, this solved it for me.
I can confirm that this simple procedure as mentioned by Plaukit solves the problem - run Eclipse as Administrator (I am using Window 7 home Edition 64bit) and Eclipse Classic
Aikunle is offline  
Reply With Quote
Old March 12th, 2012, 09:05 AM   #19 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Happy

Quote:
Originally Posted by plaukit View Post
If running Windows you need to run eclipse as admin, this solved it for me.
It works for me. I'm using Win 7. Thanks a lot!
24bridge is offline  
Reply With Quote
Old March 15th, 2012, 06:28 AM   #20 (permalink)
New Member
 
Join Date: Jan 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Running Eclipse as Administrator (and also removing c:\workspace) worked for me. THANKYOU!!!
alexbk66 is offline  
Reply With Quote
sponsored links
Reply


Go Back   Android Forums > Android Phones > Samsung Galaxy Nexus > (International / GSM) Galaxy Nexus - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:10 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.