Go Back   Android Forums > Android Phones > Samsung Galaxy Nexus > (International / GSM) Galaxy Nexus - All Things Root

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old December 20th, 2011, 08:48 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
dren's Avatar
 
Join Date: Mar 2010
Location: Iowa
Posts: 91
 
Device(s): Verizon Galaxy Nexus, Motorola Droid X (Retired), Motorola Droid (Deceased!)
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Confused MTP Device Driver Errors

Hi,

I've been trying all night and all morning to get the samsung driver's to install on my computer. I've downloaded them from samsung's site (exe), I've downloaded the zip of them to install manually, I've downloaded the naked samsung drivers. Nothing seems to be working. I get the following screen pop up every time I plug my phone into the computer:



Oh and every time I'd install a new set of drivers I always made sure to uninstall the drivers installed previously.

Does anyone have any ideas on this?

Advertisements
__________________
Samsung Galaxy Nexus, Unrooted Stock.
dren is offline  
Reply With Quote
sponsored links
Old December 20th, 2011, 03:10 PM   #2 (permalink)
Member
 
eddieruko's Avatar
 
Join Date: Nov 2011
Location: TX
Posts: 210
 
Device(s): Rooted OG Droid (Retired), Rooted Galaxy Nexus
Carrier: Not Provided

Thanks: 174
Thanked 235 Times in 118 Posts
Default

Quote:
Originally Posted by dren View Post
Hi,

I've been trying all night and all morning to get the samsung driver's to install on my computer. I've downloaded them from samsung's site (exe), I've downloaded the zip of them to install manually, I've downloaded the naked samsung drivers. Nothing seems to be working. I get the following screen pop up every time I plug my phone into the computer:






Oh and every time I'd install a new set of drivers I always made sure to uninstall the drivers installed previously.

Does anyone have any ideas on this?
do you happen to be listed as an admin on your computer? i was able to download and begin installing the drivers at work before i realized i wasn't logged in with my admin account.

if you're running XP, the samsung drivers worked for me (actually following the Droid-Life HOW TO was a easier for me).

if you haven't tried rebooting your computer, that may help as well.
eddieruko is offline  
Last edited by eddieruko; December 20th, 2011 at 03:11 PM. Reason: hid image
Reply With Quote
Old December 20th, 2011, 03:23 PM   #3 (permalink)
Senior Member
 
Kevmueller's Avatar
 
Join Date: Aug 2010
Location: Kansas City
Posts: 766
 
Device(s): Mine - The Nexus, Wife - Droid Bionic, Son - DroidX
Carrier: Not Provided

Thanks: 122
Thanked 147 Times in 119 Posts
Default

I was having this problem and then saw a post that I did not believe over on XDA but tried it and it worked.

Make sure you have Windows Media Player 11 installed. Once I upgraded to this one mine worked with no problems.
__________________
> Samsung Nexus - Rooted and Unlocked
> Huawei Ideos S7 Tablet leaked 2.2 with Stable 1.2
Kevmueller is offline  
Reply With Quote
Old December 20th, 2011, 04:34 PM   #4 (permalink)
Junior Member
Thread Author (OP)
 
dren's Avatar
 
Join Date: Mar 2010
Location: Iowa
Posts: 91
 
Device(s): Verizon Galaxy Nexus, Motorola Droid X (Retired), Motorola Droid (Deceased!)
Carrier: Not Provided

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Well I'm at work and my computer is on a domain... So I logged out of the domain and logged in locally to the Administrator account and it worked long enough for me to unlock the bootloader and that's it. Now that I'm trying to do the adb push su.zip, it won't detect any devices and now that same window keeps popping up (See OP) every time I plug my phone in.

I haven't tried installing WMP11... I don't understand how that would help but if it worked for you maybe it will work for me??? I don't know...

Anyone else want to take a stab at this one?
dren is offline  
Reply With Quote
Old December 20th, 2011, 11:08 PM   #5 (permalink)
Member
 
eddieruko's Avatar
 
Join Date: Nov 2011
Location: TX
Posts: 210
 
Device(s): Rooted OG Droid (Retired), Rooted Galaxy Nexus
Carrier: Not Provided

Thanks: 174
Thanked 235 Times in 118 Posts
Default

Quote:
Originally Posted by dren View Post
Well I'm at work and my computer is on a domain... So I logged out of the domain and logged in locally to the Administrator account and it worked long enough for me to unlock the bootloader and that's it. Now that I'm trying to do the adb push su.zip, it won't detect any devices and now that same window keeps popping up (See OP) every time I plug my phone in.

I haven't tried installing WMP11... I don't understand how that would help but if it worked for you maybe it will work for me??? I don't know...

Anyone else want to take a stab at this one?
yep. had the exact same problem.

your adb push su.zip command... is that using the "soft-boot" CWM recovery?

i ended up rebooting the phone, flashing CWM (overwriting stock recovery) and using this command from the HOW TO

Quote:
adb push su.zip /data/media/su.zip
there are plenty of experts around here to chime in why some commands don't work. but i imagine having the correct privileges on your machine has something to do with it.

if you want to try with the soft-boot CWM method, try using the same adb push form above.

this worked for me. hope it helps.
eddieruko is offline  
Reply With Quote
Old December 20th, 2011, 11:45 PM   #6 (permalink)
Member
 
Join Date: Sep 2010
Posts: 123
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by Kevmueller View Post
I was having this problem and then saw a post that I did not believe over on XDA but tried it and it worked.

Make sure you have Windows Media Player 11 installed. Once I upgraded to this one mine worked with no problems.
This is amazing...this fixed my issue as well.

Installed WMP 11 and now MTP works perfectly fine and I can see my Nexus on my PC now to browse through it.

Thanks!!
igotgame is offline  
Reply With Quote
Old December 21st, 2011, 09:14 AM   #7 (permalink)
Senior Member
 
Kevmueller's Avatar
 
Join Date: Aug 2010
Location: Kansas City
Posts: 766
 
Device(s): Mine - The Nexus, Wife - Droid Bionic, Son - DroidX
Carrier: Not Provided

Thanks: 122
Thanked 147 Times in 119 Posts
Default

Quote:
Originally Posted by igotgame View Post
This is amazing...this fixed my issue as well.

Installed WMP 11 and now MTP works perfectly fine and I can see my Nexus on my PC now to browse through it.

Thanks!!
No problem, like I said that would have been one of the last things I would have tried myself. I tried it because I had no other ideas and someone else said that is what worked. I tried it and sure enough it works. I guess in WMP 11 it puts the MTP files it needs for XP on your computer.
Kevmueller is offline  
Reply With Quote
Old April 2nd, 2012, 02:19 PM   #8 (permalink)
New Member
 
Join Date: Aug 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

my one is windows media player 12........ but yet i get the WMP error...


*** found the solution.... just had to turn the usb debugging on from the phone...
tanbin is offline  
Last edited by tanbin; April 2nd, 2012 at 02:30 PM.
Reply With Quote
Reply
Tags
bootloader, drivers, unlock


Go Back   Android Forums > Android Phones > Samsung Galaxy Nexus > (International / GSM) Galaxy Nexus - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:09 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.