Go Back   Android Forums > Android Phones > HTC One X/XL > (International Tegra 3) One X - All Things Root

Like Tree1Likes
  • 1 Post By nevablink

test: Reply
 
LinkBack Thread Tools
Old November 20th, 2012, 09:38 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Angry ROMS

i just installed a new custom ROM on my HOX but the phone wont go further than the intro.............. any advice will help (i tried both the cm923 and cm10 ) all does the same thing.

Advertisements
nevablink is offline  
Reply With Quote
sponsored links
Old November 20th, 2012, 09:47 AM   #2 (permalink)
The Real Bass Creator
 
Digital Controller's Avatar
 
Join Date: Sep 2012
Location: Cincinnati, Ohio
Gender: Male
Posts: 12,497
 
Device(s): Galaxy Note 3 4.4.2(Eclipse) , Nexus 7 (Stock), (RIP) Galaxy Nexus 4.4(SlimKat)
Carrier: Verizon

Thanks: 748
Thanked 3,423 Times in 2,163 Posts
Default

First off welcome to the forums, secondly i can move this thread into the All Things root for your device if you tell me what carrier you are with

Otherwise have you tried performing a factory reset before booting up into the ROM?
__________________
Want Faster help? Read this before posting!

I love this community and so should you! So before posting please read:
Site Rules & Guidelines and Android FAQ's
Digital Controller is offline  
Reply With Quote
The Following User Says Thank You to Digital Controller For This Useful Post:
nevablink (November 22nd, 2012)
Old November 20th, 2012, 10:00 AM   #3 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,269
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,351 Times in 8,750 Posts
Default

Did you flash the relevant boot.img file and erase cache from fastboot before booting? Alspo, what's your hboot version? If you're on 1.x or above, unless you're on a Sense ROM, you need a modified boot.img to work properly.
__________________
Site Rules & Guidelines / Staff List / Ask the Staff
Want to bring naughty posts to our attention? Use:
Be respectful to each other - That's what we're all about.
El Presidente is offline  
Reply With Quote
The Following User Says Thank You to El Presidente For This Useful Post:
nevablink (November 22nd, 2012)
Old November 21st, 2012, 11:28 AM   #4 (permalink)
Member
 
Join Date: Oct 2012
Location: Cairo, Egypt
Gender: Male
Posts: 230
 
Device(s): HTC One X BlackBerry Bold 9900
Carrier: Not Provided

Thanks: 65
Thanked 79 Times in 41 Posts
Send a message via MSN to TarekElsakka
Default

I second El Presidente on this. The first time I tried flashing I got stuck in what is known as a "boot loop", if I am not mistaken, and flashing the correct boot.img (which most of the time comes inside the package of the ROM itself) fixed it.
TarekElsakka is offline  
Reply With Quote
The Following User Says Thank You to TarekElsakka For This Useful Post:
nevablink (November 22nd, 2012)
Old November 22nd, 2012, 04:02 AM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

is there anywhere i can download the boot.img file , cos the ROM is in zip or do i need to extract the ZIP file to fine the boot.img file...................cos i tried the <fastboot flash boot.img> command in the command window and its saying ....'fastboot' is not recognized as an internal or external command,
operable program or batch file.
please what can i do, still confused "sorry for my ignorance" am just very curious to learn
nevablink is offline  
Reply With Quote
Old November 22nd, 2012, 04:10 AM   #6 (permalink)
Member
 
Join Date: Oct 2012
Location: Cairo, Egypt
Gender: Male
Posts: 230
 
Device(s): HTC One X BlackBerry Bold 9900
Carrier: Not Provided

Thanks: 65
Thanked 79 Times in 41 Posts
Send a message via MSN to TarekElsakka
Default

Yes, sir, the boot.img is most likely inside the ZIP file so you'll have to extract it first. If you don't find it, just copy and paste the exact ZIP file's name (ROM's name) and I'll Google and try to find the correct boot.img for you.

By the way, these are the fastboot files you need:

http://android-roms.googlecode.com/files/fastboot-win32.zip

1. Create a new folder on your desktop called Fastboot
2. Extract the files inside fastboot-win32.zip into that folder
3. Extract or copy the boot.img file into the fastboot folder
4. Boot into fastboot mode on your device (Google that if you don't know how to)
5. Make sure the One X says "FASTBOOT USB" on the screen
6. In the fastboot folder, hold the SHIFT button on your keyboard and right click and then choose "Open Command Prompt window here"
7. Type fastboot flash boot.img
8. All done
TarekElsakka is offline  
Reply With Quote
The Following User Says Thank You to TarekElsakka For This Useful Post:
nevablink (November 22nd, 2012)
Old November 22nd, 2012, 06:45 AM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

cm-9-20120923-NIGHTLY-endeavoru.......................here is the name of the ROM
'thanks'
nevablink is offline  
Reply With Quote
Old November 22nd, 2012, 07:20 AM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

@ Tarek....i tried the steps and this were the response using the boot.img command "unknown partition 'boot.img'
error: cannot determine image filename for 'boot.img'


and the second time i tried using only "boot" in the command it replied
"neither -p product specified nor ANDROID_PRODUCT_OUT set"
nevablink is offline  
Reply With Quote
Old November 22nd, 2012, 07:22 AM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

@ El president my Hboot version is 1.12.0000.......................
nevablink is offline  
Reply With Quote
Old November 22nd, 2012, 07:47 AM   #10 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

@ Digital controller , i am using Vodafone
nevablink is offline  
Reply With Quote
sponsored links
Old November 22nd, 2012, 08:25 AM   #11 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,269
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,351 Times in 8,750 Posts
Default

The command is "fastboot flash boot boot.img" (minus the quotes)

It goes "Tool -> Command -> Partition to flash -> What to flash"

So by missing the first boot, you were telling it to flash nothing to a partition that didn't exist. Make sense?

Then "fastboot erase cache", then flash your ROM again if needed and you're sorted.

If that doesn't work, let us know and we can sort you out.
El Presidente is offline  
Last edited by El Presidente; November 22nd, 2012 at 10:11 AM.
Reply With Quote
The Following User Says Thank You to El Presidente For This Useful Post:
nevablink (November 22nd, 2012)
Old November 22nd, 2012, 02:24 PM   #12 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

its like i dont have the correct boot.img file for it , because its giving me an error response
nevablink is offline  
Reply With Quote
Old November 22nd, 2012, 02:49 PM   #13 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,269
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,351 Times in 8,750 Posts
Default

Are you in fastboot or hboot. What's the error message?
El Presidente is offline  
Reply With Quote
The Following User Says Thank You to El Presidente For This Useful Post:
nevablink (November 22nd, 2012)
Old November 22nd, 2012, 02:58 PM   #14 (permalink)
Member
 
Join Date: Oct 2012
Location: Cairo, Egypt
Gender: Male
Posts: 230
 
Device(s): HTC One X BlackBerry Bold 9900
Carrier: Not Provided

Thanks: 65
Thanked 79 Times in 41 Posts
Send a message via MSN to TarekElsakka
Default

The error command prompt gave you doesn't mean you don't have the correct boot.img, but rather the flashing itself failed. I honestly have no idea why it is giving you that error. It should flash fine if you run the command prompt from inside the fastboot folder with boot.img inside it. Like this:



The RAR/ZIP file you downloaded, when you open it does it have a boot.img file inside it? Because that's the correct one. Can you please give me the link to the thread you downloaded the ROM from it?

I'm starting to think maybe the fastboot file I gave you is outdated or something, so here is another link:

http://koushikdutta.blurryfox.com/G1/fastboot-win32.zip

Read more about Fastboot and how to use it here:

Fastboot - CyanogenMod Wiki

Once you have the fastboot folder on the desktop, just place the correct boot.img file (That should be inside the ROM's zip) inside it and hold SHIFT and choose "Open command prompt window here" and then flash the boot.img by entering "fastboot flash boot boot.img" without the quotes, as El_Presidente mentioned above.

It should succeed and then you can install the ROM from the SD card (or however you install it).
TarekElsakka is offline  
Reply With Quote
The Following User Says Thank You to TarekElsakka For This Useful Post:
nevablink (November 22nd, 2012)
Old November 22nd, 2012, 02:59 PM   #15 (permalink)
Member
 
Join Date: Oct 2012
Location: Cairo, Egypt
Gender: Male
Posts: 230
 
Device(s): HTC One X BlackBerry Bold 9900
Carrier: Not Provided

Thanks: 65
Thanked 79 Times in 41 Posts
Send a message via MSN to TarekElsakka
Default

Quote:
Originally Posted by El Presidente View Post
Are you in fastboot or hboot. What's the error message?
OH wow.. how did I not think of that? Since he provided his HBOOT version, he's most likely NOT inside fastboot. I'm almost 99% sure of that.

You should use the arrow keys to navigate, nevablink, and when you highlight "fastboot" which, I believe, is the first choice, just click the power button to choose it and then it should say FASTBOOT USB.
TarekElsakka is offline  
Reply With Quote
The Following User Says Thank You to TarekElsakka For This Useful Post:
nevablink (November 22nd, 2012)
Old November 22nd, 2012, 03:00 PM   #16 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

@El president and tarek............... it finally worked after wiping cache through recovery, YOU GUYS ROCK !!!!
El Presidente likes this.
nevablink is offline  
Reply With Quote
Old November 22nd, 2012, 03:09 PM   #17 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

i finally got the CM10 to work but i cant find the play store........ Any advice
nevablink is offline  
Last edited by nevablink; November 22nd, 2012 at 05:22 PM.
Reply With Quote
Old November 22nd, 2012, 04:56 PM   #18 (permalink)
Beware The Milky Pirate!
 
El Presidente's Avatar
 
Join Date: Jan 2011
Location: Scotland
Posts: 27,269
 
Device(s): Xperia Z1, Nexus 7 3G, HTC One X, SGS3 Mini
Carrier: EE

Thanks: 14,350
Thanked 16,351 Times in 8,750 Posts
Default

Can you still access the phone via the pc? I think mine was doing that for a while but I could still see the SD Card normally.
El Presidente is offline  
Reply With Quote
The Following User Says Thank You to El Presidente For This Useful Post:
nevablink (November 24th, 2012)
Old November 22nd, 2012, 05:37 PM   #19 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

@ El Presidente , yes it was from the phone ROM i had to switch it on, for the computer to see the SD "just on the notification panel"
nevablink is offline  
Reply With Quote
Old November 23rd, 2012, 10:39 AM   #20 (permalink)
Member
 
Join Date: Oct 2012
Location: Cairo, Egypt
Gender: Male
Posts: 230
 
Device(s): HTC One X BlackBerry Bold 9900
Carrier: Not Provided

Thanks: 65
Thanked 79 Times in 41 Posts
Send a message via MSN to TarekElsakka
Default

I am glad you got it sorted out, mate. I am sorry but I haven't experienced your recent problem so I don't know how to fix it. If the ROM is still pretty new and you haven't really set it up or spend time organizing it, then you should just reinstall it using Recovery or Mobile ODIN or something.
TarekElsakka is offline  
Reply With Quote
sponsored links
Old November 24th, 2012, 07:22 AM   #21 (permalink)
Senior Member
 
razvan06's Avatar
 
Join Date: Jun 2010
Location: Bucharest
Gender: Male
Posts: 680
 
Device(s): Nexus One; Nexus S; Galaxy S II; HTC One X[T3]; HTC One S[S4]; HTC ONE; LG G2
Carrier: Cosmote

Thanks: 11
Thanked 86 Times in 79 Posts
Send a message via Yahoo to razvan06
Default

Quote:
Originally Posted by nevablink View Post
i finally got the CM10 to work but i cant find the play store........ Any advice
When installing a CM9/10 ROM you need the base ROM [ex : cm-10-20121124-NIGHTLY-endeavoru.zip ] AND the GAPPS for the correct version [found here @ the bottom of the page : GAPPS for CM4, 5, 6, 7, 9, 10 ROMs.

Install the ROM first and GAPPS after !
__________________
Was this reply helpful ?
Don't forget the "Thanks" button !
razvan06 is offline  
Reply With Quote
The Following User Says Thank You to razvan06 For This Useful Post:
nevablink (November 24th, 2012)
Old November 24th, 2012, 01:28 PM   #22 (permalink)
New Member
Thread Author (OP)
 
Join Date: Nov 2012
Posts: 11
 
Device(s):
Carrier: Not Provided

Thanks: 10
Thanked 0 Times in 0 Posts
Default

Done , all good now !!!
thank you all,
nevablink is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC One X/XL > (International Tegra 3) One X - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:42 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.