Go Back   Android Forums > Android Phones > HTC Legend > Legend - Support and Troubleshooting

test: Reply
 
LinkBack Thread Tools
Old September 1st, 2010, 02:12 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
erixon's Avatar
 
Join Date: Aug 2010
Location: Red Deer, AB, CAN
Posts: 47
 
Device(s): SE X10 Xperia
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via MSN to erixon
Default Unlocked HTC Legend Issue

Hey guys, I unlocked an HTC Legend on the Bell network, put in my Rogers SIM, but I have No Service displayed on my phone, is there settings or something I can change to get it to work?

Advertisements
erixon is offline  
Reply With Quote
sponsored links
Old September 1st, 2010, 02:29 PM   #2 (permalink)
Junior Member
Thread Author (OP)
 
erixon's Avatar
 
Join Date: Aug 2010
Location: Red Deer, AB, CAN
Posts: 47
 
Device(s): SE X10 Xperia
Carrier: Not Provided

Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via MSN to erixon
Default

I got one bar once, and then it just went back to none, and said no service.
erixon is offline  
Reply With Quote
Old September 2nd, 2010, 09:39 AM   #3 (permalink)
Member
 
anandroiduser's Avatar
 
Join Date: May 2010
Posts: 114
 
Device(s): HTC Legend
Carrier: Not Provided

Thanks: 0
Thanked 9 Times in 9 Posts
Default

If you don’t get a connection automatically, there are two
things to try.

Check that the data connection is turned on.
It may just be that your data connection isn’t turned
on. To check whether it is on:
1. On the Home screen, press MENU, and then tap
Settings.
2. Tap Wireless & networks, and select the Mobile
network check box to turn your connection on.
Check that the right mobile network is selected.
1. On the Home screen, press MENU, and then tap
Settings.
2. Tap Wireless & networks > Mobile network settings
> Network operators.

Taken from http://devicehelp.vodafone.co.uk/filestore/devices/HTC/Legend/HTCLegend_qs.pdf

Good luck!
anandroiduser is offline  
Reply With Quote
Old January 13th, 2011, 11:50 AM   #4 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm having similar problem. Unlocked my HTC Legend (Bell) but can't use the phone, Says no service. Trying to use with Orange Dominicana.

Followed your anandroiduser's account but when going to Network Operators all I get is an error because it couldn't find anything

Should I be able to see all the available Networks there?
loudbliss is offline  
Reply With Quote
Old January 13th, 2011, 12:03 PM   #5 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Got it, it's working now.

Option 2 from "anandroiduser" post

Check that the right mobile network is selected.
1. On the Home screen, press MENU, and then tap Settings.
2. Tap Wireless & networks > Mobile network settings > Network operators.

It may take you a couple of tries to get your network. The first time I clicked gave me an error and no results, the second time got me only another network, the sixth time it found Orange. Click on it and voila! It's going to be working in less than 10 secs.

must give a kudos to CellUnlock.net for the help and the code
loudbliss is offline  
Last edited by loudbliss; January 13th, 2011 at 12:07 PM.
Reply With Quote
Old December 24th, 2011, 08:41 PM   #6 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by loudbliss View Post
I'm having similar problem. Unlocked my HTC Legend (Bell) but can't use the phone, Says no service. Trying to use with Orange Dominicana.

Followed your anandroiduser's account but when going to Network Operators all I get is an error because it couldn't find anything

Should I be able to see all the available Networks there?

I have run into the same problem, no matter how many tries I give it, it shows up with "No networks found" and "Error while searching for networks." in Search Networks and under Select Automatically I get "Registered on a network" however I still have no service. This phone is for sure unlocked and is set to GSM mode (which is the mode I need). Trying to see if I can run it on Straight Talk network. The SIM card is activated already, I just checked with the company to make sure it is fully functional and working.
I have become highly frustrated in the game playing and I am now officially out of a phone for about a week because the NokiaE71 that I stole the card out of was defective. HELP!
italianpitbul is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC Legend > Legend - Support and Troubleshooting
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:38 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.