Go Back   Android Forums > Android Phones > LG Optimus S

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old October 23rd, 2012, 06:59 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Notsure Google Play wifi problem help!

Hello! I'm new to the Android phones and need some help. I connected my LG Optimus S to my home wifi network in order to save on data use with my carrier. I'm able to use the web with no problem if I use the browser but unable to download apps from Google Play. The downloading bar does not move or show any progress. Also, any apps already on the phone (youtube, facebook) state there's no connection even though I have an excellent wifi signal. I connected to wifi at my work and had no problems using Google Play or the apps. So now that I narrowed it down to my wifi network at home, how do I fix the problem/adjust router? What am I adjusting? LOL! Please be patient with my lack of wifi network skills. I appreciate any help. Thanks!

Trabranic is offline  
Reply With Quote
sponsored links
Old October 24th, 2012, 09:44 AM   #2 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 28
 
Device(s): Samsung Galaxy S3
Carrier: Ting (Sprint)

Thanks: 4
Thanked 11 Times in 8 Posts
Default

We can assume you've got a typical home network setup where you have either a cable or DSL modem along with your own, separate wireless router, yes? First, it never hurts to just power everything down and then restart (your modem, router, AND your phone). If your phone still has connectivity issues, here's a nice step-by-step guide on steps to take to completely re-do the settings on your wireless router:
Know Your Network, Lesson 2: Understanding Your Router
Ed Vim is offline  
Reply With Quote
Old October 24th, 2012, 07:17 PM   #3 (permalink)
Accept no imitations!
 
The_Chief's Avatar
 
Join Date: Nov 2009
Location: Manchester, TN
Gender: Male
Posts: 8,958
 
Device(s): Note 3 (rooted & ROMmed), Galaxy Nexus (retired), OG Droid (retired)
Carrier: Verizon

Thanks: 2,486
Thanked 6,921 Times in 3,277 Posts
Default

By the way Trabranic:


WELCOME TO THE FORUMS!

Let us know if that fixed the problem, or if you need more help. There are a lot of people who read this without joining the forums and they may have a similar problem... any fix posted here will be helpful to everyone.

Thanks!
__________________



If I have helped you at all, please click the "Thanks" button
Forum Rules & Guidelines
The_Chief is offline  
Reply With Quote
Old October 25th, 2012, 11:00 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Thanks!

Thanks so much for giving me a place to start. I will try this when I get home tonight. I will post my results. Thanks again!
Trabranic is offline  
Reply With Quote
Old November 3rd, 2012, 12:29 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry for the delay in my results. Had a lot going on lately. I tried restarting my phone, modem, and router and I still have the same problem. I also read the article from the link above about configuring my router but it doesn't tell me what exactly I need to configure to allow Google Play to work properly. I'm about ready to call it a day!
Trabranic is offline  
Reply With Quote
Old November 3rd, 2012, 02:38 PM   #6 (permalink)
Accept no imitations!
 
The_Chief's Avatar
 
Join Date: Nov 2009
Location: Manchester, TN
Gender: Male
Posts: 8,958
 
Device(s): Note 3 (rooted & ROMmed), Galaxy Nexus (retired), OG Droid (retired)
Carrier: Verizon

Thanks: 2,486
Thanked 6,921 Times in 3,277 Posts
Default

You shouldn't have to adjust the wifi router to fit your phone: you should be adjusting the phone to fit the router. Otherwise, you may end up knocking everything else off the network!

What I'm thinking now is backward compatibility. Is your router B/G/N compatible? I know some N-routers coming out will not connect to a G-speed device like your Optimus (few phones are N-speed capable). I had to replace the first N-router I bought because it wasn't backward compatible.

I suppose now we need to know more about your router, and what the Optimus is doing when you try to see the network and connect.
The_Chief is offline  
Reply With Quote
The Following User Says Thank You to The_Chief For This Useful Post:
Trabranic (November 3rd, 2012)
Old November 3rd, 2012, 04:29 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Oct 2012
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok. I think that might be the problem. I have an N router. It's one of those inexpensive Belkin N150 routers. Just might be going to purchase a new one. As I mentioned before, I caan access the web by the phones browser but when I try to download an app from Google Play it just sits in downloading mode with no progress. Or when I try to use an app that I was able to download at my work (no issues with my work's wifi) I get an error that the connection's lost or no connection. Any suggestions on which type of router I should purchase that will be compatable with my phone? Thanks
Trabranic is offline  
Reply With Quote
Old November 3rd, 2012, 08:55 PM   #8 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 28
 
Device(s): Samsung Galaxy S3
Carrier: Ting (Sprint)

Thanks: 4
Thanked 11 Times in 8 Posts
Default

I doubt a new router is going to solve your problem. You already stated that web browsing is not an issue -- Google Play is just another web site and the 'Play Store' app is simply an app that interacts directly with the Google Play site instead of going through the browser. If your wireless router was giving you online connectivity problems you'd also be having problems using your browser.

Maybe a more likely issue to look at is the 'Play Store' app. Go into your 'Settings' menu, select 'Applications', select 'Manage applications', scroll down and select the 'Google Play Store' app. Click on the 'Force stop' button at the top to quit the app, click on the 'Clear data' button in the middle, and then the 'Clear cache' button at the bottom. Now start up the 'Play Store' app like you normally do and see if there's any difference.

Also, if you go back into that 'Manage Applications' menu, at the bottom will be a 'XXXmb used' figure on the left and a 'XXmb free' amount on the right. I've found if my 'XXmb free' number drops below 20 MBs or so things start acting kind of out of sorts in general and I'll have to clean up various app caches.
Ed Vim is offline  
Reply With Quote
Old November 3rd, 2012, 10:35 PM   #9 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 28
 
Device(s): Samsung Galaxy S3
Carrier: Ting (Sprint)

Thanks: 4
Thanked 11 Times in 8 Posts
Default

Oh, and another thing to try and diagnose your problem would be to use your phone's web browser instead of the 'Play Store' app to go to the Google Play web site. Start up your web browser and go to:
https://play.google.com
If that page shows up properly, then your problem is probably tied to the app on your phone. If it doesn't, than try going to that site using any web browser on a computer in your household (one that's using your wireless router for online access). If both your phone and computer have problems accessing the Google Play web site (and you're still able to access other web sites like you usually do), there's probably an issue with a setting on your wireless router. (Note the lifehacker.com site in the link above is not fully accessible these days, LifeHacker got borked when Sandy hit NYC. They'll be back to normal in a few days.)
Ed Vim is offline  
Reply With Quote
Old November 10th, 2012, 05:28 AM   #10 (permalink)
Accept no imitations!
 
The_Chief's Avatar
 
Join Date: Nov 2009
Location: Manchester, TN
Gender: Male
Posts: 8,958
 
Device(s): Note 3 (rooted & ROMmed), Galaxy Nexus (retired), OG Droid (retired)
Carrier: Verizon

Thanks: 2,486
Thanked 6,921 Times in 3,277 Posts
Default

I stand corrected. I completely missed that whole line in the OP about wifi connectivity working except for...

Leave it to me to miss details like that
The_Chief is offline  
Reply With Quote
sponsored links
Old March 6th, 2013, 05:10 PM   #11 (permalink)
New Member
 
Join Date: Mar 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello!

Itīs been a few days, but I got the same Problem. Just with another Phone. Though I donīt think itīs the Phone. I normaly use a Motorola Jordan with Cyanogenmod 7. But I also tried a Samsung. Didnīt work either. Everithing works fine, exsept the Play Store and loging into google in the Phone Browser( Second one works occasionally). I even get notifications about Updates. Just canīt update them.

Itīs probably about the WiFi settings. My PC is linked by cable to the Router and with this I can enter the Play store.

Any Ideas?

(Sorry about possible typing errors. Iīm not an native english speaker.)
The Psijic is offline  
Reply With Quote
Old June 29th, 2013, 12:26 PM   #12 (permalink)
New Member
 
Join Date: Oct 2010
Location: michigan
Posts: 5
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

While I was doing some research on this, I found a solution that seems to have worked for some Android users. What they're suggesting is that if you change the primary and secondary DNS servers of your router to Google's defaults, this will cease being a problem.
That means changing your primary DNS server to 8.8.8.8, and secondary to 8.8.4.4.
superdugge is offline  
Reply With Quote
Reply

LG Optimus S
Current Rating:
Rate this Phone:

The LG Optimus S is LG's first Android phone in collaboration with Sprint. Sprint is looking to market this as a super affordable Android device. It will cost only 50.00 after rebates. It has a 3.2 inch touchscreen, a 600 Mhz processor, a 3.15 ... Read More



Go Back   Android Forums > Android Phones > LG Optimus S
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:40 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.