Go Back   Android Forums > Android Phones > LG Shine Plus

test: Reply
 
LinkBack Thread Tools
Old August 16th, 2012, 04:04 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default Incoming calls not ringing or vibrating for some contacts after 2.3.3 firmware update

I just updated my phone to Android 2.3.3 using Telus/LG's official software. Right after that, I noticed my phone wasn't ringing or vibrating on incoming calls, but all other notifications (calendar, text message, twitter, facebook) were behaving properly. I tried switching between various ringtones and adding my own, to no avail.

I thought it might have something to do with previous user information, so I've done my best to make this a new phone. I did the Foolproof Restore from the Root section of this forum (Foolproof Guide for restoring a bricked Shine Plus). I've done a factory reset, multiple times. I've deleted all apps. I have a clean SD card. I wiped all the contacts on my SIM card. Right now, I'm running a fresh install of 2.3.3 and I haven't linked any accounts (gmail, etc). The SD card says it has no contacts, and I haven't put in an SD card. Still the same issue.

Oddly enough, some numbers still get a ring, and they are all numbers that were never in my contacts. I don't know if this means anything, but like I've said, I've done my best to eliminate all contacts in my phone. Every number is unknown right now. But maybe there's some hidden file I don't know about.

I hope I've explained my issue well, and I hope someone can offer some advice.

(sidenote: this is an unlocked Telus phone running on Rogers, no issues in the 1.5 years before the 2.3.3 update).

Thank you very much in advance.

Advertisements
obviousalias is offline  
Reply With Quote
sponsored links
Old August 17th, 2012, 10:52 AM   #2 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Montreal, QC
Posts: 513
 
Device(s): Google Nexus 4, LG shine plus SOLD: Samsung Galaxy S2 international
Carrier: Not Provided

Thanks: 53
Thanked 60 Times in 49 Posts
Default

Quote:
Originally Posted by obviousalias View Post
I just updated my phone to Android 2.3.3 using Telus/LG's official software. Right after that, I noticed my phone wasn't ringing or vibrating on incoming calls, but all other notifications (calendar, text message, twitter, facebook) were behaving properly. I tried switching between various ringtones and adding my own, to no avail.

I thought it might have something to do with previous user information, so I've done my best to make this a new phone. I did the Foolproof Restore from the Root section of this forum (Foolproof Guide for restoring a bricked Shine Plus). I've done a factory reset, multiple times. I've deleted all apps. I have a clean SD card. I wiped all the contacts on my SIM card. Right now, I'm running a fresh install of 2.3.3 and I haven't linked any accounts (gmail, etc). The SD card says it has no contacts, and I haven't put in an SD card. Still the same issue.

Oddly enough, some numbers still get a ring, and they are all numbers that were never in my contacts. I don't know if this means anything, but like I've said, I've done my best to eliminate all contacts in my phone. Every number is unknown right now. But maybe there's some hidden file I don't know about.

I hope I've explained my issue well, and I hope someone can offer some advice.

(sidenote: this is an unlocked Telus phone running on Rogers, no issues in the 1.5 years before the 2.3.3 update).

Thank you very much in advance.
Hi,

It's a known issue that we advised Telus and LG about... I thought it was fixed in the v20B update. Seems I was wrong...

We have no info on what the bug could be. I think it might be related to contacts saved in LG sync vs. contacts in Google contacts... Will investigate.
karendar is offline  
Reply With Quote
The Following User Says Thank You to karendar For This Useful Post:
obviousalias (August 17th, 2012)
Old August 17th, 2012, 01:42 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by karendar View Post
Hi,

It's a known issue that we advised Telus and LG about... I thought it was fixed in the v20B update. Seems I was wrong...

We have no info on what the bug could be. I think it might be related to contacts saved in LG sync vs. contacts in Google contacts... Will investigate.
Thanks, that's good to know.

To make it even odder, I just bought a new LG Shine Plus (they were on sale from FutureShop). I did nothing except unlock it and then insert my old SIM. Same issue.

But if I put my SIM in another non LG phone (I have access to an old Nokia and a Samsung), all numbers ring. But if I put someone else's SIM in my phone, the irregular ringing continues.

I can't figure out a pattern for who rings and who doesn't, either. The ones who don't ring seem to be those most frequently contacted (work, parents, wife), but no idea what that means. However, the numbers that don't ring NEVER ring, and the ones that DO ring seem to always ring. But I cannot figure out where the phone is getting the information to not ring. Here's what I know:

- it's not from the SD card, because this is a problem even if I've never put an SD card in the phone
- it *shouldn't* be from Google Contacts, because it happens even when my phone has been wiped, and it happens in the new phone that I never connected to Google. The only thing I can think of is if the phone is somehow getting information about my profile from my phone number and my phone number alone, whether I've logged into Google on the phone or not
- could it be from the SIM card? I've deleted all the contacts stored on there, but there might still be some other information contained on it. I don't really know how it works.

*EDIT* How would I contact LG about this? It probably doesn't hurt to have more complaints come in.
obviousalias is offline  
Last edited by obviousalias; August 17th, 2012 at 02:34 PM. Reason: added question about contacting LG
Reply With Quote
Old August 17th, 2012, 02:35 PM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default Reverting?

One other question that I'm not sure on glancing at the forums-- is there any way to go back to before the 2.3.3 update? I'd love to know if reverting solves the problem. Thanks!
obviousalias is offline  
Reply With Quote
Old August 20th, 2012, 03:19 PM   #5 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Montreal, QC
Posts: 513
 
Device(s): Google Nexus 4, LG shine plus SOLD: Samsung Galaxy S2 international
Carrier: Not Provided

Thanks: 53
Thanked 60 Times in 49 Posts
Default

Quote:
Originally Posted by obviousalias View Post
One other question that I'm not sure on glancing at the forums-- is there any way to go back to before the 2.3.3 update? I'd love to know if reverting solves the problem. Thanks!
No current way of reverting to 2.1 when upgraded to 2.3.3. Blame LG. I could figure out a way, but I've got other things to do... I know the P500 is similar to our phones and has a way of switching radios back and forth.

As for phone calls not ringing, I'm thinking it has to do with the way LG Sync interacts with contacts. I'll possibly try a fix on my custom ROM to solve the issue... No promises though. It implies replacing the files related to phone calls.

And just so everyone knows, my girlfriend still runs 2.1 and has some calls that don't ring.
karendar is offline  
Reply With Quote
The Following User Says Thank You to karendar For This Useful Post:
obviousalias (August 20th, 2012)
Old August 20th, 2012, 06:55 PM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 6
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks for the information. I think I'm just going to be upgrading the phone at this point-- a cracked screen and some audio issues already existed, a lack of rings is sort of the last straw. (btw, I've installed your ROMS v 1-4, and they unfortunately fix nothing).

I will share one thing I've found that is a pseudo-fix, in case anyone else is looking for one and can't afford an upgrade. Applications like "WhoIsIt" that let you set custom vibrations for contacts can override the default vibrations. I set a custom vibration for all my contacts, and now at least every phone call vibrates. Wasn't able to find any ringtone fixes, though.
obviousalias is offline  
Reply With Quote
Old September 1st, 2012, 10:03 PM   #7 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

HI,same issue here, just bought shine plus used, unlocked Telus phone as well. The first day I had it, it worked well. Received calls, so I know the ringer worked for incoming calls. Today, the second day, nothing done different, now it doesnt sound any incoming calls, just the screen lights up, but no ringtone. Piece of junk phone. Luckily i didnt spend too much on it. Should of bought a Nokia. Have never had an issue with any of my Nokias.
LG, I was skeptical as I and my friends have had nothing but issues from this manufacturer, from dvd players, tv's, stereos, washers and dryers, myself have had issues with one tv and one microwave. Now a phone too.
Everything seems to work well on the phone, except the phone. Smartphone, i think not.
LG,=Life's Garbage.
drcolt2000 is offline  
Reply With Quote
Old September 4th, 2012, 10:16 AM   #8 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Montreal, QC
Posts: 513
 
Device(s): Google Nexus 4, LG shine plus SOLD: Samsung Galaxy S2 international
Carrier: Not Provided

Thanks: 53
Thanked 60 Times in 49 Posts
Default

Quote:
Originally Posted by drcolt2000 View Post
HI,same issue here, just bought shine plus used, unlocked Telus phone as well. The first day I had it, it worked well. Received calls, so I know the ringer worked for incoming calls. Today, the second day, nothing done different, now it doesnt sound any incoming calls, just the screen lights up, but no ringtone. Piece of junk phone. Luckily i didnt spend too much on it. Should of bought a Nokia. Have never had an issue with any of my Nokias.
LG, I was skeptical as I and my friends have had nothing but issues from this manufacturer, from dvd players, tv's, stereos, washers and dryers, myself have had issues with one tv and one microwave. Now a phone too.
Everything seems to work well on the phone, except the phone. Smartphone, i think not.
LG,=Life's Garbage.
LG phones are fixer-uppers. :P Unless you like fixing things yourself, you should stick to Samsung/Apple to be honest... Nokia, not so much anymore. But hey, I hear Windows Phone has them looking somewhat decent again.
karendar is offline  
Reply With Quote
Old September 4th, 2012, 12:09 PM   #9 (permalink)
Senior Member
 
Join Date: Nov 2010
Posts: 583
 
Device(s):
Carrier: Not Provided

Thanks: 11
Thanked 58 Times in 53 Posts
Default

I have had all the other reported upgrade issues with my LG except this one (most resolved by v20b). I have over a thousand phone numbers in my contacts list and have never noticed the phone not ringing. (Of course it could be happening, how would I know!) I have test phoned myself a few times from a few programmed numbers and it always seems to ring.

Two things. 1. I have not unlocked my phone. 2. I only use the google sync to store my contacts. I do not store any contacts on the sim or the PC Sync.

My only complaint is that the contacts search is very laggy. As I type in each letter of the name I want to search, there is almost a one second delay for the letter to pop up in the search box. Anybody else have this problem?
funpig is offline  
Last edited by funpig; September 4th, 2012 at 12:11 PM.
Reply With Quote
Old September 4th, 2012, 01:04 PM   #10 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Montreal, QC
Posts: 513
 
Device(s): Google Nexus 4, LG shine plus SOLD: Samsung Galaxy S2 international
Carrier: Not Provided

Thanks: 53
Thanked 60 Times in 49 Posts
Default

Quote:
Originally Posted by funpig View Post
I have had all the other reported upgrade issues with my LG except this one (most resolved by v20b). I have over a thousand phone numbers in my contacts list and have never noticed the phone not ringing. (Of course it could be happening, how would I know!) I have test phoned myself a few times from a few programmed numbers and it always seems to ring.

Two things. 1. I have not unlocked my phone. 2. I only use the google sync to store my contacts. I do not store any contacts on the sim or the PC Sync.

My only complaint is that the contacts search is very laggy. As I type in each letter of the name I want to search, there is almost a one second delay for the letter to pop up in the search box. Anybody else have this problem?
I'm pretty sure it's related to the fact you have over a thousand phone numbers that it needs to query to search. hehe. Considering I don't have more than 50 contacts, no way I can reproduce your issue... There might be a way to optimize the search if it uses sqlite queries... Who knows.
karendar is offline  
Reply With Quote
sponsored links
Old September 5th, 2012, 10:13 AM   #11 (permalink)
Senior Member
 
Join Date: Nov 2010
Posts: 583
 
Device(s):
Carrier: Not Provided

Thanks: 11
Thanked 58 Times in 53 Posts
Default

Quote:
Originally Posted by karendar View Post
I'm pretty sure it's related to the fact you have over a thousand phone numbers that it needs to query to search. hehe. Considering I don't have more than 50 contacts, no way I can reproduce your issue... There might be a way to optimize the search if it uses sqlite queries... Who knows.
The number of contacts could definitely be a factor. However, the lag only became a problem after the 2.3.3 update.
funpig is offline  
Reply With Quote
Old September 5th, 2012, 11:17 AM   #12 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: Montreal, QC
Posts: 513
 
Device(s): Google Nexus 4, LG shine plus SOLD: Samsung Galaxy S2 international
Carrier: Not Provided

Thanks: 53
Thanked 60 Times in 49 Posts
Default

Quote:
Originally Posted by funpig View Post
The number of contacts could definitely be a factor. However, the lag only became a problem after the 2.3.3 update.
Have you attempted using another dialer like DialerOne? Might be dialer.apk or contacts.apk related... Who knows! Worth a shot.
karendar is offline  
Reply With Quote
Reply
Tags
2.3.3, 2.3.3 gingerbread, 2.3.3 problem, ring, ringtone


Go Back   Android Forums > Android Phones > LG Shine Plus
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:37 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.