Go Back   Android Forums > Android Phones > LG Spectrum

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree1Likes
  • 1 Post By doctorj77

test: Reply
 
LinkBack Thread Tools
Old January 8th, 2013, 04:34 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default No 4G in ICS roms? Help! (SOLVED)

I got a Spectrum back whey first became available in 2012. Recently, past 5-6mo, I've rooted my phone, and using CWM "clockwork recover?" . Since then I've flashed various GB roms, Eclipse, Breakout, BlackPlague, and BlitzKrieg. Each had their uniqueness in issues. But all worked rather well.

Since the ICS OTA update became available, I've been trying to update that to my phone. While the ROM flashes just fine, I cannot get 4G to work at all. I've tried the Eclipse and ICY Fusion ICS roms. In either one, can never get 4g to work. Also, in both, after I flash either rom, I go to update my contacts by syncing my google account on my phone. Without fail, my phone only lets me do that with wifi enabled and connected. It can't connect under 3g. Same thing for Google Play, can't connect unless I'm on wireless. So I just restore my latest image of 2.3.6, currently BlitzKrieg. And all is well in GB land.


So here is what I"m doing in each flash

1. reboot into CWM recovery, factory reset my phone, wipe delvik, and for measure, wipe bat stats.
2. Install my ICS .zip file from the SD card
3. Fix Permissions after the install & reboot

Phone comes up normal like it should. Once its booted, its already activated. I can dial out, receive calls, send txt msgs. But the phone is still stuck in 3G. Data is enabled too. I've tried the #*#*4636*#*#, and that does take me to the hidden menu, I can select LTE-WCDMS-EVDO, but does little good.

Now, if I'm ignorant, and this is a known issue with all ICS roms for the spectrum, then forgive me for not putting 2+2 together. But I'm flat out of ideas. I dont' have the original GB OS, otherwise I would just flash back to stock, unroot, and apply the OTA update. Then re-root the phone. My GF has the same phone, all stock, got her OTA update, 4g works just fine on it.


Any help would be appreciated.

doctorj77 is offline  
Last edited by doctorj77; January 9th, 2013 at 11:56 AM.
Reply With Quote
sponsored links
Old January 8th, 2013, 04:41 PM   #2 (permalink)
AF Contributor
 
ortrigger's Avatar
 
Join Date: Sep 2012
Gender: Male
Posts: 838
 
Device(s): Sony Xperia Z, Asus Nexus 7 2013
Carrier: T-Mobile

Thanks: 660
Thanked 340 Times in 234 Posts
Default

Did you take the official ICS OTA? Or are you just flashing the ICS roms? If you took the original OTA, then flashing the cab and starting over is probably your best bet. If you haven't taken the OTA, you will definitely want to flash the cab for ICS. Here's a link.
__________________
Got the help you need? Join here and become a member of a great community.

Sony Xperia Z: stock; Nexus 7 2013: PSX
ortrigger is offline  
Reply With Quote
Old January 8th, 2013, 04:58 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

Both

At first, I did the OTA ICS. But by which point my phone was already rooted and running BlitzKrieg 2.3.6. So no stock rom was present at the time of the OTA download. And naturally it failed. So using clockwork recovery, I flashed back to my most recent BlitzKrieg backup.

Since then, I've just been pulling other developers custom GB and/or ICS roms, downloading them to my laptop, transferring to my phone, then flashing with Clockwork Recover. Its only the ICS that fails the data connection and 4G.

So if I understand you correctly, the ".cab" applies if I haven't the OTA update then? Meaning I can apply it now, and then reattempt the OTA? Just a note, my CWM is working fine. Not stuck in any boot loop, not even after ICS was flashed. So far, flashing and restoring have been a breeze
doctorj77 is offline  
Last edited by doctorj77; January 8th, 2013 at 05:00 PM.
Reply With Quote
Old January 8th, 2013, 06:15 PM   #4 (permalink)
AF Contributor
 
ortrigger's Avatar
 
Join Date: Sep 2012
Gender: Male
Posts: 838
 
Device(s): Sony Xperia Z, Asus Nexus 7 2013
Carrier: T-Mobile

Thanks: 660
Thanked 340 Times in 234 Posts
Default

What the cab does, is basically apply the ics ota no matter what you have installed. It will completely wipe your phone and when it's done you will have official ics. Then you can unlock the bootloader with the pwnage tool and start flashing ics and jb ROMs without problems.
ortrigger is offline  
Reply With Quote
Old January 8th, 2013, 06:21 PM   #5 (permalink)
Senior Member
 
Join Date: Jul 2012
Location: Newnan, GA
Posts: 619
 
Device(s): LG Spectrum
Carrier: VZW

Thanks: 451
Thanked 192 Times in 147 Posts
Default

The official ICS update (OTA or stock cab, not a custom ICS rom) has updates to the radio, so that might be causing your data woes. Flash the official cab using this link or the one ortrigger posted. You will lose cwm and root.

After that use the pwnage tool (link) to re-root and unlock the bootloader so you can flash custom roms again.

Finally, go get cm10 or aokp41 (link) and enjoy the awesomeness of it.


Edit: Dang, ortrigger beat me to it.
reeseboy is offline  
Reply With Quote
Old January 8th, 2013, 06:21 PM   #6 (permalink)
Senior Member
 
IMUcarmen's Avatar
 
Join Date: Mar 2012
Location: Williamsburg, VA
Posts: 1,720
 
Device(s): Droid Charge / LG Spectrum
Carrier: Not Provided

Thanks: 1,048
Thanked 351 Times in 276 Posts
Default

Quote:
Originally Posted by doctorj77 View Post
Both

At first, I did the OTA ICS. But by which point my phone was already rooted and running BlitzKrieg 2.3.6. So no stock rom was present at the time of the OTA download. And naturally it failed. So using clockwork recovery, I flashed back to my most recent BlitzKrieg backup.

Since then, I've just been pulling other developers custom GB and/or ICS roms, downloading them to my laptop, transferring to my phone, then flashing with Clockwork Recover. Its only the ICS that fails the data connection and 4G.

So if I understand you correctly, the ".cab" applies if I haven't the OTA update then? Meaning I can apply it now, and then reattempt the OTA? Just a note, my CWM is working fine. Not stuck in any boot loop, not even after ICS was flashed. So far, flashing and restoring have been a breeze
your problem is simple. You never took the official update of ics which replaces your radio files. Just flashing the ics roms doesnt replace the radio files. But you do have an easier solution than using the cab method. On the forum here you will find a thread about returning to stock using CWM. All you need to do is download a copy of V6 stock and put it in the cwm backup folder on your sd card and then boot into recovery and restore stock v6. You will also need to get the file to flash stock recovery which I think you get in the thread as well. You must have stock recovery in order to take the ota for V7.

The cab method would work as well but it's not as easy as flashing a backup in cwm in my opinion.
IMUcarmen is offline  
Reply With Quote
Old January 8th, 2013, 06:25 PM   #7 (permalink)
Senior Member
 
Join Date: Jul 2012
Location: Newnan, GA
Posts: 619
 
Device(s): LG Spectrum
Carrier: VZW

Thanks: 451
Thanked 192 Times in 147 Posts
Default

Using the return to stock v6 and taking ota is what I did personally - How to return to pure V4 or V6 Verizon stock with only CWM recovery
reeseboy is offline  
Reply With Quote
The Following 2 Users Say Thank You to reeseboy For This Useful Post:
IMUcarmen (January 8th, 2013), ortrigger (January 8th, 2013)
Old January 8th, 2013, 06:30 PM   #8 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: South Carolina - unfortunately
Posts: 860
 
Device(s): Samsung Moment, Droid 4, LG Spectrum, 2x Nook Tablet, all rooted.
Carrier: Verizon

Thanks: 54
Thanked 130 Times in 80 Posts
Default

Make sure you go to v6 and stock recovery and take the OTA, there are actually two updates, v6b which updates the radio, and v7 which gives you ICS. Once you get v6b activate your GPS and use maps or another app so it gets a lock on your position, else you "might" not have GPS working when you go to ICS.

Please read the ICS problems thread before you start the process, nearly every problem you might have is listed there, and how to avoid them, and even how to fix some of them, if you fail to avoid them.
__________________
LG Spectrum -- Rooted and running CM10.1 official M2 thanks to TDM (and too many others to list).
B&N Nook Tablet 16GB -- running CM10.1 with 10 finger multitouch
finndo77 is offline  
Reply With Quote
Old January 8th, 2013, 07:30 PM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

Well I've tried both links for the cab files, both rootzwikki and here. I thought it might of been my work intranet interfering. So I had someone off our network try it, same thing. Plus I get a page saying "forbidden" when trying it with with my phone.

Are those .cab file links active?
doctorj77 is offline  
Reply With Quote
Old January 8th, 2013, 07:58 PM   #10 (permalink)
Senior Member
 
Join Date: Jul 2012
Location: Newnan, GA
Posts: 619
 
Device(s): LG Spectrum
Carrier: VZW

Thanks: 451
Thanked 192 Times in 147 Posts
Default

Which cab file are you referring to? I tested the v7 on rootzwiki and it works, then I tried the v6 cab in the return to stock thread and it worked.
reeseboy is offline  
Reply With Quote
sponsored links
Old January 8th, 2013, 08:06 PM   #11 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by reeseboy View Post
Which cab file are you referring to? I tested the v7 on rootzwiki and it works, then I tried the v6 cab in the return to stock thread and it worked.
Interesting. Yeah I tried them all

When using Chrome, just gets a error:

Oops! Google Chrome could not connect to csmg.lgmobile.com:9002

Suggestions:
Try reloading: csmg.*lgmobile.*com:*9002/*swdata/*WEBSW/*LGVS920/*AVRZBK/*VS920ZV7_15/*VS920ZV7_15.*S7_15.*P58014.*R5.*cab


When I try in IE, just says page cannot be displayed. I had someone off my work network try the rootzwikki, looks like he can download that from outside my network
doctorj77 is offline  
Last edited by doctorj77; January 8th, 2013 at 08:09 PM.
Reply With Quote
Old January 8th, 2013, 08:22 PM   #12 (permalink)
Senior Member
 
Join Date: Jul 2012
Location: Newnan, GA
Posts: 619
 
Device(s): LG Spectrum
Carrier: VZW

Thanks: 451
Thanked 192 Times in 147 Posts
Default

I've seen that caused 2 ways - a firewall with content filtering and dns server issues. I wonder if changing your dns server to google's will help... That would be 8.8.8.8 for the dns server.
reeseboy is offline  
Reply With Quote
Old January 8th, 2013, 08:52 PM   #13 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

yeah its my work network. Unfortunately the security is locked down here pretty good. A work around, having someone download the 7.0.cab for me, sticking it in a dropbox share, and I can download it from there...... Technically should work
doctorj77 is offline  
Reply With Quote
Old January 8th, 2013, 08:57 PM   #14 (permalink)
Senior Member
 
Join Date: Jun 2010
Location: South Carolina - unfortunately
Posts: 860
 
Device(s): Samsung Moment, Droid 4, LG Spectrum, 2x Nook Tablet, all rooted.
Carrier: Verizon

Thanks: 54
Thanked 130 Times in 80 Posts
Default

You could try my website... I have the cab files there.

Joelperryproductions.com/spectrum
finndo77 is offline  
Reply With Quote
Old January 8th, 2013, 09:29 PM   #15 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

Thank you Finndo. I think I came across your site once before cruising the forums here. I'll look-up the cab files on there and give it a whirl.
doctorj77 is offline  
Reply With Quote
Old January 8th, 2013, 10:07 PM   #16 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

Well got the version 7.cab. Loaded just as the instructions said. Have my phone in download mode. Downloaded the LG USB drivers, and Utility Tool. Ran the KP500-Utils-EN as Admin.

Got the expected menu prompts. I put the path information in accordingly, then received and error immediately, followed by the LG Utility, with a bunch of ?????? in it. No actual words, just a bunch "?" instead. the Dos prompt is still running in the background saying loading. So now I'm stuck.





doctorj77 is offline  
Reply With Quote
Old January 8th, 2013, 10:18 PM   #17 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

maybe the source .cab is bad? I tried to take a peek at the contents of that file in explorer and all it says is

Can not open file
'C:\users\*****\downloads\VS920ZV7_15.S7_15.P58014 .R5.cab'
as archive

Just a FYI, the phone is fine. I Ctrl'C the process. Closed it out, pulled the battery, rebooted the phone, all is well with the old ROM still. I'll try it again tomorrow on my personal PC, not a work one.
doctorj77 is offline  
Last edited by doctorj77; January 8th, 2013 at 10:25 PM.
Reply With Quote
Old January 8th, 2013, 10:46 PM   #18 (permalink)
Senior Member
 
IMUcarmen's Avatar
 
Join Date: Mar 2012
Location: Williamsburg, VA
Posts: 1,720
 
Device(s): Droid Charge / LG Spectrum
Carrier: Not Provided

Thanks: 1,048
Thanked 351 Times in 276 Posts
Default

You'd be on jelly bean already if you had listened to me
IMUcarmen is offline  
Reply With Quote
Old January 8th, 2013, 11:06 PM   #19 (permalink)
Senior Member
 
MrB206's Avatar
 
Join Date: Mar 2012
Location: Seattle
Posts: 1,879
 
Device(s): LG Spectrum, ASUS Transformer 300T
Carrier: Not Provided

Thanks: 12
Thanked 255 Times in 227 Posts
Default

Was the cab in the same folder as the lg tool? That's a big one; I can't get the program to work unless the cab is in the same folder as the rest of the files. (tl;Dr if you answered that already)

Also, I generally run those from the city drive, not a sub folder... It seems to run better.
MrB206 is offline  
Reply With Quote
Old January 9th, 2013, 11:55 AM   #20 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: Michigun
Gender: Male
Posts: 14
 
Device(s): LG Spectrum
Carrier: Verizon

Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by IMUcarmen View Post
You'd be on jelly bean already if you had listened to me
Well after working 10hrs on a afternoon shift, it takes me a little to understand the simplest of things..... On that note, I went ahead and and downloaded v6_stock_noroot.zip + the recovery file. Flashed with CWM, installed form the zip, got my OTA updates, and now on ICS with 4g. It a beautiful thing now...................

Thank you to IMUCarmen, and all others here that helped me out with this. Phone is working great now on ICS.
IMUcarmen likes this.
doctorj77 is offline  
Reply With Quote
The Following User Says Thank You to doctorj77 For This Useful Post:
IMUcarmen (January 9th, 2013)
sponsored links
Old January 9th, 2013, 12:13 PM   #21 (permalink)
AF Contributor
 
ortrigger's Avatar
 
Join Date: Sep 2012
Gender: Male
Posts: 838
 
Device(s): Sony Xperia Z, Asus Nexus 7 2013
Carrier: T-Mobile

Thanks: 660
Thanked 340 Times in 234 Posts
Default

Quote:
Originally Posted by doctorj77 View Post
Well after working 10hrs on a afternoon shift, it takes me a little to understand the simplest of things..... On that note, I went ahead and and downloaded v6_stock_noroot.zip + the recovery file. Flashed with CWM, installed form the zip, got my OTA updates, and now on ICS with 4g. It a beautiful thing now...................

Thank you to IMUCarmen, and all others here that helped me out with this. Phone is working great now on ICS.

Glad to hear you got it going. Enjoy ics... Or jb... Whichever you choose to run.
ortrigger is offline  
Reply With Quote
Reply

LG Spectrum
Current Rating:
Rate this Phone:

The LG Spectrum for Verizon Wireless is the sucessor to the LG Revolution. Surely, LG did not want to stay behind, so this device packs some great specs and features. The Spectrum sports a 4.5-inch HD IPS display, a 1.5 GHz dual-core processor and ... Read More



Go Back   Android Forums > Android Phones > LG Spectrum
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:48 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.