Go Back   Android Forums > Android Phones > LG Marquee > Marquee - All Things Root

test: Reply
 
LinkBack Thread Tools
Old June 10th, 2012, 07:28 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Question Error during factor reset in CWM

I am getting the following error when factory resetting my phone under CWM:

formatting /sd-ext...
E:format_volume: make_extf4fs failed on /dev/block/mcblk1p2

Does anyone know the meaning? SD card error?

Please help me out.

Thanks

Advertisements
eruisi is offline  
Reply With Quote
sponsored links
Old June 10th, 2012, 07:36 PM   #2 (permalink)
Zercron Encrusted Tweezer
 
Granite1's Avatar
 
Join Date: Dec 2010
Location: Pittsburgh, PA
Gender: Male
Posts: 7,075
 
Device(s): M8, Note2(Wife) EL TEvo(retired :()
Carrier: Sprint

Thanks: 12,372
Thanked 6,978 Times in 3,720 Posts
Default

Quote:
Originally Posted by eruisi View Post
I am getting the following error when factory resetting my phone under CWM:

formatting /sd-ext...
E:format_volume: make_extf4fs failed on /dev/block/mcblk1p2

Does anyone know the meaning? SD card error?

Please help me out.

Thanks
I believe that means your SD card has a bad block. You'll need to reformat the card to fix the bad block, if that is in fact the issue. Should fix you right up.

Make sure you copy the contents of your SD card to your PC first because formatting it will wipe it clean.
__________________
"Not everything that counts can be counted, and not everything that can be counted counts." Albert Einstein
Granite1 is online now  
Reply With Quote
Old June 10th, 2012, 07:52 PM   #3 (permalink)
Member
 
Jay Aristide's Avatar
 
Join Date: Jul 2011
Location: Dyer, Tennessee, USA
Posts: 237
 
Device(s): LG Marquee w/CTMod 3.68 & Hyper 2.0, Google Nexus 7 16GB - PA w/_motley's kernel
Carrier: Not Provided

Thanks: 48
Thanked 71 Times in 54 Posts
Send a message via Yahoo to Jay Aristide
Lightbulb

Quote:
Originally Posted by eruisi View Post
I am getting the following error when factory resetting my phone under CWM:

formatting /sd-ext...
E:format_volume: make_extf4fs failed on /dev/block/mcblk1p2

Does anyone know the meaning? SD card error?

Please help me out.

Thanks
If you didn't make a seperate partition for ext4 on your sd-card, then it's failing to format /sd-ext because the partition it's trying to format doesn't exist.
This phone has a *lot* of internal memory, you really shouldn't need /sd-ext. For phones with very limited space, /sd-ext is a great idea, but it's a pretty hefty performance trade-off, depending on how slow your sd-card is.
Jay Aristide is offline  
Reply With Quote
Old June 10th, 2012, 08:49 PM   #4 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Jay Aristide View Post
If you didn't make a seperate partition for ext4 on your sd-card, then it's failing to format /sd-ext because the partition it's trying to format doesn't exist.
This phone has a *lot* of internal memory, you really shouldn't need /sd-ext. For phones with very limited space, /sd-ext is a great idea, but it's a pretty hefty performance trade-off, depending on how slow your sd-card is.
My Play Store has error message: insufficient space... when I update/download apps.

I didn't set anything special. CWM factory reset is looking for /sd-ext.

Please tell me what the problem is. My phone behaves abnormally now.
eruisi is offline  
Reply With Quote
Old June 10th, 2012, 09:15 PM   #5 (permalink)
Member
 
Jay Aristide's Avatar
 
Join Date: Jul 2011
Location: Dyer, Tennessee, USA
Posts: 237
 
Device(s): LG Marquee w/CTMod 3.68 & Hyper 2.0, Google Nexus 7 16GB - PA w/_motley's kernel
Carrier: Not Provided

Thanks: 48
Thanked 71 Times in 54 Posts
Send a message via Yahoo to Jay Aristide
Default

Quote:
Originally Posted by eruisi View Post
My Play Store has error message: insufficient space... when I update/download apps.

I didn't set anything special. CWM factory reset is looking for /sd-ext.

Please tell me what the problem is. My phone behaves abnormally now.
/mnt/block/mcblk1p2 is the second partition of your sd-card. If you didn't setup said partition, then the format errors out. It's been like that for about as long as I've been using CWM.

CWM tries to format and initialize /sd-ext by default (many custom kernels use it to store the system cache and the dalvik-cache to save internal space), and AFAIK, there's no way to turn it off.

Your phone has a LOT of internal storage and space in the system rom by default. Unless you have a LOT of apps installed, you shouldn't be getting Play Store errors.

If you have titanium backup installed, please screenshot the first screen it comes up to; The info at the bottom would greatly help figure out why Play Store is erroring out.
Jay Aristide is offline  
Reply With Quote
Old June 10th, 2012, 09:23 PM   #6 (permalink)
Member
 
Jay Aristide's Avatar
 
Join Date: Jul 2011
Location: Dyer, Tennessee, USA
Posts: 237
 
Device(s): LG Marquee w/CTMod 3.68 & Hyper 2.0, Google Nexus 7 16GB - PA w/_motley's kernel
Carrier: Not Provided

Thanks: 48
Thanked 71 Times in 54 Posts
Send a message via Yahoo to Jay Aristide
Default



^^ I'd like to see that screen, if you don't mind :-)
Jay Aristide is offline  
Reply With Quote
Old June 10th, 2012, 10:06 PM   #7 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Jay Aristide View Post

^^ I'd like to see that screen, if you don't mind :-)

Hi,

I would like to post the screen, but I don't have Titanium installed and that error prevents me from installing any apps now.

BTW: I have more than 10G free space on SD card.
eruisi is offline  
Last edited by eruisi; June 10th, 2012 at 10:11 PM.
Reply With Quote
Old June 10th, 2012, 10:42 PM   #8 (permalink)
Member
 
Jay Aristide's Avatar
 
Join Date: Jul 2011
Location: Dyer, Tennessee, USA
Posts: 237
 
Device(s): LG Marquee w/CTMod 3.68 & Hyper 2.0, Google Nexus 7 16GB - PA w/_motley's kernel
Carrier: Not Provided

Thanks: 48
Thanked 71 Times in 54 Posts
Send a message via Yahoo to Jay Aristide
Default

Quote:
Originally Posted by eruisi View Post
Hi,

I would like to post the screen, but I don't have Titanium installed and that error prevents me from installing any apps now.

BTW: I have more than 10G free space on SD card.
The available space on your sd card is of little to no consequence to your situation (well, that's not necessarily true, but we're jumping the gun).

Please go to Settings->Storage and read off to me (or screenshot) what it says under Internal Storage :-)
Jay Aristide is offline  
Reply With Quote
Old June 10th, 2012, 10:46 PM   #9 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Jay Aristide View Post
The available space on your sd card is of little to no consequence to your situation (well, that's not necessarily true, but we're jumping the gun).

Please go to Settings->Storage and read off to me (or screenshot) what it says under Internal Storage :-)
I have 2.75GB left on Internal Storage
SD Card: total 14.83G, available 14.38G

I guess some directory/partition structure on internal memory is screwed up.
eruisi is offline  
Last edited by eruisi; June 10th, 2012 at 10:49 PM.
Reply With Quote
Old June 10th, 2012, 11:04 PM   #10 (permalink)
Member
 
Jay Aristide's Avatar
 
Join Date: Jul 2011
Location: Dyer, Tennessee, USA
Posts: 237
 
Device(s): LG Marquee w/CTMod 3.68 & Hyper 2.0, Google Nexus 7 16GB - PA w/_motley's kernel
Carrier: Not Provided

Thanks: 48
Thanked 71 Times in 54 Posts
Send a message via Yahoo to Jay Aristide
Default

And you say you've done a factory reset to no avail? The problem persists after reset?
Jay Aristide is offline  
Reply With Quote
sponsored links
Old June 10th, 2012, 11:31 PM   #11 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 25
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 1 Time in 1 Post
Default

I did server sd formatting and a factory reset and now the phone is back to normal. I don't which on fix the issue though.

Thanks for help anyway.
eruisi is offline  
Reply With Quote
Old June 10th, 2012, 11:46 PM   #12 (permalink)
Member
 
Jay Aristide's Avatar
 
Join Date: Jul 2011
Location: Dyer, Tennessee, USA
Posts: 237
 
Device(s): LG Marquee w/CTMod 3.68 & Hyper 2.0, Google Nexus 7 16GB - PA w/_motley's kernel
Carrier: Not Provided

Thanks: 48
Thanked 71 Times in 54 Posts
Send a message via Yahoo to Jay Aristide
Default

Quote:
Originally Posted by eruisi View Post
I did server sd formatting and a factory reset and now the phone is back to normal. I don't which on fix the issue though.

Thanks for help anyway.
I'd imagine it was the factory reset. In the future, if you run into this issue again, try going into Settings->Manage Applications and removing the data and cache for Play Store. I seem to recall having a similar problem on my old Galaxy S 4G, and if my memory serves me, that's what fixed it.


You can also try rebooting into CWM and clearing the caches that way.

Anyways, glad your phone is back to normal. Hope you don't have any more problems with it :-)
Jay Aristide is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > LG Marquee > Marquee - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:25 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.