Go Back   Android Forums > Android Phones > ZTE AT&T Avail (ZTE Merit) > Merit - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree16Likes

test: Reply
 
LinkBack Thread Tools
Old July 3rd, 2012, 12:03 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default Complete ZTE Merit Guide: Root, Flash Recovery and Install New ROM (with links)

Moderator edit:

Please reference jcase's thread here:
[ROOT] ZTE z990g Merit (An avail variant?)
for information about rooting your ZTE Merit.
randyroyal and Kronin like this.

krystal1985 is offline  
Last edited by scary alien; December 14th, 2012 at 08:37 AM. Reason: point folks to the original source thread
Reply With Quote
The Following 8 Users Say Thank You to krystal1985 For This Useful Post:
Clout (July 16th, 2012), dustyj (August 24th, 2012), flamelurker (September 23rd, 2012), hillman312 (October 8th, 2012), kingmt (July 31st, 2012), Kronin (September 15th, 2012), maverickwolf (July 11th, 2012), yellandrebel (September 22nd, 2012)
sponsored links
Old July 3rd, 2012, 06:31 PM   #2 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

If one.three works, then my ROM should work as well. It does not have the Kernel pre-installed but it is compatible, as my device is running it now. My ROM, in my opinion takes better advantage of having su capabilities, since it includes ROM toolbox and Script manager.
Motorhead1991 is offline  
Reply With Quote
Old July 3rd, 2012, 08:51 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by Motorhead1991 View Post
If one.three works, then my ROM should work as well. It does not have the Kernel pre-installed but it is compatible, as my device is running it now. My ROM, in my opinion takes better advantage of having su capabilities, since it includes ROM toolbox and Script manager.


Guess I agree, just figured this setup would be appealing to someone who doesn't really care about that kind of stuff, and just wants a "readymade" rom without any stock bulk (seems to be trimmed down, the stock zte z990 is 133mb, vs this one is like 87mb) including an overclocking too, no crappy preinstalled launcher (believe Go Launcher is the only launcher this ROM has installed) and and one of my biggest personal reasons (call me picky): Getting rid of that hideous, embarrassing tracfone startup with annoying music.

Btw, your avatar says you overclocked to the 800s, I set mine to something in the 700's and though I get a prompt stating it was successful, how do you actually know it's really running faster? Is there a benchmark program for android? i mean, the placebo effect can take place if you know you installed something to make it speedier. I'm a n00b to Android OS, I've used iOS for years and know a lot more about that. I've found Android is more enjoyable to mess with
krystal1985 is offline  
Reply With Quote
Old July 4th, 2012, 12:21 AM   #4 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

My ROM is stripped down like one.three, it just has a couple more apps built it. As for benchmarking, does "There's an app for that" ring a bell?
Motorhead1991 is offline  
Reply With Quote
Old July 4th, 2012, 05:53 AM   #5 (permalink)
Junior Member
 
Join Date: Jun 2012
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 5 Times in 5 Posts
Default

So in order to flash a recovery or cwm u don't have to do a wipe / factory reset first?

-chud-

Edit: CWM is not on my ZTE Merit!! I answered my own question! No there is NO need to wipe/factory reset before you flash clockworkmod on the phone!!

Props to Krystal for the well put together guide "All in one AREA!"

-Chud-
Chud1 is offline  
Last edited by Chud1; July 4th, 2012 at 07:13 AM.
Reply With Quote
The Following User Says Thank You to Chud1 For This Useful Post:
krystal1985 (July 4th, 2012)
Old July 4th, 2012, 07:56 AM   #6 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Do you have to wipe data/factory reset when installing one.three on the merit?
neutrontech is offline  
Reply With Quote
Old July 4th, 2012, 10:01 AM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by Motorhead1991 View Post
My ROM is stripped down like one.three, it just has a couple more apps built it. As for benchmarking, does "There's an app for that" ring a bell?
lol i just started using android os 2 weeks ago and am still learning some of the more basic commands and by trial and error, learning what I can and cannot do with the android terminal app I do notice that the battery drains much faster and my games seem less choppy.
krystal1985 is offline  
Reply With Quote
Old July 4th, 2012, 10:04 AM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by Chud1 View Post
So in order to flash a recovery or cwm u don't have to do a wipe / factory reset first?

-chud-

Edit: CWM is not on my ZTE Merit!! I answered my own question! No there is NO need to wipe/factory reset before you flash clockworkmod on the phone!!

Props to Krystal for the well put together guide "All in one AREA!"

-Chud-
Thanks Chud! Yep, no wipe! It does come with some hokey little recovery thing (if you have rooted it and havent flashed clockworkmod yet, you can "restart recovery" from command line and see what I'm talking about!) I have no idea how to get that one to see an update file or anything, and I did try before flashing anything. I also learned that if you do flash with the wrong version of clockworkmod (I tried a few that didn't work before I found this one) it's no big deal, you just won't have the recovery option until you fix it.
krystal1985 is offline  
Reply With Quote
Old July 4th, 2012, 10:09 AM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by neutrontech View Post
Do you have to wipe data/factory reset when installing one.three on the merit?
No hun, you don't have to. I didn't and everything turned out perfect! It does mention somewhere in this very long guide of mine something that I haven't really read anywhere else, that you don't have to worry about the reset/wipe. Most people really emphasize that it seems, but if you want to go ahead. I believe that the only thing that happens if you don't that you will actually notice is that some of your settings seems to be saved. I am not completely sure, since I'm just starting out with Android, but it may be the difference between installing Windows on a computer without formatting the hard drive vs formatting the hard drive and starting out completely fresh. But I really don't think it matters too much.
krystal1985 is offline  
Reply With Quote
Old July 4th, 2012, 08:22 PM   #10 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Slow?

I just followed your instructions and was able to root my ZTE merit and install the one.three rom. It seems that the one.three rom is slower and stutters frequently. Could this be due to the cpu oc application? I have it set to ~650mhz from the default 750mhz. I wish you included that you should backup your stock rom. Where can I find the default rom incase I need to go back to stock? Thanks.
newtread is offline  
Reply With Quote
sponsored links
Old July 4th, 2012, 09:15 PM   #11 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

Not wiping the user data keeps your UI settings, your google account and any app that you had before.
Motorhead1991 is offline  
Reply With Quote
Old July 4th, 2012, 09:52 PM   #12 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

i keep running into reboot: operation not permitted on CMD shell, i cannot for the life of me figure out why,probably because i have no clue what i am doing, but still, lol.
thagnome is offline  
Reply With Quote
Old July 4th, 2012, 11:47 PM   #13 (permalink)
New Member
 
Join Date: Jul 2012
Location: NC
Posts: 5
 
Device(s): ZTE Merit Z990G
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Cry Still Can't Root my ZTE Merit!

I tried many, many times to root, but I can't proceed past #10 no matter how many times it is entered (10+). I keep getting a message that says "no such file or directory". I did a factory reset and still can't proceed. Any help would be greatly appreciated. I'm new this site and rooting.
dinat411 is offline  
Reply With Quote
Old July 5th, 2012, 05:43 AM   #14 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by newtread View Post
I wish you included that you should backup your stock rom. Where can I find the default rom incase I need to go back to stock? Thanks.
I'm linking to one that is uploaded online, not my personal backup but someone else's Z990G_Factory_Image.zip and a stock image of at&t's avail that may be worth trying if you find one like I did, I think I actually have it dL somewhere and will try to figure out where I dL'd it from if you want that one too. Normally the manufacturer would have the rom on their website I believe, but it doesn't seem to be there. Maybe b/c it's straight talk...but of course they weren't kind enough to include such things on their site.

but you are supposed to backup your own rom with clockworkmod and restore it should you run into a problem like you've mentioned before ever messing with the actual operating system. If the rom I linked doesn't work, maybe someone on here will be nice enough to link their own backup

Oh, and actually, if you set the CPU to 864 it really seems to make things smoother. My phone has been set on that since sometime yesterday and I haven't powered it off but twice to install some things, very briefly--so it's ran pretty much constantly, and it has never ran hot, the battery life seems fairly normal and no crashes. I also had a smoother experience after getting rid of those widgets and stuff like that.
krystal1985 is offline  
Last edited by krystal1985; July 5th, 2012 at 05:46 AM.
Reply With Quote
Old July 5th, 2012, 05:56 AM   #15 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by dinat411 View Post
I tried many, many times to root, but I can't proceed past #10 no matter how many times it is entered (10+).

EDIT: BTW, I'm not sure if this really has anything to do with that file not being created or not, but did you make sure to enable "USB Debugging" on your phone? I totally didn't mention to make sure to do that in my guide, and I'm sorry.

Wow, that's a lot of failed attempts...are you pressing the "Enable" button that pops up on your phone screen? I believe the file that you are referring to that isn't being created is a "properties" file and to be honest I'm not sure at exactly which step it is created...I have to assume it's created using this command that pops up the dialog box on your phone: am start -a android.intent.action.MAIN -n com.zte.emode/.logset. I had the same thing happen the first time because the guide didn't emphasize the step that step that says "Press the ENABLE button" (oh, and not that important but I mislabeled the info on step ten stating that the "previous command" creates the "local.prop" but actually all that the previous command does is list a file name, like I stated in that step). I'm not implying you necessarily forgot to do anything, but it's worth paying attention to it if you try again and making sure you do that. Also look at the instructions that I linked to, maybe they are better?? Maybe you could copy and paste all commands you type/paste up to the "fail" point or taking a screen shot (even better) and uploading it could shed some light on the problem.
randyroyal likes this.
krystal1985 is offline  
Last edited by krystal1985; July 5th, 2012 at 06:04 AM.
Reply With Quote
Old July 5th, 2012, 09:04 AM   #16 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

got all the way to step 15, wont let me root from <adb shell> will remount with cmd "adb remount" but thats as far as i can go, is it possible to just copy paste the SU.file to the phone root with usb?
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 09:07 AM   #17 (permalink)
Junior Member
 
Join Date: Jun 2012
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 5 Times in 5 Posts
Default

If I don't wipe/ factory reset before installing ROM one.three will all of the apps that I have downloaded still be on the phone or will they have to be re downloaded and installed again?

-Chud-
Chud1 is offline  
Reply With Quote
Old July 5th, 2012, 09:11 AM   #18 (permalink)
Junior Member
 
Join Date: Jun 2012
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by thagnome View Post
got all the way to step 15, wont let me root from <adb shell> will remount with cmd "adb remount" but thats as far as i can go, is it possible to just copy paste the SU.file to the phone root with usb?
Yes you can, when you hook up phone usb then pull down the menu drop down on your phone and select the option to mount as usb storage. Then it will pop up on computer and you can drag and drop su.zip on the root of sdcard!


-Chud-
Chud1 is offline  
Reply With Quote
The Following User Says Thank You to Chud1 For This Useful Post:
thagnome (July 5th, 2012)
Old July 5th, 2012, 09:20 AM   #19 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

just to double check, i need to drop the zipped file in, not just the file?
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 10:01 AM   #20 (permalink)
Junior Member
 
Join Date: Jun 2012
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 5 Times in 5 Posts
Default

That is correct the .zip file!


-Chud-
thagnome likes this.
Chud1 is offline  
Reply With Quote
The Following User Says Thank You to Chud1 For This Useful Post:
thagnome (July 5th, 2012)
sponsored links
Old July 5th, 2012, 10:36 AM   #21 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

alright, i had ROOT until i did the cleanup commands, is there anyway to complete the process and come back to this part, or is it necessary?
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 11:20 AM   #22 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

update: as of now i am rooted, and i have clockwork mod, i cannot however install one.three, it keeps coming back as
"cant open /sdcard/one.three.zip
(bad)"
I do not believe the link is bad, I figure I'm jacking something else up along the way
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 11:31 AM   #23 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

Quote:
Originally Posted by Chud1 View Post
If I don't wipe/ factory reset before installing ROM one.three will all of the apps that I have downloaded still be on the phone or will they have to be re downloaded and installed again?

-Chud-
That is correct. One.three only formats the /system and not /data (where most apps are stored), and mine only adds an app.
Motorhead1991 is offline  
Reply With Quote
Old July 5th, 2012, 11:54 AM   #24 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

oops stuck on boot screen
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 12:28 PM   #25 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

alright, now i have an issue, I accidentally deleted my stock ROM, does anyone have it?
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 02:16 PM   #26 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

What carrier are you using?
Motorhead1991 is offline  
Reply With Quote
Old July 5th, 2012, 05:01 PM   #27 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

What are the advantages of going to one.three from the stock Merit rom? I see you can overclock and it has a smaller memory footprint. Is there anything else?

Also having a problem when flashing CWM. I'm getting an error

"mtd: read error at [hex address] <out of memory>"

Using adb from Windows command prompt. Got the same error when trying with the terminal emulator on the phone itself.
neutrontech is offline  
Last edited by neutrontech; July 5th, 2012 at 05:05 PM.
Reply With Quote
Old July 5th, 2012, 05:24 PM   #28 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

Try killing any other running apps and trying again. As for your ROM question, one.three and my MH-1.0 are faster than stock because they are slimmed down, and de-odexed.
Motorhead1991 is offline  
Reply With Quote
Old July 5th, 2012, 05:48 PM   #29 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by thagnome View Post
alright, now i have an issue, I accidentally deleted my stock ROM, does anyone have it?
Hopefully someone will hook you up. I deleted mine after I realized I wouldn't want to go back to stock. Otherwise, if you have Straight Talk, then there's a link to it within this very thread. If you have an Avail/Roamer, just google "ZTE Avail stock roms".

I hope you don't mean you deleted your ROM via a clockworkmod wipe because then you're just sol. No replacement rom in the world would help, b/c as I thoroughly warned in my guide, the Merit does not have the volume up/down power button option to get into clockworkmod.
krystal1985 is offline  
Reply With Quote
The Following 2 Users Say Thank You to krystal1985 For This Useful Post:
ffoghorn (July 25th, 2012), thagnome (July 5th, 2012)
Old July 5th, 2012, 05:54 PM   #30 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by Motorhead1991 View Post
Try killing any other running apps and trying again. As for your ROM question, one.three and my MH-1.0 are faster than stock because they are slimmed down, and de-odexed.
I'm running Go Launcher Ex. I went into the app drawer and clicked on running apps, then killed them all. Tried again and got the same error.

I would just boot into recovery mode and do it that way, but I don't want to have to wipe my settings to do it.

EDIT: I got it. I downloaded Advanced Task Killer and shut a bunch of crap down!

EDIT2: Just installed one.three, I'll post if it all goes well.
neutrontech is offline  
Last edited by neutrontech; July 5th, 2012 at 06:20 PM.
Reply With Quote
sponsored links
Old July 5th, 2012, 06:31 PM   #31 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by neutrontech View Post
I'm running Go Launcher Ex. I went into the app drawer and clicked on running apps, then killed them all. Tried again and got the same error.

I would just boot into recovery mode and do it that way, but I don't want to have to wipe my settings to do it.

EDIT: I got it. I downloaded Advanced Task Killer and shut a bunch of crap down!

EDIT2: Just installed one.three, I'll post if it all goes well.
On first boot I got a mount error from Link2SD. I recreated the mount scripts and rebooted. Now my phone is showing only 6mb free. I can access all my linked apps, but for some reason the system thinks my apps are using internal storage.

EDIT: I think I got it. I had to recreate links for the Dalvik Cache

EDIT: nope. I can't get anymore than 30meg free after uninstalling EVERYTHING. So, I think I'm gonna wipe/factory reset it and see if that helps But ADB no longer sees my device
neutrontech is offline  
Last edited by neutrontech; July 5th, 2012 at 07:05 PM.
Reply With Quote
Old July 5th, 2012, 08:34 PM   #32 (permalink)
Junior Member
 
Join Date: Dec 2011
Posts: 80
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 8 Times in 7 Posts
Default

Ok, so I downloaded an app that allowed me to reboot my phone into recovery. I wiped it and reset it. Then took the SD card and wiped that as well, and setup the partitions again, creating a 1gb ext2 for apps.

I've installed a handful of apps and WOW it sucks up space fast. After wiping my phone, I had just over a 100meg free, now I'm showing 59meg free with only a fraction of the apps on it that I installed before. So, turns out there wasn't anything wrong with link2sd when I wiped it. The old ROM seemed to give me much more free space then this new one. I had 42meg free on the old rom with over 350meg worth of apps on the SD card. I have less than 200meg on the SD card now, as I haven't finished loading apps back. But at this rate, I'm gonna run out of space on the internal memory.

EDIT: After rebooting, I now have 73MB free. Might just be a delay after linking the apps before the freed space shows.

Also might want to add in the OP to set the APN settings for straight talk. I had to do that before MMS and internet would work.
neutrontech is offline  
Last edited by neutrontech; July 5th, 2012 at 09:27 PM.
Reply With Quote
Old July 5th, 2012, 08:45 PM   #33 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

sorry, was out of touch for a little bit, got the mod up and running, something in the way that i rooted did not like the mod one.three. i went to the link up top(the one you give props to) DL'd the mod(one.three) from his post, I'm not sure what the difference was, but i put my card back in, ran the .zip, and viola, full on awesomeness.
thagnome is offline  
Reply With Quote
Old July 5th, 2012, 11:36 PM   #34 (permalink)
New Member
 
Join Date: Jul 2012
Location: NC
Posts: 5
 
Device(s): ZTE Merit Z990G
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Cry Still Can't Root my ZTE Merit!

Here's my screen shot. Yes, "debugging" was set as well as "unknown sources". All files were downloaded per your instructions. I'd also tried the other person's instructions on this site when they first appeared. Yours were clearer to me because I'm new to rooting, etc. Anyway, as u can see, it still stops at step 10..."no such file or directory". I've attached just in case screen print. Thanks
Attached Images
File Type: jpg adb shell screen capture.JPG (134.6 KB, 73 views)
dinat411 is offline  
Reply With Quote
Old July 6th, 2012, 12:08 AM   #35 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

@dinat411:
Quote:
8. Paste this command and press enter (it just
removes log_kernel.txt, that's all)
rm /data/local/logs/kernel/log_kernel.txt
press "enter"
9. Paste this command and press enter, it
creates a symlink. If it gives you an error
message, that means this all has been done
before. It may say "already linked" or something
similar if you've already done this and are
starting over.
ln -s /data/local.prop /data/local/logs/kernel/
log_kernel.txt
press "enter"
Try skipping step 8, it looks like it's trying to symlink to a non-existant file. Worth a try .
Motorhead1991 is offline  
Reply With Quote
Old July 6th, 2012, 12:34 AM   #36 (permalink)
New Member
 
Join Date: Jul 2012
Location: NC
Posts: 5
 
Device(s): ZTE Merit Z990G
Carrier: Not Provided

Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Motorhead1991 View Post
@dinat411:

Try skipping step 8, it looks like it's trying to symlink to a non-existant file. Worth a try .
Symlinking is OK. I still can't create #10...ls -l /data/local.prop.
dinat411 is offline  
Reply With Quote
Old July 6th, 2012, 09:34 AM   #37 (permalink)
Senior Member
 
stayboogy's Avatar
 
Join Date: Jun 2012
Posts: 622
 
Device(s):
Carrier: Not Provided

Thanks: 36
Thanked 193 Times in 100 Posts
Default

Quote:
Originally Posted by dinat411 View Post
Symlinking is OK. I still can't create #10...ls -l /data/local.prop.
your symlinking is not okay, it clearly says "link failed file exists" that file must be deleted before it can be linked, and because it's not linked you can't get "local.prop" created

dinat411, go here http://androidforums.com/avail-all-things-root/566407-root-zte-z990g-merit-avail-variant.html and follow this to a "T"

if that still doesn't work you need to do a factory reset / T card flash and try again.

why follow someone else's method who was not the person to actually develop it??? whoever posted the directions above needs to remove them before others have more trouble. jcase's directions are more than proficient and understandable...

(according to the directions of the one who got root on the Merit)
you must make sure that this file "/data/local/logs/kernel/log_kernel.txt" is deleted before you symlink, and it can recreate the file before you get it symlinked, and then you must delete the "/data/local/logs/kernel/log_kernel.txt" and try again.

if the file is not deleted, then symlinked immediately, the "/data/local.prop" will not be created. aside from that it takes a couple of minutes before that file is created.

you need to try listing the "/data/local/logs/kernel/log_kernel.txt" file again and if it has been recreated you need to delete and try symlinking again.

follow the directions, the right directions not these in this thread

hope you get it going. it took on mine the very first try with no trouble at all, so the method is fine.
stayboogy is offline  
Last edited by stayboogy; July 6th, 2012 at 09:41 AM.
Reply With Quote
Old July 6th, 2012, 12:10 PM   #38 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

is anyone else having issues with data? i can connect to pretty much everything else, but my data is not working
thagnome is offline  
Reply With Quote
Old July 6th, 2012, 02:25 PM   #39 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

If anyone wants some STOCK roms that work on the ZTE merit (other than straight talk) I can give links, just pm since people like to bitch and moan over one little discrepancy that's being misinterpreted. The prop file was created for me, no problems. edit: btw the rom I'm using now has FTM mode capability...this splash screen comes up with big "ftm" letters which didn't happen before. maybe ill use tht mode someday, but doubt it.

BTW my directions have worked for some, others it has not. Guess some ppl misunderstand. This is the way I did it when the original directions from jcase or whatever didnt work out for me until I tried it twice.

And btw, I have clearly posted the link to the original directions for those who are whining, and the link has been there from the start. If mine don't work for you, and you want to leave bitchy comments, plz bug off and find some that do. Either a root will be a success or not, you are not going to "brick" your phone. If my directions are so terrible, obviously a moderator will close/delete the thread.
krystal1985 is offline  
Last edited by krystal1985; July 6th, 2012 at 02:39 PM.
Reply With Quote
The Following 2 Users Say Thank You to krystal1985 For This Useful Post:
algiers (August 7th, 2012), Kayoss666 (August 22nd, 2012)
Old July 6th, 2012, 02:45 PM   #40 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

worked fine for me, took a few tries, and a couple of tweaks for my phone, but i can use everything(minus 3g), i have a feeling i jacked something up there though. it's not showing my network as att, or straight talk. trying to find the problem on the forum. elsewhere, will post it when i find it if anyone else needs it, but as of time now, no one else has stated anything about the problem so i assume it is me

Edit: i also have a second completely stock, never activated merit that i can try and root and pull a ROM off of(i have no idea how to post it so if someone wants it i may need to mail it to OP for posting)
thagnome is offline  
Last edited by thagnome; July 6th, 2012 at 02:47 PM. Reason: better than putting another post on 2 seconds afterwards
Reply With Quote
sponsored links
Old July 6th, 2012, 03:31 PM   #41 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

Using a file hosting site will work fine, like 4shared or mediafire... It's looking likeI'll have all of the available APNs to make a consolidated version .
Motorhead1991 is offline  
Reply With Quote
Old July 6th, 2012, 03:44 PM   #42 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

it'd be nice to have a ready made that will run everything out of the box, i dont know enough about the systems to try myself though, i can build a computer, and install the software, but i have never gotten into the whole programming thing
thagnome is offline  
Reply With Quote
Old July 6th, 2012, 04:04 PM   #43 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Location: The Deep South
Posts: 13
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 15 Times in 5 Posts
Default

Quote:
Originally Posted by thagnome View Post
worked fine for me, took a few tries, and a couple of tweaks for my phone, but i can use everything(minus 3g), i have a feeling i jacked something up there though. it's not showing my network as att, or straight talk. trying to find the problem on the forum. elsewhere, will post it when i find it if anyone else needs it, but as of time now, no one else has stated anything about the problem so i assume it is me

Edit: i also have a second completely stock, never activated merit that i can try and root and pull a ROM off of(i have no idea how to post it so if someone wants it i may need to mail it to OP for posting)
No hun, you've been nothing but nice and thankful...it's a no-account user with one post that was giving me a hard time.

The rom I'm currently using is for a zte v860 and the built-in FM Tuner app keeps saying it "has a bad signal" and I can't tune into any local stations (but I also can't tune in via my living room radio without a large antennae) so when I get a chance to test it in town I'll report back about it. I'm pretty sure the ZTE Z990g version (which is what I have) has a radio inside of it but of course they don't exactly avertise that and have no app to operate it.

The only bad thing about the FTM mode is that I have the choice between leaving that along with the stock recovery OR reflashing to cwm and loosing the ftm. I see no use in the FTM for this particular phone so I've gotten cwm back. I guess if it was ever needed, I can just use the stock recovery image from this ROM or whatever.
krystal1985 is offline  
Reply With Quote
Old July 6th, 2012, 04:11 PM   #44 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

still havent found the problem, i'm thinking i'm going to go ahead and root the other phone, clockwork mod, then put the back up off that one on to this card and see if it will boot me into the stock straight talk, i think the issue i'm getting is that the phone doesnt want to use the signal, my bar is black, says i have 90% sig. but not getting any internet capabilities.

BTW it's saying my mobile network type is HSDPA, i have no idea what this means, shouldn't i be reading AT&T, or straight talk? i went into settings/mobile networks/ access point names/ and clicked at&t broadband still nothing

any ideas?
thagnome is offline  
Reply With Quote
Old July 6th, 2012, 05:23 PM   #45 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

Quote:
Originally Posted by krystal1985 View Post
No hun, you've been nothing but nice and thankful...it's a no-account user with one post that was giving me a hard time.

The rom I'm currently using is for a zte v860 and the built-in FM Tuner app keeps saying it "has a bad signal" and I can't tune into any local stations (but I also can't tune in via my living room radio without a large antennae) so when I get a chance to test it in town I'll report back about it. I'm pretty sure the ZTE Z990g version (which is what I have) has a radio inside of it but of course they don't exactly avertise that and have no app to operate it.

The only bad thing about the FTM mode is that I have the choice between leaving that along with the stock recovery OR reflashing to cwm and loosing the ftm. I see no use in the FTM for this particular phone so I've gotten cwm back. I guess if it was ever needed, I can just use the stock recovery image from this ROM or whatever.
Are you using my European ROM by chance? It's formatted for the V860 and has the FM Tuner...
Motorhead1991 is offline  
Reply With Quote
Old July 6th, 2012, 07:37 PM   #46 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

somehow managed to jack the other phone up while trying to root it, now it wont go past the ZTE logo
thagnome is offline  
Reply With Quote
Old July 6th, 2012, 08:01 PM   #47 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

do you have the passsword to that stock rom krystal? i dont see it anywhere
thagnome is offline  
Reply With Quote
Old July 6th, 2012, 08:24 PM   #48 (permalink)
Junior Member
 
thagnome's Avatar
 
Join Date: Jul 2012
Location: upstate, NY
Posts: 18
 
Device(s): ZTE merit (z990g)
Carrier: Not Provided

Thanks: 4
Thanked 0 Times in 0 Posts
Default

i would still like the stock rom, but i figured out the problem.
the VPN needs to be input, takes about 3 minutes(if your slow like me)
here's the link http://www.straighttalksim.com/pdf/ST_SIMCard_ActCard_AT&T_R3.pdf
thagnome is offline  
Reply With Quote
Old July 10th, 2012, 05:15 AM   #49 (permalink)
Junior Member
 
Join Date: Jun 2012
Posts: 35
 
Device(s):
Carrier: Not Provided

Thanks: 2
Thanked 5 Times in 5 Posts
Default

If flashing the one. three ROM on the zte merit without wipe/ resetting back to factory prior, will it still be a slimmed down version? Or will it leave behind some unwated bloat crap?
Any answer is greatly appreciated!


-Chud-
Chud1 is offline  
Reply With Quote
Old July 10th, 2012, 11:35 AM   #50 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Pasco, WA
Posts: 772
 
Device(s): Samsungs, Rugby Smart (AOKP), Galaxy Appeal (modded stock), Illusion (modded stock)
Carrier: Not Provided

Thanks: 12
Thanked 127 Times in 112 Posts
Default

It'll be slimmed down. It formats the system and replaces everything in the /system folder
Chud1 likes this.
Motorhead1991 is offline  
Reply With Quote
The Following User Says Thank You to Motorhead1991 For This Useful Post:
napalm6283 (January 1st, 2013)
Reply


Go Back   Android Forums > Android Phones > ZTE AT&T Avail (ZTE Merit) > Merit - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:58 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.