Go Back   Android Forums > Android Phones > Motorola Milestone 2 > Milestone 2 - All Things Root
Milestone 2 - All Things Root Rooting, ROMs, Overclocking

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old January 10th, 2011, 09:02 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 7
 
Device(s): Motorola Milestone 2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Re-install system (stock) apps?

Hi everybody.

I have a Milestone2 and made a backup of my apk's, by simply copying the files from /system/app to another location. Then, I delete some apps, like social network, gmail and some others.

But I can't re-install them, the installer says "application not installed" at end of process. Copy the files back to /system/app folder don't work as well. Android SDK bring a message saying FAILED_INSTALL_OPTDEX after "adb install" command.

A detail: Super Manager shows "(no install)" at end of file name, like "email service (no install)".

How can I can re-install these apps?

Thanks in advice.

romulocarlos is offline  
Reply With Quote
sponsored links
Old January 10th, 2011, 09:23 PM   #2 (permalink)
 
Join Date: Apr 2010
Posts: 5,867
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 633 Times in 538 Posts
Default

You need to be rooted to backup those apps. You cannot just copy the files from the system folder. And you need to be rooted to re-install those apps. If you aren;t rooted, you will have to run a stock ruu or factory reset to get them back.
sitlet is offline  
Reply With Quote
Old January 10th, 2011, 10:38 PM   #3 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by sitlet View Post
You need to be rooted to backup those apps. You cannot just copy the files from the system folder. And you need to be rooted to re-install those apps. If you aren;t rooted, you will have to run a stock ruu or factory reset to get them back.
If he backed up system apps it means he is already rooted, does it not?

As for restoring system apps. Copy the APK file into the system/app folder and change their permissions to: rw, r, r and reboot.
__________________
OT MaxDB, CD1, CD5, J5, GD96, ME45, T68i, X6, CX65, A925, E398, MPx200, X6-2, OT715, D600E, W810, M600i, BB8100, W880, N95-2, P1i, Ignito, W880, X1, MS1, MS2, TP851, XT910, GTab 10.1, SGS3, SGS4, SGNote 10.1, Nexus 7 II
Szadzik is offline  
Reply With Quote
Old January 11th, 2011, 03:01 AM   #4 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 7
 
Device(s): Motorola Milestone 2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Szadzik View Post
If he backed up system apps it means he is already rooted, does it not?

As for restoring system apps. Copy the APK file into the system/app folder and change their permissions to: rw, r, r and reboot.
Yes, I already rooted my phone with z4root.

Can you give more details about these permissions, using root explorer or super manager? Need to reset my phone after set these permissions?

Thanks.
romulocarlos is offline  
Reply With Quote
Old January 11th, 2011, 04:19 AM   #5 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by romulocarlos View Post
Yes, I already rooted my phone with z4root.

Can you give more details about these permissions, using root explorer or super manager? Need to reset my phone after set these permissions?

Thanks.
Using Root Explorer copy the file back to its original location, long press the file and choose Permissions.

On this scree put check marks as follows:
User:Read and write
Group: Read
Others: Read

Reboot the phone and the ap will start working again.
Szadzik is offline  
Reply With Quote
The Following User Says Thank You to Szadzik For This Useful Post:
romulocarlos (January 11th, 2011)
Old January 11th, 2011, 08:55 AM   #6 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 7
 
Device(s): Motorola Milestone 2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yeah, it worked! Too simple!

Now I have to find some stock apk's. You know some URL to download?

I found for Droid X, but Android 2.1. My Milestone 2 is Froyo.

Thanks.
romulocarlos is offline  
Reply With Quote
Old January 11th, 2011, 10:45 PM   #7 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by romulocarlos View Post
Yeah, it worked! Too simple!

Now I have to find some stock apk's. You know some URL to download?

I found for Droid X, but Android 2.1. My Milestone 2 is Froyo.

Thanks.
Let me know what you need and I will copy it from mine and post here or something like that.
Szadzik is offline  
Reply With Quote
Old January 12th, 2011, 03:41 AM   #8 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 7
 
Device(s): Motorola Milestone 2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

I don't know what files. Don't remember, I lost some files from my backup, but don't remember wich ones.

But your phone is English, don't? Mine is Brazilian Portuguse, is there any problems?

Thanks for your attention.
romulocarlos is offline  
Reply With Quote
Old January 12th, 2011, 04:54 AM   #9 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by romulocarlos View Post
I don't know what files. Don't remember, I lost some files from my backup, but don't remember wich ones.

But your phone is English, don't? Mine is Brazilian Portuguse, is there any problems?

Thanks for your attention.
My phone is English indeed. Not sur eif that would pose a problem.

What do you need the files for or what problems are you having that you need them?
Szadzik is offline  
Reply With Quote
Old January 12th, 2011, 10:01 AM   #10 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 7
 
Device(s): Motorola Milestone 2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Szadzik View Post
My phone is English indeed. Not sur eif that would pose a problem.

What do you need the files for or what problems are you having that you need them?
I lost some APK and ODEX files from my backup. Some problems on my phone are because this, I believe.

Some issues:
Short battery life - about 12 hours;
Freeze at least once a day;
Low internet speed;
Can't send scraps to orkut via contacts - orkut freeze any browser, as well;
Some times, a "force close" appears, for any app;
Lost signal several times a day;

And some minor issues I don't remember now. But I remember when I open the box and start to use my phone. None of issues above occoured.

Today I have uninstalled some apps (ADW Launcher, CPU Tuner and Super Manager) to verify these issues. If I get news, I tell you. But, orkut keeps freezing any browser (tried stock, Opera Mobile and Dolphin HD), even without that apps.

If you can upload your default /system/app folder, I will backup mine and test with yours.

Thanks.
romulocarlos is offline  
Reply With Quote
sponsored links
Old January 12th, 2011, 08:04 PM   #11 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jan 2011
Posts: 7
 
Device(s): Motorola Milestone 2
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Nevermind!

I found a retail SBF for Milestone 2, and flashed with it.

For now, after a few tests, everything is going fine, even orkut!

Thanks for your attention!
romulocarlos is offline  
Reply With Quote
Old January 12th, 2011, 09:35 PM   #12 (permalink)
Senior Member
 
Szadzik's Avatar
 
Join Date: Feb 2010
Gender: Male
Posts: 5,413
 
Device(s): Galaxy S4 Galaxy Note 10.1 Nexus 7 2013 LTE
Carrier: Not Provided

Thanks: 208
Thanked 729 Times in 616 Posts
Default

Quote:
Originally Posted by romulocarlos View Post
Nevermind!

I found a retail SBF for Milestone 2, and flashed with it.

For now, after a few tests, everything is going fine, even orkut!

Thanks for your attention!
Good to hear everything is working now.
Szadzik is offline  
Reply With Quote
Old March 18th, 2011, 08:10 PM   #13 (permalink)
Junior Member
 
Join Date: Jun 2010
Location: ...
Posts: 43
 
Device(s): Samsung Galaxy Note II
Carrier: Not Provided

Thanks: 8
Thanked 0 Times in 0 Posts
Default You may find this link helpful

Click here to get some system apps.
Europa76 is offline  
Last edited by Xyro; March 18th, 2011 at 11:20 PM.
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Motorola Milestone 2 > Milestone 2 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:24 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.